Subject: Last Call: Preferred Format for Literal IPv6 Addresses in URL's to Proposed Standard

From: The IESG <[email-masked]>
Date: Tue, 14 Sep 1999 11:05:19 -0400

The IESG has received a request from the IPNG Working Group to consider
Preferred Format for Literal IPv6 Addresses in URL's
<draft-ietf-ipngwg-url-literal-02.txt> as a Proposed Standard.

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by September 28, 1999.

Files can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-ipngwg-url-literal-02.txt

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Fri, 17 Sep 1999 09:29:11 -0400

In message <[email-masked]>, Harald Tveit Al
vestrand writes:
> At 17:53 16.09.99 -0700, Bill Fenner wrote:
> 
> >2 is incorrect.  While sh and bash will accept command line arguments like
> >this, csh and tcsh will not:
> >
> >fenestro% sh
> >$ echo http://[FEDC:BA98:7654:3210:FEDC:BA98:7654:3210]:80/index.html
> >http://[FEDC:BA98:7654:3210:FEDC:BA98:7654:3210]:80/index.html
> >$ tcsh
> >fenestro% echo http://[FEDC:BA98:7654:3210:FEDC:BA98:7654:3210]:80/index.htm
> l
> >echo: No match.
> >fenestro% csh
> >fenestro% echo http://[FEDC:BA98:7654:3210:FEDC:BA98:7654:3210]:80/index.htm
> l
> >echo: No match.
> >
> >I would suggest "{}" as a replacement for "[]".
> 
> Unfortunately, tcsh won't do much good with {} either.
> 
> [hta@dokka]$ echo 
> http://{FEDC:BA98:7654:3210:FEDC:BA98:7654:3210}:80/index.html
> http://FEDC:BA98:7654:3210:FEDC:BA98:7654:3210:80/index.html
> 
> TCSH strips out the curly brackets. (6.07.02).
> Let's face it. There are NO painless delimiters left.

Right.  And it's not really that much of an issue anyway, since URLs are 
rarely used at the shell level.  (Note:  I didn't say "never", I said 
"rarely".)  Given that literals are used in URLs only as an emergency measure 
anyway, I'm not concerned.

Besides -- all of this was taken into account when the document was being 
written.

		--Steve Bellovin