Subject: RE: Textual Address Change for Scope-IDs

From: Brian Zill <[email-masked]>
Date: Wed, 17 Nov 1999 17:45:40 -0800

Jim,

Could you rephrase this please?  I don't understand what position you are
taking.  The subject line is about textual address representation, but then
you talk about the binary representation (in6_addr, sin6_scope_id, the
proposal Robert Elz resurrected, etc) with what appears to be a bit of
textual representation thrown in.

Thanks,
--Brian

> -----Original Message-----
> From: Jim Bound [mailto:[email-masked]]
> Sent: Wednesday, November 17, 1999 15:43
> To: [email-masked]
> Subject: Textual Address Change for Scope-IDs
> 
> 
> Folks,
> 
> I strongly object to the idea of changing in6_addr to contain the
> scope-ID as an additional character.  This should not be confused with
> Roberts proposal of adding scope-id in SLA or such part of an IPv6
> address, which I think is a very good idea.  
> 
> I object to be clear to stuff like:
> 
>    SITEAfec0::2 (where fec0 starts the address)
> 
> We should use the companion field defined for this called 
> sin6_scope_ID.
> To hold the scope-id.
> 
> I have heard from several developers in other discussions 
> this is a bad
> idea.  
> 
> We need to discuss the merits of this and the drawbacks.
> 
> I see no merits.
> 
> Drawbacks:
>  1. Pollutes the IPv6 address
>  2. Causes changes to API functions that use addresses and in XNET
>  3. Adds no value to the issue of resolving scope-ids.
>  4. Users can easily add scope-id to sys cmds like ifconfig
>  5. Lots of others but I will stop for now.
> 
> Comments either way please, but we need to discuss this as its own
> thread.
> 
> thanks
> /jim
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jim Bound <[email-masked]>
Date: Thu, 18 Nov 1999 21:23:39 -0500

hi brian,

I don't want to see our std text representation of addresses contain
scope-ids.  A previous mail from Shin seemed to parse my issue fine.
I don't want to see inet_ntop or inet_pton changed at this point in
time. They are deployed and in BIND production nodes today.

/jim