Subject: RE: IPv6 Link-Local Address on Mediums that are Glued Together

From: Richard Draves <[email-masked]>
Date: Thu, 2 Dec 1999 11:06:52 -0800

Surely this observation does not come as a surprise?

I think the problem is relatively insignificant and we should just table it
in favor of more pressing issues.

I can imagine some future modifications/extensions of ND that could notice
duplicate addresses after DAD has finished. Eg if you send a multicast NS
and get back two NAs with the solicited & override bits both set and
different link-layer addresses, there could be a problem with the target
address. So you could warn the other nodes.

Rich

> -----Original Message-----
> From: Jim Bound [mailto:[email-masked]]
> Sent: Thursday, December 02, 1999 10:42 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: IPv6 Link-Local Address on Mediums that are Glued Together
> 
> 
> Folks,
> 
> This a.m. Mike Carney, Charlie Perkins, and I were discussing 
> DHCPv6 and
> we came across something that I want to bring to the list.  
> 
> For example:
> 
> There is an Ethernet Segment ETH1 with nodes:
> 
>  nA - linklocal address fe80::a, and nB - linklocal address fe80::b
> 
> There is another not connected to ETH1 Ethernet Segment ETH2 
> with nodes:
> 
>  nX - linklocal address fe80::a, and nY - linklocal address fe80::b
> 
> Then some admin decides to connect the two Ether segments 
> together with
> a bridge and make them one segment ETH3 without disrupting in 
> anyway or
> telling the nodes on ETH1 or ETH2.
> 
> Once they are connected nA and nX; & nX and nY; have duplicate
> link-local addresses on the same link now ETH3.
> 
> This is not good and I don't see anything in Neighbor Discovery or
> Stateless Addrconf anything to address this problem?
> 
> I use Ethernet segments as the example but there could be 
> other mediums
> like joining to cell-device networks together.
> 
> This has some ramifications we need to discuss and what do we 
> tell users
> about doing this?
> 
> Thoughts/Comments?
> 
> thanks
> /jim
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jim Bound <[email-masked]>
Date: Thu, 02 Dec 1999 14:48:05 -0500

>Surely this observation does not come as a surprise?

No.  But it just jumped in my face.

>in favor of more pressing issues.

Not sure I agree with you.

There needs to be a health warning for customers.  If we want to table it I
will send it to the IPv6 Forum and see what members think about this who
are trying to deploy IPv6.

I have customers that will be using IPv6 in the near future.  If they do
this I am not clear off top of my head what the ramifications are to
them, but intend to figure that out from a product perspective to see if
it could cause a support call to our hotline when IPv6 is turned on in
production nodes.  Which will be very soon.

>address. So you could warn the other nodes.

This will in fact happen.

Would like to hear from others on IPng too of course.

thanks
/jim