Subject: Re: Infrastructure TLDs: .ARPA should be used

From: Greg Maxwell <[email-masked]>
Date: Wed, 17 May 2000 13:05:10 -0400 (EDT)

On Wed, 17 May 2000, Vitali A. Chipitsyn wrote:

[snip]
> adding another level of indirection brings us closer to the 512 bytes limit. I know that 
> there have been attempts to solve this limit, but I am outdated on their status.
[snip]

I would imagine that the large minimum MTU with IPv6 would the 512 byte
limit even less of an issue.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Frank Solensky <[email-masked]>
Date: Wed, 17 May 2000 15:49:20 -0400

> limit even less of an issue.

It's been a while since I looked but IIRC, DNS still has a 512-byte limit for
message sizes.

---

From: [email-masked]
Date: Thu, 18 May 2000 09:27:02 +0900

>limit even less of an issue.

	the point is that the DNS server needs to know the client's maximum
	buffer size.  it looks to me that IPv6 transport-ready resolvers is
	mandatory to support EDNS0 (RFC2671), and attach EDNS0 additional
	records as necessary.

itojun

---

From: Bill Manning <[email-masked]>
Date: Wed, 17 May 2000 22:28:15 -0700 (PDT)

% 
% On Wed, 17 May 2000, Vitali A. Chipitsyn wrote:
% 
% [snip]
% > adding another level of indirection brings us closer to the 512 bytes limit. I know that 
% > there have been attempts to solve this limit, but I am outdated on their status.
% [snip]
% 
% I would imagine that the large minimum MTU with IPv6 would the 512 byte
% limit even less of an issue.
% 

actually no, the MTU is ~1280 bytes, which turns out to not be quite large 
enough. :(

-- 
--bill