Subject: RE: Stateless autoconf and dial-on-demand

From: Ole Pedersen <[email-masked]>
Date: Tue, 27 Jun 2000 09:27:01 +0200

Wouldn't it be possible to send out Router Solicitations on the dial-up
interface on initialization and with (long) interval? 

By doing this, the connection is open, so the ISP is able to return a Router
Advertisement packet...

Best regards,
Ole Pedersen

Martin Professional A/S
Email: [email-masked] <mailto:[email-masked]> 

		-----Original Message-----
		From:	Morten Heiberg Rasmussen [mailto:[email-masked]]
		Sent:	26. juni 2000 11:20
		To:	[email-masked]
		Subject:	Stateless autoconf and dial-on-demand

		Hi

		I have a question regarding IPv6 stateless address
autoconfiguration in
		combination with dial-on-demand network access.

		Suppose I have a network configured using only stateless
address
		autoconfiguration. At this point all hosts have a link local
address but
		nothing with wider scope. When a connection to the outside
world is opened
		the gateway node starts to receive router advertisements
from our ISP with
		a globally routable prefix. This prefix is distributed to
the hosts on the
		local network so that they can form complete, global IP
addresses.

		How does one implement dial-on-demand in such a setting? The
gateway for
		the network needs an outbound packet to trigger the dialing
process, but at
		that time the emitting host does not have a global address
to select as the
		packet source address. Hence the packet cannot be sent.

		Is there any way to avoid having to rewrite the first
outbound packets in
		the gateway? If it is not acceptable to open the connection
when no traffic
		is being sent and if we cannot assume that everybody uses
DNS I don't
		really see how it could be done.

		Best regards

		Morten Heiberg

		-- 
		Morten Heiberg Rasmussen              System Developer, M.
Sc. 
		Ericsson Telebit A/S                  Tel: +45 86 28 81 76
		Fabrikvej 11                          Fax: +45 86 28 81 86
		DK-8260 Viby J, Denmark               E-mail: [email-masked]

--------------------------------------------------------------------
		IETF IPng Working Group Mailing List
		IPng Home Page:
http://playground.sun.com/ipng
		FTP archive:
ftp://playground.sun.com/pub/ipng
		Direct all administrative requests to
[email-masked]
	
--------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Richard Draves <[email-masked]>
Date: Wed, 28 Jun 2000 13:06:00 -0700

> > If your dialup router is in command of the whole process, what
> > happens if it holds the first outbound packet for a while, then
> > advertises the new global prefix, *then* sends the initiator an ICMP
> > "beyond scope of source address"?  Will the initiator's stack then
> > retry with the new global-scope address?
> 
> Matt,
> 
> I guess what we are worried about is the source address 
> selection in the
> host implementations on the network. If a host needs to send 
> a packet to a
> global scope destination address and only has a link local address to
> supply as the source, are we guaranteed that the packet will 
> be put on the
> wire in the first place?

According to the draft source address selection rules, yes the packet will
be sent with a global destination and link-local source if there is no
better choice.

But then there's Matt's question of whether the initiator's stack would
retry with a new global source address after getting the ICMP error. The MSR
stack would *not* do this when establishing a TCP connection.

Backing up, I don't understand the approach. In this dial-on-demand
scenario, why not "permanently" allocate a global prefix to the dial-up
site? So router with the modem advertises this global prefix. And when the
router gets a packet that it wants to send over the modem, then it dials.

> A dumb question: Where is the "beyond scope of source address" ICMPv6
> message defined? I see it mentioned in RFC2765 (SIIT) as 
> "host unreachable,
> code 2", but the location of the definition eludes me.

draft-ietf-ipngwg-icmp-v3-00.txt, which seems to have expired.

Rich