Subject: RE: rfc2553bis comments

From: Brian Zill <[email-masked]>
Date: Mon, 26 Jun 2000 18:52:43 -0700

Steve Deering writes:
> When sending a multicast packet in IPv4, one has the
> choice of either identifying a specific outgoing
> interface or leaving it to the IP layer to choose an
> outgoing interface (the "default" multicast interface).
> 
> For IPv6, with its scoped addresses, the analogous 
> capabilities would be a choice among:
>
> - identifying a particular outgoing interface, or
> - identifying only the outgoing zone (for non-global 
>   destinations), and leaving it to the IP layer to
>   choose an outgoing interface within that zone, or
> - leaving it to the IP layer to choose both the 
>   outgoing zone (of the scope of the destination
>   address) and the outgoing interface within that zone.

I agree completely.  As I see it, having to select an interface when sending
a multicast packet in IPv4 is just a hack to get around the lack of the zone
concept in IPv4.  This the architecturally clean and simple way to do it.
We shouldn't propagate bad hacks forward from v4 into v6.

> Then, I think we could probably get rid of
> IPV6_MULTICAST_IF altogether (i.e., deprecate it).

Yes.

> The scope/zone spec is not "still missing", though it 
> certainly still needs work.

Well, the draft itself might need a little bit of cleanup, but the concepts
contained therein are well understood, exist in multiple implementations,
etc.

--Brian

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jim Bound <[email-masked]>
Date: Mon, 26 Jun 2000 22:44:37 -0400

Brian,

I completely disagree that we understand enough about zones to recommend
it to anyone.

We need to find a middle ground here.

The spirit of the spec at this point was not that IPv4 was a hack but
correct for what it did.  If we want to change that it will require much
discussion and may not be appropriate for rfc2553.

I would like to hear a lot of discussion on this from the working group.
Before this change will be supported.

regards,
/jim

---

From: Francis Dupont <[email-masked]>
Date: Tue, 27 Jun 2000 12:31:20 +0200

In your previous mail you wrote:

   As I see it, having to select an interface when sending
   a multicast packet in IPv4 is just a hack to get around the lack of the zone
   concept in IPv4.  This the architecturally clean and simple way to do it.
   We shouldn't propagate bad hacks forward from v4 into v6.
   
=> we agree but Jim's concern is still valid, ie. we should keep the old
way for old applications. The zero sin6_scope_id seems to be able to do that.

   
=> can you add more details about "exist in multiple implementations"?

Thanks

[email-masked]