Subject: RE: rfc2553bis comments

From: "Dave Thaler" <[email-masked]>
Date: Thu, 29 Jun 2000 16:42:01 -0700

I think Steve is _almost_ right :-)
and I was thinking along these same lines.

I believe it should be that for a given scope level,
all interfaces within the next higher well-known
scope level are within the same scope of that level.

For example scop 4, being smaller than site-local scope,
should use the site-local scope ids.  If you're
in multiple sites, you can't assume all interfaces
are in the same scop 4 zone.

So by default scopes 6 and higher just use 0 (same as
global), 3-5 use site ids, and 2 uses ifindex.

So my proposed correction to Steve's rule is:
"Whenever dealing with an address (multicast or unicast) of 
a scope for which you are not a boundary, the appropriate zone
is unambiguous, so the sin6_scope_id is the same zone id of
the next larger scope for which you are a boundary (e.g., zero
if you are not a boundary for any larger scope level)."

-Dave

> -----Original Message-----
> From: Steve Deering [mailto:[email-masked]]
> Sent: Thursday, June 29, 2000 4:29 PM
> To: Richard Draves
> Cc: Dave Thaler; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: rfc2553bis comments
> 
> 
> At 1:45 PM -0700 6/26/00, Richard Draves wrote:
> >I'm warming up to Dave's proposal, but I would not invent 
> new zone ids for
> >all the different multicast scope levels. (Or at least I'd leave this
> >optional for implementations.) I'd map the multicast scope 
> levels into the
> >link-local/site-local/global unicast scopes.
> 
> I don't think you have to create zone IDs for all multicast 
> scope levels
> *nor* do I think you have to "map" those levels into the 
> unicast levels.
> Rather, you only need zone IDs for those scopes for which you are a
> boundary (or in other words, only for those zones for which you are
> attached to more than one of the same scope).  Whenever 
> dealing with an
> address (multicast or unicast) of a scope for which you are 
> not a boundary,
> the appropriate zone is unambiguous (all your interfaces 
> belong to a single
> zone of that scope), so you can just use the "unspecified" (e.g., zero
> valued) zone id in the sin6_scope_id that accompanies that address.
> 
> Steve
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
>

---

From: Steve Deering <[email-masked]>
Date: Thu, 29 Jun 2000 17:39:38 -0700

>are in the same scop 4 zone.

Hmm, yes, I can see how you can use that approach to avoid creating
zone indices for scop 4 on site-boundary nodes.  I was working from
the assumption that you *would* have scop 4 zone ids on such a node,
i.e., *if* scop 4 were configured to be used within a site, it
would have to be configured on all site-boundary nodes.

However, you still need the capability to explicitly configure scop 4
zone ids on site-boundary nodes, in case the node is attached (via
different interfaces) to more than one scop 4 zone within the same site.
And you also need the capability to configure scop 4 zone ids on nodes
that are internal to a site, i.e., not site-boundary nodes.

>if you are not a boundary for any larger scope level)."

That's still not quite right, because if you are a boundary for
scope x, you are *necessarily* a boundary for all configured scopes
less than x, since a smaller zone cannot span across boundaries
of a larger zone.

Steve

---

From: Francis Dupont <[email-masked]>
Date: Fri, 30 Jun 2000 10:08:45 +0200

In your previous mail you wrote:

=> then I believe we need to standardize the way to configure zone IDs
(ie. to attach an interface to a zone). But this should be in the advanced
API, not in the basic API (rationate: this will be done by an administrator,
not by a common user).

[email-masked]