Subject: MLD MIB

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 21 Jan 2001 23:38:56 +0100

All,

The MLD MIB is close to being published as RFC.
We found a few "editorial" changes that I am proposing to
the RFC-Editor. Just so you know. If you have a real
issue with it, then speak up very quickly. None of these
changes change anything in terms of bytes on the wire
or semantics.

Bert
------------------------------------------
Editorial changes proposed:

> Change all occurences of Ipv6IfIndexOrZero and Ipv6IfIndex (from IPv6-TC)
> into the equivalent and better InterfaceIndexOrZero and InterfaceIndex
> from IF-MIB. Also change the use of Ipv6Address (from IPv6-TC) to the
equivalent and better InetAddressIPv6 (SIZE (16)) from the 
> INET-ADDRESS-MIB 
> 
> So the changes are:
> 
> OLD (page 3)
>        Ipv6Address, Ipv6IfIndexOrZero, 
>        Ipv6IfIndex                      FROM IPV6-TC 
> NEW:
>        InetAddressIPv6             FROM INET-ADDRESS-MIB
>        InterfaceIndex, InterfaceIndexOrZero
>                                             FROM IF-MIB
> 
> OLD (page 4):
>        mldInterfaceIfIndex              	Ipv6IfIndex, 
> NEW:
>        mldInterfaceIfIndex              InterfaceIndex, 
> 
OLD (page 4):
      mldInterfaceQuerier               Ipv6Address,
NEW:
      mldInterfaceQuerier               InetAddressIPv6,

> OLD (page 4):
>      mldInterfaceProxyIfIndex          Ipv6IfIndexOrZero, 
> NEW:
>        mldInterfaceProxyIfIndex          InterfaceIndexOrZero, 
>    
> OLD (page 4): 
>        SYNTAX     Ipv6IfIndex 
> NEW:
>        SYNTAX     InterfaceIndex
> 
OLD (page 5):
       SYNTAX     Ipv6Address
NEW:
       SYNTAX     InetAddressIPv6 (SIZE (16))

> OLD (page 6):
>        SYNTAX     Ipv6IfIndexOrZero 
> NEW:
>        SYNTAX     InterfaceIndexOrZero 
> 
> OLD (page 8):
       mldCacheAddress         Ipv6Address,
>        mldCacheIfIndex            Ipv6IfIndex,
       mldCacheSelf               TruthValue,
	 mldCacheLastReporter   Ipv6Address,
> NEW:
       mldCacheAddress         InetAddressIPv6,
>  mldCacheIfIndex            InterfaceIndex, 
       mldCacheSelf               TruthValue,
       mldCacheLastReporter   InetAddressIPv6,

> OLD (page 8):
       SYNTAX     Ipv6Address
> NEW:
>        SYNTAX     InetAddressIPv6 (SIZE (16)) 
      
> OLD (page 8):
>        SYNTAX     Ipv6IfIndex 
> NEW:
>        SYNTAX     InterfaceIndex 
> OLD (page 9):
       SYNTAX     Ipv6Address
> NEW:
>        SYNTAX     InetAddressIPv6 (SIZE (16)) 

> Bert

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Peder Chr. Nørgaard <[email-masked]>
Date: Tue, 23 Jan 2001 09:15:33 +0100 (CET)

On Sun, 21 Jan 2001, Wijnen, Bert (Bert) wrote:

> Date: Sun, 21 Jan 2001 23:38:56 +0100
> From: "Wijnen, Bert (Bert)" <[email-masked]>
> To: [email-masked]
> Subject: MLD MIB
>
> All,
>

I have to disagree with the premises of this statement, if not the
conclusion.  This change does indeed change the semantics of the
implementation, and also the value of the bytes on the wire.  The
InterfaceIndex and the Ipv6IfIndex are two different numbering schemes,
and replacing the latter with the former forces changes in all
implementations.  Cf discussion on the IPv6 Design Team homepage
<http://www.ibr.cs.tu-bs.de/ietf/ipv6mib-dt>.

Unfortunately that discussion never reached a conclusion, so the MLD-MIB
designers do not really have any guidance in the choice between the two
schemes.  Say, if the design team had concluded to do away with the
Ipv6IfIndex in the IPV6-MIB and friends, the MLD-MIB should of course do
the same.

From my own position, the proposed change does not hurt, for I have not
completed the implementation of the MLD-MIB.  But anyone with a working
implementation of MLD-MIB will have to modify code to adapt to this
change.

best regards

Peder Chr. Nørgaard        	 Senior System Developer, M. Sc.
Ericsson Telebit A/S       	 tel: +45 89 38 52 53
Skanderborgvej 232         	 fax: +45 89 38 51 01
DK-8260 Viby J, Denmark    	 mob: +45 21 28 66 58
       e-mail: [email-masked]
         (old e-mail 1992-2000: [email-masked])