Subject: Ipv6IfIndex and IPv4 ifIndex

From: "Deshpande, Prasad" <[email-masked]>
Date: Tue, 21 Aug 2001 10:04:20 -0400

Hi,

  If IPv6 and IPv4 unicast forwarding are enabled on the same physical
interface, would values of Ipv6IfIndex and ifIndex (IPv4) be the same
i.e. would the same row show up in both ifTable and ipv6IfTable. Is 
this implementation dependent?

   I couldnt find any draft/RFC that talks about this.

thanks
-prasad
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Dimitry Haskin <[email-masked]>
Date: Tue, 21 Aug 2001 11:09:00 -0400

Prasad,

ipv6IfIndex defines a logical IPv6 interface. There is no requirement for
its value being equal to an ifIndex value. Generally, it should be possible
to configure multiple logical IPv6 interfaces on a single physical
interface.

Regards,
  Dimitry

> -----Original Message-----
> From: Deshpande, Prasad [mailto:[email-masked]]
> Sent: Tuesday, August 21, 2001 10:04 AM
> To: [email-masked]
> Subject: Ipv6IfIndex and IPv4 ifIndex
> 
> 
> 
> Hi,
>

---

From: "Dave Thaler" <[email-masked]>
Date: Tue, 21 Aug 2001 12:46:36 -0700

What's a "logical IPv6 interface" and where is it defined?

If you're using VLANs or whatever else, you can do it
with ifIndex values, and this buys you a lot
(you get the ifStackTable, stats, etc).

I see no advantage to introducing another numbering space
and trying to get people to understand it.

So I agree that Dimitry's answer applies to RFC 2465,
but we don't keep this concept in the new MIB drafts.

-Dave

> From: Dimitry Haskin [mailto:[email-masked]]
> Sent: Tuesday, August 21, 2001 8:09 AM
> To: 'Deshpande, Prasad'; [email-masked]
> Subject: RE: Ipv6IfIndex and IPv4 ifIndex
> 
> Prasad,
>

---

From: "Dave Thaler" <[email-masked]>
Date: Fri, 24 Aug 2001 14:53:07 -0700

>   IpIfStatsEntry  in draft-ietf-ipngwg-rfc2011-update-00.txt has only
one
> set of statistcs for each ipIfStatsIfIndex. So if IPv4 and IPv6 are
> enabled
> on the same physical interface, wont you need 2 seperate ifIndex
values to
> get seperate statistics?

No, you don't.  If you look at the INDEX clause of the IfStatsTable, 
you'll see that it's:
	INDEX { ipIfStatsAFType, ipIfStatsIfIndex }
where ipIfStatsAFType identifies IPv4 or IPv6.
Hence, there's separate rows for IPv4 vs IPv6 statistics.

-Dave

---

From: "Deshpande, Prasad" <[email-masked]>
Date: Fri, 24 Aug 2001 15:41:08 -0400

Hi Dave,

  IpIfStatsEntry  in draft-ietf-ipngwg-rfc2011-update-00.txt has only one 
set of statistcs for each ipIfStatsIfIndex. So if IPv4 and IPv6 are enabled 
on the same physical interface, wont you need 2 seperate ifIndex values to 
get seperate statistics?

thanks
-prasad

> From: Dave Thaler [mailto:[email-masked]]
> Sent: Tuesday, August 21, 2001 3:47 PM
> To: Dimitry Haskin
> Cc: Deshpande, Prasad; [email-masked]
> > ipv6IfIndex defines a logical IPv6 interface. There is no 
> requirement
> for