Subject: ipv6IfStateChange traps in RFC2465

From: Daniel Chuang <[email-masked]>
Date: Mon, 20 Aug 2001 15:33:07 -0700 (PDT)

Hello,

 ipv6IfStateChange is defined as follows: 

 ipv6IfStateChange NOTIFICATION-TYPE
     OBJECTS {
         ipv6IfDescr,
         ipv6IfOperStatus 
     }
    STATUS             current
    DESCRIPTION
     "An ipv6IfStateChange notification signifies
      that there has been a change in the state of
      an ipv6 interface.  This notification should
      be generated when the interface's operational
      status transitions to or from the up(1) state."
  ::= { ipv6NotificationPrefix 1 }

This can be translated into SNMPv1 trap from the
above definition. BUT what kind of information
will be put into the "agent-addr" in the v1 Trap
PDU in the ipv6-only node?

A couple of options:

1. SNMPv1 traps are not allowed for ipv6-only node.

2. modify RFC1157.

3. any other creative methods !!

Thanks,
Daniel 

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 26 Aug 2001 16:51:05 +0200

> I prefer a standard definition and that is why I started to write
> <draft-ops-taddress-mib-00.txt> a while back. For those interested,
> you can find a copy at:
> <http://www.ibr.cs.tu-bs.de/~schoenw/draft-ops-taddress-mib-00.txt>
> 
I have made the one in the I-D repository resurected.

> One problem with TAddress/TDomain is that the community does not have
> a clear concensus whether definitions contain specific SNMP semantics
> or not. The current usage of TAddress/TDomain outside the SNMP specs
> of course assumes that there are no special SNMP semantics associated
> with TAddress/TDomain definitions...
> 
Let us define a set of TDomains and TAddresses that have no SNMP
semantics. They can then be used in SNMP specific objects, in which
case maybe they do get some SNMP meaning. But they can then also
be used for other purpuses.

Bert
> /js
> 
> -- 
> Juergen Schoenwaelder      Technical University Braunschweig
> <[email-masked]>  Dept. Operating Systems & Computer Networks
> Phone: +49 531 391 3289    Bueltenweg 74/75, 38106 
> Braunschweig, Germany
> Fax:   +49 531 391 5936    <URL:http://www.ibr.cs.tu-bs.de/~schoenw/>
> 
>