Subject: RE: Higher level question about flow label

From: [email-masked]
Date: Thu, 30 Aug 2001 00:16:00 +0300

Tony Hain wrote:
> 
> But the point is that no provider will understand or trust the 
> DSCP as it is passed between domains, so BA classification will
> fail after the first provider, and it will even fail there if 
> that provider doesn't trust the host to mark it correctly.
> 

There is no question of trust here. Every packet needs to be policed as
marked (i.e. if you "lie", you also pay more, or get down-marked). If there
would be no local mapping of the DSCP value, I don't see why it should not
work over multiple domains.
> 
> > To me it is simple:  I see the IPv6 main header divided 
> into functions
> > for forwarding, 
> > and functions for QoS. 
> 
> You appear to have forgotten that the endpoints need to
> communicate with each other. The header is also used for
> that primary function, or the others will not matter.
> 

That's why there is the source address in the header, in addition to the
"functions for forwarding". The only other field in the IPv6 header that is
NOT used for forwarding or QoS, is the "Next Header" field. Well, there is
the Version field as well, but I agree with Alex, the main IPv6 header has
only functions for forwarding and QoS (forwarding treatment).

	Jarno
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Tony Hain" <[email-masked]>
Date: Wed, 29 Aug 2001 16:07:16 -0700

Jarno Rajahalme wrote:

> If there would be no local mapping of the DSCP value, 
> I don't see why it should not

I agree completely, but that was my point about trust. The 
operators were telling the diffserv WG that they would 
refuse to deploy unless they had the ability to ignore what
the origin said and mark the bits the way they wanted to
because they couldn't trust the origin not to lie.

Tony