Subject: RE: a), b), c), d), or e)

From: Bob Hinden <[email-masked]>
Date: Thu, 30 Aug 2001 17:15:09 -0700

Yes, that was my intent.  Thanks for catching this.

Bob

At 11:31 PM 8/29/2001 +0300, [email-masked] wrote:
>Brian,
>
>Maybe Bob meant just IPv6 tunneled over IPv4, not protocol translation?
>
>         Jarno
>
>Brian E Carpenter wrote:
> > Bob Hinden wrote:
> > >
> > ..
> > > I think you are going a bit far to suggest that the fate of Diffserv
> > > depends on what the IPv6 w.g. does with the flow label
> > field.  I suspect
> > > that Diffserv will live or die based on IPv4 usage.  Also,
> > as IPv6 is
> > > deployed much of it will be initially carried over IPv4.
> > Any QoS solution
> > > that is going to be end-to-end will have to deal with a mix
> > of native IPv6
> > > and IPv4/IPv6 headers.
> >
> > Indeed, and since I don't quite see how IPSEC and NAT-PT are going to
> > work together, the need that triggered this discussion (the need to
> > classify ESP packets in the middle of the Internet) really
> > doesn't arise
> > in the case of translated packets. The concern is for a
> > native IPv6 environment.
> >
> >   Brian

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Aug 2001 10:44:57 -0500

OK. The case of unencrypted tunnels is covered by RFC 2983, as well as
a mention of protocol translation. But it doesn't analyse the case
of reclassifying ESP-protected packets.

  Brian