Subject: RE: uni-based-mcast and malloc-ipv6-guide

From: "Dave Thaler" <[email-masked]>
Date: Mon, 17 Sep 2001 15:56:27 -0700

> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]]
> Sent: Monday, September 17, 2001 3:40 PM
> To: Thomas Narten
> Cc: Dave Thaler; Erik Nordmark; [email-masked];
> [email-masked]
> Subject: Re: uni-based-mcast and malloc-ipv6-guide
> 
> Thomas Narten wrote:
> 
> > > How so?  One can renew multicast addresses.  (Conceivably an
> > > implementation could support the ability to automatically renew
> > > multicast addresses as long as the unicast address stays valid.)
> >
> > Suppose I want to get a multicast address so I can advertise a
session
> > (e.g., on a web page). I do this two weeks in advance of the event.
I
> > want the address to last one day only. The key point is that I will
> > want to use the address staring two weeks from now.
> >
> > However, because unicast lifetimes are only a week, that's too far
> > into the future to actually get the address (yet), so the address
> > can't be obtained yet. This would seem like it might be a problem.
Is
> > it? (I don't know how this scenario fits with the way multicast is
> > actually used in IPv4, so this really is a question.)
> >
> > Thomas
> 
> In IPv4 I would say, use a GLOP address for this. (We'll rent you one
if
> you don't have any.)

GLOP has exactly the same issue for end sites that don't own
their own AS #.

When you renumber, chances are it's because you changed your provider,
in which case you can no longer use your old provider's GLOP space.

Uni-based mcast addresses don't require end sites to have their
own AS # (or any other non-aggregatable number).

-Dave
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 17 Sep 2001 19:11:11 -0400

> own AS # (or any other non-aggregatable number).

Hi Dave;

Yes, but he asked "the way multicast is actually used in IPv4".
That's the answer to the question he asked, maybe not to others he
should have asked.
--
                                 Regards
                                 Marshall Eubanks

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.on-the-i.com

Test your network for multicast : http://www.multicasttech.com/mt/
 Check the status of multicast in real time :
 http://www.multicasttech.com/status/index.html