Subject: RE: uni-based-mcast and malloc-ipv6-guide

From: "Dave Thaler" <[email-masked]>
Date: Wed, 19 Sep 2001 10:43:09 -0700

> -----Original Message-----
> From: Erik Nordmark [mailto:[email-masked]]
> Sent: Wednesday, September 19, 2001 2:44 AM
> To: Dave Thaler
> Cc: Dave Thaler; Erik Nordmark; [email-masked];
> [email-masked]
> Subject: RE: uni-based-mcast and malloc-ipv6-guide
> 
> 
> > Another example would be if uni-based mcast prefixes are used
> > with BGMP, or any other scheme, to locate the root (domain) of the
> > multicast tree without doing anything different in BGP.  If the
> > domain loses its old unicast prefix, after which it's advertised
> > by no one, then the derived multicast addresses would similarly
> > be (intentionally) unusable inter-domain.
> 
> Dave,
> 
> If so it would be a fine thing to explicitly document this in the
draft
> as a potential issue.

I don't think this document should mention BGMP or any other specific
protocol.  I think it's fine to state the issue generically (i.e. not
guaranteed to be routed by all protocols).
 
> One of my comments/questions in the first mail (which you passed to
Brian
> as an editorial one) was the issue of what aspects of the IPv4 stuff
we
> need and need not carry forward to IPv6.
> 
> Clearly(?) the documents remove the need for MASC for IPv6. Is that
all?
> Will uni-based have any effect on MBGP and BGMP?
> (I can't find an BGMP draft to even have a peek.)

For this type of address, AAP is not really needed either.
There is no effect on MBGP.
The effect on BGMP is just that it makes it deployable without MASC or
doing anything different with MBGP, and hence provides a much cleaner
solution than MSDP does for IPv4.

I agree that it would be helpful to add a paragraph discussing this in
the draft.

-Dave

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 20 Sep 2001 10:07:18 +0200 (CEST)

> guaranteed to be routed by all protocols).

OK.
But given that I didn't understand the one sentence statement it seems
like this explanation needs to be at least a paragraph if not longer.

> I agree that it would be helpful to add a paragraph discussing this in

Great.

  Erik