Subject: Address Resolution with ND verus MAC address from the EUI-64 form at

From: Huber Matthias <[email-masked]>
Date: Wed, 28 Nov 2001 14:48:34 +0100

Hello all,

I've read already a couple of RFCs and books to familiarize myself with IPv6.
I'm struggling with the following: Neighbor discovery is used to find out the corresponding
Layer-2 address to a given IPv6 unicast address ( similar to the ARP process in IPv4).
On the other hand I have learned that all global aggregatable unicast addresses have to 
use the EUI-64 format for the interface ID. At least in a Ethernet (I think this is 
the majority of  the LANs today) this EUI-64 ID is derived from the MAC address in 
an reversible way. (Simply adding/removing 0xFFFE in the "middle"). So my question is
why do I need the ND in a LAN in order to do the address resolution ???
I know that there must be a simple reason, but I don't know it. 

Is anyone able to sched some light into this ?

Thanks very much
Matt 

Mit freundlichen Grüssen / with kind regards
Matthias Huber

Siemens AG                    		I&C Training Institute
CCSI CCNA                   		ICM CA VZ TI A5
Phone +49 89-722-34051         	Baierbrunnerstrasse 28
Fax +49 89-722-61684               	81359 Munich/Germany
Mail	mailto:[email-masked]

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Dave Marquardt <[email-masked]>
Date: 29 Nov 2001 09:37:04 -0600

"Huber" == Huber Matthias <[email-masked]> writes:

Huber> On the other hand I have learned that all global aggregatable
Huber> unicast addresses have to use the EUI-64 format for the
Huber> interface ID. At least in a Ethernet (I think this is the
Huber> majority of the LANs today) this EUI-64 ID is derived from the
Huber> MAC address in an reversible way. (Simply adding/removing
Huber> 0xFFFE in the "middle"). So my question is why do I need the ND
Huber> in a LAN in order to do the address resolution ???  I know that
Huber> there must be a simple reason, but I don't know it.

No, this isn't correct.  There is no requirement (that I'm aware of)
"that all global aggregatable unicast addresses have to use the EUI-64
format for the interface ID."  Not at all.  So the rest of your
argument, I think, falls apart.
-- 
Dave Marquardt
Sun Microsystems, Inc.
Austin, TX
+1 512 401-1077
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------