Subject: Tunnel Configuration Problem with Cisco routers

From: "mxwickra" <[email-masked]>
Date: Thu, 1 Nov 2001 15:17:04 -0600

hi:

I would appreciate your help.

I am new to IPv6 configuration on Cisco routers. My name is Mohan. I am a stundent 
at Wichita State University.
We have a studnet Cisco lab. My project involves IPv6, IPv4 transition.

I need some help with some IPv6 basics. I tried few times, but just could not get the 'tunnels' to work.

My configuration files follows.

PROBLEM:
IPv6 Traffic does not go thru R7(IPv4) even with tunnels installed?
(for example, ping ipv6 from R3 to int s0/0 in R4 fails)
========================================================================

Network used (IOS 12.2(T), Cisco3640s)

                        s0/0                    s1/0                s1/1                            s0/0
    <R4dual stack> -----serial-link--------<R7/IPv4 only>-----------serial-link--------< R6-IPv6/IPv4 dual stack>
                                                                                                                                |    fa0/0
                                                                                                                    ---------------------
                                                                                                                                |    fa0/0
                                                                                                                            <R3-IPv6 only router>        

========================================================================
Interface Addresses

 IPv4 Address    IPv6 Address

R4 int s0/0 193.30.60.1/24   3001::/64 eui-64

R7 int s1/0 193.30.60.2/24   NA
 int s1/1 156.27.0.2/16   NA

R6 int s0/0 156.27.0.1/16    3001::/64 eui-64
 int fa0/0 10.10.10.1/8   3002::/64 eui-64

R3 int fa0/0    3002::/64 eui-64

==========================================================

Router R6 - dual stack router, runs RIP, RIPv6, connected to IPv6 only router
R3 and IPv4 only router R7
=======================================================================

r6#sh run
Building configuration...

Current configuration : 1564 bytes
!
version 12.2

hostname r6
!
boot system flash:c3640-jk9s-mz.122-2.T.bin

ipv6 unicast-routing
!
interface Tunnel0
 no ip address
 ipv6 address 3FFE:B00:C18:1::3/127
 tunnel source 10.10.10.1
 tunnel destination 20.20.20.1
 tunnel mode ipv6ip
!
interface Tunnel1
 no ip address
 no ip redirects
 tunnel source Serial0/0
 tunnel mode ipv6ip auto-tunnel
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.0.0.0
 duplex auto
 speed auto
 ipv6 address 3002::/64 eui-64
 ipv6 rip Rip6 enable
!
interface Serial0/0
 ip address 156.27.0.1 255.255.0.0
 ipv6 address 3001::/64 eui-64
 ipv6 rip Rip6 enable
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
router rip
 network 10.0.0.0
 network 156.27.0.0
!
!
ipv6 router rip Rip6
!
end

r6#

=======================================================================

r6#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    193.30.60.0/24 [120/1] via 156.27.0.2, 00:00:00, Serial0/0
R    20.0.0.0/8 [120/2] via 156.27.0.2, 00:00:00, Serial0/0
C    156.27.0.0/16 is directly connected, Serial0/0
C    10.0.0.0/8 is directly connected, FastEthernet0/0

======================================================================
r6#sh ipv6 int brief
FastEthernet0/0            [up/up]
    3002::204:9AFF:FE8A:5641
Serial0/0                  [up/up]
    3001::4:9A8A:5641:3
TokenRing0/0               [administratively down/down]
    unassigned
Serial0/1                  [administratively down/down]
    unassigned
ATM2/0                     [administratively down/down]
    unassigned
Tunnel0                    [up/up]
    3FFE:B00:C18:1::3
Tunnel1                    [up/up]
    ::156.27.0.1
==================================================================

r6#sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::204:9AFF:FE8A:5641
  Global unicast address(es):
    3002::204:9AFF:FE8A:5641, subnet is 3002::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF8A:5641
    FF02::9
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
Serial0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::4:9A8A:5641:3
  Global unicast address(es):
    3001::4:9A8A:5641:3, subnet is 3001::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF41:3
    FF02::9
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::A0A:A01
  Global unicast address(es):
    3FFE:B00:C18:1::3, subnet is 3FFE:B00:C18:1::3/127
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF41:A
    FF02::1:FF00:3
    FF02::1:FFC8:D201
    FF02::1:FF0A:A01
  MTU is 1480 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
Tunnel1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::9C1B:1
  Global unicast address(es):
    ::156.27.0.1, subnet is ::/96
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF41:B
    FF02::1:FF1B:1
  MTU is 1480 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
r6#

==================================================================

r6#sh ipv6 rou
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
Timers: Uptime/Expires

L ::156.27.0.1/128 [0/0]
  via ::156.27.0.1, Tunnel1, 00:39:32/never
  via ::, Tunnel1, 00:39:31/never
C ::156.27.0.1/96 [0/0]
  via ::, Tunnel1, 00:39:31/never
L 3001::4:9A8A:5641:3/128 [0/0]
  via ::, Serial0/0, 01:00:07/never
C 3001::/64 [0/0]
  via ::, Serial0/0, 01:00:07/never
L 3002::204:9AFF:FE8A:5641/128 [0/0]
  via ::, FastEthernet0/0, 01:00:07/never
C 3002::/64 [0/0]
  via ::, FastEthernet0/0, 01:00:07/never
L 3FFE:B00:C18:1::3/128 [0/0]
  via ::, Tunnel0, 00:04:02/never
C 3FFE:B00:C18:1::3/127 [0/0]
  via ::, Tunnel0, 00:04:02/never
L FE80::/64 [0/0]
  via ::, Null0, 01:00:07/never
r6#

=============================================================================
=============================================================================

Router R4 -dual stack router at the other end of IPv4 router

r4#sh run
Building configuration...

Current configuration : 1167 bytes
!
version 12.2

hostname r4
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 ipv6 address 3FFE:B00:C18:1::2/127
 tunnel source 20.20.20.1
 tunnel destination 10.10.10.1
 tunnel mode ipv6ip
!
interface Tunnel1
 no ip address
 no ip redirects
 tunnel source Serial0/0
 tunnel mode ipv6ip auto-tunnel
!
interface FastEthernet0/0
 ip address 20.20.20.1 255.0.0.0
 duplex auto
 speed auto
 ipv6 enable
 ipv6 rip rip4 enable
!
interface Serial0/0
 ip address 193.30.60.1 255.255.255.0
 ipv6 address 3001::/64 eui-64
 ipv6 rip rip4 enable
 no fair-queue
!
router rip
 network 20.0.0.0
 network 193.30.60.0
!
!
ipv6 router rip rip4
!
end

r4#
=================================================================

r4#
r4#sh ipv6 rou
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
Timers: Uptime/Expires

L ::193.30.60.1/128 [0/0]
  via ::193.30.60.1, Tunnel1, 00:42:54/never
  via ::, Tunnel1, 00:42:53/never
C ::193.30.60.1/96 [0/0]
  via ::, Tunnel1, 00:42:53/never
L 3001::4:9AE4:4B81:3/128 [0/0]
  via ::, Serial0/0, 01:28:41/never
C 3001::/64 [0/0]
  via ::, Serial0/0, 01:28:41/never
L 3FFE:B00:C18:1::2/128 [0/0]
  via ::, Tunnel0, 00:08:50/never
C 3FFE:B00:C18:1::2/127 [0/0]
  via ::, Tunnel0, 00:08:50/never
L FE80::/64 [0/0]
  via ::, Null0, 01:47:39/never
r4#

======================================================================

r4#
r4#sh ipv6 neigh
r4#sh ipv6 int brief
FastEthernet0/0            [up/up]
    FE80::204:9AFF:FEE4:4B81
Serial0/0                  [up/up]
    3001::4:9AE4:4B81:3
TokenRing0/0               [administratively down/down]
    unassigned
Tunnel0                    [up/up]
    3FFE:B00:C18:1::2
Tunnel1                    [up/up]
    ::193.30.60.1
r4#

=======================================================================

r4#sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::204:9AFF:FEE4:4B81
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::1:FFE4:4B81
    FF02::2
    FF02::9
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
Serial0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::4:9AE4:4B81:3
  Global unicast address(es):
    3001::4:9AE4:4B81:3, subnet is 3001::/64
  Joined group address(es):
    FF02::1
    FF02::1:FF81:3
    FF02::2
    FF02::9
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1414:1401
  Global unicast address(es):
    3FFE:B00:C18:1::2, subnet is 3FFE:B00:C18:1::2/127
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF81:8
    FF02::1:FF00:2
    FF02::1:FFC8:C801
    FF02::1:FF14:1401
  MTU is 1480 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
Tunnel1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C11E:3C01
  Global unicast address(es):
    ::193.30.60.1, subnet is ::/96
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF81:9
    FF02::1:FF1E:3C01
  MTU is 1480 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
r4#
========================================================================

r4#sh ipv6 rip
RIP process "rip4", port 521, multicast-group FF02::9, pid 112
     Administrative distance is 120.  Routing table is 0
     Updates every 30 seconds, expire after 180
     Holddown lasts 180 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 221, trigger updates 0
r4#

=========================================================================
=========================================================================

r3#sh ipv6 rou
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
Timers: Uptime/Expires

R 3001::/64 [120/2]
  via FE80::204:9AFF:FE8A:5641, FastEthernet0/0, 00:02:07/00:02:47
L 3002::204:9AFF:FEE4:4B61/128 [0/0]
  via ::, FastEthernet0/0, 02:50:48/never
C 3002::/64 [0/0]
  via ::, FastEthernet0/0, 02:50:48/never
L FE80::/64 [0/0]
  via ::, Null0, 02:50:48/never

==================================================================

r3#ping ipv6 3001::4:9A8A:5641:3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3001::4:9A8A:5641:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r3#ping ipv6 3001::4:9AE4:4B81:3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3001::4:9AE4:4B81:3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

==================================================================
r3#sh run
Building configuration...

Current configuration : 916 bytes
!
version 12.2

hostname r3
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.0.0.0
 duplex auto
 speed auto
 ipv6 address 3002::/64 eui-64
 ipv6 rip rip3 enable
 ipv6 rip rip3 default-information originate
!
!
ipv6 router rip rip3
!
end

==================================================================
r3#

r3#sh ipv6 neigh
IPv6 Address                              Age Link-layer Addr State Interface
3002::204:9AFF:FE8A:5641                  131 0004.9a8a.5641  STALE FastEthernet
0/0
FE80::204:9AFF:FE8A:5641                    2 0004.9a8a.5641  STALE FastEthernet
0/0

r3#

==================================================================
r3#sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::204:9AFF:FEE4:4B61
  Global unicast address(es):
    3002::204:9AFF:FEE4:4B61, subnet is 3002::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FFE4:4B61
    FF02::9
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
r3#

====================================================================
====================================================================

r7#sh run
Building configuration...

version 12.2

hostname r7
!
!
interface Serial1/0
 ip address 193.30.60.2 255.255.255.0
 clockrate 2000000
!
interface Serial1/1
 ip address 156.27.0.2 255.255.0.0
 clockrate 2000000
!
router rip
 network 193.30.60.0
 network 156.27.0.0
!
end

r7#

---

From: Ole Troan <[email-masked]>
Date: Fri, 02 Nov 2001 00:52:14 +0000

Mxwickra,

this list is for IPv6 standardisation work. feel free to contact cisco
support directly for your issues. the TAC for released software, or
[email-masked] for IPv6 beta/EFT software.

cheers,
Ole

> (for example, ping ipv6 from R3 to int s0/0 in R4 fails)
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------