Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols

From: Keith Moore <[email-masked]>
Date: Thu, 13 Jun 2002 08:38:40 -0400

> developers who use link-local for customer apps are going to get burned. 

tell that to the zeroconf folks.
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 08:37:15 -0400

developers who use link-local for customer apps are going to get burned. How many apps only run on a link?  not many.  if we kill all but global, mulicast, and link-local it will be prevented by programmer ipv6 evolution.  

/jim

> -----Original Message-----
> From: Keith Moore [mailto:[email-masked]]
> Sent: Friday, June 07, 2002 12:23 PM
> To: R.P. Aditya
> Cc: [email-masked]
> Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols 
> 
> 
> > For link-local addresses, as long as the scope is
> > well-defined, what are your objections?
> 
> for the most part, they're only a problem if you try to use
> them in applications (where zero-configuration appliances
> are an important subset of applications)
> 
> part of the problem is that the scope of link-local addresses
> is *not* well-defined from an application's point of view,
> since applications in general don't know, and shouldn't have
> to know, about network topology.
> 
> (scoped addresses in general are a nightmare for apps)
> 
> so LL is fine for RD/ND etc.  but the vast majority of apps
> should never see them.
> 
> unfortunately the zeroconf WG is trying to make LL addresses
> be a general-purpose mechanism for internet appliances to
> obtain an address - perhaps without supporting any mechanism
> to get a global address,  assuming (incorrectly IMHO) that the
> hosts that need to access that appliance will be on the same
> link anyway.
> 
> the problem is not the fact that LL addresses exist, it's that
> there are no well-defined constraints on their use.
> 
> Keith