Subject: Multicast address recommended hop counts?

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 19 Jun 2002 15:25:11 -0500

Is there any document (RFC or draft) that gives any guidance on setting
the hop counts for multicast addresses?

The hop limit is 1 by default (based on the RFC 2553) which is fine for
link-local multicasts, but what about site local or other scoped
multicast addresses?

For example, RFC 2373 lists the following scope values for multicast
groups:
         0  reserved
         1  node-local scope
         2  link-local scope
         3  (unassigned)
         4  (unassigned)
         5  site-local scope
         6  (unassigned)
         7  (unassigned)
         8  organization-local scope
         9  (unassigned)
         A  (unassigned)
         B  (unassigned)
         C  (unassigned)
         D  (unassigned)
         E  global scope
         F  reserved

Is there a corresponding recommended hop count for each of the
assigned scopes:
         1  node-local scope         Hops = 1
         2  link-local scope         Hops = 1
         5  site-local scope         Hops = ? (8, 16, 32?)
         8  organization-local scope Hops = ? (8, 16, 32?)
         E  global scope             Hops = default IP TTL (64)?

- Bernie Volz

---

From: [email-masked]
Date: Thu, 20 Jun 2002 09:22:51 +1000

>          E  global scope             Hops = default IP TTL (64)?

	I wouldn't bother with additional knobs.  Just use the same
	default TTL for site/organization/global.

	Mark
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------