Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols

From: Keith Moore <[email-masked]>
Date: Thu, 13 Jun 2002 08:36:31 -0400

> link-locals are different.  The reason is that link-local is a 
> control mechanisms in the Internet architecture and gives the 
> /etc/init of stateless addr-conf, whereas site-local is a carry 
> over of the band-aid of private addresses from IPv4 gone bad.

I understand the need for LLs.  But it would be a Good Idea IMHO
to explain that they're not intended for general-purpose use
or as a security mechanism, nor to relieve simple devices
of the burden of supporting other mechanisms for acquiring
addresses (and this applies to IPv4 also!)
 
> As an implementor I would love to rip out all but global, multicast, 
> and link-local from the architecture it would be worth the pain and
> as Margaret pointed out in her /etc/init and steve responded to they 
> don't work anywhere now.
 
> Lets kill them.

I'm inclined to agree, at least for SLs.  

Keith
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 08:30:54 -0400

link-locals are different.  The reason is that link-local is a control mechanisms in the Internet architecture and gives the /etc/init of stateless addr-conf, whereas site-local is a carry over of the band-aid of private addresses from IPv4 gone bad.

As an implementor I would love to rip out all but global, multicast, and link-local from the architecture it would be worth the pain and as Margaret pointed out in her /etc/init and steve responded to they don't work anywhere now.

Lets kill them.

/jim

> -----Original Message-----
> From: Keith Moore [mailto:[email-masked]]
> Sent: Thursday, June 06, 2002 3:51 PM
> To: Steven M. Bellovin
> Cc: [email-masked]
> Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols 
> 
> 
> > My strong preference would be to drop site-local addresses 
> completely.
> > I think they're an administrative and technical nightmare.
> 
> for that matter, so are link-local addresses.  they do have some
> legitimate uses, but they need to be kept to a minimum
> (in both ipv6 and ipv4)
> 
> Keith