Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols

From: Keith Moore <[email-masked]>
Date: Thu, 13 Jun 2002 08:43:27 -0400

> Go say FTP or DNS to your private accountant, lawyer, or doctors office 
> they will look at us like we have two heads.

yeah, but they do that no matter what I say to them, unless it's 
"here is your money" :)

I agree that we shouldn't fall into the trap of assuming that everybody
uses the same apps, or that the web and email are the only important use
cases for the 'net. 

Keith
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 08:39:31 -0400

these are what I call "standard" Internet applications that have long lives.  But a NASTRAN MCAD network app should not being using link-local.  The ones people use who use networks and computers to run their business and most users dont see the standard apps anymore except net admins.  Go say FTP or DNS to your private accountant, lawyer, or doctors office they will look at us like we have two heads.

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, June 07, 2002 1:10 PM
> To: Keith Moore
> Cc: R.P. Aditya; [email-masked]
> Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols 
> 
> 
> >> For link-local addresses, as long as the scope is
> >> well-defined, what are your objections?
> >for the most part, they're only a problem if you try to use
> >them in applications (where zero-configuration appliances
> >are an important subset of applications)
> >part of the problem is that the scope of link-local addresses
> >is *not* well-defined from an application's point of view,
> >since applications in general don't know, and shouldn't have
> >to know, about network topology.
> 
> 	as long as the applications are properly implemented 
> with sockaddrs,
> 	they are okay.  the problem reside in protocols that pass IPv6
> 	addresses in payloads (since view of the scope is 
> different by nodes),
> 	including:
> 	- FTP (EPSV/EPRT does not help - for instance, how do you decide
> 	  the scope zone for data connection?)
> 	- DNS (AAAA/PTR does not represent scope correctly)
> 	- and all NAT-unfriendly protocols
> 
> 	I'm okay to see site-local IPv6 address to go away, however, I'm
> 	worried because there are more than a couple of 
> protocols designed with
> 	site-local IPv6 address in mind (DHCPv6, router 
> renumbering, ...).
> 
> 	we need to keep link-local IPv6 address at least for 
> ND.  use of 
> 	link-locals within zeroconf environment needs further study.
> 
> itojun