Subject: RE: Fwd: IPv6 Scoped Addresses and Routing Protocols

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 09:11:40 -0400

Without managing protocols like icmp or mibs or something to use this then its still a  virtual abstraction in the code that must be understoond.  the room for error or isolating nodes incorrectly in a network design is very bad.  In my role as consultant to several large deployers of IPv6 with mission critical networks where lives are at stake I strongly advise to not even use them.  anycast as I said before is close to being a bad idea too but that maybe is workable.

Read the latest architectural Internet doc  by Bush et al.  Lets keep it simple.  site-locals IMO kill that Internet principle completely.

Good diagram too.

/jim

> -----Original Message-----
> From: Bill Fenner [mailto:[email-masked]]
> Sent: Monday, June 10, 2002 4:01 PM
> To: [email-masked]
> Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols
> 
> 
> 
> An example that may be a little too contrived:
> 
> 			      H1
> 			      |
>                               |//
>                       B-------A
>                      /      // \
> 		    /          |
> 		    |          |
> 		    C          D
> 		    |          |
> 		    |          |
> 		    \       \\ /
> 		     E--------F
> 			      |\\
> 			      |
> 			      H2
> 
> A,B,C,E,F are in one site (on the left); A, D, and F are in 
> another site (or
> no site).  H1 is connected to A, and H2 is connected to F.
> 
> It's fairly clear how to allow A and F to not advertise site-local
> addresses across the boundary (at least, as long as it 
> coincides with a
> routing protocol boundary, e.g. OSPF area).  However, if H1 knows that
> H2 is witchin the same site, H1 is allowed to use its 
> site-local source
> address to send to H2's global address.  However, along the 
> H1-A-D-F-H2
> path, A would have to drop the packet because it has a 
> site-local address
> and is trying to cross a site boundary.
> 
> 
> Although this example is a bit contrived, it comes close to describing
> the topology at AT&T, with Research split between the coasts and both
> a private link (e.g. the internal site link) and links to the AT&T
> internal network (which is still organizational-internal, so it's
> reasonable to speak an IGP).
> 
>   Bill
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Randy Bush <[email-masked]>
Date: Thu, 13 Jun 2002 12:57:49 -0700

> Read the latest architectural Internet doc  by Bush et al.

from the credit where due department: dave meyer was the principal author