Subject: RE: Fwd: IPv6 Scoped Addresses and Routing Protocols

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 09:04:33 -0400

randy,

I know how this must work and its even more horrifying than you might imagine.

What you have to do in a nutshell is add tons of context and management to the implementation to note the boundaries and then the sub-boundaries as you can have in the future org-scope, or dept-scope and on and on.  Its insane to keep this in the architecture.  And NO ONE has it working and the code to be removed is insignificant. As Jinmei pointed out with the API as one example.

yes we have to manage more state with anycast but that is minimal and well defined. that is good and ok.

Also this is not the case for link-local.  The reason is that the links are hardwired in the implementation and treating them as zones works for links.  But sites are "virtual".

The entire use of them is bogus IMO.

/jim

> -----Original Message-----
> From: Randy Bush [mailto:[email-masked]]
> Sent: Monday, June 10, 2002 7:07 AM
> To: Francis Dupont
> Cc: Steven M. Bellovin; [email-masked]
> Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols 
> 
> 
> >> But as site is rather vaguely defined, I think many 
> vendors just skip
> >> this little detail..
> > I disagree: we have a similar but more complex issue for multicast
> > forwarding and the zone boundary check is very easy to implement
> 
> cool.  how do you detect that you are at the edge of a site?
> 
> randy
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Fri, 14 Jun 2002 14:17:09 +0700

Date:        Thu, 13 Jun 2002 09:04:33 -0400
    From:        "Bound, Jim" <[email-masked]>
    Message-ID:  <[email-masked]>

  | Also this is not the case for link-local.  The reason is that the links
  | are hardwired in the implementation and treating them as zones works for
  | links.  But sites are "virtual".

More FUD...

Sites are only "virtual" until someone decides which links belong to the
site, and which do not, and configures things that way.

They're no more virtual than an ATM based link level, where someone has
to decide which ATM PVCs and SVCs perhaps are part of the link, and which
are not, and/or any modern switch where someone has to decide which ports
belong to which VLAN.

Once configured, any and all of these things are just as real as each
other.

kre