Subject: RE: Mandating Route Optimization

From: [email-masked]
Date: Sat, 1 Jun 2002 06:59:03 +0300

Hi Jari,

> P.S. John: I believe the current drafts do describe how to use RO.
> They even describe how to survive the situation that the peer does
> not implement RO. So in this respect I don't think we need anything
> new. See e.g. MN state machine 'WaitHC' state and the ICMP action.
> Please let us know if something additional is needed. At the moment
> I don't see it.

Good.  I have to catch-up on my reading.  If that is in the document,
I am satisfied.

thanks,
John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Sun, 2 Jun 2002 17:52:52 -0700

Hi Charlie,

One reason might be that the correspondent node has detected an attempt
to divert traffic to a node which does not legitimately possess the home
address is is trying to divert from. A sysadmin might want to shut off
route optimization until the attacker was discovered or gave up.

            jak

----- Original Message -----
From: "Charles E. Perkins" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, May 31, 2002 9:49 AM
Subject: Re: Mandating Route Optimization

>
> Hello John,
>
> [email-masked] wrote:
>
> >                   I do think that additional work
> > will be needed to detail how RO is used, if there
> > is a need for protocol negotiation, etc. I think
> > that the important thing is to have a strong
> > statement of support for implementing RO.  How
> > RO is used probably needs some real deployment
> > experience, etc.  I think that RO needs to be
> > implemented, but its use is probably still open
> > to local control, etc.
>
> If there is any issue here, it is mainly a matter
> of allowing mobile nodes to hide their location.
> That's simple -- the node should simply do reverse
> tunneling, and not issue HoTI and CoTI.
>
> I can't imagine a reason why a correspondent node
> would prefer to have traffic going through the
> home network rather than directly to its mobile
> communications partner, but if there is a reason,
> then certainly the correspondent node can simply
> avoid sending HoT and CoT.
>
> Even with HoTI, CoTI, HoT, CoT, and BU mandated
> for implementation, the mobile nodes still have
> to correctly and courteously handle the cases
> where HoT and CoT and even Binding Error messages
> are never received.
>
> I hope these matters will be viewed as specified
> clearly.  Anywhere they are not, we should fix.
>
> Regards,
> Charlie P.

---

From: [email-masked]
Date: Tue, 4 Jun 2002 13:37:14 +0300

Dear list,

this issue is taking much time and ammunition, and it's mostly wasted. We know that the decision between MUST and SHOULD will be made in the IESG, not here. It all boils down to interpreting the words of RFC2119.

The make some progress, I'd like to suggest a work plan.
Step 1: someone near to the IESG members asks, if we have an option at all. Even an unofficial opinion would help.
Step 2: if MUST seems possible, list the reasons for it. A few use cases and pointers to research reports would be ideal.
Step 3: if the IESG keeps on throwing the book at us, accept SHOULD, but add the results of step 2 to the draft.

Even SHOULD with the explanations seems acceptable to me ("SHOULD with teeth" said John Loughney). Good reasons can be more persuasive than plain orders.

> -----Original Message-----
> From: ext Charles E. Perkins [mailto:[email-masked]]
<...> 
> I reckon that before IETF last call on any universal IPv6 mandate,
> the mobile-ip working group will have the responsibility to make
> the reasons for the mandate clear.

Excellent! We already have a volunteer for step 2 :-)

-- Lassi

---

From: [email-masked]
Date: Fri, 7 Jun 2002 13:53:04 +0300

Hi Derek,

> for routers => SHOULD
> for minimal nodes => MAY
> for other nodes => MUST

From the entire 'Cellular Hosts' discussion, I have learned that
the concept of 'minimal nodes' is in the eye of the beholder
and quite temporal at that.  

I think we can clearly diffentiate between routers and hosts,
beyond that I am not sure it is a good idea to differentiate
further.

John

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 08:33:29 -0400

I agree.  Its just not a good use of our time or to get this spec done.
/jim

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, June 07, 2002 6:53 AM
> To: [email-masked]; [email-masked]
> Subject: RE: Mandating Route Optimization
> 
> 
> Hi Derek,
> 
> > for routers => SHOULD
> > for minimal nodes => MAY
> > for other nodes => MUST
>