Subject: RE: Fwd: IPv6 Scoped Addresses and Routing Protocols

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 08:59:58 -0400

Exactly.  The entire IPv6 code base would be reduced in size and more importantly the decision constructs and data struct lookups which is a big win.

Lets face it site-locals are very painful for real development currently and in the long run will produce more bugs in all our products (handhelds, servers, routers, clients) and adds another degree of complexity to all our IETF protocols like SCTP.

Lets kill them.:--)

/jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: Monday, June 10, 2002 2:53 AM
> To: Margaret Wasserman
> Cc: Brian Haberman; [email-masked]
> Subject: Re: Fwd: IPv6 Scoped Addresses and Routing Protocols
> 
> 
> >>>>> On Sun, 09 Jun 2002 18:56:11 -0400, 
> >>>>> Margaret Wasserman <[email-masked]> said:
> 
> > I'm also concerned about the complexity that site-local addressing
> > adds to an IPv6 host.  Looking at the default address 
> selection rules,
> > it appears that host implementations will be impacted by site-local
> > addressing (implementation size and complexity), even in cases 
> > where it isn't really used.
> 
> Regarding the default address selection rules, I don't think
> site-local adds much stuff.  We also need to handle link-local in the
> selection rules, which could impact the host implementations enough.
> 
> In fact, in our implementation of the address selection, there is only
> few additional code that is specific to site-local.
> 
> If the host implementation is *completely* unconscious of scoped
> addresses (which would be the case for some "minimal" implementation),
> it will be able to reduce much on the size and complexity.
> 
> 					JINMEI, Tatuya
> 					Communication Platform Lab.
> 					Corporate R&D Center, 
> Toshiba Corp.
> 					[email-masked]
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Fri, 14 Jun 2002 14:13:01 +0700

Date:        Thu, 13 Jun 2002 08:59:58 -0400
    From:        "Bound, Jim" <[email-masked]>
    Message-ID:  <[email-masked]>

  | Exactly.  The entire IPv6 code base would be reduced in size and more
  | importantly the decision constructs and data struct lookups which is a 
  | big win.

Can you actually justify that, or is this just more nonsense?

Remember that as long as link locals stay, and as long as their are
apps that use them (doesn't BGP peering use LL's these days?) then all
of the system support for scoped addresses has to remain, including the
data structs, API's, ...

What you would gain by removing them is the change from testing
fe80::/9 into testing fe80::/10 when deciding if the address you
have is one that also needs a scope.   Beyond that it is essentially
all the same if scopes are involved - are the scopes for source &
destination the same, etc - regardless of whether it is fe80::/10 or
fec0::/10 that the address happens to be.

So, just where is this saving?

kre