Subject: RE: [mobile-ip] Re: HAO and BE processing will be mandated

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 17 Jul 2002 23:44:59 +0200

> [email-masked] writes:
  >  > >it is. if a CN does not support HAO, it will send an 
  > ICMP error message
  >  > >pointing to the offending octet. when the MN receives 
  > this message, it
  >  > >starts reverse-tunneling through the Home Agent. where 
  > is the problem?
  >  > >if this is not clearly specified in the MIPv6 draft, it 
  > can be. the 
  >  > >binding error functionality can also be substituted by 
  > an ICMP error.
  >  > >Binding Error was specified so that it is easier for 
  > the MN to figure
  >  > >out whats going on.
  >  > 
  >  > 	then I see no reason for the MUST.
  > 
  > Sez RFC 2119:
  > 
  > 6. Guidance in the use of these Imperatives
  > 
  >    Imperatives of the type defined in this memo must be 
  > used with care
  >    and sparingly.  In particular, they MUST only be used where it is
  >    actually required for interoperation or to limit 
  > behavior which has
  >    potential for causing harm (e.g., limiting retransmisssions)  For
  >    example, they must not be used to try to impose a 
  > particular method
  >    on implementors where the method is not required for
  >    interoperability.
  > 
  > Given that MIPv6 will interoperate without binding
  > code in CN's, it looks pretty much like a SHOULD
  > to me. Indeed, the protocol would not be robust if
  > it didn't consider the case of a non-conformant CN.

=> Exactly, IMHO the support for HAO is tied to
RO support which is a SHOULD anyway, so the HAO
should follow that. 

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 17 Jul 2002 14:51:40 -0700

hi Hesham,

> RO support which is a SHOULD anyway, so the HAO

we have been through this before. the support for HAO is tied
to the verifiability of the home address (otherwise you can
have reflection attacks). there are other mechanisms apart
from RO to verify a particular home address. I am not going
to get into those mechanisms now. check the archives.

Vijay