Subject: regarding ipv6 - ipv4 router configuration

From: jaganbabu rajamanickam <[email-masked]>
Date: Tue, 2 Jul 2002 06:07:28 +0100 (BST)

Hi,
  I have a basic question on configuring IPV6 router
with IPV4 peer.

 +--------+             +--------+
 |        |             |        |
 |        |IF1          |        |
 |  R1    |<----------->|   R2   |
 |        |         IF2 |        |
 +--------+             +--------+

  If R1 is router which supports both IPV6 and IPV4
stack.
  If R2 is simple IPV4 router.

   so in the above case, should the interface address
at R1 (IF1) be of IPV4 address, since it is connecting
to another router "R2" which is an IPV4 router.

Thanx,
Jags

________________________________________________________________________
Want to sell your car? advertise on Yahoo Autos Classifieds. It's Free!!
       visit http://in.autos.yahoo.com
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Vikram Shekhar" <[email-masked]>
Date: Tue, 2 Jul 2002 10:46:43 +0530

The interface for the router R1 will still be with the ipv6 addressing
since, ipv6 also supports ipv4.

Whenever it receives a packet of type ipv4, it should be encapsulated
into ipv6 at the IF1.
To transmit a packet out for ipv4, the ipv6 packet from IF1 will again be
transmitted
as an ipv4 packed instead of ipv6.

The ipv6 provides compatibility between the other version, and hence should
not pose any conflict.

Vikram Shekhar

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of jaganbabu rajamanickam
Sent: Tuesday, July 02, 2002 10:37 AM
To: [email-masked]
Subject: regarding ipv6 - ipv4 router configuration

Hi,

 +--------+             +--------+
 |        |             |        |
 |        |IF1          |        |

Thanx,
Jags

---

From: jaganbabu rajamanickam <[email-masked]>
Date: Tue, 2 Jul 2002 14:16:35 +0100 (BST)

Hi,
  If we have just ipv6 address configured at the
router R1 interface (IF1), then if i need to have a
BGP peering sesssion between IPV6 router and an IPV4
router, then how the IPV4 socket will get connected to
the IPV6 router (R1), because in the case of IPV4
router, while creating the socket we need to give the
negibouring ip address(only IPV4 address), since my
neighboring interface IP address is of IPV6 address it
won't be possible for me to create an socket from IPV4
router to the IPV6 router.
  so my utlimate question is that it necessery to have
an IPV4 address at the interface IF1 (IPV4 to IPV6
translated address).

Thanx,
Jags

--- Vikram Shekhar <[email-masked]> wrote: > The
interface for the router R1 will still be with
> the ipv6 addressing

---

From: jaganbabu rajamanickam <[email-masked]>
Date: Tue, 2 Jul 2002 14:16:35 +0100 (BST)

Hi,

Thanx,
Jags