Subject: RE: [mobile-ip] Re: HAO and BE processing will be mandated

From: Pekka Savola <[email-masked]>
Date: Mon, 22 Jul 2002 21:41:33 +0300 (EEST)

Trimmed up the Cc: list a bit.  I think this is getting way off topic
though..

On Mon, 22 Jul 2002, Kuntal Chowdhury wrote:

> Here are two of the reasons why I think RO will be undesirable:
>  
> 1. It allows the users to entirely bypass the home IP provider's network.
> This will keep the home IP network providers out of added revenue streams.
> The situation will be even worse when the AAA clients for accounting are in
> the home IP network which will not be in the data path due to RO.

The data does not go to the home IP provider's network so there is 
absolutely zero reason be able to gain revenue from that.  
  
> 2. Imposes unnecessary processing requirement on ALL IPv6 devices to support
> this non-mandatory functionality.

My personal opinion is a SHOULD, but I think 'unnecessary' is a bit harsh.
  
> Here is a reason why I think RO will be meaningless:
>  
> The core of the internet is managed by large carriers. These carriers use
> (or will be using) Constrained Based Routing (OSPF-TE) instead of plain
> OSPF. 

In which world?

> The main purpose is traffic engineering. Therefore the path between
> the CN and the MN may not always be the shortest one even with RO. It
> entirely depends on the traffic engineering of the intervening networks. As
> an example:
> If the CN is in Chicago, MN is in Dallas and the HA is in Miami, if the
> shortest route between Chicago and Dallas has less weight (not preferred by
> OSPF-TE) then all the IP packets between CN and the MN will be routed via an
> alternative path which may well be via Miami. Therefore RO will be a waste
> of time and resource.

If TE is used to route the traffic via such slow paths the difference is 
noticeable (at least, without measurement tools), the network is designed 
and operated badly, period.  Nobody would want to pay for that kind of 
service.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Kuntal Chowdhury" <[email-masked]>
Date: Mon, 22 Jul 2002 13:13:36 -0500

OSPF. The main purpose is traffic engineering. Therefore the path between

Regards,
Kuntal

>Michael Thomas wrote: 
>>    Frankly, I don't think that there is any evidence 
>>    that the net would be substantially harmed if RO 
>>    wasn't widely implemented and/or enabled. Indeed, 
>>    I think  there's good reason to believe that many/most 
>>    nodes will not enable RO even if their kernel 
>>    implements it. In some cases, it's likely to be 
>>    a nice and useful optimization, but I really 
>>    don't see it as a "if we don't do this the net 
>>    will fall apart". As such, SHOULD seems like it 
>>    strikes the right balance. 
>> 
>>              Mike 
>> 
>
>I could not agree more with this point. RO would be a required 
>functionality a number of years back, when the net was in it's 
>infancy and bandwidth availability in the backbone networks 
>(even transoceanic links) were severely limited. 
>We are in the age of OC-192/768s over DWDM. The delay that an IP 
>packet incurs in the core is almost negligible. 
>If bottleneck in the HA is the primary driver for RO, then it is 
>possible to solve the problem with load balancing with DHAAD. 
>
>My two cents. 
 
RO gives you the capability of having two end-points connected without
having to rely on intermediate nodes such as the HA being
involved. The HA is not the bottleneck. One of the benefits of RO is
lesser traffic in the backbone and to a certain degree reduced
latency. But these are some of the lesser motivations. 
 
Having a mobile anchored at some point in the network (HA) when it is
non-essential is just not the right approach. Mandating HAO processing
in all IPv6 nodes is the only way to accomplish this and reverse
tunnelling or having a node anchored at the HA is an option only for
backward compatibility to the nodes that already deployed (which is a
pretty small percentage of IP nodes).
 
>Regards, 
>Kuntal 
 
-Basavaraj

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Mon, 22 Jul 2002 13:46:11 -0700

RE: [mobile-ip] Re: HAO and BE processing will be mandated  Here are two of the reasons why I think RO will be undesirable:
 
  1. It allows the users to entirely bypass the home IP provider's network. This will keep the home  
  IP network providers out of added revenue streams. The situation will be even worse when the  
  AAA clients for accounting are in the home IP network which will not be in the data path due to 
  RO.

This is not a techical reason, this is a business reason. If we get into this aspect
of technology deployment, protocol designs might change in rather strange ways :)
I don't think we want to go there.

Also, if any operator is trying to bill users by baning route optimizations, what is their
plan for non-Mobile IP? What happens when mobile node uses its care-of address
as its end point of a communication?

Despite any protocol work here, an operator can still force all the traffic to
flow through home network, if it is determined to do so...

alper

---

From: Jari Arkko <[email-masked]>
Date: Tue, 23 Jul 2002 11:25:39 +0300

> Here are two of the reasons why I think RO will be undesirable:

There might be reasons at some situations to not do RO. But
the spec already allows for that, either by the decision of the
MN or the CN.

So, we can cover the situations that you list, whether or not
your reasons are valid. So can we please close this discussion,
and concentrate only the discussion of what functionality is
mandatory to support in the CNs?

Jari