Subject: RE: IPv6 w.g. Last Call on "Well known site local unicast addres ses for DNS resolver"

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 17 Oct 2002 16:40:29 +0200

> I must chime in to say I dislike this approach a bit, but 
  > it could be
  > salvageable.  (Though, I must admit I like an option in RA's more..)
  > 
  > Most of all, I dislike using *3* well known site local 
  > addresses.  One
  > should suffice just fine.  Remember that this mechanism, at 
  > least in my
  > eyes, is intended for *bootstrapping* only.  

=> Hmm. I wonder if 1 address is enough. What if _that_
DNS crashed? Of course we can reuse that same address
on other DNSs... oops we can't use anycast. 

I didn't really get the impression about this mechanism
is only for bootstrapping, although the example you
mention can certainly be done. Maybe the authors or 
someone else can clarify.

After there is 
  > something that
  > works, one could use some other mechanism (e.g. a DNS lookup :-) to
  > discover *real* DNS server addresses and ignore the site 
  > local.  It seems
  > to me that _3_ addresses just triples delays (5-10 seconds 
  > each, per DNS
  > lookup?) if none of those have been configured in the site.

=> I think you're arguing for "how a host knows
if it should use this mechanism" or "what is the 
deafult?". If this question is handled, the number of 
addresses is only relevant for redundancy. 

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 21 Oct 2002 00:30:00 +0200

> At Thu, 17 Oct 2002 19:03:48 +0200, Hesham Soliman wrote:
  > > 
  > > Are you assuming that more than one server will be configured with
  > > the same well-known site-local address? Because I don't think this
  > > is necessary, now that we have 3 different addresses. The binding
  > > betweem the well-known address and the name server need 
  > not change.
  > 
  > Since the alleged purpose of this mechanism is to avoid 
  > using any kind
  > of real discovery protocol, and given the discussion of route
  > injection in the draft, I am assuming that the recovery 
  > mechanisms in
  > case of a server failure may include fiddling with the 
  > routing system.

=> I didn't get that impression. You mean if 3 servers 
fail at the same time ? I don't have a problem with
assuming that the DNS discovery mechanism in this draft
will fail if all 3 servers fail at the same time. 
Perhaps we can can add that to the draft. 

Hesham