Subject: RE: Optimistic DAD draft ...

From: "Bound, Jim" <[email-masked]>
Date: Thu, 17 Oct 2002 02:34:59 -0400

Nick,

Have you tested hmipv6 to the scale that mobility operator working with
ISPs can cover the entire metropolis of L.A.?  

If your saying these tests can support moving a draft to PS I agree.

But I would have agreed to moving hpmipv6 to PS last year.

No one has deployed layer 3 in production environment I am aware of?

Nor would I trust it yet simply because of this mail discussion.

I will do technical detailed implementation analysis of James's draft
and have asked mobile node comrades to test it.  But I am tired of
chasing ghosts in the IETF but I will yet one more time.

Thanks
/jim

-----Original Message-----
From: Nick 'Sharkey' Moore [mailto:[email-masked]] 
Sent: Wednesday, October 16, 2002 6:46 PM
To: Bound, Jim
Cc: Alper E. YEGIN; [email-masked]; Pekka Savola;
[email-masked]
Subject: Re: Optimistic DAD draft ...

On Wed, Oct 16, 2002 at 11:18:52AM -0400, Bound, Jim wrote:
> Alper,
> 
> None of us working on this are even clear layer 3 handover will ever
> work?  Not sure if that matters does it?  Are we talking about the
> future?

We're pretty clear on this: we've tested it.

The significant delays are:

* 100-1000ms Network RTT for binding updates (FIX: hmipv6, etc)
* 1000ms DAD timeout delay (FIX: Optimistic DAD, etc)
* 200ms+ L2 handover delay (argh!)

----N

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Thu, 17 Oct 2002 17:44:57 +1000

On Thu, Oct 17, 2002 at 02:34:59AM -0400, Bound, Jim wrote:
> > > Bound, Jim wrote:

To clarify: we've been doing some work to identify and isolate
the causes of L3 handover delays, and they each seem solvable
by one means or another.

For example, hmipv6 offers one possible way of eliminating the RTT
delay caused by sending BUs. In its current form, it probably
isn't scalable to that level, but sadly I don't have a megapolis
to test it with -- I'm a research engineer not a product engineer :-)

Actually, JinHyeock reminded me that I'd forgotten to mention
the Movement Detection Delay ... we've been tackling that
with inter-layer signalling to prompt router solicitations.

> Nor would I trust it yet simply because of this mail discussion.

Ummm ... I hope it isn't my Optimism which has caused your 
concerns ... although if you've got technical comments or
concerns re: my draft I'd love to hear them.  It is, after
all, a work in progress.

The Optimistic DAD thing comes about because I thought
the FH stuff was getting a bit theoretical and I felt that a
set of small, easily implemented patches, one per cause of
L3 handover delay, would be a good way to move forward in the
short term.

cheers,
-----Nick

---

From: "James Kempf" <[email-masked]>
Date: Thu, 17 Oct 2002 08:24:36 -0700

Nick,

> to test it with -- I'm a research engineer not a product engineer :-)

With the latest FMIPv6 draft, HMIP isn't really necessary as a handover
optimization technology, though it can contribute if routers supporting FMIPv6
are not an option. However, it is very useful for providing a primitive form of
location privacy, because it hides movement within a geographical area. The
European Union issues an opinion last spring (Opinion 2/2002: On the use of
unique identifiers in telecommunications equipment: the example of IPv6) which
discusses location privacy. HMIPv6 would be useful in satisfying that
requirement.

W.r.t. scalability, simulation is typically the best way to test scalability
lacking a megapolis. I think it would be extremely useful to have a simulation
of HMIP. There are caveats in using simulation, of course. I don't think
simulation is necessary to go to PS, however, it will certainly be necessary for
recommending HMIP to operators who are interested in deployment.

                jak

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Fri, 18 Oct 2002 08:52:32 +1000

G'day James,

On Thu, Oct 17, 2002 at 08:24:36AM -0700, James Kempf wrote:
> optimization technology, though it can contribute if routers supporting
> FMIPv6 are not an option.

With all the ... uh ... debate surrounding FMIP drafts, I figured
I'd just pick an example I'm more familiar with.  Pretty much
any mechanism which allows you to keep a stable CoA will work to
eliminate the BU RTT delay.

I've been thinking about it a bit too, and in many ways the HMIP and
three-party-handover mechanisms reduce to the same thing if you
think of the MAP as a kind of dummy AR ...

> W.r.t. scalability, simulation is typically the best way to test
> scalability lacking a megapolis.

Yep, we've got some folks here working on an IPv6 simulation
suite with OMNeT++, and getting MIP / HMIP / FMIP / etc
functionality in there.  I'm hoping I can convince them to
run me up a million node Optimistic DAD testbed ...

-----N