Subject: RE: IPv6 subnet-local addresses and draft-ietf-ipngwg-addr-arch-v3-10.txt

From: "Dave Thaler" <[email-masked]>
Date: Thu, 10 Oct 2002 09:44:06 -0700

> > > >>From: Brian Haberman [mailto:[email-masked]]
> > > >>
> > > >>>>The more I think about it, the more I realize that
"automagically"
> > > >>>>creating the subnet-local scope zone id isn't going to work.
> > > >>>>Especially with multiple prefixes per interface.
> > > >>>
> > > >
> > > > Why not?  Can you elaborate?
> > > > Shouldn't it always be true that if any two interfaces have the
> > > > same (non-link-local) subnet prefix, then their subnet-local
> > > > zone id MUST be the same?
> > >
> > > What happens to the zone ids when:
> > >
> > >       1. Interface 1 has prefix1 and prefix2
> > >       2. Interface 2 has prefix1 and prefix3
> > >       3. Interface 3 has prefix2 and prefix4
> >
> > According to the default rule, all three are in the
> > same subnet-local zone.  You've just chosen for some
> > reason not to advertise some prefixes on some links.
> > Personally, I'd put this in the category of "don't do that",
> > just like I wouldn't recommend using using different subnet
> > ids for different prefixes on the same link.
> 
> Why are some prefixes not advertised?

Apparently because some admin configured it that way
for some unknown (to me) reason.  It's definitely not
a zeroconf box in that configuration.

> What happens if prefix3 is FE80:1:2:3::/64 and Interfaces 2&3 have
> different site-local zone ids? 

Then you'd be in violation of the scoped addr architecture doc,
since you're sharing the same global prefix (prefix2) across
two site zones.

-Dave

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Sat, 12 Oct 2002 13:43:42 +0700

Date:        Thu, 10 Oct 2002 09:44:06 -0700
    From:        "Dave Thaler" <[email-masked]>
    Message-ID:  <[email-masked]>

  | Then you'd be in violation of the scoped addr architecture doc,
  | since you're sharing the same global prefix (prefix2) across
  | two site zones.

If that's what that doc says, then it needs to change.   Trying to make
a strict hierarchy out of the different kinds of addresses is neither
necessary, nor desirable.   Many sites will choose to implement it that
way, but it shouldn't have to be required.

If I have just a single point of external connectivity, and hence am
getting just a single global prefix, there's no reason at all that I can't
run multiple sites (in the sense of site local addressing) inside there -
in fact I thought that was one of the original planned scenarios.

Similarly, there's no reason that I can't run multiple global prefixes
within one site.

All the same should apply to subnets.

I can understand if you don't want to (yet) define how to make some of
these situations work, or if some (eg: routing) protocols don't want to
support all of the possibilities.   That's fine.

But an addr architecture doc certainly shouldn't be banning any of them.

kre