Subject: RE: Limiting the Use of Site-Local

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 28 Oct 2002 17:53:18 +0100

> >=> This makes a lot more sense IMHO. How can we write
  > >"MUST NOT use site-local when global addresses are available"
  > >in a spec? I mean how can we enforce that? If we can't enforce
  > >a "MUST" or "MUST NOT" then it shouldn't be in the spec
  > >in the first place.
  > 
  > I disagree.  The scoped addressing architecture will define how
  > scoped addresses are used on the network.  It already has lots
  > of things in it that can't be "enforced" programmatically on a
  > single node, such as:
  > 
  >          - scope boundaries are in nodes, not on links
  >          - scopes are contiguous and convex
  >          - smaller scopes are completely contained within
  >                  larger scopes
  > 
  > All of these things require that an administrator configure a
  > network in a way that meets these guidelines.

=> Because if he/she doesn't do that, communication will
fail in many cases. But how can one force administrators
who (for some reason we don't know now) decide to use 
both global and site-local prefixes in a site and defined
SBRs to support this? That would break a MUST NOT in the
spec, but things will still work.

  > 
  > Similarly, we could say that site-local addresses should not be
  > assigned on globally-connected networks.
  > 
  > Besides, it would be possible (although perhaps not adviseable)
  > to enforce this restriction.  Nodes could immediately deprecate
  > site-local addresses whenever a global address is configured.

=> Just so they feel that they followed our standards? 
I don't think so. A much better approach IMHO would be 
to highlight the problems and discourage people from 
using site-local addresses for globally connected sites
_because_ of the highlighted problems. After that you
can hope that people will follow. That's all we can do.

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 28 Oct 2002 09:08:09 -0800

Hello Hesham,

"Hesham Soliman (EAB)" wrote:

>       ....       A much better approach IMHO would be
> _because_ of the highlighted problems.

Doesn't this boil down to saying "SHOULD NOT" instead
of "MUST NOT"?

Regards,
Charlie P.