Subject: RE: Node Requirements Issue 3

From: [email-masked]
Date: Fri, 25 Oct 2002 06:45:46 +0300

Hi Brian, Rich & Keith,

Maybe the best way forward would be to work on a BCP on Site
Local addresses.  This could point out what site-locals are
good for, what they are not good for and some recommendations
on using them.

John
> -----Original Message-----
> From: ext Brian Haberman [mailto:[email-masked]]
> Sent: 24 October, 2002 23:21
> To: Richard Draves
> Cc: Keith Moore; Margaret Wasserman; [email-masked]
> Subject: Re: Node Requirements Issue 3
> 
> 
> Rich,
>       Just for my edification:
> 
>       1. Who else has site-local support?
> 
>       2. Can you describe the operational deployments?
> 
>       3. What applications?
> 
> Thanks,
> Brian
> 
> Richard Draves wrote:
> > This is craziness. We (I don't mean just MS) have shipping
> > implementations that support site-locals. We have operational
> > deployments using site-locals. We have applications that 
> work just fine
> > with site-locals.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Thu, 24 Oct 2002 23:54:13 -0400

> good for, what they are not good for and some recommendations

I don't think this would solve the problem that I'm concerned about -
which is that the very existence of scoped addresses, coupled
with the expectation by sites that it's acceptable to use them
by applications, has the effect of damaging reliability and
response time of apps that are exposed to such addresses, and
drastically increasing the complexity of distributed applications 
that try to deal with them in a sane fashion.

trying to justify SLs in a BCP seems like the wrong approach - 
it's really not clear that SLs are good for anything or that they
should ever be used (except perhaps on completely isolated networks) 
when you consider the associated costs.

IMHO SLs should go the way of A6 records.

Keith