Subject: RE: IPv6 w.g. Last Call on "Well known site local unicast addresses for DNS resolver"

From: [email-masked]
Date: Wed, 16 Oct 2002 18:49:10 -0700

Hello everybody,

after reading all the previous mails about this topic, I totally agree that the proposed DNS discovery is not a perfect solution. However, it is *a* solution that works. 

I believe it is easy to miss the main point: We currently do not have any mechanisms to configure a IPv6 host with the DNS resolver/server address - except of course by manual configuration. I am sure that if we wait a few years more, and keep working on this issue open we will find a better or at least more politically correct solution. The problem is that it does not solve our problem now.

The currently proposed DNS discovery solution is simple, it does not break anything, and it works. Let's wrap it up, and have at least a solution. (And actually a backwards compatible solution, if a host supports manual configuration! ;)
It might not be the perfect solution, but it works!

Cheers,

Jonne.

> -----Original Message-----
> From: ext Derek Fawcus [mailto:[email-masked]]
> Sent: Wednesday, October 16, 2002 5:41 PM
> To: [email-masked]
> Subject: Re: IPv6 w.g. Last Call on "Well known site local unicast
> addresses for DNS resolver"
> 
> 
> 
> I think this draft is a poor idea,  and that if people want an
> autoconfig mechanism,  then something along the lines of
> draft-beloeil-ipv6-dns-resolver-option-00.txt would be nore sensible.
> 
> Mind one would still have to configure the router to generate the
> above option in a RA,  but then something would always have to be
> configured somewhere.
> 
> DF
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Mon, 21 Oct 2002 17:59:02 +0700

Date:        Wed, 16 Oct 2002 18:49:10 -0700
    From:        [email-masked]
    Message-ID:  <[email-masked]>

  | I believe it is easy to miss the main point: We currently do not have
  | any mechanisms to configure a IPv6 host with the DNS resolver/server
  | address - except of course by manual configuration. I am sure that if
  | we wait a few years more, and keep working on this issue open we will
  | find a better or at least more politically correct solution. The problem
  | is that it does not solve our problem now.

This is the "we need a solution today, it doesn't matter if it is a
crappy solution, we have to have something so we can pretend we have
done all of the work" argument.   Some of us are not missing this at
all...

  | The currently proposed DNS discovery solution is simple,

true.

  | it does not break anything,

Not true.  It breaks my subnet assignment plan.   I have already
allocated SLA FFFF to use for P2P links.   Now, after that's already
out there and in use the WG is proposing to tell me to renumber things:

gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
        tunnel inet 128.250.1.21 --> 128.250.1.130
        inet6 3ffe:8001:2:ffff::101:2 -> :: prefixlen 112

(this one happens not to have a SL address, but obviously we want our
SL addr subnet numbers to be 1::1 with the globals).

We should never be attempting to define the internals of anyone's
address space usage.

kre