Subject: Query about automatic tunneling and ND

From: "Anurag Uxa" <[email-masked]>
Date: Wed, 9 Oct 2002 09:40:48 +0530

Dear Mr. Tony and all

I have two queries . Can you pls give me the details. and tell me about some
usefull document .

Questions:
1.
HOST1 and HOST2 are in different networks and having IPv6 addresses
HOST1 send one tunneled IPV4 packet <Encapsulated IPV6 UDP packet> to the
HOST2
            (Before sending the tunneled packet out, Will the HOST1 send
tunneled mulitcast NS to HOST2 ?<For Reachability Confirmation>)

2.
Is Automatic tunnels always unidirectional or only for following condition
[Neighbor Discovery and Stateless Address Autoconfiguration] ?

P.S: RFC-2893
Automatic tunnels and unidirectional configured tunnels are considered to be
unidirectional. Thus the only aspects of Neighbor

Discovery [7] and Stateless Address Autoconfiguration [5] that apply to
these tunnels is the formation of the link-local address.

Thanks
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
IF U FIND SOME ONE WITHOUT A SMILE,GIVE ONE OF YOUR'S

Anurag Uxa
IWave Embedded systems
Bangalore
ph.6786243/5 extn :210

DISCLAIMER:

This e-mail and any attachment (s) is for authorised use by the intended recipient (s) only. It may contain proprietary material, confidential information and/or be subject to the legal privilege of iWave Systems Technologies Private Limited. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from retaining, using, copying, alerting or disclosing the content of this message. Thank you for your co-operation. 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Tony Hain" <[email-masked]>
Date: Tue, 8 Oct 2002 21:55:10 -0700

Anurag Uxa wrote:
> Dear Mr. Tony and all
> 
> I have two queries . Can you pls give me the details. and 
> tell me about some usefull document .
> 
> Questions:
> 1.
> HOST1 and HOST2 are in different networks and having IPv6 
> addresses HOST1 send one tunneled IPV4 packet <Encapsulated 
> IPV6 UDP packet> to the HOST2
>             (Before sending the tunneled packet out, Will the 
> HOST1 send tunneled mulitcast NS to HOST2 ?<For Reachability 
> Confirmation>)

No, there is no need for NS because the necessary 'link' reachability
information is already imbedded in the IPv6 address.

> 
> 2.
> Is Automatic tunnels always unidirectional or only for 
> following condition [Neighbor Discovery and Stateless Address 
> Autoconfiguration] ?

Yes they are always unidirectional. 

> 
> P.S: RFC-2893
> Automatic tunnels and unidirectional configured tunnels are 
> considered to be unidirectional. Thus the only aspects of Neighbor
> 
> Discovery [7] and Stateless Address Autoconfiguration [5] 
> that apply to these tunnels is the formation of the 
> link-local address.

Don't spend too much time on 2893 type automatic tunnels. The
replacement
http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-mech-v2-00.txt
has removed them for lack of ability to scale well. 
Spend more time on RFC 3056, 
http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-isatap-04.txt, 
& http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-shipworm-08.txt

Tony

> This e-mail and any attachment (s) is for authorised use by 
> the intended recipient (s) only. It may contain proprietary 
> material, confidential information and/or be subject to the 
> legal privilege of iWave Systems Technologies Private 
> Limited. If you have received this message in error, please 
> notify the originator immediately. If you are not the 
> intended recipient, you are notified that you are strictly 
> prohibited from retaining, using, copying, alerting or 
> disclosing the content of this message. Thank you for your 
> co-operation.

---

From: "Anurag Uxa" <[email-masked]>
Date: Fri, 11 Oct 2002 10:38:44 +0530

Dear All
I have few queries.
I have gone through all drafts and RFC 3056,2893, But still i am not able to under stand 

HOST1 and HOST2 are in different networks and having IPv6 
 addresses HOST1 send one tunneled IPV4 packet <Encapsulated  IPV6 UDP packet> to the HOST2
             (Before sending the tunneled packet out, Will the 
 HOST1 send tunneled mulitcast NS to HOST2 ?<For Reachability Confirmation>).

1.
PS:2893-If an implementation provides bidirectional configured tunnels it MUST at least accept and respond to the probe packets used by Neighbor Unreachability Detection [for ND all new drafts and rfc3056 is reffering RFC2893.
2.
[RFC2893] SHOULD also send NUD probe packets to detect when the configured tunnel fails at which point the implementation can use an alternate path to reach the destination.

Please anybody can explain with examples then i will be very thank ful

Anurag Uxa

----- Original Message ----- 
From: "Tony Hain" <[email-masked]>
To: "'Anurag Uxa'" <[email-masked]>; "'Pekka Savola'" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, October 09, 2002 10:25 AM
Subject: RE: Query about automatic tunneling and ND

DISCLAIMER:

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 11 Oct 2002 15:35:26 +0200 (CEST)

> [RFC2893] SHOULD also send NUD probe packets to detect when the configured
> tunnel fails at which point the implementation can use an alternate path to
> reach the destination.

The above refers to configured tunnels, and your question
seems to be about the automatic tunnels specified in RFC 2893.

I don't interpret RFC 2893 to recommend doing NUD on its automatic tunnels.
Furthermore, the upcoming revision to RFC 2893 is removing support for
automatic tunneling since the RFC 3056 6to4 tunnels provides a superset.

   Erik