Subject: RE: IPv6 subnet-local addresses and draft-ietf-ipngwg-addr-arch-v3-10.txt

From: "Dave Thaler" <[email-masked]>
Date: Wed, 9 Oct 2002 14:02:35 -0700

> -----Original Message-----
> From: Brian Haberman [mailto:[email-masked]]
> Sent: Wednesday, October 09, 2002 1:48 PM
> To: [email-masked]
> Subject: Re: IPv6 subnet-local addresses and
draft-ietf-ipngwg-addr-arch-
> v3-10.txt
> 
> Dave Thaler wrote:
> >>From: Brian Haberman [mailto:[email-masked]]
> >>
> >>>>The more I think about it, the more I realize that "automagically"
> >>>>creating the subnet-local scope zone id isn't going to work.
> >>>>Especially with multiple prefixes per interface.
> >>>
> >
> > Why not?  Can you elaborate?
> > Shouldn't it always be true that if any two interfaces have the
> > same (non-link-local) subnet prefix, then their subnet-local
> > zone id MUST be the same?
> 
> What happens to the zone ids when:
> 
>       1. Interface 1 has prefix1 and prefix2
>       2. Interface 2 has prefix1 and prefix3
>       3. Interface 3 has prefix2 and prefix4

According to the default rule, all three are in the
same subnet-local zone.  You've just chosen for some
reason not to advertise some prefixes on some links.
Personally, I'd put this in the category of "don't do that",
just like I wouldn't recommend using using different subnet
ids for different prefixes on the same link.

-Dave

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian Haberman <[email-masked]>
Date: Thu, 10 Oct 2002 06:00:16 -0400

> ids for different prefixes on the same link.

Why are some prefixes not advertised?

What happens if prefix3 is FE80:1:2:3::/64 and Interfaces 2&3 have
different site-local zone ids?  Then obviously you can't make all
three interfaces be in the same subnet-local zone id.

Brian