Subject: RE: Optimistic DAD draft ...

From: "Bound, Jim" <[email-masked]>
Date: Wed, 16 Oct 2002 14:32:29 -0400

Charlie,

Test beds are good.  But no one is going to use it till we make sure it
works across many products.  I would not put my shit on the line for
anyones implementation of layer 3 such as a soldier or hospital
emergency rescue team.  Nor for IPv6 at this time. 

I would like to see specs for this and agreement on MIPv6 movement. We
can't even get MIPv6 PS in the IETF.

Thanks
/jim

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: Wednesday, October 16, 2002 1:11 PM
To: Bound, Jim
Cc: [email-masked]; [email-masked]
Subject: Re: Optimistic DAD draft ...

Hello Jim,

Layer 3 handover definitely can and does work.
We have been showing smooth layer-3 handover for
voice for almost two years now, even with conference
demos and press releases, using Mobile IPv6.
Improvements have been done for QoS and several
other features which aren't the point of this
note.  Video is either done or doable depending
on your definitions.

The media and technology (Mobile IP and fast
handovers) support it;  some way of alleviating
DAD delays is required for it to work.  The market
and the standardization process are another matter
entirely.  Research publications are yet another
matter, but some papers have been published.

Regards,
Charlie P.

"Bound, Jim" wrote:
> 
> Alper,
> 
> None of us working on this are even clear layer 3 handover will ever 
> work?  Not sure if that matters does it?  Are we talking about the 
> future?
> 
> Thanks
> /jim
>

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 16 Oct 2002 11:47:09 -0700

Hello Jim,

"Bound, Jim" wrote:

> works across many products.

Of course, people in general can't use it until it's productized.
And, productization depends on standardization.  However, I was
responding to your sentence:

> work?

I am providing the information that it DOES work.  How long it
takes to get to market will depend on things other than whether
the technology is workable.  In fact, the very things you pointed
out.

>                             I would not put my shit on the line for

Well, you could, but without products it would be hard.
But productization and standardization have been hindered
by factors which would not be important for the applications
that you indicated.  On the other hand, it's easier to write
applications for products (vs. custom platforms) because it
is easier to fund because there's more profit in it.

> can't even get MIPv6 PS in the IETF.

We are currently busting our tails to respond to Working Group
Last Call comments, and we are down to the end.  You can see
the progress by looking at our page of issues:
    http://www.piuha.net/~jarkko/publications/mipv6/MIPv6-Issues.html

Everyone knows it's been a long and contentious process.
However, pessimism is not justified by current events.

Regards,
Charlie P.