Subject: RE: multihomed host

From: "Michel Py" <[email-masked]>
Date: Wed, 9 Oct 2002 15:55:55 -0700

> Bill Sommerfeld wrote:
> From the point of view of what applications need to do,
> it's safest to assume that all V6 hosts are multiaddressed.

Strongly agree. Although multiaddressed does not necessarily mean
multihomed, it is likely that part of the multihoming solution is
multiadressed hosts.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Fri, 11 Oct 2002 00:39:09 +0200

> >>> "Bill" == Bill Sommerfeld <[email-masked]> writes:
  > 
  >     Bill> For what  it's worth, I've occasionally heard  
  > the term used
  >     Bill> in  an application-layer  context to  refer to  
  > hosts having
  >     Bill> multiple  IP addresses rather  than/in addition  
  > to multiple
  >     Bill> interfaces.
  > 
  > This  just  looks like  the  degenerate  case  -- multiple  
  > addresses,
  > multiple  interfaces,  except that  each  of  the multiple  
  > interfaces
  > happen to  be the  same. It seems  to me  that the network  
  > layer code
  > should treat both cases identically. Does this make sense?

=> I don't think so. There is a difference in existing 
standards (2461) and implementations between the 2 cases. 
A multiaddressed node with a single interface assumes 
that any address can be used as a source address with any
default router. This is clearly not a good assumption 
for multi-interfaced (multihomed) nodes

Hesham

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 11 Oct 2002 15:15:30 +0200 (CEST)

> This  just  looks like  the  degenerate  case  -- multiple  addresses,
> multiple  interfaces,  except that  each  of  the multiple  interfaces
> happen to  be the  same. It seems  to me  that the network  layer code

There are some important differences when it comes to the relationship
between IP source address and routes that are used.

draft-ietf-ipv6-default-addr-select-09.txt
specifies that the candidate source address are related to the
interface on which a packet is sent.

Hence there is a difference  between 
case 1:
	Host with one interface, two routers, two global addresses with
	different prefixes (whether one router advertises each addrconf prefix
	or both routers advertise both prefixes).

	In this case the candidate source address will be both global
	addresses, and the other rules in the source address selection
	will determine which source address is used.

	Note that there is no relationship between the source address selected
	and which (default) router is used for sending packets.

case 2:
	Host with two interface, one router on each interface, one global
	address being configured on each interface with different prefixes
	(each router advertises a single addrconf prefix)

	In this case the candidate source address set will be coupled
	to the (default) route used to send the packet, since there
	are two interfaces.

In both cases there are issues of what happens when e.g. one of the routers
fail, which have to do with not only how the host behaves but also how
routing works beyond the first hop routers.

  Erik