Subject: IPv6 node requirements - some comments

From: [email-masked]
Date: Wed, 16 Oct 2002 19:14:08 +0300

Hi all,

it has been quite silent around "IPv6 node requirements" lately.
http://www.ietf.org/internet-drafts/draft-ietf-ipv6-node-requirements-01.txt

Here are some comments on it to hopefully activate the discussion again:

- 1.2: There has been discussion on using the conformance groups. Somehow I would feel much more comfortable with the conventional MUST / SHOULD / MAY keywords.

- 2.: Abbreviations list should be made more complete, i.e. adding PPP, ATM, FDDI, NBMA, etc. abbreviations mentioned in the document

- 3.1.8: IMHO, RFC2529 is a transition mechanism and does not very well fit here...

- 4.1.1: As RFC2460 is one of the most relevant IPv6 RFCs, I'm just wondering, whether so long descriptive text is actually needed in this document? Would just saying that RFC2460 is mandatory / MUST do the job?

- 4.4  and 4._1_.1  Why making this subchapter, i.e. could ICMPv6 RFC just be mentioned in 4.4?

- 4.5.5 and 5.3.1: Should we combine these and have DHCPv6 mentioned only in 4.5.5? 

- 5. Why are DNS and Transport Layers in the same chapter? => make separate chapters?

- 5.2: DNS discovery is an important and missing thing here, I propose mentioning at least this mechanism here
   http://www.ietf.org/internet-drafts/draft-ietf-ipv6-dns-discovery-06.txt

- 6.: What should we do with the transition things in this document? Is this something we should totally leave for v6ops wg? As we all know, 4 design teams (unmanaged, enterprise, ISP and cellular) are working at the moment.

- 7.: I think we should wait until the MIPv6 RFC has been completed to finalize this section. IMHO, at least things that are mandatory for all IPv6 nodes should be mentioned / actually specified here. Route Optimization requirements for all Correspondent Nodes may also be mentioned here. But what comes to Mobile Node or Home Agent functionality, maybe those do not belong to this "minimum IPv6 node requirements" document.

Best Regards,
		-Juha W.-

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Oct 2002 16:03:20 +0300

> - 1.2: There has been discussion on using the conformance groups. Somehow I would feel much more comfortable with the conventional MUST / SHOULD / MAY keywords.

Me too. What is essential also, however, is that we retain the conditional
concept. I would propose the following terminology:

unconditionally mandatory => MUST support ...
conditionally mandatory => MUST support ..., when ...
                         or SHOULD support ..., when ...
                         (depending on case)
unconditionally optional => MAY support ...

> - 2.: Abbreviations list should be made more complete, i.e. adding PPP, ATM, FDDI, NBMA, etc. abbreviations mentioned in the document

Yes.

> - 4.1.1: As RFC2460 is one of the most relevant IPv6 RFCs, I'm just wondering, whether so long descriptive text is actually needed in this document? Would just saying that RFC2460 is mandatory / MU…

I agree that the text should be crisper, but I don't agree that we should
remove actual information. For instance, routing is optional whereas
acting as an endpoint is mandatory.

> - 5. Why are DNS and Transport Layers in the same chapter? => make separate chapters?

These are probably due to a general decision on the structure of the document.
John?

> - 7.: I think we should wait until the MIPv6 RFC has been completed to finalize this section. IMHO, at least things that are mandatory for all IPv6 nodes should be mentioned / actually specified he…

I don't recall the name of this document was minimal ipv6 node requirements. In fact, we have listed plenty
of optional things. So, I think route optimization is a SHOULD, mobile node is a MAY, and the routers...
hmmm... I'm not sure if we were treating router functionality? If we are, then its a MAY.

Jari