Subject: RE: Optimistic DAD draft ...

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 17 Oct 2002 15:20:33 +0200

>    Optimistic DAD is a useful optimization because DAD is far more 
  >    likely to succeed than fail, by a factor of at least 
  > 10,000,000,000
  >    to one[SOTO].  This makes it worth a little disruption 
  > in the failure
  >    case to provide faster handovers in the successful case, 
  > as long as
  >    the disruption is recoverable.
  > 
  > ==> this is totally, and completely wrong.  [SOTO] only 
  > provide analysis 
  > in *some* cases, in particular autoconfigured vs privacy 
  > addresses.  For 
  > manually assigned addresses, I believe the ratio is closer 
  > to 1:10 or 
  > 1:100 (unmeasurable, of course).

=> I think that manually configuring a CoA is not 
something we should do or talk about in standards.
So it is probably not important to include it in
any useful (useable) statistics on the probability 
of address duplication.

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Thu, 17 Oct 2002 16:45:09 +0300 (EEST)

> any useful (useable) statistics on the probability 

I agree, but the analysis was done on the specific case, not the generic 
case.  The wording is wrong.  The optimistic DAD extensions could be used 
outside of the MIPv6 context too!

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords