Subject: RE: IPV6_V6ONLY and a possible generic alternative

From: "Bound, Jim" <[email-masked]>
Date: Sat, 19 Oct 2002 23:37:00 -0400

This would not change what the default is today which is NOT IPV6_V6ONLY
per the IEEE spec.  If we want to add redefinition of options or
structures for the base API I suggest that it be done in a new draft to
the current draft of the Base API.

We should move the latest rev to Info RFC and folks can start building
addendum INFO RFCs. To change the base API which is now widely
implemented is really out of the hands of the IETF per se.  But
addendums can be proposed to new work in IEEE.

Mail to Bob Hinden exists to wrap this draft up and move on.

Regards,
/jim

> -----Original Message-----
> From: Kyle C Quest [mailto:[email-masked]] 
> Sent: Saturday, October 19, 2002 4:36 PM
> To: [email-masked]
> Subject: IPV6_V6ONLY and a possible generic alternative
> 
> 
> The rfc2553bis draft introduces the IPV6_V6ONLY socket option 
> to let applications limit the use of an ipv6 socket to ipv6 
> communication only. I think a better(more generic) solution 
> would be a generic socket option which says "my family only". 
> There could be "SO_ONEFAMILY" or similar generic socket 
> option to do that. The idea is that if we have a socket and 
> we want to restrict it to IPv6 or IPv4 (or some future IPvX) 
> we'd have a way to do that.
> 
> I don't know if this idea has been already discussed here... 
> (I checked only the last couple of months). I'd like to know 
> what people think about it.
> 
> Thank you,
> 
> Kyle C Quest
> 
> 
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 19 Oct 2002 23:37:52 -0400

I happen to agree with you.
/jim

> From: Markku Savela [mailto:[email-masked]] 
> Sent: Saturday, October 19, 2002 5:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: IPV6_V6ONLY and a possible generic alternative
> 
> 
> 
> > From: "Kyle C Quest" <[email-masked]>
> > 
> > The rfc2553bis draft introduces the IPV6_V6ONLY socket 
> option to let 
> > applications limit the use of an ipv6 socket to ipv6 communication 
> > only. I think a better(more generic) solution would be a generic 
> > socket option which says "my family only". There could be 
> > "SO_ONEFAMILY" or similar generic socket option to do that. 
> The idea 
> > is that if we have a socket and we want to restrict it to 
> IPv6 or IPv4 
> > (or some future IPvX) we'd have a way to do that.
> 
> This is wrong direction to go. MOST applications should never 
> care whether the communication is over IPv6 or IPv4 (or 
> whatever IPvX).
> 
> If a new IPv6 application is written, it should work the same 
> with IPv4 and IPv6. If it does not, then I would consider 
> application (and API) broken.
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 19 Oct 2002 23:39:38 -0400

The reason we have an IPV6_V6ONLY option is because some implementors
would like to only run IPv6 packets over the socket and not permit
IPv4_MAPPED.  This was to give those implementors that capability.  But
the default is IPv4_MAPPED and IPv6.

/jim

> Sent: Saturday, October 19, 2002 5:16 PM
> To: Markku Savela
> ----- Original Message -----
> From: "Markku Savela" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Saturday, October 19, 2002 4:59 PM
> > > only. I think a better(more generic) solution
> would be
> > > a generic socket option which says "my family only".
> option to do
> that.
> > > The idea is that if we have a socket
> > > and we want to restrict it to IPv6 or IPv4 (or some future IPvX) 
> > > we'd
> have a
> > > way to do that.
> >
> > This is wrong direction to go. MOST applications should never care 
> > whether the communication is over IPv6 or IPv4 (or whatever IPvX).
> >
> > If a new IPv6 application is written, it should work the same with 
> > IPv4 and IPv6. If it does not, then I would consider 
> application (and 
> > API) broken.
> >
> 
> You bring up a good point... but why then rfc2553bis draft 
> defines IPV6_V6ONLY option?
> 
> 
> 
> 
>