Subject: RE: IPv6 w.g. Last Call on "Well known site local unicast addres ses for DNS resolver"

From: [email-masked]
Date: Fri, 18 Oct 2002 19:38:51 -0700

Hi Pekka,

> -----Original Message-----
> From: ext Pekka Savola [mailto:[email-masked]]
> addres ses for DNS resolver"
> 
> 
> Exactly, but this wouldn't have to be so.  Introduction:
> 
>                             Except for name resolution, all the other
>    services are usually described using names, not addresses, such as
>    smtp.myisp.net or webcache.myisp.net.  For obvious bootstrapping
>    reasons, a node needs to be configured with the IP address (and not
>    the name) of a DNS resolver.
> 
> doesn't really require 3 DNS addresses.
> 
> If one of the site-locals doesn't answer you, it's highly 
> unlikely that 
> the next one will (ie: not configured at all).  If the second doesn't 
> answer either, it is almost unheard of if the third one does answer.

I do not really see what harm would three addresses do. You may have networks that would have only one DNS server (small business or a home user with for a reason or another his own DNS server). However, in cases like ISPs or bigger businesses there may be multiple DNS servers configure. I believe this is the case even now.

In short, I would argue that three is the right number.

Cheers,

Jonne.
--------
Jonne Soininen
Nokia

Tel. +1 650 864 6794
Cellular: +1 650 714 7733
Email: [email-masked] 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Sat, 19 Oct 2002 12:12:20 +0300 (EEST)

On Fri, 18 Oct 2002 [email-masked] wrote:
> I do not really see what harm would three addresses do. You may have
> networks that would have only one DNS server (small business or a home
> user with for a reason or another his own DNS server). However, in cases
> like ISPs or bigger businesses there may be multiple DNS servers
> configure. I believe this is the case even now.
> 

Consider the case where the resolver has been upgraded to support this 
mechanism but the network isn't: this has an impact on 3 vs 0/1/2.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords