Subject: RE: Changing RS Reply Timing for Mobile IPv6

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 30 Oct 2002 01:15:34 +0100

James, 

  > Do you anticipate that the changes in FMIPv6 for access 
  > routers will be in all
  > IPv6 routers?

=> I don't know. But I know that any router can be
an "access router". People don't develop a special router
because it will be connected to an ethernet that has a an 
802.11 base station at the other end. It's just a router, 
it can be connected anywhere.

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Greg Daley <[email-masked]>
Date: Wed, 30 Oct 2002 12:38:38 +1100

Hi Hesham, James, Jim,

I think that the advantages of Opti-DAD
particularly are that there's no dependence
on support in Router infrastructure
(beyond existing ND).

With FastRA, the amount of state kept and the
required code changes are miniscule
(was an afternoon's work for the prototype,
including configuration subsystem).

There's really no strict relationship with
these mechanisms and MIPv6 Fast Handovers,
which requires significant changes in added
signalling mechanisms in Access Routers,
as well as neighboring routers/L2 access
point mappings.

Of course, they will play nicely with each
other though, since both FastRA and OptiDAD
are designed to interwork with existing IP
standards and Mobile-IP drafts.

As far as isolating FastRA from the core, I think
that's relatively simple, even in the case where
all routers ship identical code:

The FastRA draft says that it's configurable
and defaults to off.

Greg Daley

---

From: "James Kempf" <[email-masked]>
Date: Tue, 29 Oct 2002 21:02:07 -0800

> it can be connected anywhere.

I think what I've been hearing from Jim Bound and others that they would rather
not have these specialized features that FMIPv6 is specifying as general purpose
for any IPv6 router, because they want to move forward with their IPv6
(including base MIPv6 which works with any IPv6 router) product plans. I would
argue that the oDAD and FastRA are in the same category.

Thus, I think it makes sense to consider the oDAD and FastRA work as an
optimized mobility enhancement, since I see no real need for it in wired
networks. Most wired hosts will only do DAD once per boot, and if it takes an
additional second, it's not such a big deal. On the other hand, if it takes a
second for a mobile node to do a handover, it is a very big deal indeed.

            jak