Subject: Re: Node Requirements Issue 9

From: "Adam Machalek" <[email-masked]>
Date: Mon, 28 Oct 2002 07:37:47 -0600

I vote Strongly for a MAY.  This is clearly a case where the
Vendor/Developer in concert with the Customer/User should define what kind
of transition stratagy is desirable for a particular implementation.  At
most, a statement that "A system should have some transition stratagy"
would be acceptable.  However, I would don't want to see any particular
transition mechanisms specified a SHOULD or MUST.

Adam Machalek

                      <john.loughney@nokia.                                                                                              
                      com>                         To:       <[email-masked]>                                                  
                      Sent by:                     cc:                                                                                   
                      <[email-masked]        Subject:  Node Requirements Issue 9                                                   
                      ng.sun.com>                                                                                                        

                      10/27/2002 06:25 AM                                                                                                

Hi all,

9) Are Transition mechanisms mandatory; is support for IPv4 mandatory?

I think that IPv4 is not mandatory, but a strong SHOULD.  If IPv4
is supported, then some sort of transition mechanism is madatory -
anyone have suggestions on what should be mandatory?  Text suggestions
are helpful.

John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Mon, 28 Oct 2002 09:43:29 -0500

> transition mechanisms specified a SHOULD or MUST.

I'm fairly convinced that (for nodes that support v4 in addition to v6)
there needs to be a "must implement" transition strategy, otherwise
we will get not only devices but applications that can only work with
a particular network configuration (since the apps will depend on the
artifacts or lack thereof of a particular transition strategy).

Keith