Subject: RE: Forwarding packets with site-local source [Re: Choices to go forward with SL]

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 29 Oct 2002 22:45:46 +0100

> > Some read it (many):
  > > 
  > >  "if I configure a site here, I must also block site-locals 
  > > from spreading 
  > > out or false site-locals coming in"
  > > 
  > > Some others read it:
  > > 
  > >  "if I use site-locals here, my upstream router will block 
  > > the site-local 
  > > addresses from spreading out and prevent anyone from spoofing 
  > > site-locals 
  > > to my site"
  > > 
  > > The latter is how I read it must be implemented -- and 
  > > reading Microsoft's implementation and the reason they're 
  > > using SL *strongly* suggests they 
  > > also have read it that way.  There are very probably many others.
  > 
  > No, I think you're the only person reading it the latter way.

=> Agreed. I haven't seen anyone else interpret it this way.

Hesham

  > 
  > My expectation is that routers will need to be configured 
  > to understand
  > site boundaries. A conservative position is that routers by default
  > should regard their interfaces as belonging to different 
  > sites, unless
  > they are configured to be in the same site. Or perhaps 
  > other aspects of
  > the router's configuration (eg the network prefixes assigned to
  > different interfaces, or the routing protocols in use) 
  > could be used to
  > default the site configuration.
  > 
  > Rich
  > 
  > --------------------------------------------------------------------
  > IETF IPng Working Group Mailing List
  > IPng Home Page:                      http://playground.sun.com/ipng
  > FTP archive:                      ftp://playground.sun.com/pub/ipng
  > Direct all administrative requests to [email-masked]
  > --------------------------------------------------------------------
  > 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Richard Draves" <[email-masked]>
Date: Wed, 30 Oct 2002 13:33:38 -0800

> My take is that the two possible router configs for site locals is
> 
>       1.  All interfaces are in the same site
>       2.  All interfaces are in unique sites
> 
> Margaret's proposal that the default behavior is a node's 
> interfaces are in 1 site results in case 1.  For a router, a 
> safer config may be 2.  That would strictly limit the outward 
> flow of site local addresses.

I like the idea the hosts default to all interfaces in one site, and
routers default to each interface is in a different site.

> This difference in behavior for hosts and routers leads to
> some interesting issues.  One big one is how the site-local 
> zone ids are setup and potentially changed when a host 
> becomes a router or vice versa.

This is a good question but a) it seems surmountable and b) I don't
think the answer needs to be standardized, since changing on the fly
between router & host behavior is not standardized.

For example suppose that in the absence of configuration, host
interfaces use the site id 1. When a host interface is changed to become
a router interface, if it has site id 1 then it automatically changes to
a new unused site id (eg, one larger than the largest currently in use
on the node). When a router interface is changed to a host interface,
you leave the site id alone (unless the operator also changes it
explicitly of course).

Rich

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 30 Oct 2002 16:47:58 -0500

>routers default to each interface is in a different site.

I have some concerns about this idea, because it means that routers
won't work out-of-the-box in a disconnected, multi-network site that
is only numbered using site-locals...

Also, does it require that all routers will be capable of acting
as SBRs?

Margaret

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 30 Oct 2002 22:51:05 +0100

> I like the idea the hosts default to all interfaces in one site, 

=> I think this will be a problem for mobile hosts. Using
ND alone you can't know if both interfaces are in the 
same site. 

Hesham