Subject: Re: Node Requirements issue 8

From: Margaret Wasserman <[email-masked]>
Date: Sun, 27 Oct 2002 12:06:42 -0500

At 07:23 AM 10/27/02, [email-masked] wrote:
>Hi all,
>
>8) Support for DNS (is it a MUST)?  Support for DNS discovery / DHCP?

These are actually three questions, I think.

IMO, a DNS (resolver) is not a required feature of an IPv6
node (a MAY).  There are plenty of IPv4 nodes that do not
include a DNS resolver, and there will be plenty of IPv6
nodes that do not.  Examples include printers, consumer
products, industrial control equipment, parts of cars and
airplanes, etc...  There are many IPv4 nodes that never
serve as "clients", and there will hopefully be even more
IPv6 nodes in these types of roles.

Margaret

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Adam Machalek" <[email-masked]>
Date: Mon, 28 Oct 2002 07:21:37 -0600

For DNS, I'd like to see a MAY.  Some systems simply have no need for DNS.
Turning it into a mandatory requirement, or even a strong SHOULD is to
much.   This is a case where if you need it, put it in, if your system
doesn't need it, don't put it in.

As for DHCPv6, in order to have some consistancy with RFC2462 and that
RFC's statements on Stateful Address config, this should probabally be a
SHOULD here.  On the otherhand, a MAY with descriptive language clearing up
the ambiguity in RFC2462 would also be suffiicient.

Adam Machalek

                      <john.loughney@nokia.                                                                                              
                      com>                         To:       <[email-masked]>                                                  
                      Sent by:                     cc:                                                                                   
                      <[email-masked]        Subject:  Node Requirements issue 8                                                   
                      ng.sun.com>                                                                                                        

                      10/27/2002 06:23 AM                                                                                                

Hi all,

The design team has waviered over DNS.  Some say a strong SHOULD is enough,
others say it is a MUST.  What does this list feel?

Should some level of DNS discovery / configuration be mandatory if DNS
is used?  I guess manual configuration would be a MUST in that case.
The on-going DNS discovery issue still is yet to be completed, but could
we mention something in the draft+

Also, what about DHCPv6?  Is it mandatory, if so what are the madatory
components, etc.  Should it be mandatory for all types of devices?  I think
a SHOULD or MAY, with some detail may be sufficient.

best regards,
John

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 28 Oct 2002 18:53:45 +0100

> 
  > > DNS should not be a MUST.  not all applications need to use it.
  > > Also, DNS is a separate service from IP. IP should not be 
  > > thought to be dependent on DNS.
  > 
  > I tend to agree with you.  I see the following options:
  > 
  > 1) For IPv6 nodes, DNS is a MUST if applications require it.

=> I dislike having a "MUST if". I think MUSTs should be
unconditional. This option amounts to 2) below.

  > 2) For IPv6 nodes, support for DNS SHOULD be included, as many
  > 	applications require it.
  > 3) For IPv6 nodes, DNS SHOULD be included as DNS support is a 
  > 	'good thing.'
  > 4) For IPv6 nodes, DNS MAY be included.

=> I'm fine with 2,3 or 4.

Hesham

  > Any suggestions?