Subject: RE: some opinion about the requirement level of DHCPv6 (for nodereq)

From: [email-masked]
Date: Thu, 20 Mar 2003 18:06:21 +0200

Hi Jinmei,

In the text, I've tried to seperate the requirements for Stateless Address Autoconfig
from the use of DHCP for other config info.

My opinion is that Stateless Address Autoconfig support is MAY.  If a node would need
Stateless Address Autoconfig, then DHCPv6 support is a MUST for Stateless Address 
Autoconfig.

If a node needs other config info, then DHCPv6 is a SHOULD, which is independent
of Stateless Address Autoconfig.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: 19 March, 2003 21:20
> To: [email-masked]
> Subject: Re: some opinion about the requirement level of 
> DHCPv6 (for nodereq)
> 
> 
> (oops, sorry, the message was incomplete)
> 
> >>>>> On Thu, 20 Mar 2003 03:31:22 +0900, 
> >>>>> JINMEI Tatuya <[email-masked]> said:
> 
> > As for other configuration (e.g. DHCPv6) by DHCPv6:
> > I would vote for SHOULD, with one condition that 
> 
> ... that the other configuration specification is clearly separated
> from full support of DHCPv6 (to mitigate the load of implementing the
> full spec).  draft-droms-dhcpv6-stateless-guide may help to explore
> this separation.
> 
> 					JINMEI, Tatuya
> 					Communication Platform Lab.
> 					Corporate R&D Center, 
> Toshiba Corp.
> 					[email-masked]
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 20 Mar 2003 19:10:27 +0200

I, of course, meant stateful below, not stateless.  I shouldn't send mail
before the caffeine has kicked in.

John

> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 20 March, 2003 18:06
> To: [email-masked]; [email-masked]
> Subject: RE: some opinion about the requirement level of 
> DHCPv6 (for nodereq)
> 
> 
> Hi Jinmei,
>