Subject: RE: 5.2 DNS [Re: Nodes Requirements Input]

From: "Bound, Jim" <[email-masked]>
Date: Wed, 19 Mar 2003 01:16:22 -0500

John,

> The earlier drafts used different language to try to capture 
> these conditional requirements.  The WG did not like the 
> terms (Unconditionally Mandatory, 
> Conditionally Mandatory and Unconditionally Optional), so we 
> dropped them. There seemed to be comments that we should 
> stick to minimum / basic requirements and things which are 
> IPv6 specific.

Don't disagree with the WG.  

I a saying we need multiple node requirements documents.

- Node Reqs 3GPP services
- Node Database Services
- Node Requirements iSCSI/IP

Etc Etc.  

The scope is to narrow currently.

Regards,
/jim

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Wed, 19 Mar 2003 08:25:43 +0200 (EET)

> The scope is to narrow currently.

One would think that one could exercise own judgment and listen to the 
customers (if applicable) when deciding which features to implement on top 
of the minimal set recommended by node requirements.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Jari Arkko <[email-masked]>
Date: Wed, 19 Mar 2003 18:51:44 +0200

>The scope is to narrow currently.
Jim, I can see what you would like to do, but I don't
agree that this is possible. It is not possible to document
the requirements for all potential applications. And I don't
want to start arguing about what the three most important
applications are, if that's what you were thinking.

What we *can* do, however, is to list the "components" IPv6
as a reference for implementers, vendors, and customers. While
it may be obvious to some folks what these components are, I
believe this is an extremely useful exercise which will also
help IPv6 deployment.

Also, we in this working group should be able to specify what
the core components -- those which are always mandatory no
matter what -- are. We are also documenting the optional features*.
After a discussion on the mailing list we concluded that the
MUST/SHOULD/MAY language is the best choice for this
documentation. But by no means should this be taken to mean
that an "optional" component is not absolutely necessary
in a specific application. Clearly they can be, but I agree
with Pekka that some judgment outside the IETF standards needs
to be applied as well.

Jari
*) Actually, only some optional components e.g. on sub-IP are
listed. I disagree with this approach, I'd rather have all
the optional components.