Subject: RE: avoiding NAT with IPv6

From: "Michel Py" <[email-masked]>
Date: Thu, 20 Mar 2003 17:38:20 -0800

> Aleksey wrote:
> BTW, I prepared a draft which spells out NAT6

If you're tired of life, there probably are better ways to go than being
lynched by a crowd of IETFers.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Quality Quorum <[email-masked]>
Date: Thu, 20 Mar 2003 21:00:41 -0500

> lynched by a crowd of IETFers.

Ever heard about SNMP wars? I highly doubt that by now there is so much
fire left anywhere in IETF :)

Speaking seriously, it seems to me that people underestimate both how easy
is to do NAT6 even without any official blessing and how hard is to fight
against market forces.

So, it is quite possible that nobody would ever want NAT6, but if there
is a desire it will be unstoppable. Moreover, the only result of special
measures making NAT6 harder to do will result in more starving companines
trying to differenciate themselves by providing workarounds.

IMHO being NAT6-neutral/NAT6-friendly would at least reduce its
commercial attractivness (similar to drug legalization).

BTW, giving every organization /48 will lead to a pretty big routing
tables.

> Michel.

Thanks,

Aleksey

---

From: Greg Daley <[email-masked]>
Date: Fri, 21 Mar 2003 14:27:43 +1100

Hi Aleksey

> commercial attractivness (similar to drug legalization).

I'm pretty sure this would cripple any (reasonable)
end-to-end assumptions people may want to make with
programming IPv6 apps.

Please, think of your children when asking us to
support NAT.  We're trying to make the Internet a system which
will support the applications we need in 2020, not 1999.

I'm not advocating "fight against the tide", but
initially IPv6 can be marketed as better than IPv4
because of NAT4.  Once IPv6 starts taking off, then
it's our job to educate people about NAT being evil.

We shouldn't be accomodating it now.

Greg

---

From: "Jeroen Massar" <[email-masked]>
Date: Fri, 21 Mar 2003 11:42:31 +0100

Quality Quorum wrote:

> Ever heard about SNMP wars? I highly doubt that by now there 
> is so much fire left anywhere in IETF :)

/me puts on his DareDevil suit, hmmm no radar but unlike
the real DareDevil I can see and kick your .... :)
Or to quote some others: send in the clones.

> commercial attractivness (similar to drug legalization).

Don't say anything about drug legalization when you don't live
in the Netherlands. 80% of the Dutch Nederwiet is destined for export.
Thus allowing it only makes it worse.

> BTW, giving every organization /48 will lead to a pretty big routing

You are avoiding the fact that 'organizations' (the people getting
/48's)
get that /48 out of a /32 from their upstream and that the routing
table _should_ be filtered on those boundaries

Maybe you could take a look at http://www.sixxs.net/tools/grh/lg/
which, thanks to Gert Doering contains BGP data back to 25 Aug 2001.
The routing tables are getting cleaner by the day. See also Gert's
presentations at RIPE: http://www.space.net/~gert/RIPE/ and his
Filtering list: http://www.space.net/~gert/RIPE/ipv6-filters.html

If you are talking about Multihoming etc, I am sure Michel Py
can enlighten you about it. They have been making great hops
of progress the last couple of weeks.

Greets,
 Jeroen

---

From: Quality Quorum <[email-masked]>
Date: Fri, 21 Mar 2003 07:30:48 -0500

> end-to-end assumptions people may want to make with

I do not think so.

> will support the applications we need in 2020, not 1999.

If you are making assumptions that there will be no NAT6, but
it may be forced on us by the market, it is you who are
crippling the Internet of the future.

> it's our job to educate people about NAT being evil.

If you are successful there will be no NAT6 even it if
it is supported, however if you are unsuccessful the damage
done by the no-NAT6 decision will be significant.

> We shouldn't be accomodating it now.

Your own argument points the other way - if we are thinking
about future we should not artificially cripple the
environment now.

> Greg

Anyway, I suppose the issue had been discussed enough.

Thanks,

Aleksey

---

From: Quality Quorum <[email-masked]>
Date: Fri, 21 Mar 2003 07:34:23 -0500

> table _should_ be filtered on those boundaries

And how many /48s are in /32 ?

> Filtering list: http://www.space.net/~gert/RIPE/ipv6-filters.html

I would love to beleive you but it may be just an aberration of
an early and very limited deployment.

Thanks,

Aleksey

---

From: "Jeroen Massar" <[email-masked]>
Date: Fri, 21 Mar 2003 13:49:38 +0100

> And how many /48s are in /32 ?

Though the exact calculation depends on how the administrators
of the network distribute this address space across their company.

But without that consideration:
 2^(128-32-48) = 2^48 = 281474976710656

281.474.976.710.656, let's see how one can pronounce that.
281.474.976 milion
281 billiongazzilion or something?

At least anyone can deposit it in eurocents or even centavos on
my bankaccount and I will be quite a happy chap for the rest of
my live and won't bugger anybody again *ever* :)

In other words it should be adequate for most very large ISP's :)
And enough for your worst wet bedtime dreams.

Also that's the reason why we won't want to see single /48's in the DFZ.

> an early and very limited deployment.

Can you explain why you think in such a way?

Actually I think you might be interrested in some good docs IPv6:
http://isoc.nl/activ/cursusmateriaal/2002-Masterclass-IETF-IPv6.ppt
http://isoc.nl/activ/cursusmateriaal/2002-Masterclass-IETF-IPv6.sxi

First one is Steve Deerings presentation in Powerpoint, second one
in Open Office format.

Greets,
 Jeroen

---

From: Greg Daley <[email-masked]>
Date: Mon, 24 Mar 2003 12:20:01 +1100

Hi Aleksey,

I'm giving this one last attempt.

>>end-to-end assumptions people may want to make with

Well, have you ever seen the hoops required for a
NAT to undertake H.323 or another peer to peer
application with multiple channels?
NAT only works relatively easily with single session
client apps.

P-to-P applications are a candidate NextBigThing.

Of course, we can't support NAT modifications for
every application which will be programmed, so
devices on NAT'ed networks will not be able to participate
in p-to-p.

IPv4 networks are rife with NAT, so IPv6 adoption may
be driven by p-to-p.  If NAT is good enough, there
is currently no significant reason to go to IPv6.

> crippling the Internet of the future.

Actually, I'm not. I'm asking that all efforts toward
NAT6 be dropped until there is interest from the user
community.  We know how NAT4 works, NAT6 will be trivial.

In the mean time we'll try to wean people off NAT,
by providing better applications and connectivity with
end-to-end IPv6.

> done by the no-NAT6 decision will be significant.

There is no damage to be done.  We've got almost 2^61 networks
to give away, and almost 2^45 organizations to give addresses
to. It will be at least 3 years before there are 2^45 people in
the world :)

NAT can come in if we get to the point when we've used
up 2^44 organizational allocations and have 2^44 left.
I'd suggest that by that time we'd be able to go to
the next IPng though.

> about future we should not artificially cripple the

End-to-end will never cripple NAT.  NAT can ALWAYS be
retrofitted to an end-to-end network (maybe some
applications won't work, but we know ones that will).
If there's need, we can do it simply.

Running end-to-end applications on a NAT network is
a nightmare, though.

Why don't we wait for the problem to arise before
we implement NAT?
It's not like we don't have better things to do.

Greg