Subject: RE: A use for site local addresses?

From: "Michel Py" <[email-masked]>
Date: Mon, 24 Mar 2003 19:43:33 -0800

Mike,

>> Michel Py wrote:
>> At this point in time I would advise to consider site-local
>> addresses dead. Although I was among those who voted not to
>> deprecate them, the problem needed to be solved and we need
>> to move on. You could use a 6to4 address with an RFC1918
>> address as the v4 address. For 10.0.0.0/8 this translates
>> into 2002:0A00::/24.

> Mike Saywell wrote:
> I could do, but (in my mind) that's worse than using a
> site-local address!

That's what I also think but you have to do with what you have on the
shelf. I actually don't recommend using FECO::/10 anymore although it is
more than probable that it will not be reallocated to another use any
time soon. In the midterm you might find implementations that hardcode a
blackhole.

> However if the final decision has been made I guess something
> like this may be the best option, unless...

The final decision has not been made; what is decided during WG meetings
needs to be confirmed on the mailing list. However, given the fact that
some pro site-locals such as myself will recommend going with ahead with
the deprecation for the sake of not staying stuck on this for years....

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Michel Py" <[email-masked]>
Date: Tue, 25 Mar 2003 08:00:26 -0800

Mike,

> Mike Saywell wrote:
> It's self-contained in that by default there is no default
> route onto the internet, however some sites may offer free
> internet access by advertising a second global prefix on
> their node only.  The other option for internet access is
> via a gateway of some sort, which you connect to using PPPoE
> etc, and you get a global IP from there. So the addresses we
> use on the network cant clash with anything outside.

You are one of the cases why site-locals were designed in the first
place. Since this community as chosen the path not to serve your needs
you need to adapt. 2002:0A00::/24 is your best bet today.

Michel.

---

From: Tim Hartrick <[email-masked]>
Date: Tue, 25 Mar 2003 11:03:20 -0800 (PST)

Jeroen,

> 
> Enduser ISP's will always charge for extra IP space as it's
> currently not customary to give an enduser more than 1 IP.
> Also IPv4 is a becoming a 'scarce' resource.
>

And what precisely we change this custom for IPv6?  Quoting RFCs
is silly in the face MBAs motivated by profit is folly.
 
> > Absent some regulation, there is no reason to believe that
> > they will stop charging for IPv6 address space no matter
> > how freely the bits are made available to them. 
> > It would be great if ISPs would charge for bandwidth
> > only but that simply isn't the way the world currently works 
> > and there is absolutely nothing about IPv6 that will change that.
> > More bits in the address don't mean diddly if the only way to
> > get the bits is through an oligarchy of ISPs.
> 
> If the ISP doesn't provide /48's to an endsite, other ISP's
> will have the advantage that they do. Also if the ISP doesn't
> they are going against RFC's.
>

RFCs fall regularly in the face of the profit motive.
 
> You might also realize that the current TLA policy for RIR's
> demands that you have 200 prospect clients. That is 200x /48.
> Aka 200 endusers on DSL will suffice for them.
> 
> Currently even most tunnelbroker system endusers get
> a /48 and in some cases even more. And they are not even
> paying for bandwidth nor for ipspace. Go figure ;)
> 

I have little faith that the current state of affairs will resemble the
eventual state of affairs.  No one currently expects to make money from
IPv6.  Once they do, address space will become a profit center.  MBAs don't
care about RFCs.

Tim Hartrick
Mentat Inc.

---

From: "Michel Py" <[email-masked]>
Date: Wed, 26 Mar 2003 11:05:13 -0800

> There's a caveat to using 2002:FOO (where FOO is in private
> address space).  If any implementation in the network has
> 6to4 pseudo-interface enabled, the packets it sends in that
> network will be blackholed.
> Not necessarily a bad thing, but one has to be careful when
> proclaiming it as a solution.

I don't proclaim it a solution..... I was just trying to find a way out
of hijacking a real prefix which is what people did before RFC1594.

Michel.

---

From: "Michel Py" <[email-masked]>
Date: Wed, 26 Mar 2003 11:06:48 -0800

> David Conrad wrote:
> I suspect you are underestimating the difficulty of
> renumbering and  overestimating the level of clue of
> people asked to do the renumbering.

Agree.

Michel.

---

From: "Michel Py" <[email-masked]>
Date: Wed, 26 Mar 2003 11:18:15 -0800

> David Conrad wrote: 
> - Estimated world population as of 3/26/03, 17:40:10 GMT+5: 

People interested in IPv6 addresses related to population can have a
look at the following link.
http://arneill-py.sacramento.ca.us/ipv6mh/geov6.txt

Michel.

---

From: "Michel Py" <[email-masked]>
Date: Wed, 26 Mar 2003 11:57:15 -0800

> Pekka Savola wrote:
> As for the alternatives, you already listed some, plus using
> site-locals regardless of the deprecation.

Right, and also keeping one's 3FFE:: address even after they are
recalled on 6/6/6.

Michel.

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 26 Mar 2003 17:57:52 -0800

One of the advocated uses of site local addresses was for disconnected
sites. However, Dino made the point in the meeting that, if a site is
truly disconnected, it can just as well pick any random addresses it
wants. The absence of a "reserved range" (a la RFC 1918) will pressure
the disconnected site to renumber when it actually connects, rather than
go on using private addresses and a NAT.

In fact, most large sites have at least one IPv4 address, and they can
get a unique 2002::/48 prefix out of that address, even if they don't
have an actual IPv6 ISP yet.

-- Christian Huitema

---

From: "Michel Py" <[email-masked]>
Date: Mon, 31 Mar 2003 19:09:04 -0800

Brian,

> Brian E Carpenter wrote:
> IMHO it doesn't make a case for SLs in their present
> incarnation (i.e. ambiguous address space).

Note that if the present state is still ambiguous, it's largely due to
the fact that authors of drafts to make them unique (non-ambiguous)
namely Bob Hinden, Charlie Perkins and myself have kind of put their
drafts on the back burner waiting for this site-local turmoil to settle
down.

Michel.