Subject: RE: Implementing DNS client for support IPv6/IPv4

From: "sasson, shuki" <[email-masked]>
Date: Mon, 17 Nov 2003 21:37:44 -0500

Thanks Suresh & Niels, the left question for me is can both IPv4 and IPv6
addresses can be acquired by one DNS request?
I know that the AAAA RFC says that the response  by the DNS server should
include the IPv4 addresses in the additianal information field. Can I rely
on this?

Shuki

-----Original Message-----
From: Suresh Satapati [mailto:[email-masked]]
Sent: Monday, November 17, 2003 8:37 PM
To: Niels Möller
Cc: sasson, shuki; [email-masked]
Subject: Re: Implementing DNS client for support IPv6/IPv4

> for A records. If you only want IPv6 addresses, you may want to send
> requests for both A and AAAA addresses anyway, and convert any
> received A records into "IPv4-mapped IPv6"-addresses to be returned to
> the application.

I would say, just send AAAA request if you only want IPv6 address.
Do not convert A records into "IPv4-mapped IPv6"-addresses, as mentioned
above.

There are problems w/ using mapped addresses. Refer to:
http://community.roxen.com/developers/idocs/drafts/draft-itojun-v6ops-v4mapp
ed-harmful-02.html

--
Suresh

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 18 Nov 2003 14:24:45 +1100

> include the IPv4 addresses in the additianal information field. Can I rely

	Actually RFC3565 does NOT say to return A records in the
	additional section in response to AAAA queries.

	It does say that both AAAA and A records should be returned
	if additional section processing would have previously
	returned just A record

	Mark
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]