Subject: RE: Issue 13: Omission of prefix options - summary

From: "Bound, Jim" <[email-masked]>
Date: Fri, 7 Nov 2003 01:00:33 -0500

Greg,

That is good and clear mail.  Thanks then lets see what happens at DNA
BOF.  I am on mipshop and quite nervous about the extreme conservative
charter for time-to-market of those technologies as a note.  I  missed
that charter discussion and I plan on being at DNA BOF if for no other
reasons self defense.

So DNA BOF
Look at what is needed not done in mipshop
then look at 2461.

Here is my reasoning why its ok to do ND extensions out of IPv6 WG I
will share with you and why more importantly it is good for the IETF
processes to keep evolving specs in a reasonable manner.  As implementor
as you, I have no issue of having ND integrated into a spec for a
specific purpose.  Even if one whacks reserved fields in 2461 because if
implementor just supports 2461 but not MIPv6 it will just work just like
any good engineering mod overlay.  Now if the 2461 overlay needs an
update that is different I agree.  And that does not mean it changes
standards track status because of adding an overlay.

Anyway here is my logic using a systems view:

-------------------------------
Whenever one can multitask or multithread and solve problems
simultaneously with discrete vectors the system is more efficient.  The
key is to manage all vectors so they do not break the overall system.  I
believe an IETF spec can extend a core spec and it just needs to be
reviewed by that core spec center of expertise without adding to the
core spec.  This permits work to flow around the core spec as an
extension and not all vectors bottleneck at the one core spec.  This is
also a theory I have how to live with chaos within systems and extension
to how nature operates on our planet.  But that gets into all systems
not just IETF.  
-----------------------------

/jim

"The drinkin' bone's connected to the party bone.
The party bone's connected to the stayin' out all night long.
An' she won't think it's funny and I'll wind up all alone.
And the lonely bone's connected to the drinkin' bone." - Tracy Byrd

> -----Original Message-----
> From: Greg Daley [mailto:[email-masked]] 
> Sent: Thursday, November 06, 2003 5:02 PM
> To: Bound, Jim
> Cc: JinHyeock Choi; Soliman Hesham; [email-masked]; Tim Hartrick
> Subject: Re: Issue 13: Omission of prefix options - summary
> 
> 
> Hi Jim,
> 
> Bound, Jim wrote:
>  >Tbis discussion should go to mipshop IMO.
>  >
>  >Of course I do not have an issue with other docs extending 
> ND options.  >  >But I don't believe this is needed and would 
> like to see clear what 
>  >problem is this solving.  It does not help with MD but I do 
> not think 
>  >this WG is the place to disuss MD issues but mipshop.
>  >
>  >/jim
> 
> Mipshop has a very restricted charter which doesn't
> cover these issues.
> 
> The DNA BoF is currently looking at these issues,
> as a generic attempt to tighten up the Network Attachment 
> strategies for wireless hosts.
> 
> This is similar to  what Mobile IP requires, but has
> broader applicability. For example, with some systems
> MobileIP signalling may be unnecessary, but
> detection of network change is.
> 
> The issues are: does it need to be done?
> If so, where and when?
> 
> where is the venue (IPv6, DNA, Mipshop....)
> 
> The when is whether it is applicable to 2461bis.
> 
> Greg
> 
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Gregory Daley <[email-masked]>
Date: Tue, 11 Nov 2003 02:37:58 +1100

Hi Jim,

----- Original Message -----
From: "Bound, Jim" <[email-masked]>
Date: Friday, November 7, 2003 5:00 pm
Subject: RE: Issue 13: Omission of prefix options - summary

> Greg,
> 
> That is good and clear mail.  Thanks then lets see what happens
> at DNA BOF.  I am on mipshop and quite nervous about the
> extreme conservative charter for time-to-market of those
> technologies as a note.  I  missed that charter discussion
> and I plan on being at DNA BOF if for no other reasons self
> defense.

I hope there are even  better reasons than
that to visit the BoF :)

The close nature of the MIPSHOP group has been
a concern which initially drove the DNA BoF.

At this stage, (as you can see) there is some early
work to get this worked out for DNA (or some other
modification to ND).  I'd have to say that a comprehensive
solution for DNA still needs work.

We're starting to get a good idea of what's useful
to DNA though (the problem and goals).  Hopefully
we can develop this into a coherent draft solution
before the next IETF.

> processes to keep evolving specs in a reasonable manner.  As 
> implementoras you, I have no issue of having ND integrated into a 
> spec for a

Indeed.  rfc2461bis is for clarification, not
new function.
 
> also a theory I have how to live with chaos within systems and 
> extensionto how nature operates on our planet.  But that gets into 
> all systems
> not just IETF.  

I think this is a good way to look at things
(and accords with how I see things).

Please tell me if I don't seem to be following
this maxim.

Greg