Subject: RE: IPv6 w.g. Last Call on "Unique Local IPv6 Unicast Addresses"

From: "Bound, Jim" <[email-masked]>
Date: Sun, 9 Nov 2003 15:34:14 -0500

Itojun,

I see your point.  But, we need to give the market away to do this or
they will invent addreses.  This is better than SL.  Unless we believe
it is ok for users to use Experimental RFC and are renumbering is strong
enough that we can support a change later with implementations.

So for now I have to support this for standards track but I am listening
to you seriously.

thanks
/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jun-ichiro itojun Hagino
> Sent: Sunday, November 09, 2003 6:50 AM
> To: [email-masked]
> Subject: Re: IPv6 w.g. Last Call on "Unique Local IPv6 
> Unicast Addresses"
> 
> 
> > > This is a IPv6 working group last call for comments on 
> advancing the 
> > > following document as an Proposed Standard:
> > > 
> > > 	Title		: Unique Local IPv6 Unicast Addresses
> > > 	Author(s)	: R. Hinden, B. Haberman
> > > 	Filename	: draft-ietf-ipv6-unique-local-01.txt
> > > 	Pages		: 15
> > > 	Date		: 2003-9-24
> 
> 	i object to publish this document as a standard track document.
> 	experimental would be more preferable.
> 
> 	unique local IPv6 unicast address avoids some problems 
> of site-local,
> 	but not all; there are major problem still remains.
> 	- it is not expected to be routable, however, it will be treated
> 	  as if it is a global address.  therefore it is likely 
> to be leak out.
> 	  1.0 asserts that "even if it leaks out there's no 
> conflict", but
> 	  "no conflict" is not enough - we do need to be 100% 
> sure there's no
> 	  leak out, otherwise it is unacceptable.
> 	- operationally, there's a much easier way to get a 
> block of address
> 	  which has the features unique local IPv6 unicast address has;
> 	  it is to use 6to4 address prefix 
> (2002:v4v4:v4v4::/48).  as long as
> 	  you do not renumber IPv4 address and IPv6 address at 
> the same time,
> 	  6to4 address will give you enough address for the 
> suggested use of
> 	  unique local IPv6 unicast address.  moreover, 6to4 address are
> 	  routable (though there's tunnelling overhead if 
> outsiders are to
> 	  contact 6to4 address accidentally).  there is no need 
> to define
> 	  unique local IPv6 unicast address.
> 
> 	some may object on the 2nd point, like "when I don't 
> have IPv4 address
> 	what should I do?".  well, IPv6/v4 dual stack operation 
> will continue
> 	for ages so i do not consider it a problem.
> 
> itojun
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Stephen Sprunk" <[email-masked]>
Date: Mon, 10 Nov 2003 14:20:13 -0600

Thus spake "Iljitsch van Beijnum" <[email-masked]>
> > I don't see how this can be true in general.
> > Here is an example using referrals; the three nodes involved are A, B,
> > C. Node A and B are in the same site, have both local and global
> > addresses, and C is in a different site.
>
> > Node A and B are communicating using these local addresses.
> > In particular, B contacted A using FQDN(A) and the naming system
> > somehow so that they ended up communcating with local addresses. (My
> > understanding is that part of the benefit of these local addresses is
> > that local communication prefer using local addresses over global
> > addresses.)
>
> Yes, but how???
>
> A simple method would be to check the first 48 bits of the IP addresses
> that are suspected of having "local" reachability. But this doesn't
> allow for the merging of two sites, which was presented as a rather
> prominent requirement during the site local wars (or at least the part
> I got to witness).

I don't see this is a problem at all; any given address on a host may only
be able to reach a subset of destinations, whether it's a site-local address
or not.  The only way to be sure is to try them all and see which works; if
the working one happens to be a site-local, who cares?

S

Stephen Sprunk         "God does not play dice."  --Albert Einstein
CCIE #3723         "God is an inveterate gambler, and He throws the
K5SSS        dice at every possible opportunity." --Stephen Hawking

---

From: "Christian Huitema" <[email-masked]>
Date: Tue, 11 Nov 2003 11:23:27 -0800

> > "Private" implies security virtues that they don't have.
> > "Local" implies geographical limitations that they don't have.
> > "Site" ditto.
> > "Organizational" implies usage limitations that they don't have.
> > "Limited scope" upsets people because of the complexity of the scope
> debate.
> > "Entity" really isn't different from "organization".
> >
> > Does anybody have a thesaurus handy?
> 
> Well, we have Autonomous Systems so maybe autonomous addressing?   Or
does
> that have too much ASN baggage/confusion, or hint too much at
> independence?

Globally Unique Non Normally Routable Address Class -- GUNNRAC ?