Subject: Re: IPv6 w.g. Last Call on "Unique Local IPv6 Unicast Addresses"

From: "Stephen Sprunk" <[email-masked]>
Date: Mon, 10 Nov 2003 14:08:02 -0600

Thus spake "Iljitsch van Beijnum" <[email-masked]>
> 1. To number systems/interfaces that are only accessible from withing
> the local network.
>...
> In the case of 1. the scope is site local, although the difinition of
> "site" may be subject to change.

Perhaps it'd clear things up if we changed the common name to
"org(anization) local" addresses?  I believe that was the intent behind the
original site-local addresses, but many/most end-users have more than one
phyiscal site and may be confused.

> Being able to route these addresses throughout the internet would be
> more of a drawback than a usable feature, as packets using these
> addresses may not enter or leave the network.

I think it would be reasonable to add a section explicitly stating such
addresses SHOULD NOT be routed in public networks, but that end-user
organizations MAY use them amongst themselves on private connections.

S

Stephen Sprunk         "God does not play dice."  --Albert Einstein
CCIE #3723         "God is an inveterate gambler, and He throws the
K5SSS        dice at every possible opportunity." --Stephen Hawking

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 Nov 2003 21:52:46 +0100

How about simply calling whatever we end up with "organizational addresses"?
I think that captures it much better than "local", "site local", "private"
or whatever.

   Brian

---

From: Mark Smith <[email-masked]>
Date: Tue, 11 Nov 2003 09:25:27 +1030

On Mon, 10 Nov 2003 21:52:46 +0100

> I think that captures it much better than "local", "site local", "private"

I agree. I think it is a more descriptive name.

In accompanying text, I think it would be good to state that an individual can also be classed as an "organisation" for these purposes.

(the name "entity addresses" comes to mind, but I think it is a bit too generic)

Regards,
Mark.

---

From: Bob Hinden <[email-masked]>
Date: Mon, 10 Nov 2003 15:25:14 -0800

>I agree. I think it is a more descriptive name.

As long as the final name doesn't end up being "Hinden/Haberman" I am open 
to what every name the working group thinks is best :-)

I assume this suggestion means changing the title and text in the document 
from:
   Unique Local IPv6 Unicast Addresses
to:
   Unique Organizational IPv6 Unicast Addresses
or:
   Organizational IPv6 Unicast Addresses

Bob

---

From: Hans Kruse <[email-masked]>
Date: Mon, 10 Nov 2003 19:54:05 -0500

That works for me...

--On Monday, November 10, 2003 21:52 +0100 Brian E Carpenter 
<[email-masked]> wrote:

> How about simply calling whatever we end up with "organizational
> addresses"? I think that captures it much better than "local", "site
> local", "private" or whatever.
>
>    Brian

Hans Kruse, Associate Professor
J. Warren McClure School of Communication Systems Management
Adjunct Associate Professor of Electrical Engineering and Computer Science
Ohio University, Athens, OH, 45701
740-593-4891 voice, 740-593-4889 fax

---

From: Mark Smith <[email-masked]>
Date: Tue, 11 Nov 2003 11:57:18 +1030

On Mon, 10 Nov 2003 15:25:14 -0800
Bob Hinden <[email-masked]> wrote:

I'd be inclined to go with this one, as it avoids implying a guarantee of uniqueness, which would then imply they could be used as PI addresses from day one.

Regards,
Mark.

---

From: Mark Smith <[email-masked]>
Date: Tue, 11 Nov 2003 12:20:28 +1030

Oops, sorry, just looked at the ID again, noticed that it states they are unique. Along those lines "Unique Organizational IPv6 Unicast Addresses" would be an acceptable title.

Hmm, at least for me, I would take the word "unique" to guarantee no duplication. With local generation, this isn't a guarantee as the uniqueness can't be validated. Maybe the term "near-unique" could be used throughout the text when describing the local generation case, to better describe what the user is getting a.k.a. truth in advertising.

Maybe just "Organizational IPv6 Unicast Addressesing" would be a better name, split into unique and near-unique types of organizational addressing within the document.

Thanks,
Mark.

On Tue, 11 Nov 2003 11:57:18 +1030

---

From: Tim Chown <[email-masked]>
Date: Tue, 11 Nov 2003 02:09:39 +0000

Only nit aside from a flavour of OSI is having to grep for "organi[sz]ational" 
in drafts/RFCs.

Most use of "site local" may be in SOHO networks; not sure the word fits
well for home use, but if site local has stigma attached...

Tim

---

From: "Chirayu Patel" <[email-masked]>
Date: Tue, 11 Nov 2003 09:03:46 +0530

IMHO, "private" is appropriate. As noted in other emails, "organization"
is bit too specific. Plus, "Private (IPv4) addresses" is a well known
concept, and it would simpler for IPv4 network (home, organization, etc
networks) operators to extend the same understanding to IPv6.

CP

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 11 Nov 2003 17:46:18 +0100

"Private" implies security virtues that they don't have.
"Local" implies geographical limitations that they don't have.
"Site" ditto.
"Organizational" implies usage limitations that they don't have.
"Limited scope" upsets people because of the complexity of the scope debate.
"Entity" really isn't different from "organization".

Does anybody have a thesaurus handy?

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 

NEW ADDRESS <[email-masked]> PLEASE UPDATE ADDRESS BOOK

---

From: Zefram <[email-masked]>
Date: Tue, 11 Nov 2003 16:56:02 +0000

>Does anybody have a thesaurus handy?

"Non-global"?

-zefram

---

From: Tim Chown <[email-masked]>
Date: Tue, 11 Nov 2003 16:57:25 +0000

> Does anybody have a thesaurus handy?

Well, we have Autonomous Systems so maybe autonomous addressing?   Or does
that have too much ASN baggage/confusion, or hint too much at independence?

Tim