Subject: RE: Issue 13: Omission of prefix options - resolution

From: Soliman Hesham <[email-masked]>
Date: Tue, 4 Nov 2003 22:17:19 -0500

> When this problem was noted in the early days I remember 
 > suggesting adding
 > "Solicited" bit to the router advertisement to address this 
 > issue.  Because
 > of backward compatibility problems that solution will no 
 > longer work well.
 > 
 > Is there some reason why we wouldn't want to add a new bit, say the
 > "Complete" bit, to the reserved field of the router 
 > advertisement?  I realize
 > I just finished ranting against adding new bits but using 
 > one of the reserved
 > bits for this purpose seems cleaner to me.

=> Apart from the fact that we have less reserved bits
than codes, is there any difference that you see
between adding a bit to the RS/RA Vs adding a new code?

Hesham

 > Tim Hartrick
 > Mentat Inc.

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Wed, 5 Nov 2003 08:39:25 +0200 (EET)

> between adding a bit to the RS/RA Vs adding a new code?

Current implementations probably ignore whole messages with codes != 0,
while the flag bits are merely ignored?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Greg Daley <[email-masked]>
Date: Wed, 05 Nov 2003 16:54:49 +1100

Hi Hesham,

> between adding a bit to the RS/RA Vs adding a new code?

A solicited bit doesn't tell you who solicited it in the first
place if the RA is multicast (so an S-bit only says we're likely
to be sending all PIOs).

Since most RA systems multicast responses, this may be
a big issue.

Erik had some ideas about this off-list though.

Greg