Subject: ISATAP in unmanaged networks?

From: Fred Templin <[email-masked]>
Date: Thu, 13 Nov 2003 06:47:02 -0800 (PST)

Hello,
 
It just now occurs to me that Christian's unmanaged networks
presentiation during v6ops yesterday did not mention ISATAP
as one of the automatic tunneling alternatives, and I wonder
why this is so.
 
I have not studied this space, but it occurs to me that ISATAP
could be tried as a first alternative to check whether the two
hosts are separated by a NAT. If there is no intervening NAT,
it seems to me that ISATAP would provide the benefit of not
needing the UDP header and "bubble" packets, yielding
greater efficiency. Otherwise, if blocked by a NAT the
initiating host coud after a short timeout try again with
Teredo.
 
I know that ISATAP has been seen as in the Enterprise
space, but I see potential applicability here for the
unmanaged. Comments?
 
Fred Templin
[email-masked]

---

From: Fred Templin <[email-masked]>
Date: Thu, 13 Nov 2003 07:15:29 -0800 (PST)

Pekka,
 
It is not at all true that the cooperation of an ISP is needed to
support ISATAP. ISATAP works just fine in intermittently
connected/disconnected networks - even of the mobile ad-hoc
variety. I spent several years proving this in my previous
employment at SRI, and nothing has changed since then.
 
See the "goals for local communications within sites" document
in the IPv6 space for other scenarios that would benefit from ISATAP.
 
Fred
[email-masked] 

Pekka Savola <[email-masked]> wrote:
I removed [email-masked] from Cc: to avoid unnecessary cross-posting.

> initiating host coud after a short timeout try again with

There are multiple cases to consider:

- host/router is not behind a NAT:
* the ISP is providing the ISATAP service
==> this is a cornercase of tunnel service by the ISP

- host/router is behind a NAT:
* .. when the ISP is doing the NAT (e.g., GPRS -kind of scenario, also 
sometimes used for commmon xDSL networks)
==> same as above, the service provided by the ISP

I don't think there's really applicability for ISATAP in this space if the 
ISP is co-operating (which is the requirement for ISATAP anyway). 
Configured tunneling (+ enhancements) is simpler and more generic.

-- 
Pekka Savola "You each name yourselves king, yet the
Netcore Oy kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "Christian Huitema" <[email-masked]>
Date: Thu, 13 Nov 2003 07:40:26 -0800

> initiating host coud after a short timeout try again with

Pekka already answered: we considered ISATAP, and found only one domain
of applicability, the "corner case" that Pekka mentioned. If the ISP is
not providing global addresses (e.g. provides net 10 addresses to
subscribers), then the subscribers cannot use the 6to4 technology. The
nodes could use Teredo, but the current specification requires that the
Teredo server uses a global address, which means that the Teredo clients
will have good connectivity with nodes outside the ISP, but poor
connectivity with nodes on the inside. Subscribers of a net 10 ISP will
be better served if this ISP provides an ISATAP service, including a
router. This will enable direct connectivity between the nodes, and
communication through the ISATAP router with the nodes outside the ISP.
We will document that.

However, the service only provides one IPv6 address per IPv4 address.
When the unmanaged network is connected through a NAT to a net 10
network, the nodes behind the NAT cannot directly use an ISATAP service
provided by an ISP. 

-- Christian Huitema 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------