Subject: Lower case allowed in IPv6??

From: "guru prasad" <[email-masked]>
Date: Fri, 02 Jul 2004 18:06:25 +0800

Hello All,

I have some basic queries.
 
1] Are lowercase Hex digits allowed in IPv6 address strings? 
2]Should these lower case digits be converted to uppercase and stored?

Thanks in Advance,
Regards,
Guruprasad SD
-- 
India.com free e-mail - www.india.com. 
Check out our value-added Premium features, such as an extra 20MB for mail storage, POP3, e-mail forwarding, and ads-free mailboxes!

Powered by Outblaze

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Mohacsi Janos <[email-masked]>
Date: Fri, 2 Jul 2004 12:34:42 +0200 (CEST)

> 1] Are lowercase Hex digits allowed in IPv6 address strings?

Yes.

> 2]Should these lower case digits be converted to uppercase and stored?

It is left to implementor to decide. Most of the implementation stores 
hexdigits in lower case.

Regards,

Janos Mohacsi
Network Engineer, Research Associate
NIIF/HUNGARNET, HUNGARY
Key 00F9AF98: 8645 1312 D249 471B DBAE  21A2 9F52 0D1F 00F9 AF98

---

From: "O.L.N.Rao" <[email-masked]>
Date: Fri, 02 Jul 2004 16:58:47 +0530

Hi Guru,

    Standard does not restrict.
    However, it depends on the implementation.
    FreeBSD & Linux allow both upper & lower case hex.

    And coming to storing the data ?
    What exactly you do with the stored data is important.
    If you are using the data to give to another call something like
inet_pton then no need to change its case.

    Hope this helps

Regards,
O.L.N. Rao

----- Original Message ----- 
From: "guru prasad" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 02, 2004 3:36 PM
Subject: Lower case allowed in IPv6??

> Check out our value-added Premium features, such as an extra 20MB for mail
storage, POP3, e-mail forwarding, and ads-free mailboxes!