Subject: Re: IPv6 WG Last Call:draft-ietf-ipngwg-icmp-v3-05.txt

From: Tim Hartrick <[email-masked]>
Date: 27 Oct 2004 16:12:29 -0700

All,

On Wed, 2004-10-27 at 15:18, Fred Templin wrote:
> It wasn't specified, but the IPv6 layer should have reasonable
> assurance that
> the corruption occurred beyond the end of the header before sending
> ICMPs.
>  

It is hard to imagine the IESG allowing functionality this speculative
to arrive in a specification that is recycling at DS.  And for good
reason.  There is no chance that any functionality like this could get
implementation reports sufficient to qualify for DS within three IETFs
let alone within a couple of days or weeks.

This work doesn't belong in this specification.  It may not belong
anywhere because of the issues cited by Perry.

Tim Hartrick
Mentat Inc.

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: [email-masked]
Date: Fri, 29 Oct 2004 01:35:46 -0500

Fred,

Looking at all the discussion/arguments, I think we have 
consensus about not adding the proposed code point to the
spec.

I agree with all others that it is not required in this
spec and it is not a good idea to add this code point at
this (DS) stage.

Regards
Mukesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Tim Hartrick
> Sent: Wednesday, October 27, 2004 4:12 PM
> To: Fred Templin
> Cc: Brian Haberman; IPv6 WG; Pekka Savola; Perry Lorier
> Subject: Re: IPv6 WG Last Call:draft-ietf-ipngwg-icmp-v3-05.txt
> 
> 
> 
> 
> All,
>

---

From: [email-masked]
Date: Fri, 29 Oct 2004 01:38:16 -0500

Pekka,

Sorry to have that missed.  I somehow assumed that we needed no 
modification after the consensus.  My bad !

I will try to rephrase the text while addressing all the other
LC comments.

Regards
Mukesh

> ext Pekka Savola
> Sent: Wednesday, October 27, 2004 9:39 AM
> To: Brian Haberman
> Cc: IPv6 WG
> Hi,
> On Mon, 25 Oct 2004, Brian Haberman wrote:
> >     This is the start of a 1-week IPv6 working group last call for
> > recycling:
> >
> > 	Title		: Internet Control Message Protocol 
> (ICMPv6)for the
> > 			  Internet Protocol Version 6 (IPv6) 
> Specification
> > 	Author(s)	: A. Conta, et al.
> > 	Filename	: draft-ietf-ipngwg-icmp-v3-05.txt
> > 	Pages	: 26
> > 	Date		: 2004-10-22
> >
> > at Draft Standard.  This LC is aimed at ensuring resolution of all
> > issues raised during the previous last call.  Substantive comments
> > should be directed to the mailing.  This last call will end 
> on 11/01/2004.
> 
> I think it was forgotten to clarify the ICMPv6 rate-limiting language 
> (at the very least, using 'originate' instead of 'send') based on the 
> consensus called at:
> 
> http://www.ietf.org/mail-archive/web/ipv6/current/msg03539.html
> 
> One attempt by me to fix this was at:
> 
> http://www.ietf.org/mail-archive/web/ipv6/current/msg03421.html
> 
> Other than that, I think the doc should be fine.
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
>

---

From: [email-masked]
Date: Fri, 29 Oct 2004 01:44:59 -0500

Fred,

Regards
Mukesh