Subject: [psg.com #599] State diagram does not consider NA with S=1 O = 0

From: [email-masked]
Date: Mon, 25 Oct 2004 03:11:25 +0000

Subject: State diagram does not consider NA with S=1 O = 0

Issue description:

>From Peter Grubmair:

In the state diagram in RFC2461-bis
in Appendic C, page 79, the event of receiving
a NA with solicitated = 1 and Override = 0
in state DELAY is not handled.
To my understanding the same treatment as in
state STALE or PROBE has to be applied.
To me it also seems, that the state DELAY can
be treated to equal to PROBE, only the start of timer in
state STALE has to use another timing value as
starting the timer uppon timeout in PROBE state.
In my model entering the PROBE state does not
send NS, but only starts the delay timer.
This can be done without changing behavior, maybe
state DELAY should be dropped.

=> I've added DELAY to the states STALE and PROBE
in the state machine. 

This issue is now resolved.

Hesham

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: [email-masked]
Date: Mon, 25 Oct 2004 03:11:26 +0000

Hesham