Subject: RE: Query:IPv6 Over ATM PVC Operation

From: "Nimrod Sterrn" <[email-masked]>
Date: Mon, 4 Oct 2004 11:07:38 +0200

see my comments in ==>

-----Original Message-----
From: arvind saproo [mailto:[email-masked]]
Sent: Fri, October 01, 2004 3:44 PM
To: [email-masked]
Subject: Query:IPv6 Over ATM PVC Operation

Hi, 
  I have the following query regarding IPv6 Over ATM PVC operation (rfc2492).
  I would appreciate if someone could answer the same.

 Query -
===== 
RFC does not clearly mention what to fill as the Source/Target
Link Layer address in the Source/Target Link Layer options 
of IND (Inverse ND) messages. 

Also, there is no mention of any reference document which
covers the same.

All that is said is [Section 3. PVC Environments] - 

"Since ATM PVC links do not use link-layer addresses, the link-layer
address options SHOULD not be included in any ND message [11].  If a
link-layer address option is present in an ND message, then the
option SHOULD be ignored."

==>  It may be confusing after reading RFC3122 (inverse ND) which requires it as part of the 
     solicitation (src and dst LL address) and reply (target LL address).
     but since PVC in "permanent" its not needed (?!)
  
Does this mean that we zero fill the Link Layer address in Source/Target 
Link Layer options of the IND messages?

This information must be clearly mentioned to avoid interoperability issues. 

Thanks for your time,
Rgds,
arvind

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: arvind saproo <[email-masked]>
Date: Thu, 07 Oct 2004 10:26:27 +0530

Hi,
  Thanks for the reply.
  If the Source and Target Link Layer Address Options 
are not included in (IPv6 Over ATM PVC) IND 
message, then the message will straight-away be considered an 
invalid one as per the message validation checks
specified in IND RFC (rfc 3122).
  A better option would be to zero fill the options
though the options would be useless in that scenario (?)

Alex, could you help on this issue since the
authors of IPv6 Over ATM RFC (rfc 2492) are not
reachable at the e-mail address specified in the RFC?

Rgds,
arvind

-----Original Message-----
From: Nimrod Sterrn [mailto:[email-masked]] 
Sent: Monday, October 04, 2004 2:38 PM
To: arvind saproo
Cc: [email-masked]
Subject: RE: Query:IPv6 Over ATM PVC Operation

see my comments in ==>

-----Original Message-----
From: arvind saproo [mailto:[email-masked]]
Sent: Fri, October 01, 2004 3:44 PM
To: [email-masked]
Subject: Query:IPv6 Over ATM PVC Operation

Hi, 
  I have the following query regarding IPv6 Over ATM PVC operation
(rfc2492).
  I would appreciate if someone could answer the same.

 Query -
===== 

==>  It may be confusing after reading RFC3122 (inverse ND) which requires
it as part of the 
     solicitation (src and dst LL address) and reply (target LL address).
     but since PVC in "permanent" its not needed (?!)

Thanks for your time,
Rgds,
arvind

---

From: Alex Conta <[email-masked]>
Date: Fri, 22 Oct 2004 11:41:14 -0400

Arvind,

I believe that Inverse Discovery (RFC3122) has its own rules, within its 
own scope, which is Inverse Discovery, as opposed to Discovery. These 
rules apply generically to the typical users of Inverse Discovery, like 
ATM, or Frame Relay.

I hope this helps,
Alex