Subject: RE: Solicit comments on draft-pashby-ipv6-network-discovery-00.txt

From: "Pashby, Ronald W CTR NSWCDD-B35" <[email-masked]>
Date: Wed, 28 Sep 2005 07:55:53 -0500

Agreed. However, if it is mandatory then there is more of a leg to stand on in requiring it.

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Wednesday, September 28, 2005 8:50
To: Pashby, Ronald W CTR NSWCDD-B35
Cc: Jari Arkko; [email-masked]
Subject: RE: Solicit comments on
draft-pashby-ipv6-network-discovery-00.txt

On Wed, 28 Sep 2005, Pashby, Ronald W CTR NSWCDD-B35 wrote:
> Yes, but that is experimental so it is not mandatory to implement 
> either. So, again I say there is no mandatory way in which a network 
> management application can reliably discover IPv6 networks. This is 
> why the draft recommends making IND mandatory.

Yes, so we get back to the main point.  It's not really the IETF's 
business to mandate or not mandate certain protocols for 
implementation.  If you put it as a requirement in your CFF's, you're 
likely going to get a better response.

In other words, if you can convince the vendors and other users that a 
feature is really useful, it's going to be implemented... if you 
can't, then it's probably better than an IETF mandate which the 
vendors can (and _do_) ignore in any case.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Jeff Pickering" <[email-masked]>
Date: Wed, 28 Sep 2005 09:13:59 -0400

Ron,

Sorry if this has already been asked. But why change icmp ehco request
if IND is mandated and is multicast?

Jeff

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Pashby, Ronald W CTR NSWCDD-B35
Sent: Wednesday, September 28, 2005 8:56 AM
To: Pekka Savola
Cc: Jari Arkko; [email-masked]
Subject: RE: Solicit comments on
draft-pashby-ipv6-network-discovery-00.txt

Agreed. However, if it is mandatory then there is more of a leg to stand
on in requiring it.

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Wednesday, September 28, 2005 8:50
To: Pashby, Ronald W CTR NSWCDD-B35
Cc: Jari Arkko; [email-masked]
Subject: RE: Solicit comments on

Notice: The information contained in this e-mail message and/or attachments to it may contain confidential or privileged information. If you are not the intended recipient, any dissemination, use, review, distribution, printing or copying of the information contained in this e-mail message and/or attachments to it are strictly prohibited. If you have received this communication in error, please notify us by reply e-mail or telephone and immediately and permanently delete the message and any attachments. Thank you

---

From: "Pashby, Ronald W CTR NSWCDD-B35" <[email-masked]>
Date: Wed, 28 Sep 2005 11:37:03 -0500

Jeff,
The change to icmp is to avoid too many responses that may flood the querier and also to limit DoS attacks of multicast ICMP echo requests. ICMP is mandatory so this is guaranteed to work unless disabled on a per host basis. The recommendation is to mandate IND and put the hold-off timer in. If IND was mandated (and available in all nodes) it would serve the discovery purpose but not change the ICMP DoS case.
Ron

-----Original Message-----
From: Jeff Pickering [mailto:[email-masked]]
Sent: Wednesday, September 28, 2005 9:14
To: Pashby, Ronald W CTR NSWCDD-B35
Cc: [email-masked]
Subject: RE: Solicit comments on

Ron,

Jeff

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Wednesday, September 28, 2005 8:50
To: Pashby, Ronald W CTR NSWCDD-B35
Cc: Jari Arkko; [email-masked]
Subject: RE: Solicit comments on

--