Subject: RE: Solicit comments on draft-pashby-ipv6-network-discovery-00.txt

From: "Pashby, Ronald W CTR NSWCDD-B35" <[email-masked]>
Date: Wed, 28 Sep 2005 07:15:41 -0500

Yes, but that is experimental so it is not mandatory to implement either. So, again I say there is no mandatory way in which a network management application can reliably discover IPv6 networks. This is why the draft recommends making IND mandatory.

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Wednesday, September 28, 2005 1:47
To: Pashby, Ronald W CTR NSWCDD-B35
Cc: Jari Arkko; [email-masked]
Subject: RE: Solicit comments on
draft-pashby-ipv6-network-discovery-00.txt

On Mon, 26 Sep 2005, Pashby, Ronald W CTR NSWCDD-B35 wrote:
> These hosts will still have a global address and there is no way to 
> discover those addresses.

I guess node-information queries could be used to get that?

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]]
> Sent: Monday, September 26, 2005 1:53
> To: Pashby, Ronald W CTR NSWCDD-B35
> Cc: Jari Arkko; [email-masked]
> Subject: RE: Solicit comments on
> draft-pashby-ipv6-network-discovery-00.txt
>
>
> On Fri, 23 Sep 2005, Pashby, Ronald W CTR NSWCDD-B35 wrote:
>> There are many networks that devices do not through routers. So
>> asking the router for their addresses is not sufficient.
>
> So, in these cases using the link-local all-hosts multicast address
> should be fine?
>
>

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Wed, 28 Sep 2005 15:49:41 +0300 (EEST)

On Wed, 28 Sep 2005, Pashby, Ronald W CTR NSWCDD-B35 wrote:
> Yes, but that is experimental so it is not mandatory to implement 
> either. So, again I say there is no mandatory way in which a network 
> management application can reliably discover IPv6 networks. This is 
> why the draft recommends making IND mandatory.

Yes, so we get back to the main point.  It's not really the IETF's 
business to mandate or not mandate certain protocols for 
implementation.  If you put it as a requirement in your CFF's, you're 
likely going to get a better response.

In other words, if you can convince the vendors and other users that a 
feature is really useful, it's going to be implemented... if you 
can't, then it's probably better than an IETF mandate which the 
vendors can (and _do_) ignore in any case.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 28 Sep 2005 16:01:21 +0300

Agreed.

--Jari