Subject: RE: [Int-area] Re: KHIs and SHA-256

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 14 Nov 2005 18:03:02 -0500

I didn't assume that the identifier space with no locator overtones must
be non-intersecting with a routable network space.

Are you saying that use of these identifiers must only apply to isolated
nets?

Bert

> -----Original Message-----
> From: Geoff Huston [mailto:[email-masked]] 
> Sent: Monday, November 14, 2005 5:54 PM
> To: Manfredi, Albert E
> Cc: Internet Area; [email-masked]
> Subject: RE: [Int-area] Re: KHIs and SHA-256 
> 
> Don't present such packets to the router.
> 
> i.e. if you are working in an identifier space that has no locator 
> overtones (I have already seen the assertion that these 
> identifiers are 
> "non-routeable"), then how exactly will these identity values 
> show up in a 
> packet on the wire and be presented to routers are a 
> destination or source 
> locator?
> 
>    Geoff
> 
> 
> 
> 
> 
> 
> At 08:03 AM 15/11/2005, Manfredi, Albert E wrote:
> >Geoff,
> >
> >How would a router know not to forward such packets, in the event the
> >top 64 bits clash with a real IPv6 address?
> >
> >Bert
> >
> >
> > > -----Original Message-----
> > > From: Geoff Huston [mailto:[email-masked]]
> > > Sent: Monday, November 14, 2005 3:11 PM
> > > To: Pekka Nikander
> > > Cc: [email-masked]; Brian Haberman; Internet Area
> > > Subject: Re: [Int-area] Re: KHIs and SHA-256
> > >
> > > But nothing in what you have said is inconsistent with the
> > > proposition that
> > > there is _no_ requirement to allocate IPv6 unicast address
> > > space for this
> > > form of use of 128 numbers.
> > >
> > > As you yourself point out "they are non-routeable" and theya
> > > re understood
> > > to be "semantically different".
> > >
> > > i.e. what you are going with the number in this context is really
> > > interesting, and a Good Thing in terms of furthering our
> > > understanding of
> > > the implications of the identifier / locator split. But I
> > > have yet to see a
> > > justification as to why these numbers should also entail a
> > > reservation in
> > > the IPv6 unicast number space. Indeed, I can think of 
> some tolerable
> > > arguments as to why they should deliberately clash with
> > > unicast address values.
> > >
> > > regards,
> > >
> > >       Geoff
> >
> >
> >--------------------------------------------------------------------
> >IETF IPv6 working group mailing list
> >[email-masked]
> >Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> >--------------------------------------------------------------------
> 
> 
> 
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Geoff Huston <[email-masked]>
Date: Tue, 15 Nov 2005 10:39:32 +1100

I heard "non-routeable" with respect to these identifiers.

Is this _really_ the case?

   Geoff