Subject: RE: IPR Notification on RFC 2462 and 2464

From: "Bound, Jim" <[email-masked]>
Date: Fri, 4 Nov 2005 12:43:50 -0500

We had stateless implemented in 1994 and the company in question was not
part of the original ND or Stateless discussions except now via
Christian Huitema who is now with the company in question.  Also I am
sure Bill Simpson can verify prior art and most likely even back to OSI
ES-IS.  This is really to bad folks.

/jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Greg Daley
Sent: Friday, November 04, 2005 2:15 AM
To: Margaret Wasserman
Cc: [email-masked]
Subject: Re: Fwd: IPR Notification on RFC 2462 and 2464

Hi,

Sorry to follow myself up, but I have further information
which may be relevant to establishment of prior art for
IPv6 Stateless Address Autoconf.

The previous e-mails' description of existing published
documents may only describe 102(a) prior art, (As
described by PUBPAT's own information on prior art).

As such, it is susceptible to a prior unpublished
invention date by the patent holders (documented
internally to the patent holder's Lab for example).

There seems to be evidence though that
FTP software was shipping IPv6 code with SAA
more than 1 year before the patent was applied for
(August 1996 ship):

www.connectathon.org/talks97/helen.pdf

This would constitute 102(b) prior art if the
presentation's contents were true.

In that case, there could not be applicability of this
patent to IPv6 Stateless Address Autoconfiguration,
so long as the product was available in the USA at the
time (as far as I can tell).

Greg

Greg Daley wrote:
> Hi Margaret,
> 
> I'm not sure how this affects the IPR notification,
> but I've had a quick look at existing art available
> at the time of the patent application.
> 
> There are existing specifications of IPv6 autonomous
> address configuration in published drafts which
> significantly predate the patent application (> 12 months).
> 
> This I guess, it substantively the same as the current
> RFC2462bis, and RFC2462 (and RFC1971 - August 1996).
> 
> The descriptions of Address configuration with DAD were
> also described in earlier published drafts:
> 
>
http://www.watersprings.org/pub/id/draft-ietf-addrconf-ipv6-auto-02.txt
> 
> And a fairly complete description of how DAD works (with
> different message names) is contained in the earlier version:
> 
>
http://www.watersprings.org/pub/id/draft-ietf-addrconf-ipv6-auto-01.txt
> 
> The latest of these two documents is dated June 5, 1995
> (although it may have been received in the repository later?).
> 
> Since provisional patent applications have only been supported
> for IPR protection since June 8 1995, and the Patent application
> for patent number 6,101,499 is April 8, 1998 (and doesn't
> reference any provisional application anyway), my guess is that
> the existing draft publications provide a clear prior art for
> IPv6 autonomous addressing.
> 
> Provisional applications description:
> http://www.uspto.gov/web/offices/pac/provapp.htm
> 
> Actually, given the wealth of existing IPv6 autonomous address
> configuration techniques, it's amazing that there's no reference
> to them in the description of the patent, made at application time.
> 
> Clearly, I'm not able to provide legal advice about this
> situation, but the above information may be able to help someone
> who is.
> 
> Greg Daley.
> 
> 
> Margaret Wasserman wrote:
> 
>>
>> FYI --
>>
>> The official disclosure will probably be posted by the secretariat 
>> shortly, but in the meantime I thought that the IPv6 WG should be 
>> aware of this incoming IPR notification.
>>
>> Margaret
>>
>>> Date: Mon, 24 Oct 2005 12:01:49 -0400
>>> From: Dan Ravicher <[email-masked]>
>>> X-Accept-Language: en-us, en
>>> To: Margaret Wasserman <[email-masked]>,
>>>         Mark Townsley <[email-masked]>,
>>>         Robert Hinden <[email-masked]>,
>>>         Brian Haberman <[email-masked]>
>>> Subject: Fwd: IPR Notification
>>> X-Spam: [F=0.0001020200; B=0.500(0); S=0.010(2005092001); 
>>> MH=0.500(2005102404); R=0.010(s3/n722); SC=none; spf=0.500]
>>>
>>> Dear Ms. Wasserman and Messrs. Townsley, Hinden and Haberman:
>>>
>>> The Public Patent Foundation ("PUBPAT") formally notified IETF today

>>> of the existence of intellectual property rights that may relate to 
>>> technology described in IETF documents.  Specifically, U.S. Patent 
>>> No. 6,101,499 ("the '499 patent") owned by Microsoft Corporation may

>>> relate to RFC 2462 - IPv6 Stateless Address Autoconfiguration and
RFC 
>>> 2464 - Transmission of IPv6 Packets over Ethernet Networks 
>>> (collectively referred to as "IPv6").  A copy of the formal 
>>> notification appears below.
>>>
>>> As stated in the notification, although others have disclosed the 
>>> '499 patent with respect to IPv4, its claims may also relate to
IPv6. 
>>> For example, claims 1 and 30 could relate to the technology
described 
>>> in RFC 2462.  However, other than identifying this potential 
>>> relationship, PUBPAT takes no position regarding the validity or 
>>> scope of the '499 patent.
>>>
>>> If PUBPAT can provide any further information or be of any other 
>>> assistance to IETF in its review of this matter, including perhaps 
>>> raising this issue with the entire IPv6 Working Group, should that
be 
>>> desirable, please do not hesitate to contact me.
>>>
>>> Sincerely,
>>>
>>> Daniel B. Ravicher
>>> Executive Director
>>> Public Patent Foundation
>>> 1375 Broadway, Suite 600
>>> New York, NY 10018
>>> (212) 796-0571 direct
>>> (212) 796-0570 main
>>> (212) 591-6038 fax
>>> [email-masked]
>>> www.pubpat.org
>>>
>>>
>>>
>>> -------- Original Message --------
>>> Subject: IPR Notification
>>> Date: Mon, 24 Oct 2005 11:53:54 -0400
>>> From: Dan Ravicher <[email-masked]>
>>> To: [email-masked]
>>>
>>> Dear IETF:
>>>
>>> Pursuant to IETF RFC 3979 Section 6.1.3, the Public Patent
Foundation
>>> ("PUBPAT") hereby notifies IETF of the existence of intellectual
>>> property rights that may relate to technology described in IETF
>>> documents.  Specifically, U.S. Patent No. 6,101,499 ("the '499
patent")
>>> owned by Microsoft Corporation may relate to RFC 2462 - IPv6
Stateless
>>> Address Autoconfiguration and RFC 2464 - Transmission of IPv6
Packets
>>> over Ethernet Networks (collectively referred to as "IPv6").
>>>
>>> Although IETF was previously notified of the '499 patent with
respect to
>>> IPv4 related documents (see
>>> http://www.ietf.org/ietf/IPR/MICROSOFT-499.txt and
>>> https://datatracker.ietf.org/public/ipr_detail_show.cgi?ipr_id=554),
the
>>> '499 patent's claims, including for example claims 1 and 30, could
>>> possibly be read as also relating to IPv6.  However, other than
>>> identifying this potential relationship, PUBPAT takes no position
>>> regarding the validity or scope of the '499 patent.
>>>
>>> If we can provide any further information or be of any other
assistance
>>> to IETF in its review of this matter, please do not hesitate to 
>>> contact me.
>>>
>>> Sincerely,
>>>
>>> Daniel B. Ravicher
>>> Executive Director
>>> Public Patent Foundation
>>> 1375 Broadway, Suite 600
>>> New York, NY 10018
>>> (212) 796-0571 direct
>>> (212) 796-0570 main
>>> (212) 591-6038 fax
>>> [email-masked]
>>> www.pubpat.org
>>>
>>
>> --------------------------------------------------------------------
>> IETF IPv6 working group mailing list
>> [email-masked]
>> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
>> --------------------------------------------------------------------
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Mark Smith <[email-masked]>
Date: Sat, 5 Nov 2005 10:40:39 +1030

On Fri, 4 Nov 2005 12:43:50 -0500

> ES-IS.  This is really to bad folks.

I'm pretty sure both Novell's IPX and Apple's Appletalk also use similar, if
not the same techniques to generate automated layer 3 addresses, in the
absence of routers announcing prefixes to use on the link.

Regards,
Mark.