Subject: [IPP] ISSUE: Should JPS2 shorten "job-delay-output-until[-time]" to just "job-delay-until[-time]" to align with MFD (and PWG Semantic Model)?

From: "Tom Hastings" <[email-masked]>
Date: Sun, 18 Apr 2010 23:12:34 -0700

Peter,

ISSUE: Should we remove the "-output" from the name to align the names more
with the MFD spec (and PWG Semantic Mode)?

In other words:

"job-delay-until" 

instead of :

"job-delay-output-until"

and:

ISSUE: Should we remove the "-output" from the name to align the names more
with the MFD spec (and PWG Semantic Mode)?

In other words:

"job-delay-until-time" 

instead of :

"job-delay-output-until-time"

Tom

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 19 Apr 2010 04:16:33 -0700

Tom,

The PWG Semantic Model schema uses JobDelayOutputUntil and
JobDelayOutputUntilTime which aligns with the JSP2 specification.
(schema elements dropped the '-' and uppercased the following letter)  I
prefer to have the schema track JPS2 and I think the JPS2 attribute name
is more descriptive.  The MFD specification will synch up with JPS2 when
it is in final form.

Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

From: Tom Hastings [mailto:[email-masked]] 
Sent: Monday, April 19, 2010 2:13 AM
To: Zehler, Peter
Cc: [email-masked]
Subject: ISSUE: Should JPS2 shorten "job-delay-output-until[-time]" to
just "job-delay-until[-time]" to align with MFD (and PWG Semantic
Model)?

Peter,

ISSUE: Should we remove the "-output" from the name to align the names
more with the MFD spec (and PWG Semantic Mode)?

In other words:

"job-delay-until" 

instead of :

"job-delay-output-until"

and:

ISSUE: Should we remove the "-output" from the name to align the names
more with the MFD spec (and PWG Semantic Mode)?

In other words:

"job-delay-until-time" 

instead of :

Tom

---

From: Ira McDonald <[email-masked]>
Date: Mon, 19 Apr 2010 12:11:58 -0400

Hi,

Agreed - we should keep "output" in the names, because
otherwise "delay" alone is far too ambiguous about its
behavior as a description.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Mon, Apr 19, 2010 at 7:16 AM, Zehler, Peter <[email-masked]> wrote:
> JobDelayOutputUntilTime which aligns with the JSP2 specification.  (schema
> elements dropped the ‘-‘ and uppercased the following letter)  I prefer to
> have the schema track JPS2 and I think the JPS2 attribute name is more
> descriptive.  The MFD specification will synch up with JPS2 when it is in
> final form.
>
> Pete
>
>
>
>
>
> Peter Zehler
>
> Subject: ISSUE: Should JPS2 shorten "job-delay-output-until[-time]" to just
> "job-delay-until[-time]" to align with MFD (and PWG Semantic Model)?
>
>
>
> Peter,
>
>
>

---

From: "William Wagner" <[email-masked]>
Date: Tue, 20 Apr 2010 15:56:28 -0400

All,

Sorry I missed yesterday's call, but I was traveling.

I wonder at Tom's comment since they MFD Overall document
(ftp://ftp.pwg.org/pub/pwg/mfd/wd/wd-mfdoverallmod10-20100329.pdf)
definitely uses the terms JobDelayOutputUntil and JobDelayOutputUntilTime
and has from the time that these terms  were introduced in January. Perhaps
there is some other document he is referring too?

Bill Wagner

From: Zehler, Peter [mailto:[email-masked]] 
Sent: Monday, April 19, 2010 7:17 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: ISSUE: Should JPS2 shorten "job-delay-output-until[-time]" to
just "job-delay-until[-time]" to align with MFD (and PWG Semantic Model)?

Tom,

elements dropped the '-' and uppercased the following letter)  I prefer to

Pete

Peter Zehler

Peter,

In other words:

"job-delay-until" 

instead of :

"job-delay-output-until"

and:

In other words:

"job-delay-until-time" 

instead of :

Tom

---

From: Ira McDonald <[email-masked]>
Date: Tue, 20 Apr 2010 16:36:36 -0400

Hi Bill,

Perhaps Tom was looking at some other source?

But the confusion was definitely resolved yesterday to keep
"delay-output" in the names - because "delay" alone is too
ambiguous (i.e., appears to be a "hold" synonym).

In addition we removed the "job-delay-output-xxx" entirely
from the Hold-Job operation - they can only be set using
the Set-Job-Attributes operation.

Cheers,
- Ira

On Tue, Apr 20, 2010 at 3:56 PM, William Wagner <[email-masked]> wrote:
> All,
>
>
>
> Sorry I missed yesterday’s call, but I was traveling.
>
>
>
> I wonder at Tom’s comment since they MFD Overall document