Subject: [IPP] Stable draft of IPP Everywhere Project Charter (17 April 2010)

From: Ira McDonald <[email-masked]>
Date: Sat, 17 Apr 2010 13:37:22 -0400

Hi,

[For discussion during IPP WG meeting on Monday 19 April]

In preparation for PWG Formal Vote, I have just posted a Stable draft of the
IPP Everywhere Project Charter (4th version) at:

 ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100417.pdf / doc
 - clean copy with line numbers

 ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100417-rev.pdf
/doc
 - redline copy with line numbers

Only changes are status to Stable and corrected several typos.

Cheers,
- Ira (IPP co-editor)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "William Wagner" <[email-masked]>
Date: Fri, 23 Apr 2010 13:55:30 -0400

Sorry I missed the IPP call and did not bring this up at the Steering
committee call. What is the status of this charter? Is it going to be put up
for PWG vote? 

Thanks,

Bill Wagner

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira
McDonald
Sent: Saturday, April 17, 2010 1:37 PM
To: [email-masked]; Michael R Sweet; Ira McDonald
Subject: [IPP] Stable draft of IPP Everywhere Project Charter (17 April
2010)

Hi,

 ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100417.pdf /
doc
 - clean copy with line numbers

Cheers,
- Ira (IPP co-editor)

---

From: Ira McDonald <[email-masked]>
Date: Fri, 23 Apr 2010 14:11:48 -0400

Hi Bill,

Yes, we agreed at the April PWG F2F that Mike Sweet (as
PWG Chair and IPP Secretary and IPP Everywhere Technical
Lead) would announce a normal length (22 calendar days)
PWG Formal Vote on the Charter.

Votes to be returned to Mike, Paul, and Ira, for safety.

I just changed the status from Interim to Stable to follow our
process for a document to enter PWG Formal Vote.

Mike said a couple of days ago that he'd get to it soon.

We do need to get it moving, to complete *before* the
June PWG F2F.

Cheers,
- Ira

---

From: Michael Sweet <[email-masked]>
Date: Fri, 23 Apr 2010 11:25:52 -0700

> committee call. What is the status of this charter? Is it going to be put up

Yes, Ira posted a "final draft" and I am in the process of getting that email out...  If not today, Monday...

>  579 Park Place  Saline, MI  48176

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Michael Sweet <[email-masked]>
Date: Tue, 27 Apr 2010 15:45:44 -0700

On Apr 27, 2010, at 3:33 PM, George Liu wrote:
>> IPP Everywhere (wd-ippeve10-yyyymmdd) - defines ... one IPP Everywhere
> conformance level, based on the IPP/2.0 conformance level defined in PWG
> IPP Version 2.0 Second Edition
> 
> Does it mean a IPP Everywhere complaint software/printer has to be IPP
> 2.0 or 2.1 or 2.2 compliant?

Since we haven't even started the charter vote for IPP Everywhere yet (hoping to get that out today, we'll see...) it is impossible to answer that authoritatively, however I have always pitched IPP Everywhere as IPP/2.0+ (that is, 2.0 or higher).

>> STD-2 Prototype working draft of IPP Everywhere - Q2 2011
> Has any company committed to the development of IPP Everywhere
> prototype?

See above.  I have received positive feedback from several vendors already, so I think it is a safe bet that we'll have at least a few prototypes to play with.  Also, CUPS already implements everything that has been discussed for IPP Everywhere thus far...

> Thanks
> George
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Michael Sweet
> Sent: Friday, April 23, 2010 11:26 AM
> To: William Wagner
> Cc: [email-masked]
> Subject: Re: [IPP] Stable draft of IPP Everywhere Project Charter (17
> April2010)
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 27 Apr 2010 17:39:13 -0700

On Apr 27, 2010, at 5:22 PM, George Liu wrote:
> Michael,
> 
> Thanks for the quick feedback.
> 
> I studied the Charter document. From the problem statement, it seems
> that the ultimate goal is to develop a comprehensive solution that can
> eliminate printer drivers. 
> 
> If my understanding is correct, I feel the "goal of IPP Everywhere"
> paragraph is not emphasizing the objective of "eliminating printer
> drivers" enough. 

Fair enough, and good feedback that can be applied to the final version of the charter.

> Also I feel setting an objective of " Use IPP/2.0 conformance level as
> basis of IPP Everywhere." is too strict. No use case has been developed
> for IPP Everywhere, it might be a bit earlier to decide on the technical
> details. 

Given that this will be a project for the IPP working group and that IPP/2.0 is the current version of IPP approved by the PWG, I don't think it is a stretch to make IPP/2.0 the basis of "IPP Everywhere".

That said, there have also been discussions of mapping any new stuff we come up with to the PWG semantic model, which will allow it to be used with other protocol bindings as well.

> 
> Thanks for your attention.
> George
> 
> 
> From: Michael Sweet [mailto:[email-masked]] 
> Sent: Tuesday, April 27, 2010 3:46 PM
> To: George Liu
> Cc: William Wagner; [email-masked]
> Since we haven't even started the charter vote for IPP Everywhere yet
> (hoping to get that out today, we'll see...) it is impossible to answer
> that authoritatively, however I have always pitched IPP Everywhere as
> IPP/2.0+ (that is, 2.0 or higher).
> 
> See above.  I have received positive feedback from several vendors
> already, so I think it is a safe bet that we'll have at least a few
> prototypes to play with.  Also, CUPS already implements everything that
> has been discussed for IPP Everywhere thus far...
> 
>> 
>> 
>> Thanks
>> George
>> 
>> Yes, Ira posted a "final draft" and I am in the process of getting
> that
>> email out...  If not today, Monday...
>> 
>>> 
>>> Thanks,
>>> 
>>> Bill Wagner
>>> 
>> Ira

---

From: Ira McDonald <[email-masked]>
Date: Wed, 28 Apr 2010 13:39:39 -0400

Hi George,

Thanks for your good feedback.

Apparently, we're going to have to bend the PWG Process
a bit - e.g., to allow a Yes vote with editorial comments.

The PWG does NOT normally *vote* on individual project
charters - only on entire new working group charters.

But Bill Wagner suggested in the PWG Steering Committee
that we make this exception in order to get wider visibility for
the IPP Everywhere project.

Note that IPP/2.0 is simply IPP/1.1 with *correct* handling
of errors and exceptions (as already specified in IPP/1.1),
so I think it's a reasonable basis for IPP Everywhere.

Also, although IPP Everywhere supports the goal of printing
with generic (PDL-based) printer drivers, it's NOT an actual
requirement - I'm not sure about adding this to the charter,
rather than the *future* IPP Everywhere Requirements spec.

Mike - remember that "Yes with comments" should be allowed
in your posted PWG Formal Vote announcement.

Cheers,
- Ira

---

From: "Paul Tykodi" <[email-masked]>
Date: Wed, 28 Apr 2010 14:26:34 -0400

Hi Ira,

I wanted to add my voice, as the current IPP Working Group Chair, to say
that I fully support the decision to not require printing with generic
(PDL-based) printer drivers as a conformance requirement for IPP Everywhere.

I do believe the printing experience would be greatly enhanced by reducing
the need for printer drivers but I don't think adding this as a requirement
to IPP Everywhere would enhance the proposed specification's acceptance by
the industry at this moment in time.

Do you think we should develop a short FAQ on some of the potential IPP
Everywhere use case scenarios we have already started collecting for other
reasons within PWG (i.e. Cloud Printing) to help give people further context
on the plans for IPP Everywhere prior to the actual vote?

Let me know your thoughts.

Thanks.

Best Regards,

/Paul
--
Paul Tykodi
Principal Consultant
TCS - Tykodi Consulting Services LLC

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked]
WWW:  http://www.tykodi.com

> Sent: Wednesday, April 28, 2010 1:40 PM
> To: Michael Sweet; Ira McDonald
> Cc: [email-masked]; George Liu
> > Given that this will be a project for the IPP working group and that
> IPP/2.0 is the current version of IPP approved by the PWG, I don't think
> it is a stretch to make IPP/2.0 the basis of "IPP Everywhere".
> >
> > That said, there have also been discussions of mapping any new stuff we
> come up with to the PWG semantic model, which will allow it to be used
> with other protocol bindings as well.
> >
> >>
> >> ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100417-
> rev.p
> >>> df
> >>>> /doc

---

From: "William Wagner" <[email-masked]>
Date: Wed, 28 Apr 2010 14:47:52 -0400

I would like to clarify that "my" suggestion that Ira cites was echoed by
others, primarily in response to (my understanding of) Mike's indication
that he wanted to proceed with IPP-Everywhere only if there was significant
support from the industry (which is an excellent criterion). Putting it up
for vote both acts to engage more of the membership and  "requires" that
negative responses include an explanation of why it is rejected. There
several generally acknowledged needs that IPP-Everywhere intends to address,
but also several different ideas about how they are best addressed.

Looking at the Mike's IPP-Everywhere Wiki page
(http://pwg-wiki.wikispaces.com/IPP+Everywhere), the main points are a
standard document format (or two) which should address much of the driver
issue, and a printer discovery method. These are critical issues, and are
also critical aspects of the Google CloudPrint initiative. But both by name
and by assumption, the solution is linked by many to IPP. And the Charter
makes this link very specific and very tight.

Although I think that there is little question but that IPP represents the
refinement of printing semantics and that these semantics should be
preserved in the next manifestation of printing interface, I do think that
there are differing views on whether this next manifestation should be an
add-on to IPP or a step beyond IPP. In favor of the former, the fact that
IPP is implemented in most networked printers suggests that an
IPP-Everywhere that is an incremental addition to IPP should be well
accepted by the industry as "good bang for the buck". But there is another
viewpoint that might maintain:
    a. IPP has not been all that successful in terms of use, is not
supported by current Windows OS's, and is regarded (or perhaps disregarded)
by some business sorts in the industry as a wasted effort. There was even
the suggestion that there is a negative perception of IPP and that the "IPP"
term be replaced in IPP-Everywhere (although no agreement on replaced with
what.)
    b. IPP uses a "transition" transport of HTTP over IP, which seemed
reasonable ten years ago, but is something of an anachronism in a world
going with a "web services" approach. And one would expect that the
Discovery, Eventing & Notification aspects that IPP-Everywhere needs will
come out of the Web Services world. Perhaps, when Google indicates that
IPP-Everywhere addresses much of what is needed in CloudPrint but has some
serious things missing, and when they ask for a CloudPrint use case using
IPP-Everywhere, they may be thinking of issues in this area.

So in considering the IPP-Everywhere charter, members must consider not just
whether IPP-Everywhere is a good and needed capability, I don't think that
there is much question about that, but whether the specific approach
specified in the charter is the optimum way to produce the optimum product.
And hopefully members will comment on this one way or the other since the
comments and actual participation in the specification and development of
IPP-Everywhere will be much more significant than an up or down vote.

Bill Wagner

-----Original Message-----

Hi George,

Cheers,
- Ira

> Given that this will be a project for the IPP working group and that
IPP/2.0 is the current version of IPP approved by the PWG, I don't think it
is a stretch to make IPP/2.0 the basis of "IPP Everywhere".
> That said, there have also been discussions of mapping any new stuff we
come up with to the PWG semantic model, which will allow it to be used with
other protocol bindings as well.

---

From: Ira McDonald <[email-masked]>
Date: Wed, 28 Apr 2010 16:43:45 -0400

Hi Bill:

Comments on your points:

(a) I fail entirely to see the merit in beating up "IPP" on the
      IPP WG mailing list - this is not constructive.

(b) IPP, like WebDAV and a dozen other IETF application
      protocols in the last 10 years, uses HTTP over a unique
      IANA-registered IP port number (not 80).  Folks in the
      REST camp would take particular issue with "transition",
      as though SOAP was the only possible Web Services
      binding.

Mike - we should abandon this PWG Formal Vote idea and
instead put this Charter up for PWG Last Call - PWG Process
doesn't allow non-editorial changes after a PWG Formal Vote.

This particular charter is *not* for Everywhere over some yet
to be determined transport.  It's for IPP Everywhere - and that's
the only reasonable binding - because existing deployed printers
already support IPP - any new transport is a real-world loser for
the near-term mobile environment.

Cheers,
- Ira

This particular proposal

---

From: "William Wagner" <[email-masked]>
Date: Wed, 28 Apr 2010 17:37:33 -0400

Hi Ira,

I am sorry that you think I was "beating up" on IPP. I have been involved
with IPP from the start (over 10 years ago), have done my part in getting it
deployed, and so have a certain affinity for it. But some observations have
been made, and they have some validity and bearing on this effort, but they
have not gotten much exposure. I do not agree that ignoring these things is
preferable and dealing with them is "not constructive".

Your idea of putting the charter up for PWG "Last Call" is good. I think the
intent was to get the sense of the membership about the approach specified
in the charter. The charter most certainly is for developing an addition to
IPP. I do not know if the membership agrees that "any new transport [other
than used by IPP] is a real-world loser" (most networked printers I know
also support WSD), but it would be to everyone's advantage to find out.

Bill Wagner

-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Wednesday, April 28, 2010 4:44 PM
To: William Wagner; Ira McDonald
Cc: Michael Sweet; [email-masked]; George Liu
Subject: Re: [IPP] Stable draft of IPP Everywhere Project Charter (17
April2010)

Hi Bill:

Comments on your points:

Cheers,
- Ira

This particular proposal

---

From: Michael Sweet <[email-masked]>
Date: Wed, 28 Apr 2010 14:40:27 -0700

> (PDL-based) printer drivers as a conformance requirement for IPP Everywhere.

FWIW, I'm certainly hoping that we *do* end up with at least one common, required PDL, otherwise IPP Everywhere will be as useless as IPP/2.0 - we don't need another raw transport pipe...  And if you'll remember I argued for a required PDL when we defined IPP/2.0 as well (for the same reasons...)

> the industry at this moment in time.

Given that a common PDL is pretty much the only way to get away from printer drivers (which opens up LOTS of new markets, particularly in the mobile space), I think we do really need to make it a requirement.

> on the plans for IPP Everywhere prior to the actual vote?

I think a FAQ (along with updates to my slides) is entirely appropriate.

---

From: Michael Sweet <[email-masked]>
Date: Wed, 28 Apr 2010 14:42:27 -0700

On Apr 28, 2010, at 11:47 AM, William Wagner wrote:
> going with a "web services" approach.

which is usually SOAP over HTTP, sounds strangely familiar...

---

From: Michael Sweet <[email-masked]>
Date: Wed, 28 Apr 2010 14:43:52 -0700

On Apr 28, 2010, at 1:43 PM, Ira McDonald wrote:
> ...

Agreed, will put that out ASAP...

---

From: "Petrie, Glen" <[email-masked]>
Date: Thu, 29 Apr 2010 07:38:18 -0700

Ira,

I disagree with your comment (a) below; I believe the PWG email lists are the correct place to have open discussions on any aspect of PWG activities.  I don't believe that individuals should be told what is constructive or non-constructive comments or subject matter for emails. Some email content may be out of scope but will be addressed by the PWG members. I hope that PWG continue to be open forum for print standards.

If other members of PWG disagree with me; then, I would like to who decides what is constructive/non-constructive comments?

Glen 

> Sent: Wednesday, April 28, 2010 1:44 PM

---

From: Ira McDonald <[email-masked]>
Date: Thu, 29 Apr 2010 14:25:45 -0400

Hi all,

Sorry for various confusion.

Bill - I meant that criticizing IPP transport because Microsoft
doesn't make it easy (they (*do* support IPP in all Windows 7
distributions) isn't constructive.  Though some printers (many
less than IPP) do support WS-Print, a PWG standard (that
also works in the Apple, Linux, UNIX, and mainframe markets)
shouldn't specify WS-Print as a required transport for IPP
Everywhere.

Future open standard Web Services printing protocols are
just that - future - not applicable to the IPP Everywhere topic.

Glen - one or a few REQUIRED PDLs have always been an IPP
Everywhere requirement, from the start.

George - adding the requirement that common PDLs be emitted
by a so-called "driverless client" (actually a client with a standard
driver that is not vendor-built) is too restrictive and could (as Paul
noted) delay the adoption of IPP Everywhere by many vendors.
In a future IPP Everywhere requirements spec, iit might be a
reasonable goal, but it does not belong in this Charter.

Cheers,
- Ira