Subject: [IPP] Working Group Last Call on IPP/2.0 SE (ends Friday 17 Sept 2010)

From: Ira McDonald <[email-masked]>
Date: Tue, 24 Aug 2010 20:31:27 -0400

Hi,

This is the formal announcement of the IPP Working Group Last Call
of the IPP Version 2.0 Second Edition spec, which is located at:

  ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipp20-20100821.pdf
  - clean version with line numbers

This IPP WG Last Call will start today Tuesday 24 August 2010 and
will end on Friday 17 September 2010 at 10pm US PDT.

All newly required operations and attributes defined in this document
have been prototyped by Apple and/or Xerox.

To send your comments, simply hit "Reply All" to this message.

After a lively discussion at yesterday's IPP WG teleconference, we
concluded that we probably don't want to delay the completion of
IPP/2.0 SE (and therefore the availability of new IPP/2.2 conformance
level) for 6 or 8 months - the probable delay in order to include the
proposed IPP Job and Printer Extensions Set3 spec (new attributes
and any new operations needed for IPP Everywhere conformance
profile).

Please take the time to review this specification.

Cheers,
- Ira (IPP/2.0 SE co-editor)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 25 Aug 2010 14:46:24 -0700

Comments:

1. The intro paragraph for Section 3 is a bit repetitious.  I recommend combining the last two sentences to read "This section also describes ... and defines ...".

2. Missing bullet on line 236

3. Bad justification on line 338

4. Suggest the removal of "and because REQUIRED Create-Job/Print-Job in IPP/2.1 make Validate-Job trivial to implement" from lines 382-383 since we are not in the position to make that assessment.

5. Suggest the removal of "and because REQUIRED Create-Job/Print-Job in IPP/2.1 make Validate-Job trivial to implement" from lines 408-409 since we are not in the position to make that assessment.

6. Suggest change of wording on line 448: "because it OFTEN cannot be supported"

7. Suggest change of wording on line 470: "because it OFTEN cannot be supported"

8. Suggest change of wording on line 498: "because it OFTEN cannot be supported"

9. Missing 2.2 version after line 581 for IANA registration.

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair