Subject: [IPP] IPP Document Encryption

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Tue, 1 Sep 2020 20:28:33 +0000

All,

Looking at the IPP Document Encryption white paper:  https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-doccrypt-20180205.pdf

I presume there have to be standard ciphers/keywords defined for document-encryption-ciphers-supported?  Am I correct in this?  If so, have they been defined and where would I find them?

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 1 Sep 2020 16:41:45 -0400

Hi Chris,

That whitepaper is obsoleted by the standards-track IPP Encrypted Jobs and
Documents
now in Prototype draft and discussed at the August PWG F2F:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20200218-rev.pdf

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)Co-Chair - TCG Trusted
Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Tue, Sep 1, 2020 at 4:28 PM Rizzo, Christopher via ipp <[email-masked]>
wrote:

> All,
>
>
>
> Looking at the IPP Document Encryption white paper:
> https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-doccrypt-20180205.pdf
>
>
>
> I presume there have to be standard ciphers/keywords defined for
> document-encryption-ciphers-supported?  Am I correct in this?  If so, have
> they been defined and where would I find them?
>
>
>
> Thanks,
>
> Chris
>
>
>
> Christopher Rizzo
>
> Xerox Corporation
>
> "The realization came over me with full force that a good part of the
> remainder of my life was going to be spent in finding errors in my own
> programs."
>
> -Maurice Wilkes, * Memoirs of a Computer Pioneer*

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 1 Sep 2020 20:52:56 +0000

Hi Chris,

What Ira said.

If you don't mind my asking, how did you come across this document? Were you browsing the FTP site directly? Or did it pop up in a search engine? I posted a bunch of draft documents into /pub/pwg/ipp/whitepaper and I'm not sure that was the right thing to do. If not, I'm going to consider moving them to /pub/pwg/ipp/wd even though that will break links in the reflector archive.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Sep 1, 2020, at 2:41 PM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi Chris,
> 
> That whitepaper is obsoleted by the standards-track IPP Encrypted Jobs and Documents
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20200218-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20200218-rev.pdf>
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Co-Chair - TCG Trusted Mobility Solutions WG
> Co-Chair - TCG Metadata Access Protocol SG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
> 
> 
> On Tue, Sep 1, 2020 at 4:28 PM Rizzo, Christopher via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> All,
> 
> 
> 
> Looking at the IPP Document Encryption white paper:  https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-doccrypt-20180205.pdf <https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-doccrypt-20180205.pdf>
> 
> 
> Email: [email-masked] <mailto:[email-masked]>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Tue, 1 Sep 2020 21:00:51 +0000

Hi Smith,

Google "ipp document encryption".  It is the 1st result.

Chris

Christopher Rizzo
Xerox Corporation

From: "Kennedy, Smith (Wireless & IPP Standards)" <[email-masked]>
Date: Tuesday, September 1, 2020 at 1:54 PM
To: Christopher Rizzo <[email-masked]>
Cc: Ira McDonald <[email-masked]>, PWG Workgroup <[email-masked]>
Subject: Re: [IPP] IPP Document Encryption

Hi Chris,

What Ira said.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

On Sep 1, 2020, at 2:41 PM, Ira McDonald via ipp <[email-masked]<mailto:[email-masked]>> wrote:

Hi Chris,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]<mailto:[email-masked]>
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Sep 1, 2020 at 4:28 PM Rizzo, Christopher via ipp <[email-masked]<mailto:[email-masked]>> wrote:
All,

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 1 Sep 2020 17:32:11 -0400

Hi,

I'm guessing (?) that the Google ranking was simply because it was the
oldest
link on PWG site to the topic.  Anyway, second guessing search engine
rankings
is a waste of everyone's time.

Cheers,
- Ira

PS - Smith, you can *copy* whitepapers into '/wd' (although you shouldn't,
by our
Namespace Policy), but you *must not* intentionally break posted document
links
(just like the IETF, that's our long-term promise about publicly posted
drafts).

On Tue, Sep 1, 2020 at 5:00 PM Rizzo, Christopher <
[email-masked]> wrote:

> *From: *"Kennedy, Smith (Wireless & IPP Standards)" <[email-masked]>
> *Date: *Tuesday, September 1, 2020 at 1:54 PM
> *To: *Christopher Rizzo <[email-masked]>
> *Cc: *Ira McDonald <[email-masked]>, PWG Workgroup <[email-masked]>
> *Subject: *Re: [IPP] IPP Document Encryption
>
>
>
> Hi Chris,
>
>
>
> What Ira said.
>
>
>
> If you don't mind my asking, how did you come across this document? Were
> you browsing the FTP site directly? Or did it pop up in a search engine? I
> posted a bunch of draft documents into /pub/pwg/ipp/whitepaper and I'm not
> sure that was the right thing to do. If not, I'm going to consider moving
> them to /pub/pwg/ipp/wd even though that will break links in the reflector
> archive.
>
>
>
> Smith
>
> /**
>     Smith Kennedy
>     HP Inc.
> */
>
>
>
> *Ira McDonald (Musician / Software Architect) Co-Chair - TCG Trusted
> Mobility Solutions WG*
>
> *Chair - Linux Foundation Open Printing WG Secretary - IEEE-ISTO Printer
> Working Group Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG IETF
> Designated Expert - IPP & Printer MIB Blue Roof Music / High North Inc
> <http://sites.google.com/site/blueroofmusic>
> <http://sites.google.com/site/highnorthinc> mailto: [email-masked]
> <[email-masked]> (permanent) PO Box 221  Grand Marais, MI 49839
> 906-494-2434*
>
>
>
>
>
> -Maurice Wilkes, *Memoirs of a Computer Pioneer*
>

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 1 Sep 2020 23:06:35 +0000

Hi Ira,

> On Sep 1, 2020, at 3:32 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> I'm guessing (?) that the Google ranking was simply because it was the oldest
> link on PWG site to the topic.  Anyway, second guessing search engine rankings

I don't know if it would help, but we don't have a "robots.txt" at the root of the FTP site, but perhaps we should.

> 
> Cheers,
> - Ira
> 
> PS - Smith, you can *copy* whitepapers into '/wd' (although you shouldn't, by our
> Namespace Policy), but you *must not* intentionally break posted document links
> (just like the IETF, that's our long-term promise about publicly posted drafts).

The problem is that I and perhaps others erroneously put a number of documents that have seemingly finalized titles (e.g. the one that Chris was confused about - tb-doccrypt-20180205.pdf) into /pub/pwg/ipp/whitepaper, which makes them appear as though they were ratified, when the title page and other locations reveals they are actually working drafts. 😞 We can discuss how to deal with this mess in a separate dialog in the SC since this isn't strictly speaking an IPP WG issue. But it benefits the IPP WG if draft work doesn't appear to be ratified to those not attuned to these details. I agree it will break links, but in this case that may turn out to be a feature rather than a bug.

> On Tue, Sep 1, 2020 at 5:00 PM Rizzo, Christopher <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Smith,
> 
> 
> 
> From: "Kennedy, Smith (Wireless & IPP Standards)" <[email-masked] <mailto:[email-masked]>>
> To: Christopher Rizzo <[email-masked] <mailto:[email-masked]>>
> Cc: Ira McDonald <[email-masked] <mailto:[email-masked]>>, PWG Workgroup <[email-masked] <mailto:[email-masked]>>
> On Sep 1, 2020, at 2:41 PM, Ira McDonald via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
> Hi Chris,
> 
> 
>