Subject: [IPP] Printers using "media-size-name" instead of "media-size"

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 6 Jul 2021 20:07:13 +0000

Hi there,

PWG 5100.7 5.3.1.15 and 5.3.1.16 define the "media-size" and "media-size-name" members of "media-col" thus:

What isn't clear to me is whether a Printer will be running a risk if it decides to implement "media-size-name" instead of "media-size", since Clients aren't required to support it? If that is the case, then I'm not sure how a Printer could go about supporting "media-size-name" without risking interoperability issues with Clients.

Am I reading this correctly? If I'm not, I think we have some work to do on this because I don't know how "media-size-name" provides value given that set of normative requirements.

Thanks for any thoughts,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 6 Jul 2021 16:42:33 -0400

Smith,

> On Jul 6, 2021, at 4:07 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Hi there,
> 
> What isn't clear to me is whether a Printer will be running a risk if it decides to implement "media-size-name" instead of "media-size", since Clients aren't required to support it?

"media-size" is REQUIRED while "media-size-name" is RECOMMENDED.

> If that is the case, then I'm not sure how a Printer could go about supporting "media-size-name" without risking interoperability issues with Clients.

The way we defined them allows a Printer to support both attributes, the Client can discover what the Printer supports, and the Client can use whichever supported attribute is best.  The only issue with the current wording is that a Printer can't report both member attributes in a media-col-database or media-col-ready collection.

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 6 Jul 2021 20:54:25 +0000

Hi Mike,

> On Jul 6, 2021, at 2:42 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> > PWG 5100.7 5.3.1.15 <http://5.3.1.15> and 5.3.1.16 <http://5.3.1.16> define the "media-size" and "media-size-name" members of "media-col" thus:
> >
> >

Yep, that's my exact point - we need to change that language so that a Printer can report both.

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 6 Jul 2021 20:57:34 +0000

> On Jul 6, 2021, at 2:54 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Mike,
> 
>> On Jul 6, 2021, at 2:42 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Smith,
>> 
>> > On Jul 6, 2021, at 4:07 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> >
>> > Signed PGP part
>> > Hi there,
>> >
>> > PWG 5100.7 5.3.1.15 <http://5.3.1.15/> and 5.3.1.16 <http://5.3.1.16/> define the "media-size" and "media-size-name" members of "media-col" thus:
>> >
>> >

I'll file an erratum for this in a few minutes.