Subject: Re: [IPP] IANA registration request

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 7 Oct 2021 20:33:06 +0000

Hi Mike,

I'm not seeing it in the registry yet. When do you expect IANA to add it?

Smith

> On Sep 9, 2021, at 3:04 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
> 
> This is in my TODO list for upcoming registry updates. I'm hoping to get time for this next week.
> 
> 
> > On Sep 9, 2021, at 3:21 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> >
> > Hi Alan,
> >
> > Thanks for this! This was mentioned to me privately a week or two ago, and at the time I suggested that a Mopria representative notify the IPP WG. When this didn't occur, I filed an errata against 5100.16 (https://www.pwg.org/dynamo/issues.php?U111 <https://www.pwg.org/dynamo/issues.php?U111>) to have the "printer-requested-job-attributes" attribute registered in the IANA IPP Registry (https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml <https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml>). This was discussed and approved in the September 2 IPP Workgroup meeting (minutes: https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210902.pdf <https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210902.pdf>).
> >
> > The registration process is usually pretty quick, depending on IANA staff workloads. Mike Sweet can probably provide some more detailed status on its resolution.
> >
> > I CC'ed Mike Rhines, the Mopria liaison to the PWG, on this reply.
> >
> > Cheers,
> > Smith
> >
> > /**
> > Smith Kennedy
> > Chair, IEEE ISTO Printer Working Group
> > HP Inc.
> > */
> >
> >
> >> On Sep 9, 2021, at 11:23 AM, Berkema, Alan C via ipp <[email-masked]> wrote:
> >>
> >> Hello PWG IPP folks,
> >>
> >> It has been a while since I posted to the IPP reflector, hope you are all doing well.
> >>
> >> Brandon Jacobs and I have the following request:
> >>
> >> New IPP IANA Registration
> >> • Type of registration: attribute
> >> • Proposed keyword name of this attribute: printer-requested-job-attributes
> >> • Type of attribute: Printer Description
> >> • Operations to be used if the attribute is an operation attribute: N/A
> >> • Object (Document, Job, Printer, Subscription, etc. if bound to an object): N/A
> >> • Attribute syntax: 1setOf keyword
> >> • If attribute syntax is 'keyword' or 'enum', is it type1 or type2? N/A
> >> • If this is a Printer attribute, MAY the value returned depend on "document-format"?: No
> >> • If this is a Job Template attribute, how does its specification depend on the value of the "multiple-document-handling" attribute? N/A
> >> • Specification of this attribute: PWG5100.16
> >>
> >> The above is just a suggestion in case it helps
> >>
> >> Please let us know if you have questions,
> >> Thanks,
> >> Alan Berkema
> >> HP Inc.
> >>
> >>
> >> _______________________________________________
> >> ipp mailing list
> >> [email-masked]
> >> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> >
> > _______________________________________________
> > ipp mailing list
> > [email-masked]
> > https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
> ________________________
> Michael Sweet
> 
> 

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 7 Oct 2021 16:46:53 -0400

Smith,

I haven't sent it yet.  Soon...

> On Oct 7, 2021, at 4:33 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi Mike,
> 
>> > Thanks for this! This was mentioned to me privately a week or two ago, and at the time I suggested that a Mopria representative notify the IPP WG. When this didn't occur, I filed an errata against 5100.16 (https://www.pwg.org/dynamo/issues.php?U111) to have the "printer-requested-job-attributes" attribute registered in the IANA IPP Registry (https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml). This was discussed and approved in the September 2 IPP Workgroup meeting (minutes: https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210902.pdf).
>> > 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 7 Oct 2021 20:50:33 +0000

Ok so it is submitted and we are just waiting for them to publish the update.

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Oct 7, 2021, at 2:47 PM, Michael Sweet <[email-masked]> wrote:

 Smith,

>> > Thanks for this! This was mentioned to me privately a week or two ago, and at the time I suggested that a Mopria representative notify the IPP WG. When this didn't occur, I filed an errata against 5100.16 (https://www.pwg.org/dynamo/issues.php?U111<https://www.pwg.org/dynamo/issues.php?U111>) to have the "printer-requested-job-attributes" attribute registered in the IANA IPP Registry (https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml<https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml>). This was discussed and approved in the September 2 IPP Workgroup meeting (minutes: https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210902.pdf<https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210902.pdf>).
>> >
>> >> https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>
>> >
>> > https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>
>>
>> ________________________
>> Michael Sweet
>>
>>
>

________________________
Michael Sweet