Subject: [IPP] NODRIVER: "client-info" for only Job Creation operations, or all operations?

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Tue, 22 Feb 2022 23:52:32 +0000

Hi there,

We have defined the "client-info" operation attribute sufficiently abstractly that it could be included in any IPP operation. For Job Creation operations, it will be stored in the Job as a Job Status attribute (read-only). What from a specification point of view should a Printer do with it for other operations? Syslog? Or should we limit it to only be for Job Creation operations?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Tue, 22 Feb 2022 19:26:46 -0500

Smith,

Given that client-info is OPTIONAL for the Client to supply and (assuming the Client and Printer conform to the Job Accounting BP) the Client obtains explicit consent from the User only to send client-info in Job Creation operations, I don't think we want to go down that road, both for interoperability and legal compliance reasons.

> On Feb 22, 2022, at 6:52 PM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]> wrote:
> 
> Hi there,
> 

________________________
Michael Sweet