Subject: [Ippm-ioam-ix-dt] Fwd: New Version Notification for draft-ioamteam-ippm-ioam-direct-export-00.txt

From: Tal Mizrahi <[email-masked]>
Date: Sat, 12 Oct 2019 16:01:00 +0300

Hi,

In IETF 105 it was decided that we should consolidate "immediate exporting"
with "postcard-based telemetry (PBT-I)", and come up with a joint solution.
This new draft combines some of the concepts of immediate exporting with
some of the concepts of the postcard telemetry draft.
The draft is the product of the IPPM Immediate Exporting design team.

There is still one open issue that we are looking at, regarding how Hop
Limit / Hop Count is supported with the new direct exporting option. This
open issue is discussed in the "Topics for Further Discussion" section. We
would be happy to get feedback from the WG about this issue.

Comments will be appreciated.

Cheers,
Tal.

---------- Forwarded message ---------
From: <[email-masked]>
Date: Sat, Oct 12, 2019 at 3:34 PM
Subject: New Version Notification for
draft-ioamteam-ippm-ioam-direct-export-00.txt
To: Frank Brockners <[email-masked]>, Zhenbin Li <[email-masked]>,
Barak Gafni <[email-masked]>, Haoyu Song <[email-masked]>,
Shwetha Bhandari <[email-masked]>, Tal Mizrahi <
[email-masked]>, Tianran Zhou <[email-masked]>, Ramesh
Sivakolundu <[email-masked]>

A new version of I-D, draft-ioamteam-ippm-ioam-direct-export-00.txt
has been successfully submitted by Tal Mizrahi and posted to the
IETF repository.

Name:           draft-ioamteam-ippm-ioam-direct-export
Revision:       00
Title:          In-situ OAM Direct Exporting
Document date:  2019-10-12
Group:          Individual Submission
Pages:          11
URL:
https://www.ietf.org/internet-drafts/draft-ioamteam-ippm-ioam-direct-export-00.txt
Status:
https://datatracker.ietf.org/doc/draft-ioamteam-ippm-ioam-direct-export/
Htmlized:
https://tools.ietf.org/html/draft-ioamteam-ippm-ioam-direct-export-00
Htmlized:
https://datatracker.ietf.org/doc/html/draft-ioamteam-ippm-ioam-direct-export

Abstract:
   In-situ Operations, Administration, and Maintenance (IOAM) is used
   for recording and collecting operational and telemetry information.
   Specifically, IOAM allows telemetry data to be pushed into data
   packets while they traverse the network.  This document introduces a
   new IOAM option type called the Direct Export (DEX) option, which is
   used as a trigger for IOAM data to be directly exported to a
   collector without being pushed into in-flight data packets.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Tommy Pauly <[email-masked]>
Date: Sat, 12 Oct 2019 07:34:30 -0700

Thanks, Tal! And thanks to everyone who worked together on the design team. Having a solution that clearly combines the previous documents is a great step forward.

Looking forward to discussing this more in Singapore. 

Best,
Tommy

> On Oct 12, 2019, at 6:01 AM, Tal Mizrahi <[email-masked]> wrote:
> 
> 
> Hi,
> 
> In IETF 105 it was decided that we should consolidate "immediate exporting" with "postcard-based telemetry (PBT-I)", and come up with a joint solution.
> This new draft combines some of the concepts of immediate exporting with some of the concepts of the postcard telemetry draft.
> There is still one open issue that we are looking at, regarding how Hop Limit / Hop Count is supported with the new direct exporting option. This open issue is discussed in the "Topics for Further Discussion" section. We would be happy to get feedback from the WG about this issue.
> 
> Subject: New Version Notification for draft-ioamteam-ippm-ioam-direct-export-00.txt
> To: Frank Brockners <[email-masked]>, Zhenbin Li <[email-masked]>, Barak Gafni <[email-masked]>, Haoyu Song <[email-masked]>, Shwetha Bhandari <[email-masked]>, Tal Mizrahi <[email-masked]>, Tianran Zhou <[email-masked]>, Ramesh Sivakolundu <[email-masked]>
> 
> 
> 
> URL:            https://www.ietf.org/internet-drafts/draft-ioamteam-ippm-ioam-direct-export-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-ioamteam-ippm-ioam-direct-export/
> Htmlized:       https://tools.ietf.org/html/draft-ioamteam-ippm-ioam-direct-export-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ioamteam-ippm-ioam-direct-export
> 
> 
> Abstract:
> -- 
> Ippm-ioam-ix-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm-ioam-ix-dt