Subject: Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary - October 23, 2019

From: Tal Mizrahi <[email-masked]>
Date: Mon, 4 Nov 2019 10:10:35 +0200

Hi,

We were considering to hold a virtual meeting before Singapore to discuss
open issues regarding the IOAM flags. However, some of the key people are
not available.
Therefore, we will not hold a virtual meeting before Singapore.

We will hold an IOAM side meeting on Thursday (of the IETF meeting week) at
8:30 (Orchard room).
A more detailed agenda will be published before the meeting.

Thanks,
Tal.

On Wed, Oct 23, 2019 at 10:06 AM Tal Mizrahi <[email-masked]>
wrote:

> IPPM IOAM Immediate Exporting Design Team
> Virtual meeting
> October 23rd, 2019, 06:00 UTC
> Webex meeting
>
> Attendees:
> Shwetha Bhandari, Frank Brockners, Barak Gafni, Tal Mizrahi, Ramesh
> Sivakolundu, Haoyu Song, Mickey Spiegel, Tianran Zhou.
>
> Minutes by Tal Mizrahi.
>
>
> Summary:
> ========
> - Will update the direct exporting presentation and upload an updated
> version.
> - We will try to hold another virtual meeting before IETF 106 to discuss
> open issues about draft-ietf-ippm-ioam-flags.
> - Will schedule an IOAM side meeting for IETF 106.
> - Due to DST changes, future virtual meetings will be held at 07:00 UTC.
>
>
> Direct exporting slides for IETF 106:
> =====================================
> - Tal presented preliminary slides for the IETF 106 IPPM meeting.
>
> https://github.com/inband-oam/ietf/blob/master/presentations/ippm-ioam-direct-exporting-ietf-106.pptx
> - Barak: on slide 3 - we talk about a collector. It might be multiple
> collectors.
> - Tal: right. We may need to fix the draft as well.
> - Frank: let's simplify by not mentioning the collector.
> - Tal: remove the collector from the figure?
> - Frank: right, we can just have an arrow pointing to the "sky".
> - Ramesh: right, talking about multiple collectors may raise the question
> about how you bind each node to a collector.
> - Frank: right, it would be best not to mention collecotors.
> - Tal: there is a question of whether we want to raise the open issue
> about the hop limit / hop count. There may be a very long discussion if we
> raise this open issue.
> - Frank: we mainly want slide 8 - asking for WG adoption. Then we can
> handle the open issue. We want to say that we took the WG input from the
> last meeting, and the WG can go ahead and adopt it.
> - Tal: are we fine with removing slides 6-7 about hop limit / hop count?
> - Frank: that would be best.
> - Barak: I agree. We can have additional side meetings to discuss the open
> issue further.
> - Tal: I am going to remove slides 6-7, 10.
> - Tal: any other comments about the presentation?
> - Barak: I have another comment about the draft. Will send it to the
> mailing list or github.
> - Frank: it would be best on the mailing list to stir up some discussion.
>
>
> IOAM side meeting in IETF 106
> =============================
> - Tal: should we schedule an IOAM side meeting?
> - Frank: that would be a good idea. The IPPM slot may be tight. About 0.5
> hour.
> - Tal: I will schedule a side meeting.
> - Frank: who will be in singapore?
> - Frank, Ramesh, Shwetha, Tal, Haoyu, Barak (not final yet).
>
>
> Flag draft
> ==========
> Tal: the flag draft was updated - removed the immediate export flag, and
> also some updates regarding the loopback flag, adding explanations and
> clarifications.
> Frank: we may want to further discuss this in a side meeting in singapore.
> It is for further discussion whether instructing data plane behavior is
> within the scope of this draft or not. The discussion about the flag draft
> requires participation of the people that raised their concerns.
> Tal: right.
> Frank: we can try to get these people to join the next virtual meeting.
> Tal: I will try to schedule a virtual meeting about the flag draft before
> Singapore, and invite the people who raised the open issues (Tom Herbert,
> Greg Mirsky).
> Mickey: a DST change is approaching - we may want to shift the time of the
> virtual meeting.
> Tal: may shift by an hour. Will send a notification.
>
>
> Other issues
> ============
> Frank: there is another open topic. Issue #135 on github - we can try to
> address it.
> Tal: do we need further discussion about this?
> Frank: no, we can suggest the text change. Basically to ignore unknown
> options or flags and remove them at the decapsulating node.
> Tal: sounds good.
> Frank: anything else that is open for the data draft?
> Tal: are we ready to request WG last call?
> Frank: with that last open issue closed, we definitely want to do ask for
> WG last call.
> Ramesh: draft 07 is the current version?
> Frank: yes.
>

---

From: Barak Gafni <[email-masked]>
Date: Mon, 4 Nov 2019 19:36:40 +0000

Hi Tal,
Can you please move the side meeting at Singapore to Monday or Tuesday?
I won’t be at Thursday, and if I understood it right at our last call Ramesh may not be there as well.

Thanks,
Barak

From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Monday, November 4, 2019 12:11 AM
To: [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary - October 23, 2019

Hi,

We were considering to hold a virtual meeting before Singapore to discuss open issues regarding the IOAM flags.. However, some of the key people are not available.
Therefore, we will not hold a virtual meeting before Singapore.

We will hold an IOAM side meeting on Thursday (of the IETF meeting week) at 8:30 (Orchard room).
A more detailed agenda will be published before the meeting.

Thanks,
Tal.

On Wed, Oct 23, 2019 at 10:06 AM Tal Mizrahi <[email-masked]<mailto:[email-masked]>> wrote:
IPPM IOAM Immediate Exporting Design Team
Virtual meeting
October 23rd, 2019, 06:00 UTC
Webex meeting

Attendees:
Shwetha Bhandari, Frank Brockners, Barak Gafni, Tal Mizrahi, Ramesh Sivakolundu, Haoyu Song, Mickey Spiegel, Tianran Zhou.

Minutes by Tal Mizrahi.

Summary:
========
- Will update the direct exporting presentation and upload an updated version.
- We will try to hold another virtual meeting before IETF 106 to discuss open issues about draft-ietf-ippm-ioam-flags.
- Will schedule an IOAM side meeting for IETF 106.
- Due to DST changes, future virtual meetings will be held at 07:00 UTC.

Direct exporting slides for IETF 106:
=====================================
- Tal presented preliminary slides for the IETF 106 IPPM meeting.
  https://github.com/inband-oam/ietf/blob/master/presentations/ippm-ioam-direct-exporting-ietf-106.pptx<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Finband-oam%2Fietf%2Fblob%2Fmaster%2Fpresentations%2Fippm-ioam-direct-exporting-ietf-106.pptx&data=02%7C01%7Cgbarak%40mellanox.com%7C3feb21512133482255f208d760fe857f%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C1%7C637084518585830640&sdata=EntMVGW4lGcxOcWbVJWfGa6ZQtGcsqHEX4fsQFrm8BI%3D&reserved=0>
- Barak: on slide 3 - we talk about a collector. It might be multiple collectors.
- Tal: right. We may need to fix the draft as well.
- Frank: let's simplify by not mentioning the collector.
- Tal: remove the collector from the figure?
- Frank: right, we can just have an arrow pointing to the "sky".
- Ramesh: right, talking about multiple collectors may raise the question about how you bind each node to a collector.
- Frank: right, it would be best not to mention collecotors.
- Tal: there is a question of whether we want to raise the open issue about the hop limit / hop count. There may be a very long discussion if we raise this open issue.
- Frank: we mainly want slide 8 - asking for WG adoption. Then we can handle the open issue. We want to say that we took the WG input from the last meeting, and the WG can go ahead and adopt it.
- Tal: are we fine with removing slides 6-7 about hop limit / hop count?
- Frank: that would be best.
- Barak: I agree. We can have additional side meetings to discuss the open issue further.
- Tal: I am going to remove slides 6-7, 10.
- Tal: any other comments about the presentation?
- Barak: I have another comment about the draft. Will send it to the mailing list or github.
- Frank: it would be best on the mailing list to stir up some discussion.

- Frank: that would be a good idea. The IPPM slot may be tight. About 0.5 hour.

Flag draft
==========
Tal: the flag draft was updated - removed the immediate export flag, and also some updates regarding the loopback flag, adding explanations and clarifications.
Frank: we may want to further discuss this in a side meeting in singapore. It is for further discussion whether instructing data plane behavior is within the scope of this draft or not. The discussion about the flag draft requires participation of the people that raised their concerns.
Tal: right.
Frank: we can try to get these people to join the next virtual meeting.
Tal: I will try to schedule a virtual meeting about the flag draft before Singapore, and invite the people who raised the open issues (Tom Herbert, Greg Mirsky).
Mickey: a DST change is approaching - we may want to shift the time of the virtual meeting.
Tal: may shift by an hour. Will send a notification.

Other issues
============
Frank: there is another open topic. Issue #135 on github - we can try to address it.
Tal: do we need further discussion about this?
Frank: no, we can suggest the text change. Basically to ignore unknown options or flags and remove them at the decapsulating node.
Tal: sounds good.
Frank: anything else that is open for the data draft?
Tal: are we ready to request WG last call?
Frank: with that last open issue closed, we definitely want to do ask for WG last call.
Ramesh: draft 07 is the current version?
Frank: yes.

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 5 Nov 2019 11:44:12 +0200

I booked us another slot for Monday at 8:30 (Orchard room).
(It looks like there are side meetings on Tuesday and Wednesday morning
which some people may want to attend).

We can keep the Thursday slot as a backup for now.

Thanks,
Tal.

On Mon, Nov 4, 2019 at 9:36 PM Barak Gafni <[email-masked]> wrote:

> *From:* Ippm-ioam-ix-dt <[email-masked]> *On Behalf Of *Tal
> Mizrahi
> *Sent:* Monday, November 4, 2019 12:11 AM
> *To:* [email-masked]
> *Subject:* Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary -
> October 23, 2019
>
>
>
> Hi,
>
>
>
> open issues regarding the IOAM flags.. However, some of the key people are
> not available.
>
> <https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Finband-oam%2Fietf%2Fblob%2Fmaster%2Fpresentations%2Fippm-ioam-direct-exporting-ietf-106.pptx&data=02%7C01%7Cgbarak%40mellanox.com%7C3feb21512133482255f208d760fe857f%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C1%7C637084518585830640&sdata=EntMVGW4lGcxOcWbVJWfGa6ZQtGcsqHEX4fsQFrm8BI%3D&reserved=0>

---

From: Barak Gafni <[email-masked]>
Date: Tue, 5 Nov 2019 16:18:01 +0000

Thank you Tal. If we can have tentative time on Tue following the ippm meeting it could be great as well. Would you like to do that?

Thanks,
Barak
________________________________
From: Tal Mizrahi <[email-masked]>
Sent: Tuesday, November 5, 2019 1:44:12 AM
To: Barak Gafni <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary - October 23, 2019

I booked us another slot for Monday at 8:30 (Orchard room).
(It looks like there are side meetings on Tuesday and Wednesday morning which some people may want to attend).

Thanks,
Tal.

On Mon, Nov 4, 2019 at 9:36 PM Barak Gafni <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tal,

Thanks,

Barak

From: Ippm-ioam-ix-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Tal Mizrahi
Sent: Monday, November 4, 2019 12:11 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary - October 23, 2019

Hi,

Thanks,

Tal.

Attendees:

Minutes by Tal Mizrahi.

Summary:
========

  https://github.com/inband-oam/ietf/blob/master/presentations/ippm-ioam-direct-exporting-ietf-106.pptx<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Finband-oam%2Fietf%2Fblob%2Fmaster%2Fpresentations%2Fippm-ioam-direct-exporting-ietf-106.pptx&data=02%7C01%7Cgbarak%40mellanox.com%7C909834c5fec9440cc61508d761d4bde4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C1%7C637085438651824181&sdata=iPh7RIhN7H2ZXYHyyAGZVijhMIVO5Ycv03%2BIXCsXD1w%3D&reserved=0>

Flag draft
==========

Other issues
============

---

From: Barak Gafni <[email-masked]>
Date: Mon, 18 Nov 2019 03:49:28 +0000

Hi,
Thanks for the good discussion this morning. Are we setting up another one for tomorrow, Tuesday?

Thanks,
Barak

From: Barak Gafni <[email-masked]>
Sent: Tuesday, November 5, 2019 8:18 AM
To: Tal Mizrahi <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary - October 23, 2019

Thanks,
Barak
________________________________
From: Tal Mizrahi <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, November 5, 2019 1:44:12 AM
To: Barak Gafni <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ippm-ioam-ix-dt] Design Team Virtual Meeting Summary - October 23, 2019

Thanks,
Tal.

Hi Tal,

I won't be at Thursday, and if I understood it right at our last call Ramesh may not be there as well.

Thanks,

Barak

Hi,

Thanks,

Tal.

Attendees:

Minutes by Tal Mizrahi.

Summary:
========

Flag draft
==========

Other issues
============