Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

From: Tal Mizrahi <[email-masked]>
Date: Wed, 20 May 2020 09:32:28 +0300

IPPM IOAM Design Team
Virtual meeting
May 20th, 2020, 06:00 UTC
Webex meeting

Attendees:
Frank Brockners, Barak Gafni, Greg Mirsky, Tal Mizrahi, Mickey Spiegel.

Minutes by Tal Mizrahi.

Summary:
========
- Data draft: Everyone will read the data draft again and send
comments if there are any.
- Direct exporting draft: Frank will will follow up with Al Morton
regarding his feedback on the hop count issue:
  https://mailarchive.ietf.org/arch/msg/ippm/n-KVPj2tNOPp7qRZ6Y6wDt4H9H4/
- The next IOAM virtual meeting will be on the 3rd of June, 06:00 UTC.

Detailed Discussion:
====================

Data draft
----------
Frank: the WG chairs started another WG last call for the data draft
(version 09). Has everyone read it, and are there any comments?
Tal: specifically, are there any open issues that should still be
discussed by the people here?
Barak: are there any recent updates?
Frank: there were various issues on Github and text proposals, all
integrated into version 09. We were waiting for some more reviews, and
since there were no comments the WG chairs started another WG last
call. Are there any other comments? If there are no more comments
please read the draft again, and let us know if there are any
comments.

Direct exporting draft
----------------------
Tal: the hop count issue is still an open issue. There was a bit of
discussion on the mailing list, but not much progress. How should we
proceed? Should we ask the chairs to take a decision?
Frank: looks like there was only one person who supports the Hop
Count, Haoyu Song, right?
Tal: well, Al Morton also expressed his support. We need to consider
these two voices.
Frank: right.
Barak: there was no response to our argument that the DEX draft should
follow the approach of the data draft.
Mickey: we have been saying the same things, and there was no
progress. Maybe we should ask the chairs.
Frank: I should express my opinion on the mailing list. There is no urgency.
Tal: should we wait a couple of weeks for some more discussion and
talk about it again on the next virtual meeting?
Greg: we should ask the chairs for their opinion about rough
consensus. This is a working group document.
Frank: the main question is *when* to ask the chairs to take a decision.
Greg: I do not have a specific opinion about that. Maybe another
reminder to people outside the design team can help. Maybe some more
discussion with Al Morton would be useful.
Tal: let's get some more discussion on the mailing list and try to
talk to Al a bit.
Frank: I will approach Al Morton about this.

Tal: the next meeting will be two weeks from now.

---

From: Haoyu Song <[email-masked]>
Date: Wed, 20 May 2020 17:36:24 +0000

Sorry I missed last night's meeting. For the DEX hop count issue, here's the summary of my current consideration and the proposed solution.  
Please let me know if it's acceptable. Thanks!

1)  The capability of data correlation should be the inherent feature of the DEX option header itself.
I have explained why hop count is a part of triplet (in addition to the flow ID and sequence number) for unambiguous data correlation.
Supporting data correlation with data from other sources is either unreliable or difficult.

2) The proposed hop count requires only simple in-place update. It doesn't rely on or affect other fields. It doesn't inflate the packet size. 
This is the key difference with the trace option. I agree that for the E2E option, the option header should not be changed on path.
But there's no fundamental reason the DEX option header should also not be changed on path. 
DEX is an on-path feature and its header is processed on path.

3) In case such information is not needed or the operator prefer to keep the header read-only, we can make using/updating the hop count field optional,
by either using a flag bit or setting the field to some special value (e.g., the saturated all 1s value). 
I think this flexible approach can satisfy any requirements  in any application environments. 

Best regards,
Haoyu

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, May 19, 2020 11:32 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary:
========
- Data draft: Everyone will read the data draft again and send comments if there are any.
- Direct exporting draft: Frank will will follow up with Al Morton regarding his feedback on the hop count issue:
  https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fippm%2Fn-KVPj2tNOPp7qRZ6Y6wDt4H9H4%2F&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C881a01c1a3554d442ca108d7fc879d53%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255531709039617&amp;sdata=trZ4ZWt9eiF57GGFYG8PmlK9NPVI81Al%2B5pXz3FdI%2BQ%3D&amp;reserved=0
- The next IOAM virtual meeting will be on the 3rd of June, 06:00 UTC.

Detailed Discussion:
====================

Data draft
----------
Frank: the WG chairs started another WG last call for the data draft (version 09). Has everyone read it, and are there any comments?
Tal: specifically, are there any open issues that should still be discussed by the people here?
Barak: are there any recent updates?
Frank: there were various issues on Github and text proposals, all integrated into version 09. We were waiting for some more reviews, and since there were no comments the WG chairs started another WG last call. Are there any other comments? If there are no more comments please read the draft again, and let us know if there are any comments.

Direct exporting draft
----------------------
Tal: the hop count issue is still an open issue. There was a bit of discussion on the mailing list, but not much progress. How should we proceed? Should we ask the chairs to take a decision?
Frank: looks like there was only one person who supports the Hop Count, Haoyu Song, right?
Tal: well, Al Morton also expressed his support. We need to consider these two voices.
Frank: right.
Barak: there was no response to our argument that the DEX draft should follow the approach of the data draft.
Mickey: we have been saying the same things, and there was no progress. Maybe we should ask the chairs.
Frank: I should express my opinion on the mailing list. There is no urgency.
Tal: should we wait a couple of weeks for some more discussion and talk about it again on the next virtual meeting?
Greg: we should ask the chairs for their opinion about rough consensus. This is a working group document.
Frank: the main question is *when* to ask the chairs to take a decision.
Greg: I do not have a specific opinion about that. Maybe another reminder to people outside the design team can help. Maybe some more discussion with Al Morton would be useful.
Tal: let's get some more discussion on the mailing list and try to talk to Al a bit.
Frank: I will approach Al Morton about this.

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C881a01c1a3554d442ca108d7fc879d53%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637255531709039617&amp;sdata=sMmzDMVVrzZ3tkil%2B0fd%2FWpWWB4Az03KPp4nezDcXIE%3D&amp;reserved=0

---

From: Barak Gafni <[email-masked]>
Date: Wed, 20 May 2020 22:22:54 +0000

Haoyu,
I am trying to make sure that I understand what is the suggestion below - do you suggest to add this field as a 3rd optional field, while they will all either present or not together?
I don't think we should add logic for the processing of this header to check a flag or similar mechanism for that. If such header will eventually exist in the draft: management should be the one to configure network elements whether to update such a field or not if they see these additional optional header.
I suggest to prevent any potentially write-able data to exist in the base header of DEX, as this may make it harder to incorporate into some encapsulations going forward.
I think we all agree that simplicity is a key principle of DEX.

Thanks,
Barak

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Haoyu Song
Sent: Wednesday, May 20, 2020 10:36 AM
To: Tal Mizrahi <[email-masked]>; [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

3) In case such information is not needed or the operator prefer to keep the header read-only, we can make using/updating the hop count field optional, by either using a flag bit or setting the field to some special value (e.g., the saturated all 1s value). 
I think this flexible approach can satisfy any requirements  in any application environments. 

Best regards,
Haoyu

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, May 19, 2020 11:32 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary:
========
- Data draft: Everyone will read the data draft again and send comments if there are any.
- Direct exporting draft: Frank will will follow up with Al Morton regarding his feedback on the hop count issue:
  https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fippm%2Fn-KVPj2tNOPp7qRZ6Y6wDt4H9H4%2F&amp;data=02%7C01%7Cgbarak%40mellanox.com%7Cf75b2d2a97a14c448cae08d7fce45976%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637255929990918709&amp;sdata=NnFH6hjZWMxWVlduirNpysugF6J3oMLPAnI23aFcubQ%3D&amp;reserved=0
- The next IOAM virtual meeting will be on the 3rd of June, 06:00 UTC.

Detailed Discussion:
====================

Data draft
----------

Direct exporting draft
----------------------

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Cgbarak%40mellanox.com%7Cf75b2d2a97a14c448cae08d7fce45976%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637255929990918709&amp;sdata=2v6edPoVf%2BpthNcIqn%2F1iQGlvgan5D68XTNOTGLCegs%3D&amp;reserved=0

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Cgbarak%40mellanox.com%7Cf75b2d2a97a14c448cae08d7fce45976%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637255929990918709&amp;sdata=2v6edPoVf%2BpthNcIqn%2F1iQGlvgan5D68XTNOTGLCegs%3D&amp;reserved=0

---

From: Haoyu Song <[email-masked]>
Date: Thu, 21 May 2020 05:58:16 +0000

Hi Barak,

I suggest the field is still at the currently proposed location but its usage is optional.  This won't change the header size. 

I don't understand why the need to update this field can complicate the encapsulations. Can you elaborate this point?

Simplicity is important. But self-contained information completeness is more important for an option header.
I have shown several examples and suggest a compromise to allow it to not be updated. I think this should be a balanced solution. 

Thanks!
Haoyu

-----Original Message-----
From: Barak Gafni <[email-masked]> 
Sent: Wednesday, May 20, 2020 3:23 PM
To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; [email-masked]
Subject: RE: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

Haoyu,

Thanks,
Barak

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Haoyu Song
Sent: Wednesday, May 20, 2020 10:36 AM
To: Tal Mizrahi <[email-masked]>; [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

Best regards,
Haoyu

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, May 19, 2020 11:32 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting, May 20th, 2020

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary:
========
- Data draft: Everyone will read the data draft again and send comments if there are any.
- Direct exporting draft: Frank will will follow up with Al Morton regarding his feedback on the hop count issue:
  https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fippm%2Fn-KVPj2tNOPp7qRZ6Y6wDt4H9H4%2F&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cd20c1e59d2ef4793706f08d7fd0c5bf0%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256101835798041&amp;sdata=zx%2Bls6MlJdG1sD3DqiQ%2Bsc2ZYMaW1pijUgLVnH7np4g%3D&amp;reserved=0
- The next IOAM virtual meeting will be on the 3rd of June, 06:00 UTC.

Detailed Discussion:
====================

Data draft
----------

Direct exporting draft
----------------------

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cd20c1e59d2ef4793706f08d7fd0c5bf0%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256101835798041&amp;sdata=33Gddw71HXdb8TCWcXgnV3UwSklAIwhTROIpwd6upEo%3D&amp;reserved=0

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cd20c1e59d2ef4793706f08d7fd0c5bf0%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637256101835798041&amp;sdata=33Gddw71HXdb8TCWcXgnV3UwSklAIwhTROIpwd6upEo%3D&amp;reserved=0