Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

From: Tal Mizrahi <[email-masked]>
Date: Wed, 17 Jun 2020 09:27:07 +0300

IPPM IOAM Design Team
Virtual meeting
June 17th, 2020, 06:00 UTC
Webex meeting

Attendees:
Greg Mirsky, Mickey Spiegel, Tal Mizrahi.

Minutes by Tal Mizrahi.

Summary
========
- Due to low attendance we had a very short meeting.
- Next meeting will be held on July 1st.

Direct Exporting
============
-  Greg: there is a draft in WG last call in 6man we should take a
look at (draft-ietf-6man-spring-srv6-oam). The O-Flag in that draft is
a trigger for IPFIX-based exporting. This is similar to direct
exporting. Why do we need two different methods for the same thing?
- Mickey: I believe that is a bit different, and I still believe there
is a valid use case for having IOAM direct exporting.
- Tal: the O-Flag sounds a bit similar to the marking bit in alternate
marking, which was also discussed in the PBT-M concept in
draft-song-ippm-postcard-based-telemetry.
- Greg: this issue may be worth discussing in IPPM.
- Tal: next meeting will be in two weeks.

---

From: Barak Gafni <[email-masked]>
Date: Wed, 17 Jun 2020 06:42:49 +0000

Greg, thanks for pointing out.
Some differences compared to DEX from in my view:
1. It applies only for SRv6, while DEX doesn't limit for IPv6 or any other protocol
2. It should get processed only at the segment end point, while DEX should get processed potentially at every node in the network
3. This may be implantation dependent, but the draft calls for processing of this bit ahead of the SR processing, copy the packet etc. which may theoretically cause different behavior than what one may expect from DEX
4. The way to communicate required data is through management plane rather than through the data plane

Thanks,
Barak

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, June 16, 2020 11:27 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary
========

Direct Exporting
============
-  Greg: there is a draft in WG last call in 6man we should take a look at (draft-ietf-6man-spring-srv6-oam). The O-Flag in that draft is a trigger for IPFIX-based exporting. This is similar to direct exporting. Why do we need two different methods for the same thing?
- Mickey: I believe that is a bit different, and I still believe there is a valid use case for having IOAM direct exporting.
- Tal: the O-Flag sounds a bit similar to the marking bit in alternate marking, which was also discussed in the PBT-M concept in draft-song-ippm-postcard-based-telemetry.
- Greg: this issue may be worth discussing in IPPM.
- Tal: next meeting will be in two weeks.

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Cgbarak%40mellanox.com%7Cfdf004bb414a4e67ac7e08d81287a024%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637279720999229145&amp;sdata=Xx62FvG%2FMx0H66uCzzq7ZGeZQpgQuSP3BdTqwzkqJDw%3D&amp;reserved=0

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 17 Jun 2020 06:48:21 +0000

In brief, IOAM-DEX is PBT-I method, and the srv6 o-flag is PBT-M method.
Both methods are discussed in draft-song-ippm-postcard-based-telemetry.
I really think this draft worth to document as generic methods that could be used in many transports, and the protocol design. 

Cheers,
Tianran

-----Original Message-----
From: Ippm-ioam-ix-dt [mailto:[email-masked]] On Behalf Of Barak Gafni
Sent: Wednesday, June 17, 2020 2:43 PM
To: Tal Mizrahi <[email-masked]>; [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

Greg, thanks for pointing out.
Some differences compared to DEX from in my view:
1. It applies only for SRv6, while DEX doesn't limit for IPv6 or any other protocol 2. It should get processed only at the segment end point, while DEX should get processed potentially at every node in the network 3. This may be implantation dependent, but the draft calls for processing of this bit ahead of the SR processing, copy the packet etc. which may theoretically cause different behavior than what one may expect from DEX 4. The way to communicate required data is through management plane rather than through the data plane

Thanks,
Barak

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, June 16, 2020 11:27 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary
========

Direct Exporting
============

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm-ioam-ix-dt

---

From: Haoyu Song <[email-masked]>
Date: Wed, 17 Jun 2020 17:47:31 +0000

The latest proposed SRv6 o-flag usage has been covered by the following draft.  Yes it's different from IOAM DEX and it's an implementation of PBT-M
https://tools.ietf.org/html/draft-song-6man-srv6-pbt-01

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tianran Zhou
Sent: Tuesday, June 16, 2020 11:48 PM
To: Barak Gafni <[email-masked]>; Tal Mizrahi <[email-masked]>; [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

Cheers,
Tianran

-----Original Message-----
From: Ippm-ioam-ix-dt [mailto:[email-masked]] On Behalf Of Barak Gafni
Sent: Wednesday, June 17, 2020 2:43 PM
To: Tal Mizrahi <[email-masked]>; [email-masked]
Subject: Re: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

Thanks,
Barak

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, June 16, 2020 11:27 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Summary

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary
========

Direct Exporting
============

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb40c8329c30d4f36e4ae08d8128a7250%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637279733125285690&amp;sdata=2rRM27a%2FTmvL%2FCm177JQWA7XBAWALB2XLVhIKcKdHok%3D&amp;reserved=0

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb40c8329c30d4f36e4ae08d8128a7250%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637279733125285690&amp;sdata=2rRM27a%2FTmvL%2FCm177JQWA7XBAWALB2XLVhIKcKdHok%3D&amp;reserved=0

-- 
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb40c8329c30d4f36e4ae08d8128a7250%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637279733125285690&amp;sdata=2rRM27a%2FTmvL%2FCm177JQWA7XBAWALB2XLVhIKcKdHok%3D&amp;reserved=0