Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Minutes, July 22nd, 2020

From: Tal Mizrahi <[email-masked]>
Date: Wed, 22 Jul 2020 15:55:25 +0300

IPPM IOAM Design Team
Virtual meeting
July 22nd, 2020, 06:00 UTC
Webex meeting

Attendees:
Shwetha Bhandari, Frank Brockners, Barak Gafni, Tal Mizrahi.

Minutes by Tal Mizrahi.

Summary:
========
- The IOAM presentations for IETF 108 were discussed.
- The next meeting will be on the 12th of August.

IETF 108 Presentation Discussion
================================
Tal: regarding the DEX presentation, we still have the open issue of hop
limit / hop count. I suggest we just describe the status of the draft, and
ask the WG chairs for help with the open issue.
Barak: there was the PBT-M draft, which is open. Should it be to some
extent integrated into the DEX document?
Frank: let's try to focus on what we have, and not try to have a too
complicated solutions document.
Barak: IPv6 encap is also in IPPM. It is on the agenda.
Shwetha: the data draft is not on the agenda.
Frank: regarding the IPv6 options - we need to handle the concern of
leaking information, and the proper use of the two flags in the option
definition (which tell the router whether to skip the extension, discard
the packet, etc.). There is an ongoing disucssion on the mailing list about
how to prevent leaking; that routers must drop packets with the IOAM
extension unless explicitly configured to handle IOAM extensions. A domain
that contains non-IOAM nodes will drop packets - that is a problem. We have
two possible approaches: (1) require every node in the IOAM domain to be
IOAM capable, or (2) we put the '00' value, which means that routers not
familiar with this extension should skip it.
Shwetha: here is the discussion:
https://mailarchive.ietf.org/arch/msg/ippm/F3Ew6hBp6xihMajU7iV0hTtqPYo/
Barak: filtering should be done by firewalls, not routers.
Frank: this is an unresolved issue that we should raise. Implementers need
some guidance. I will work with Shwetha on a slide or two that presents the
issue. Let's see what the working group thinks.
Tal: flags draft - a couple of people said they will review the security
part again.
Frank: better ping the people before the meeting.
Tal: will do that. There is also an open issue about the loopback on the
reverse path.
Frank: you may want more details about this in the slides.
Tal: I will add a slide about the loopback open issue.
Frank: regarding the POT draft - was there a conclusion for the WG last
call?
Tal: I will ping the SFC WG chairs.
Barak: what about IOAM over Geneve - what is the status of this draft?
Frank: still working on it, but not sure where it will be accepted, and we
may consider just publishing as informational. We may want to raise this
question on the mailing list.

---

From: Haoyu Song <[email-masked]>
Date: Wed, 22 Jul 2020 17:29:56 +0000

Sorry I couldn’t attend the meeting. Many thanks to Tal for providing the detailed minutes. Below are some of my thoughts in response to the discussion.

  1.  In previous emails,  I have summarized all the pros and cons with or without the hop counts in IOAM DEX header, and suggest a solution to make it optional so that people can use it as they like. I’d like to ask everyone to provide some feedback about this suggestions: whether you insist on eliminating it altogether or  think such flexibility is helpful.

  1.  Regarding the IPv6 option, in addition to the issues in the minutes,  I also start an email thread to discuss its issues and suggested solutions. I’d like to see what you think about it and you are welcome to provide feedbacks.

Best regards,
Haoyu

From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Wednesday, July 22, 2020 5:55 AM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Minutes, July 22nd, 2020

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary:
========

IETF 108 Presentation Discussion
================================
Tal: regarding the DEX presentation, we still have the open issue of hop limit / hop count. I suggest we just describe the status of the draft, and ask the WG chairs for help with the open issue.
Barak: there was the PBT-M draft, which is open. Should it be to some extent integrated into the DEX document?
Frank: let's try to focus on what we have, and not try to have a too complicated solutions document.
Barak: IPv6 encap is also in IPPM. It is on the agenda.
Shwetha: the data draft is not on the agenda.
Frank: regarding the IPv6 options - we need to handle the concern of leaking information, and the proper use of the two flags in the option definition (which tell the router whether to skip the extension, discard the packet, etc.). There is an ongoing disucssion on the mailing list about how to prevent leaking; that routers must drop packets with the IOAM extension unless explicitly configured to handle IOAM extensions. A domain that contains non-IOAM nodes will drop packets - that is a problem. We have two possible approaches: (1) require every node in the IOAM domain to be IOAM capable, or (2) we put the '00' value, which means that routers not familiar with this extension should skip it.
Shwetha: here is the discussion: https://mailarchive.ietf.org/arch/msg/ippm/F3Ew6hBp6xihMajU7iV0hTtqPYo/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fippm%2FF3Ew6hBp6xihMajU7iV0hTtqPYo%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C69f96d1a962345c1862208d82e3e8c62%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637310193462054297&sdata=6m1v8jd22XnLilWS10EKEj%2BF03SufPOdyTQ2uirVxgg%3D&reserved=0>
Barak: filtering should be done by firewalls, not routers.
Frank: this is an unresolved issue that we should raise. Implementers need some guidance. I will work with Shwetha on a slide or two that presents the issue. Let's see what the working group thinks.
Tal: flags draft - a couple of people said they will review the security part again.
Frank: better ping the people before the meeting.
Tal: will do that. There is also an open issue about the loopback on the reverse path.
Frank: you may want more details about this in the slides.
Tal: I will add a slide about the loopback open issue.
Frank: regarding the POT draft - was there a conclusion for the WG last call?
Tal: I will ping the SFC WG chairs.
Barak: what about IOAM over Geneve - what is the status of this draft?
Frank: still working on it, but not sure where it will be accepted, and we may consider just publishing as informational. We may want to raise this question on the mailing list.

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Sun, 26 Jul 2020 11:10:04 +0000

Per the discussion in our last DT meeting: Here’s a draft set of slides to discuss the status of
draft-ietf-ippm-ioam-ipv6-options-01 – incl. the issue that Tom recently brought up on the mailing list:
https://docs.google.com/presentation/d/1ku4bbsjh45JHkOQuy93szMXHBDb7KCceJZbTpETvTuA/

Appreciate your comments/thoughts/edits.

Thanks, Frank

From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Mittwoch, 22. Juli 2020 14:55
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Virtual Meeting Minutes, July 22nd, 2020

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary:
========

Shwetha: here is the discussion: https://mailarchive.ietf.org/arch/msg/ippm/F3Ew6hBp6xihMajU7iV0hTtqPYo/