Subject: [Ippm-ioam-ix-dt] For your review: PR to include draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-ipv6-options

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 7 Sep 2020 07:56:23 +0000

Hi folks,

Per the discussion in the last IOAM DT meeting: Could you give the PR which is to include draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-ipv6-options a quick review?
https://github.com/inband-oam/ietf/pull/194

Thanks much

Cheers, Frank

---

From: Haoyu Song <[email-masked]>
Date: Mon, 14 Sep 2020 18:14:23 +0000

Hi Frank,

I have some concerns about the proposed approach. The IPv6-in-IPv6 encapsulation may not meet the requirement C1 (which is the fundamental reason why IOAM is useful) in case the forwarding is not only determined by the DA (e.g., ECMP). Similar issue applies to IP-in-IPv6.

Besides, the encapsulation use the original dest IP address as the outer header dest IP but let the domain egress node remove the extension header, which still violates the RFC8200 (only the node with the destination address are allowed to delete the extension headers)

I don't see how such encapsulation can prevent packet leaking out of the domain as well.

In my opinion, the ultimate solution is to remove the EH limitation imposed by RFC8200 by addressing the potential negative effects for inserting/removing extension header/options within networks. I saw a recent draft from Tom Herbert and believe it's on the right track to solve the problem.

https://datatracker.ietf.org/doc/draft-herbert-6man-eh-attrib/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-herbert-6man-eh-attrib%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C6c16e201f26942abf0cb08d8587a6679%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637356630020227817&sdata=G7Gbep6zdvhlFmIk5hHC%2FL4G5TE0bEpt7Q5bvjX5gD0%3D&reserved=0>
Best regards,
Haoyu

From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Frank Brockners (fbrockne)
Sent: Monday, September 7, 2020 12:56 AM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] For your review: PR to include draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-ipv6-options

Hi folks,

Per the discussion in the last IOAM DT meeting: Could you give the PR which is to include draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-ipv6-options a quick review?
https://github.com/inband-oam/ietf/pull/194<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Finband-oam%2Fietf%2Fpull%2F194&data=02%7C01%7Chaoyu.song%40futurewei.com%7C276765d495414b6bcee308d853039111%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637350622097947703&sdata=1ikoblikC0ElQok2eGMqZIKvfapwQZidU%2B9qp%2BEdr3w%3D&reserved=0>

Thanks much

Cheers, Frank

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 15 Sep 2020 06:55:41 +0000

Hi Haoyu,

Thanks for your comments. We need to address them two-fold:

* The current PR is just to execute the request from the WG chairs to merge the two documents. For that reason, we won't be able to make changes to the content. My asks for review was about whether the merger was done appropriately (i.e. there are no more messed up references etc.)
* Once we have a new rev with the deployment considerations included, let's revisit the content. You bring up an important point below: IP-in-IPv6 without a changed dest address in the outer header might indeed cause trouble. We definitively need to revisit that - and take the discussion to the entire IPPM list. E.g. we could consider ways to use the anticipated decap node as the outer address (how that would be determined is up for discussion) or simply drive towards IP-in-IPv6 w/ ULA only.

Thanks, Frank

From: Haoyu Song <[email-masked]>
Sent: Montag, 14. September 2020 20:14
To: Frank Brockners (fbrockne) <[email-masked]>; [email-masked]
Subject: RE: For your review: PR to include draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-ipv6-options

Hi Frank,

From: Ippm-ioam-ix-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Frank Brockners (fbrockne)
Sent: Monday, September 7, 2020 12:56 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Ippm-ioam-ix-dt] For your review: PR to include draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-ipv6-options

Hi folks,

Thanks much

Cheers, Frank