Subject: [Ippm-ioam-ix-dt] IPPM IOAM Meeting - March 3rd, 2021

From: Tal Mizrahi <[email-masked]>
Date: Wed, 3 Mar 2021 09:20:39 +0200

IPPM IOAM Design Team
Virtual meeting
March 3rd, 2021, 07:00 UTC
Webex meeting

Attendees:
Frank Brockners, Barak Gafni, Greg Mirsky, Mickey Spiegel, Tal Mizrahi.

Minutes by Tal Mizrahi.

Summary:
========
- Slides for the IETF meeting next week will be posted for comments
today/tomorrow.
- The next meeting is on March 17th, at 07:00 UTC - please notice the
DST change in the US (which occurs on March 14th).

Discussion
==========
- Tal: the IETF meeting is next week. We are working on slides. The
flag and Direct Exporting (DEX) drafts have not changed much.
Regarding DEX, the slides will discuss the two open issues. Regarding
both drafts we will go over the security concerns that have been
raised a number of times and how we address them.
- Frank: sounds good. Not much changes in these two drafts since last
IETF meeting.
- Tal: Frank - do you plan to give an update on the data draft?
- Frank: not this time. I will give an update on the IPv6 options
draft. One change is related to the direct exporting option. Tianran
will present the YANG draft. I will bring up the deployment draft,
just to make sure everyone is aware. The main agenda time will be
spent on the integrity draft. Thanks Greg for the comments. Two
updates on the flags and DEX drafts. No need for any updates on the
data draft.
- Tal: right.
- Frank: I will put up some slides. Tal - will be happy if you can
help with the integrity slides.
- Tal: sure.
- Mickey: the YANG draft does not address any of my comments.
- Frank: you may want to send an email to the list.
- Mickey: I will do that. The draft hasn't changed much other than
become a WG draft.
- Tal: next virtual meeting two weeks from now. Watch out for the
daylight saving time in the US.

---

From: Haoyu Song <[email-masked]>
Date: Wed, 3 Mar 2021 23:07:22 +0000

Hi IOAM design team,

I'd like to seek interest to develop a draft support IOAM edge-to-edge information feedback. The concept is similar to the IOAM trace option loopback flag.  
The use case and proposal has been discussed in the following draft:
https://datatracker.ietf.org/doc/draft-song-ippm-inband-e2e-rtt-measurement/
I briefly introduce it in a meeting but we don't have time to have in-depth discussion yet. 
The only requirement here is to claim a few bits for flags in the E2E option header. 
I think this modification can greatly enhance the usefulness of the E2E option.
I'll also give an introduction of this draft in the IETF IPPM meeting if time permits.
But I'd like to get your opinion here and that would be great if you'd like to join the work.

Thanks,
Haoyu

-----Original Message-----
From: Ippm-ioam-ix-dt <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Tuesday, March 2, 2021 11:21 PM
To: [email-masked]
Subject: [Ippm-ioam-ix-dt] IPPM IOAM Meeting - March 3rd, 2021

IPPM IOAM Design Team
Virtual meeting

Attendees:

Minutes by Tal Mizrahi.

Summary:
========
- Slides for the IETF meeting next week will be posted for comments today/tomorrow.
- The next meeting is on March 17th, at 07:00 UTC - please notice the DST change in the US (which occurs on March 14th).

Discussion
==========
- Tal: the IETF meeting is next week. We are working on slides. The flag and Direct Exporting (DEX) drafts have not changed much.
Regarding DEX, the slides will discuss the two open issues. Regarding both drafts we will go over the security concerns that have been raised a number of times and how we address them.
- Frank: sounds good. Not much changes in these two drafts since last IETF meeting.
- Tal: Frank - do you plan to give an update on the data draft?
- Frank: not this time. I will give an update on the IPv6 options draft. One change is related to the direct exporting option. Tianran will present the YANG draft. I will bring up the deployment draft, just to make sure everyone is aware. The main agenda time will be spent on the integrity draft. Thanks Greg for the comments. Two updates on the flags and DEX drafts. No need for any updates on the data draft.
- Tal: right.
- Frank: I will put up some slides. Tal - will be happy if you can help with the integrity slides.
- Tal: sure.
- Mickey: the YANG draft does not address any of my comments.
- Frank: you may want to send an email to the list.
- Mickey: I will do that. The draft hasn't changed much other than become a WG draft.
- Tal: next virtual meeting two weeks from now. Watch out for the daylight saving time in the US.

--
Ippm-ioam-ix-dt mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm-ioam-ix-dt&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ca83ae8e8517c4e84522508d8de14e413%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637503528602794474%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Fh6iYwKtcrKKcTjXPkUfb5WRfp0qiRgqnACGuiksImA%3D&amp;reserved=0