Subject: RE: Non-poisson models of Internet traffic

From: Grotefeld Glenn-cecl03 <[email-masked]>
Date: Thu, 16 Sep 1999 09:04:58 -0500

A thought.

A "session" may be modeled as a poisson process for session starts, but the
traffic characteristics of the session would need to reflect a "session
type", each of which should have distinctive traffic characteristics and
probably none reflected by an easily characterizable formula.

Glenn Grotefeld
Motorola, Inc.
Schaumburg, IL USA

~-----Original Message-----
~From: Michael Welzl [mailto:[email-masked]]
~Sent: Thursday, September 16, 1999 4:28 AM
~To: [email-masked]
~Subject: Non-poisson models of Internet traffic
~
~
~Hi all,
~
~What are appropriate models for Internet traffic?
~
~I'm interested in bandwidth estimations - specifically, estimating the
~expected bandwidth based on the bandwidth history.
~
~I don't think that a Poisson process is an appropriate model for that
~as it does not allow any predictions about the future. According to
~Burke's theorem, the output of a M/M/1 queueing system (which 
~is probably
~a valid model for a router) is a poisson process if the input is a
~poisson process; for the Internet, this would mean that adaptive
~application would be useless as it would be impossible to predict the
~future based on measurements of the past.
~
~Therefore, I need a different model to deal with bandwidth estimations.
~
~Regards,
~Michael Welzl
~

---

From: Michael Welzl <[email-masked]>
Date: Thu, 16 Sep 1999 16:45:25 +0200

> probably none reflected by an easily characterizable formula.

I probably should have mentioned that earlier: I'm dealing with
general bandwidth estimations for a link in a router, so this is
not user- or session-oriented.

The traffic characteristics are of the "there's much going on in
the evening whereas everyone's asleep at 3 a.m." kind instead.

Hmm... doesn't sound like a behaviour that could be modelled
mathematically, does it?

I once read something about self-similarity in Internet traffic...
anyone know more about that? Maybe this could help.

Regards,
Michael Welzl

---

From: Grotefeld Glenn-cecl03 <[email-masked]>
Date: Thu, 16 Sep 1999 10:04:47 -0500

And something I should have mentioned earlier:

The individual "sessions" with their corresponding traffic characteristics
would be based on a target node/link/cloud in the Internet, which would
generate the number of individual sessions contending for use of the
resource.

Glenn Grotefeld

~-----Original Message-----
~From: Michael Welzl [mailto:[email-masked]]
~Sent: Thursday, September 16, 1999 9:45 AM
~To: 'Grotefeld Glenn-cecl03'; [email-masked]
~Subject: RE: Non-poisson models of Internet traffic
~
~
~> A "session" may be modeled as a poisson process for session 
~> starts, but the
~> traffic characteristics of the session would need to reflect 
~> a "session
~> type", each of which should have distinctive traffic 
~> characteristics and
~> probably none reflected by an easily characterizable formula.
~
~I probably should have mentioned that earlier: I'm dealing with
~general bandwidth estimations for a link in a router, so this is
~not user- or session-oriented.
~
~The traffic characteristics are of the "there's much going on in
~the evening whereas everyone's asleep at 3 a.m." kind instead.
~
~Hmm... doesn't sound like a behaviour that could be modelled
~mathematically, does it?
~
~I once read something about self-similarity in Internet traffic...
~anyone know more about that? Maybe this could help.
~
~Regards,
~Michael Welzl
~

---

From: Bo Ryu <[email-masked]>
Date: Thu, 16 Sep 1999 12:10:14 -0700

Poisson session arrival is not the whole story. There is an empirical
evidence that
sessions arrive in a Fractal correlation pattern with marginal expoentially
distributed inter-session times. For example, see the july issue of IEEE
Comm. Mag. 1999 entitled "Modeling and Simulation of Broadband Satellite
Networks: Part II -- Traffic Modeling" which
contains an anlysis/characterization of web request arrivals (HTTP GET)
generated by a large number of users (from UC Berkeley trace). It shows
fractal behavior (from correlation point of view).

Cheers,

-Bo

=========================
Bo Ryu
Sr Research Staff Member
Teledesic
Tel: 425-602-6360

> -----Original Message-----
> From: Grotefeld Glenn-cecl03 [mailto:[email-masked]]
> Sent: Thursday, September 16, 1999 7:05 AM
> To: [email-masked]'; [email-masked]
> Subject: RE: Non-poisson models of Internet traffic
> 
> 
> A thought.
>