Subject: Non-poisson models of Internet traffic

From: Michael Welzl <[email-masked]>
Date: Thu, 16 Sep 1999 11:27:40 +0200

Hi all,

What are appropriate models for Internet traffic?

I'm interested in bandwidth estimations - specifically, estimating the
expected bandwidth based on the bandwidth history.

I don't think that a Poisson process is an appropriate model for that
as it does not allow any predictions about the future. According to
Burke's theorem, the output of a M/M/1 queueing system (which is probably
a valid model for a router) is a poisson process if the input is a
poisson process; for the Internet, this would mean that adaptive
application would be useless as it would be impossible to predict the
future based on measurements of the past.

Therefore, I need a different model to deal with bandwidth estimations.

Regards,
Michael Welzl

---

From: Matthew Roughan <[email-masked]>
Date: Fri, 17 Sep 1999 09:43:55 +1000

> Therefore, I need a different model to deal with bandwidth estimations.

Hi Michael,

there has been a lot of work on characterising Internet traffic. I
suggest you have a look at a couple of papers like:

@Article{PaxsonFloyd94,
  author =       {V. Paxson and S. Floyd},
  title =        {Wide-Area Traffic: The Failure of Poisson Modeling},
  journal =      {IEEE/ACM Transactions on Networking},
  year =         1994,
  volume =       3,
  number =       3,
  pages =        {226-244},
  note =         {http://ee.lbl.gov/nrg-papers.html}
}

and

@Article{CrovellaBestavros97,
  author  = "Mark E. Crovella and Azer Bestavros",
  title   = "Self-Similarity in {W}orld {W}ide {W}eb Traffic: Evidence
             and Possible Causes",
  journal = "IEEE/ACM Transactions on Networking",
  year    = "1997",
  VOLUME  = "5",
  number  = "6",
  month   = "December"
}

and

@Article{lelandetal94:_exten_version,
  author =       {Will E. Leland and Murad S. Taqqu and Walter Willinger
and Daniel V. Wilson},
  title =        {On the Self-Similar Nature of {E}thernet Traffic 
                  (Extended Version)},
  journal =      {IEEE/ACM Transactions on Networking},
  year =         1994,
  volume =       2,
  number =       1,
  month =        {Feb},
  pages =        {1--15}
}

Once you've had a look at these you'll be in a better position to
understand some of the later stuff we have been doing. We are actually
doing some research on estimation -- once you have read some of the
stuff above, you might like to have a look at Darryl Veitch's home page
<http://www.serc.rmit.edu.au/~darryl> to find some of the work we have
been doing in this area. It is an active area of research here, I could
forward some of the papers we are writing at the moment, once they are
finished, if you are interested.

Best wishes,
Matt Roughan

-- 
Matthew Roughan                  
Software Engineering Research Centre, RMIT University
110 Victoria St, Carlton, Vic 3053,  AUSTRALIA
Ph:    +61 3 9925 4093      
Fax:   +61 3 9925 4094     
Email: [email-masked]     
WWW:   http://www.serc.rmit.edu.au/~matt