Subject: [ippm] On agenda point #7

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 05 Jul 2010 11:28:49 +0200

IPPM Group,

The Maastricht agenda has this entry:

7. Metrics registry (25)
   = Intro (Henk)
   = draft-morton-ippm-rfc4148-obsolete (Al)
   = draft-stephan-ippm-registry-ext (Emile)
   = Discussion

The background of this is the following: in RFC 4148, a registry for the IPPM
metrics has been introduced. This registry has seen very little use over the
years, mainly because the registry does not allow to store the parameters used
for every metric. That the registry isn't widely used, is best witnessed when
RFC 5644 was published and a typo was introduced in the registry. Any parser
would have detected this syntax error. Yet, it took more than 8 months before
somebody noticed. Also, the author of the original document agrees that the
registry needs to be improved.

The question is how to proceed here.  There are several options:

 a. Withdraw the current registry.  This is proposed in
    draft-morton-ippm-rfc4148-obsolete.

 b. Expand the current registry in order to make it more useful.
    This is proposed in draft-stephan-ippm-registry-ext.

 c. Drop the current registry, start with a new one from scratch.

The plan is to have 2 presentations of the draft (about 5 minutes each),
followed by a discussion.

Comments, both to the list and at the meeting, are welcome,

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.xs4all.nl/~henku
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

I confirm today what I denied yesterday.            Anonymous Politician.

---

From: <[email-masked]>
Date: Tue, 6 Jul 2010 15:24:50 +0200

Hi,
 
RFC 4148 initiated an IANA registry (http://www.iana.org/assignments/ianaippmmetricsregistry-mib) for identifying each metric the IPPM WG defines. Currently it contains 70 metrics.
 
The WG started a process to reexamine the need to continue to feed this registry.
 
I suggest the following for starting the discussion. 
 
The usage:
Is the current Registry not used?
How can we be sure than the current registry is not used? 
 
The need:
Is it not used because there is not need for a registry at all?
 
The content:
Is it not used because it only numbers the metrics?
Is it not used because it does not describe metrics options and parameters?
 
The language:
Is it not used because it is written for MIB compiler (SMIv2)?
 
The future:
Should we consult the WGs working on interfaces which exchange network performance information?
What are these WGs?
 
Current suggestions:
http://www.ietf.org/internet-drafts/draft-stephan-ippm-registry-ext-00.txt <http://www.ietf.org/internet-drafts/draft-stephan-ippm-registry-ext-00.txt> 
http://tools.ietf.org/html/draft-morton-ippm-rfc4148-obsolete-01 <http://tools.ietf.org/html/draft-morton-ippm-rfc4148-obsolete-01>  

Regards
Emile
 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Henk Uijterwaal
> Envoyé : lundi 5 juillet 2010 11:29
> À : IETF IPPM WG
> Objet : [ippm] On agenda point #7
> 
> IPPM Group,
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Wed, 07 Jul 2010 11:44:14 +0200

> How can we be sure than the current registry is not used?

Speaking as myself, not WG-chair:

We can't, though I don't see this as the biggest issue.  If one looks at
the IANA site, there are more registries that have been obsoleted.  If
this happens, IANA marks the registry as such and adds a note that no
new registrations are accepted.  Whatever is there on the day it is
obsoleted, remains there.  In other words, if there is somebody who
depends on this file, then the file will be there forever.

> Is it not used because there is not need for a registry at all?

As WG chair:

I think this is the most important question.  If/when we want to declare
consensus on the new registry format, it should be clear that there is a
need for a registry in the format we've specified by then.  If not, then
why bother to standardize it?

And in order to find out what the need is, it would be good if people
who are using the current registry, or who considered using it but
decided against it, spoke up.

Henk