Subject: [ippm] [Editorial Errata Reported] RFC5644 (2321)

From: RFC Errata System <[email-masked]>
Date: Fri, 9 Jul 2010 07:13:14 -0700 (PDT)

The following errata report has been submitted for RFC5644,
"IP Performance Metrics (IPPM): Spatial and Multicast".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5644&eid=2321

--------------------------------------
Type: Editorial
Reported by: Cypryan T. Klish II <[email-masked]>

Section: 2.7

Original Text
-------------
Figure 2 is ambiguous for two reasons:

Use "X" for both types of nodes: 1) the graphic only labels intermediate nodes with "X" and 2) both "nodes that are points of interest" and "nodes that are not points of interest" are label "X" in the note following the graphic. Thus there is no difference between nodes that are points of interest and those that are not, and the distinction between the two types is not apparent

The destination node "Dst" has no representation in the "Hosts" identifier column.  the "Dst" label is in the same vertical column as the Hosts

Corrected Text
--------------
Change a subset of intermediate nodes (all currently labeled X) to "Y". Change the second line of the note to read "'Y' are nodes thatare not points of interest.

Shift the "Hosts column to the left to provide vertical separation for "Dst". Label "Dst" as "K" in the hosts column.

Notes
-----
It would be useful to clarify if the nodes that are points of interest must be contiguous or if the subset can truly be selected in an arbitrary fashion.  For a contiguous subset of point of interest nodes it is suggested that it would be useful to associate this with a higher abstract architectural construct (container) since the group might well align with a physical or administrative segment, or provider specific segment of the network.  This would aid in modeling the system for performance management applications since a one to one relationship can be created between the higher level container object and the segment object

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5644 (draft-ietf-ippm-multimetrics-12)
--------------------------------------
Title               : IP Performance Metrics (IPPM): Spatial and Multicast
Publication Date    : October 2009
Author(s)           : E. Stephan, L. Liang, A. Morton
Category            : PROPOSED STANDARD
Source              : IP Performance Metrics
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 12 Jul 2010 10:30:14 +0200

On 09/07/2010 16:13, RFC Errata System wrote:

> Use "X" for both types of nodes: 1) the graphic only labels intermediate
> nodes with "X" and 2) both "nodes that are points of interest" and "nodes
> that are not points of interest" are label "X" in the note following the
> graphic. Thus there is no difference between nodes that are points of
> interest and those that are not, and the distinction between the two types is
> not apparent

The figure uses "X" and "x".  These are different, even though I agree that
the difference can be hard to see if you don't look carefully.  X and Y would
have been clearer.

> The destination node "Dst" has no representation in the "Hosts" identifier
> column.  the "Dst" label is in the same vertical column as the Hosts

The way I read the diagram, is that there is a path "src 1 2 3 ... J dst".

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.xs4all.nl/~henku
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

I confirm today what I denied yesterday.            Anonymous Politician.