Subject: [ippm] SID for IPv6

From: Steve Baillargeon <[email-masked]>
Date: Tue, 7 Dec 2010 14:39:23 -0500

Hi
I have one quick question about the construction of a SID for an IPv6 host that does not support IPv4.

The OWAMP/TWAMP spec states the following:

   SIDs SHOULD be constructed by concatenation of the 4-octet IPv4 IP
   number belonging to the generating machine, an 8-octet timestamp, and
   a 4-octet random value.  To reduce the probability of collisions, if
   the generating machine has any IPv4 addresses (with the exception of
   loopback), one of them SHOULD be used for SID generation, even if all
   communication is IPv6-based.  If it has no IPv4 addresses at all, the
   last four octets of an IPv6 address MAY be used instead.  Note that
   SID is always chosen by the receiver.  If truly random values are not
   available, it is important that the SID be made unpredictable, as
   knowledge of the SID might be used for access control.

The spec suggests to use the last four octets of an IPv6 address.

Does this mean the first 4 octets of the SID could be the last four octets of an interface identifier (see RFC4291) ?

I am afraid the use of the last four octets of an interface identifier will not ensure SID uniqueness across the network unless the timestamp and random value are truly random.

Any comments/suggestions?

Regards
Steve

---

From: "Jeff W. Boote" <[email-masked]>
Date: Tue, 7 Dec 2010 13:32:51 -0700

> Any comments/suggestions?

Why does this concern you? Is it because you think the SID might be easily guessed in this case, and the SID might be used for access control? Or is it something else?

I don't believe there is any requirement that the SID be unique across the network for the protocol to work. (I agree that the text makes it sound desirable.) It needs to be unique at a specific receiver for the fetch-sessions messages to work, but these bytes will be identical for that use case anyway. It is possible that a process managing many sender sessions to several receivers might key on the SID as a key. But, there are many other fields that could be used there as well with the most likely being remote host address.

jeff

>  
> Regards
> Steve
>  
>  
>  
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm