Subject: [ippm] WGLC for draft-morton-ippm-rfc4148-obsolete-02

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 20 Dec 2010 08:09:24 +0100

IPPM Group,

This is a Working Group Last Call for the draft:

    RFC 4148 and the IPPM Metrics Registry are Obsolete
    draft-morton-ippm-rfc4148-obsolete-02

This draft has been discussed extensively at the Maastricht and Beijing
meetings, as well as on the list.  Please review the draft and raise any
issues by Monday, January 3, 9:00 UTC.  An URL for the draft is:

   https://datatracker.ietf.org/doc/draft-morton-ippm-rfc4148-obsolete/

Matt & Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.xs4all.nl/~henku
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

I confirm today what I denied yesterday.            Anonymous Politician.

---

From: <[email-masked]>
Date: Wed, 22 Dec 2010 00:52:44 +0100

Hi Henk

Most of the people are not available during Christmas time.

So I suggest delaying the end of the last call to mid January instead of the 14 of January 2010. 

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Henk Uijterwaal
> Envoyé : lundi 20 décembre 2010 08:09
> À : IETF IPPM WG
> Objet : [ippm] WGLC for draft-morton-ippm-rfc4148-obsolete-02
> 
> IPPM Group,
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Wed, 22 Dec 2010 08:26:13 +0100

Hi Emile,

> So I suggest delaying the end of the last call to mid January instead of the 14 of January 2010. 

The topic has been under discussion since July, nobody spoke up in support
of the registry, the document is very short and can be reviewed in 5 minutes,
so I don't see that a longer WGLC is needed.

Henk

---

From: <[email-masked]>
Date: Wed, 22 Dec 2010 09:44:30 +0100

Hi Henk, 

The situation has changed. In Beijing we discussed about the freezing of the registry after spatial composition draft becomes RFC. On going discussions during the AUTH48 phase of spatial composition draft are taking a totally different direction. 

You and Al consider draft-morton-ippm-rfc4148-obsolete-02 as an important document. Then why do you place the WGLC in a period where nobody will take care of the document?

At large I will oppose that we obsolete the current IPPM metric registry until the WG provides a replacement to this registry which corrects its lacks.

I will send a proposal but need time for editing and discussions.

Regards
Emile 

> Envoyé : mercredi 22 décembre 2010 08:26
> À : STEPHAN Emile RD-CORE-LAN
> Cc : [email-masked]; [email-masked]
> Objet : Re: [ippm] WGLC for draft-morton-ippm-rfc4148-obsolete-02
> 
> Hi Emile,
>

---

From: Henk Uijterwaal <[email-masked]>
Date: Wed, 22 Dec 2010 09:58:11 +0100

Hi Emile,

> The situation has changed. In Beijing we discussed about the freezing of the
> registry after spatial composition draft becomes RFC. On going discussions
> during the AUTH48 phase of spatial composition draft are taking a totally
> different direction.

That is not how I remember it.  We discussed freezing the registry with the
content it has on the day it is frozen.  If the spatial composition draft
would become an RFC before that date, the metrics will be in the registry,
otherwise, they won't.

> You and Al consider draft-morton-ippm-rfc4148-obsolete-02 as an important
> document. Then why do you place the WGLC in a period where nobody will take
> care of the document?

The issue has been discussed since July, the document merely reflects the
conclusion that was drawn.  Yes, this makes it an important document but
No, this does not require a lengthy review period.  The document doesn't
say much more than "obsolete the registry".

> I will send a proposal but need time for editing and discussions.

As I said earlier, there does not seem to be sufficient interest to
work on this topic at the moment.  If this changes, then yes, this
can become a WG document.

Henk

---

From: Al Morton <[email-masked]>
Date: Wed, 22 Dec 2010 09:24:44 -0500

Hi Emile,

I think you are overlooking yet another advantage of
freezing the registry as soon as possible. For the sake
of others on the list, let me briefly summarize the
recent discussions and delays during the publication of
RFC 6049-to-be, the Spatial Composition Metrics.

I'm still trying to understand more details of the problem,
but in summary: IPPM can not simply append metrics to the registry
with a dedicated section at the end of a memo, as we have done before.
Apparently, additional licensing conditions are now needed
for anyone who extracts information from the IPPM Metrics Registry MIB,
beyond the original copyright from 2005. There was a request to
republish the entire registry document under the new licenses.
But with no one using the registry, only the licensing issues
would be served. RFC 6049 was held for 2 months trying to sort this out.

So, the current registry continues to require attention and
effort (any draft with metrics needs the IANA section, or ?),
but as we've learned over the last 6 months, no one benefits.
The sooner we freeze the 4148 registry, the better.

regards,
Al

---

From: <[email-masked]>
Date: Wed, 22 Dec 2010 18:07:07 +0100

Hi Al,

My concern is that nobody points the rule which has changed. In 2009 we updated the registry with 2 new set of metrics from 2 different RFC without any difficulties. 

Is it because it is a MIB module? What is the exact text that has to be added? Why not inserting this text in the DESCRIPTION field of the REVISION added by IANA?

'    REVISION      "201009070000Z"    -- September 7, 2010
   DESCRIPTION
             "Added values 71-83 as published in RFC-ietf-ippm-spatial-composition-16."'

Regards
Emile

> De : [email-masked] [mailto:[email-masked]] De la part de Al
> Morton
> Envoyé : mercredi 22 décembre 2010 15:25
> À : Henk Uijterwaal; [email-masked]; STEPHAN Emile RD-CORE-LAN

---

From: Al Morton <[email-masked]>
Date: Wed, 22 Dec 2010 13:56:53 -0500

Hi Emile,

According to Russ, it is the new approach to IETF Copyright
that has changed, and now a BSD license is required when
extracting code (the IANA section, with new elements for
the registry MIB).  It appears that adding the text you
suggest below won't cover the BSD license (I think the
text was shared with us in one of the messages from
the RFC Editor).

Al

At 12:07 PM 12/22/2010, [email-masked] wrote:
>Hi Al,
>
>My concern is that nobody points the rule which 
>has changed. In 2009 we updated the registry 
>with 2 new set of metrics from 2 different RFC without any difficulties.
>
>Is it because it is a MIB module? What is the 
>exact text that has to be added? Why not 
>inserting this text in the DESCRIPTION field of the REVISION added by IANA?
>
>              "Added values 71-83 as published 
> in RFC-ietf-ippm-spatial-composition-16."'
>
>Regards
>Emile
>

---

From: <[email-masked]>
Date: Fri, 24 Dec 2010 10:21:33 +0100

Hi Henk

Is not is not a matter of interest. Most people (see below) are on vacation and will only return to work on 3 January, 2010.

S I think that it is reasonable to delay the end of WGLC to mid January.

Regards
Emile

-----Message d'origine-----
De : RFC Editor [mailto:[email-masked]] 
Envoyé : mercredi 22 décembre 2010 18:51
À : [email-masked]; [email-masked]
Cc : RFC Editor
Objet : RFC Production Center Holiday Schedule

Greetings All,

Please note that the RFC Production Center staff will be on holiday
from 24 December - 31 December.  We will return to the office on
3 January, 2010.  If there are any urgent issues, please send mail to
[email-masked], as staff will be monitoring the mail
throughout the week.  

We hope that you are all enjoying the holiday season and that the new
year finds you in good health.

(Our apologies if you receive this message multiple times.)

Thanks,
Sandy
for the RFC Production Center

> Envoyé : mercredi 22 décembre 2010 09:58
> À : [email-masked]

---

From: Al Morton <[email-masked]>
Date: Fri, 24 Dec 2010 10:25:59 -0500

FYI - I just fielded a request to *start* a BMWG Last call
*before* the holidays, because many people use this time
for best-effort reviews and volunteer work...

Al
bmwg chair

At 04:21 AM 12/24/2010, [email-masked] wrote:
>Hi Henk
>
>Is not is not a matter of interest. Most people 
>(see below) are on vacation and will only return to work on 3 January, 2010.
>