Subject: [ippm] Mail regarding draft-elteto-ippm-twamp-mib

From: Robert Shearman <[email-masked]>
Date: Thu, 2 Apr 2015 15:15:45 +0100

Dear authors,

Thanks for your work on this MIB.

I have a couple of comments/questions on the draft. However, in light of 
the recent publication of draft-cmzrjp-ippm-twamp-yang and its statement 
about progress on draft-elteto-ippm-twamp-mib being stalled, is it worth 
me articulating those comments? In other words, will there be any 
further updates to draft-elteto-ippm-twamp-mib?

Thanks,
Rob

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 3 Apr 2015 04:22:59 +0000

Hi Rob,
many thanks for your interest and kind consideration of our work. It is true that after IESG statement on development of new R/W MIBs at IETF we've decided to stop this work.
But I think it will benefit not only authors but the IPPM WG if you could share your comments and suggestions that would help in work on TWAMP and TWAMP-Light YANG models.

	Regards,
		Greg

-----Original Message-----
From: Robert Shearman [mailto:[email-masked]] 
Sent: Thursday, April 02, 2015 7:16 AM
To: [email-masked]
Cc: [email-masked]
Subject: Mail regarding draft-elteto-ippm-twamp-mib

Dear authors,

I have a couple of comments/questions on the draft. However, in light of the recent publication of draft-cmzrjp-ippm-twamp-yang and its statement about progress on draft-elteto-ippm-twamp-mib being stalled, is it worth me articulating those comments? In other words, will there be any further updates to draft-elteto-ippm-twamp-mib?

Thanks,
Rob

---

From: Robert Shearman <[email-masked]>
Date: Wed, 8 Apr 2015 10:27:36 +0100

Hi Greg,

Thanks for your quick reply.

I'm not sure how much help these comments will be in the development of 
the YANG model (which I intend to provide some feedback on separately), 
but here they are anyway.

Editorial:

		ippmPDVMetricsGroup OBJECT-GROUP
			OBJECTS {
                      pmForwardJitter,
                      pmForwardJitterMaximum,
                      pmReverseJitter,
                      pmReverseJitterMaximum
                  }
			STATUS current
			DESCRIPTION
				"Collection of one-way delay variation (jitter) metrics."
			::= { twampGroups 5 }

		ippmReoMetricsGroup OBJECT-GROUP
			OBJECTS {
                      pmForwardReordering,
                      pmReverseReordering
                  }
			STATUS current
			DESCRIPTION
				"Collection of one-way test packet re-order
metrics."
			::= { twampGroups 5 }

The same oid is allocated for two objects. This can be resolved simply 
by bumping up the oid for ippmReoMetricsGroup and all subsequent members 
of twampGroups.

Editorial:

		twampTest OBJECT IDENTIFIER ::= { twamp 2 }

Since twampTest really provides a representation of the Server and 
Session-Reflector roles of RFC5357, it would perhaps have been better 
named twampServer.

General:

There is no way to configure more than one test session per control 
session via the controller, which is allowable by the protocol and 
potentially has good use cases.

Similarly, on the server side, the ability to group the test sessions by 
the control session they belong to would be useful, along with providing 
access to properties of the control session, such as the far-end IP 
address and far-end TCP port.

Thanks,
Rob

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 8 Apr 2015 14:49:21 -0400

Hi Rob,

> From: ippm [mailto:[email-masked]] On Behalf Of Robert Shearman
> Sent: Wednesday, April 08, 2015 5:28 AM
>
> <snip> ...
> 
> General:
> 

Your general issues above are features of the draft YANG model, 
http://tools.ietf.org/html/draft-cmzrjp-ippm-twamp-yang-00.txt

just fyi,
Al