Subject: [ippm] metric registry parameter names

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 30 Sep 2015 12:29:17 +0200

Hi,

I think it would be desirable if parameters of metrics have well defined
names. In section 4.3.5 of draft-morton-ippm-initial-registry-00.txt I see:

   o  Upper limit on Poisson distribution (values above this limit will
      be clipped and set to the limit value). (if fixed, Upper limit =
      30 seconds.)

So what is the name of this option if I want to configure it?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 30 Sep 2015 17:06:11 +0000

> So what is the name of this option if I want to configure it?

I agree. The problem here is that the referenced specification is a bit vague wrt to certain "parameters", and the registry is being used as a means of tightening up the specification. I think that's fine, but what I would recommend is that the Reference Definition field include the name and definition of all parameters that are not explicitly named and defined in the referenced spec. I would rather the Fixed and Run-time Parameters simply provide a parsable list of parameters (and their values for Fixed Parameters), with names taken either directly from the referenced spec or from a list of additional parameters defined in the Reference Definition. 

In the Act_IP_UDP_Round-trip_Delay_Raw_95th-percentile_Poisson example, the Reference Definition would need to include text along the lines of...

The following parameters are defined and/or provided default values here:
"upper_limit" is the upper time limit on Poisson distribution (values above this limit will be clipped and set to the limit value). Default is "upper_limit"="30 seconds".
"seq_num" is an 8-byte field inside the payload of the test packet. The Src host shall set the initial value of seq_num in the payload of the first test packet and increment it by 1 with each subsequent test packet.
"timestamp" is an 8 byte field inside the payload of the test packet. The Src host shall set the timestamp value in each test packet payload.

Both "seq_num" and "timestamp" need to be listed as Run-time Parameters, and not Fixed.

BTW, the lambda definition in the registry sample may be wrong. RFC 2681 defines lambda as "a rate in reciprocal seconds" and 1/lambda as a time interval between packets; but the sample registry entry defines 1/lambda as a rate (packets/second). I think perhaps the registry parameter needs to be lambda and not 1/lambda.

And since there seems to be a need to tighten RFC 2681 wrt default value of lambda, I recommend putting such default recommendations also in Reference Definition, with the other parameter definitions and defaults.
Default "lambda"="1 packet/second" 

Barbara