Subject: [ippm] Alvaro Retana's No Objection on draft-ietf-ippm-multipoint-alt-mark-07: (with COMMENT)

From: Alvaro Retana via Datatracker <[email-masked]>
Date: Wed, 11 Mar 2020 13:58:49 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-ippm-multipoint-alt-mark-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ippm-multipoint-alt-mark/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

(1) Some of the terminology in this document can be confusing.  For example, I
can't help but thinking about multicast and replication when reading about a
point-to-multipoint flow.  Digging into the document, the concept is eventually
explained (and the fact that multicast is not supported).  I think that there
would be great benefit in adding a Terminology section to include a short
definition of the flow types and other terms (production network, monitoring
network, etc.).

(2) This document is classified as Experimental.  What is the experiment?

Given that the document describes a methodology and not an interoperable
implementation, should the experiment be, for example, to consider the
applicability of the methodology to different applications?  It can obviously
be something else...but I think it is important to indicate what it is.

FWIW, given that this is an "extension of RFC 8321", I think that Experimental
is the right status.

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 12 Mar 2020 16:13:03 +0000

Dear Alvaro,
Thanks for your comment.
Please find my answers inline tagged as [GF].
If you agree, I will add a Terminology section in the next version.

Best Regards,

Giuseppe

-----Original Message-----
From: Alvaro Retana via Datatracker [mailto:[email-masked]] 
Sent: Wednesday, March 11, 2020 9:59 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Tal Mizrahi <[email-masked]>
Subject: Alvaro Retana's No Objection on draft-ietf-ippm-multipoint-alt-mark-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

(1) Some of the terminology in this document can be confusing.  For example, I can't help but thinking about multicast and replication when reading about a point-to-multipoint flow.  Digging into the document, the concept is eventually explained (and the fact that multicast is not supported).  I think that there would be great benefit in adding a Terminology section to include a short definition of the flow types and other terms (production network, monitoring network, etc.).

[GF]: I will add a Terminology section. It makes sense to me for a better explanation. 

Given that the document describes a methodology and not an interoperable implementation, should the experiment be, for example, to consider the applicability of the methodology to different applications?  It can obviously be something else...but I think it is important to indicate what it is.

FWIW, given that this is an "extension of RFC 8321", I think that Experimental is the right status.

[GF]: Agree, and in my opinion, this document is borderline between Experimental and Informational. In the end, we considered it as Experimental since it is the extension of RFC 8321, as you noticed.