Subject: [ippm] Barry Leiba's No Objection on draft-ietf-ippm-multipoint-alt-mark-07: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Mon, 09 Mar 2020 21:51:34 -0700

Barry Leiba has entered the following ballot position for
draft-ietf-ippm-multipoint-alt-mark-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ippm-multipoint-alt-mark/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I found this to be a somewhat difficult read, with some awkward wording. 
Because of time constraints I’ll mostly not comment specifically, but leave it
to the RPC.  My comments below on Section 1 are examples.

— Abstract —

   This document aims to generalize and expand this
   methodology

“This document generalizes and expands this methodology”

— Section 1 —
The “; so” in the first sentence doesn’t follow from what comes before.  It
seems that you’ve just glued together two unrelated sentences, and I would
unglue them: “point-to-point path.  The extension proposed”

How does the extension explain anything?  Isn’t it the document that does the
explaining, but then the extension that does the enabling?

I can’t parse the first sentence of the second paragraph, and I can’t figure
out what you’re trying to say.  Can you try re-writing it?

Please check to make sure you are consistent about capitalizing “Alternate
Marking” and “Multipoint Alternate Marking” through the document.  It looks
like you have it about half and half.

---

From: Giuseppe Fioccola <[email-masked]>
Date: Tue, 10 Mar 2020 14:16:00 +0000

Dear Barry,
Thanks for your comment.
I have included your suggested changes and capitalized “Alternate Marking” through the document.

Regarding the first paragraph, I can change "explains" with "applies to". It should be better.

Regarding the second paragraph, I can rephrase it as follows: " The Alternate Marking methodology described in RFC 8321 allows the synchronization of the measurements in different points by dividing the packet flow into batches. So it is possible to get coherent counters..."

These changes are addressed in my local version.

I will upload a new revision as soon as I get the additional ballot positions and comments.

Regards,

Giuseppe

-----Original Message-----
From: Barry Leiba via Datatracker [mailto:[email-masked]] 
Sent: Tuesday, March 10, 2020 5:52 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Tal Mizrahi <[email-masked]>; [email-masked]
Subject: Barry Leiba's No Objection on draft-ietf-ippm-multipoint-alt-mark-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I found this to be a somewhat difficult read, with some awkward wording. 
Because of time constraints I’ll mostly not comment specifically, but leave it to the RPC.  My comments below on Section 1 are examples.

— Abstract —

— Section 1 —
The “; so” in the first sentence doesn’t follow from what comes before.  It seems that you’ve just glued together two unrelated sentences, and I would unglue them: “point-to-point path.  The extension proposed”

How does the extension explain anything?  Isn’t it the document that does the explaining, but then the extension that does the enabling?

I can’t parse the first sentence of the second paragraph, and I can’t figure out what you’re trying to say.  Can you try re-writing it?

Please check to make sure you are consistent about capitalizing “Alternate Marking” and “Multipoint Alternate Marking” through the document.  It looks like you have it about half and half.

---

From: Barry Leiba <[email-masked]>
Date: Tue, 10 Mar 2020 11:19:57 -0400

Thanks for the quick replies, Giuseppe, and thanks for addressing my comments.

Barry