Subject: RE: History of IPR in IP Storage WG and Questions It Raises

From: "Eric Burger" <[email-masked]>
Date: Wed, 4 Dec 2002 14:20:20 -0500

The IETF requires early disclosure if *I* submit the technology.  The existing rules cover that.  It is a pain, but we do it.

What the IETF *cannot* do is require me to give away my portfolio because someone else submitted my protected property.

The IETF *cannot* require me to monitor every work group to see if someone else is giving away my property.

What I would love to see is the "reasonable knowledge" clause strengthened.  I cannot get away with the tricks that very large companies can get away with.  For example, it is "unreasonable" for a large company to do a search to see if something they are submitting is covered by IPR.  If it is unreasonable at submission time, I would offer that it is unreasonable *after* submission time, too.  That is, if you don't disclose IPR on your own submission, even if the IPR is from another group in your company, you lose the ability to charge for the IPR for the purposes of implementing the given specification.

> -----Original Message-----
> From: Christian Huitema [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 1:59 PM
> To: Eric Burger; Elizabeth Rodriguez; [email-masked]
> Subject: RE: History of IPR in IP Storage WG and Questions It Raises
> 
> 
> One thing is to require that all patents be licensed for free, another
> is to require disclosure. In one case there is loss of 
> property, in the
> other there is the inconvenience of having to disclose the 
> existence of
> an application. Compare that inconvenience to the symmetric
> inconvenience of the working group members who work on a 
> technology for
> 12-24 month only to discover then that "you won't license it cheap". I
> would say that your inconvenience of early disclosure is less 
> than their
> inconvenience of having to rework the standard. 
> 
> > -----Original Message-----
> > From: Eric Burger [mailto:[email-masked]]
> > Sent: Wednesday, December 04, 2002 10:11 AM
> > To: Elizabeth Rodriguez; [email-masked]
> > Subject: RE: History of IPR in IP Storage WG and Questions It Raises
> > 
> > The problem is not with the RFC 2026, but with the patent system.
> > 
> > I will speak for myself, not for Lucent.
> > 
> > When I file for a utility patent, I have no idea what the patent
> office
> > will allow.  For example, I may file a patent that claims everything
> you
> > need to do Protocol X, namely technologies A, B, and C.  
> However, two
> > years from now *if* the patent issues, the patent office 
> may pare down
> my
> > claims to only C.  Moreover, technology C may not be applicable to
> > Protocol X.  Thus I cannot say if my application does or does not
> cover
> > Protocol X.
> > 
> > Why can't I disclose what my application is?  I can't do 
> that because
> it
> > opens myself to some expensive flack from competitors.  I won't
> disclose
> > unless I have to, which occurs when the patent office publishes the
> > application.  That is why the EPO publishes applications 
> immediately,
> and
> > the USPTO publishes patents after 12-24 months (depending on
> > circumstances).
> > 
> > Why doesn't my "What I submit is RAND/RF" statement cover 
> things that
> > others submit?  This should be quite obvious.  I spend $Blns on a
> > technology.  My competitor sees it is a good thing, but knows that I
> won't
> > license it cheap (because I need to get my money back somehow).
> Rather
> > than licensing it from me, *they* submit it to a standards body that
> > requires me to license it for free.  Last I looked there is another
> word
> > for that.  We call that "theft."
> > 
> > 
> > > -----Original Message-----
> > > From: Elizabeth Rodriguez [mailto:[email-masked]]
> > > Sent: Monday, November 18, 2002 2:38 AM
> > > To: [email-masked]
> > > Subject: History of IPR in IP Storage WG and Questions It Raises
> > >
> > >
> > > All,
> > >
> > > Below is a history of IPR issues that were faced in the 
> IPS working
> > > group.
> > > Some of these issues were mentioned at the IPR meeting in 
> Yokohoma.
> > > I plan on discussing some of these issues again at the IPR meeting
> > > Monday.
> > >
> > > Elizabeth Rodriguez
> > > IPS co-chair
> > > -----
> > >
> > > The IPS working group has encountered several issues in 
> relation to
> > > IPR in the course of deciding which security algorithms and
> protocols
> > > to specify for their drafts. The case in this email shows
> disclosures
> > > that were done in ways that were problems for the working group.
> > >
> > > In the IPR meeting in Yokohoma, Elizabeth Rodriguez and 
> David Black,
> > > co-chairs of the IPS WG, briefly discussed some of these 
> issues that
> > > were faced by IPS WG with respect to IPR.  This message 
> is intended
> to
> > > briefly expand that report, and raise detailed problems, to see if
> > > the policy and Note Well need some tuning to support better
> practice.
> > >
> > > For the most part, the situation in the IPS WG centered around a
> > > specific technology -- SRP.  SRP is the Secure Remote Password
> > > protocol, specified in RFC 2945.
> > >
> > > SRP was contributed by Thomas Wu of Stanford University.  Stanford
> > > University has offered a royalty free license for SRP.  
> Stanford has
> > > also indicated that they believe that SRP is free of other IPR.
> > >
> > > (http://www.ietf.org/ietf/IPR/WU-SRP;
> > > http://www-cs-students.stanford.edu/~tjw/srp/license.txt;
> > > http://www-cs-students.stanford.edu/~tjw/srp/whatisit.html)
> > >
> > > But it came to the attention of the IPS WG that two other 
> companies,
> > > Lucent Technologies and Phoenix Technologies, might have 
> IPR related
> > > to SRP.  Through the security area, it was noted that EKE (Lucent)
> and
> > > SPEKE (Phoenix) might be related to SRP, despite the Stanford
> > > disclaimer.  The Security Area had been struggling with EKE and
> SPEKE
> > > claims against SRP for a while. It should be noted that 
> the security
> > > area of the IETF has an unwritten policy against the use of
> > > cryptographic algorithms and protocols that have IPR 
> claims against
> > > them in all but the most extreme/demanding circumstances.
> > >
> > > SRP was not a work item in any WG of the IETF. Lucent has a
> > > general IPR
> > > statement (Statement available at:
> > > http://www.ietf.org/ietf/IPR/LUCENT-Patents)indicates states that:
> > >
> > >      If part(s) of a submission by Lucent is(are) included in a
> > >      standard and Lucent has patents and/or pending application(s)
> > >      that are essential to implementation of such included part(s)
> in
> > >      said standard, Lucent is prepared to grant - on the basis of
> > >      reciprocity (grantback) - a license on such included 
> part(s) on
> > >      reasonable, non-discriminatory terms and conditions.
> > >
> > > Since Lucent did not contribute to the development of SRP, Lucent
> > > indicated that the above statement did not apply.
> > >
> > > Issue: Does the general IPR statement above satisfy the 
> IETF policy
> on
> > > IPR submission?  Essentially, if read in the most strict 
> sense, the
> > > above indicates that if Lucent did not formally contribute to a
> > > technology, in written form, the above does not apply. (This seems
> to
> > > be the manner in which Lucent intended this statement, see Lucent
> > > letter of Nov 30, 2001 (bottom of
> > >   http://www.ietf.org/ietf/IPR/LUCENT-SRP disclosure)
> > >
> > >     As you are aware, RFC 2945 was neither submitted or proposed
> > >     by Lucent.  Therefore, Lucent's general patent statement
> > > to IETF in
> > >     1999 does not cover RFC 2945.
> > >
> > > One interpretation of the Note Well is that a general IPR 
> statement
> > > meets the requirements of the Note Well, and thus no further IPR
> > > disclosure from a company is required when they have IPR on a
> specific
> > > technology, and participants in a Working Group.  If the 
> general IPR
> > > statement had applied in this case, disclosure of IPR in 
> a specific
> > > technology such as SRP might not have had to be made to the WG.
> > >
> > > This is problematic, in that while it may or may not 
> satisfy a legal
> > > requirement (e.g. Dell VL-Bus suit), it would not satisfy the
> > > spirit of
> > > the request.  That is, in order for a WG to make an intelligent
> > > decision on a technology, they need to know about any IPR that any
> of
> > > their contributors (where contributions is defined as attendance,
> > > verbal or written comment or formal submission) might 
> possess about
> a
> > > technology when it is being discussed.  While the general 
> statement
> > > may allow anyone to license adopted IPR on reasonable terms and
> > > conditions, it does not meet the IETF's technical need.  
> The working
> > > group needs to have some information to make its 
> determination about
> > > the decision on the technology (it is understood that
> > > companies will not
> > >
> > > always be willing or able to give pointers to the 
> specific location
> of
> > > the
> > > claim, or the claim may still be pending, so the information
> > > cannot be
> > > expected to be perfect).
> > >
> > > As previously stated, Lucent determined the 1999 general IPR
> statement
> > > did
> > > not apply to SRP. At first, Lucent indicated that they 
> would make a
> > > disclosure to the IPS WG, and then changed their minds. After much
> > > delay,
> > > (and some negative press -- see
> > > http://www.byteandswitch.com/document.asp?doc_id=11764) they
> > > finally did
> > > give a statement to the IETF on IPR related to SRP.  That 
> statement:
> > >
> > >      Lucent has not conducted and has no current plans to 
> conduct a
> > >      search of its patent portfolio with respect to SRP.  In
> addition,
> > >      Lucent has not studied and has no current plans to study its
> > >      patents with respect to SRP.  However, in the event that any
> > >      Lucent patents are determined to be essential to the
> > >      implementation of SRP as an IETF standards track 
> specification,
> > >      Lucent is prepared to grant - on the basis of reciprocity
> > >      (grantback) - a license to those patents on reasonable and
> > >      non-discriminatory terms.
> > >
> > > (Full statement available at:
> > > http://www.ietf.org/ietf/IPR/LUCENT-SRP)
> > >
> > > This statement seems evasive of the working group's needs 
> in that it
> > > neither claims or denies rights in SRP. In essence, a conditional
> > > disclosure. Such a statement is probably worse than no 
> disclosure at
> > > all, in
> > > that it implies IPR in SRP without explicitly stating a claim.
> > >
> > >
> > > The Phoenix Technologies statement on the SRP is found at
> > > http://www.ietf.org/ietf/IPR/PHOENIX-SRP-RFC2945.txt.  This
> statement:
> > >
> > >      This is to advise the IETF that Phoenix Technologies Ltd.
> > >      ("Phoenix") has U.S. Patent Number 6,226,383 that may
> > >      relate to the IETF document RFC 2945 titled "The SRP
> > >      Authentication and Key Exchange System".
> > >
> > >      To the extent that this patent assigned to Phoenix is
> > >      necessary for implementation of RFC 2945 or any related
> > >      IETF standard, Phoenix will provide, upon written request,
> > >      to implementers of the relevant standard, a non-exclusive
> > >      license under reasonable and non-discriminatory terms.
> > >
> > > This statement is clearer than Lucent's in that it at least
> > > identified a
> > > specific patent, though it is still provisional.  There may not be
> > > issues
> > > to raise with respect to the policy and the Phoenix 
> disclosure.  But
> > > its presence should not distract from the issues raised by the
> Lucent
> > > case.
> > > Other disclosures emulate Lucent's language now.
> > >
> > > The SRP issue caused major problems for the IPS working group,
> > > delaying the decision on the mandatory to implement authentication
> > > method
> > > for some 7 months or more.  A majority of the people actively
> > > participating
> > > in IPS wanted SRP to be the mandatory to implement authentication
> > > method.
> > > Technical analysis convinced this group that it was by 
> far the best
> > > choice.
> > > But, a group of people were very concerned with SRP being 
> mandatory
> to
> > > implement -- especially members of the open source community
> > > and smaller
> > > companies who did not necessarily have the monetary funds, IP
> > > portfolios
> > > or
> > > legal resources to undertake a patent search and license the
> > > technology
> > > from
> > > multiple companies.
> > >
> > > The outcome of this whole issue basically boiled down to the
> submitter
> > > the
> > > following:
> > >   - The SRP protocol, Tom Wu backed by Stanford 
> University, granted
> a
> > >     royalty free license to SRP.
> > >   - The legal department at Stanford had performed IPR 
> searches, and
> > >     felt that SRP was free of other IPR.
> > >   - Even with this assurance, the IETF IPR policy allowed 
> others to
> > > state
> > >     they might have claims, without definitively claiming
> > > IPR.  At least
> > > one
> > >     claim can be argued to be poorly formed in terms of RFC
> > > 2026 and the
> > >     Note Well policy, but the presence of both claims cast much
> doubt.
> > >   - The same techniques as were used by Lucent might 
> hypothetically
> be
> > >     used to bias against a technology in a working group setting.
> > >
> > > Is this case enough of an example to suggest 
> strengthening the IETF
> > > policy?
> > > We can offer recommendations if the case seems compelling -
> > > the changes
> > > need not be large.
> > >
> > >
> > >
> > >
> > > ------- End of Forwarded Message
> > >
> > > _______________________________________________
> > > Ipr-wg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ipr-wg
> > >
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ipr-wg
> 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Scott Bradner <[email-masked]>
Date: Wed, 4 Dec 2002 16:14:51 -0500 (EST)

> What the IETF *cannot* do is require me to give away my portfolio because 
> someone else submitted my protected property.

nor does it try to do so

> else is giving away my property.

nor does it try to
but if you want to play in a group where this happened you have to say
"hey, that's my IPR" before playing

Scott

---

From: [email-masked] (Bruce Perens)
Date: Wed, 4 Dec 2002 16:35:47 -0800 (PST)

From: "Eric Burger" <[email-masked]>
> someone else submitted my protected property.

Let's please be clear that this is a theoretical discussion of a more
draconian policy than proposed. The draft W3C policy doesn't require that
you freely license your own IP when it is submitted by your competitor.

It does require that you _either_ license, or disclose that a patent
claim exists. You have the option to make a blanket committment early
in the process if you are not worried about this scenario and would rather
avoid the need to search your own IP.

The intent is to discourage "patent farming" by WG members.

> someone else is giving away my property.

Also not in the W3C proposal.

And most important, note that the W3C proposal is not "giving away" your
patent. The grant that you make is for the very limited purpose of
implementing the standard, not for any other use.

> What I would love to see is the "reasonable knowledge" clause
> strengthened.  I cannot get away with the tricks that very large
> companies can get away with.  For example, it is "unreasonable" for a
> large company to do a search to see if something they are submitting
> is covered by IPR.  If it is unreasonable at submission time, I would
> offer that it is unreasonable *after* submission time, too.  That is,
> if you don't disclose IPR on your own submission, even if the IPR is
> from another group in your company, you lose the ability to charge for
> the IPR for the purposes of implementing the given specification.

It sounds as if we're agreed regarding patent farming. This is the
blanket committment that you can make in the draft W3C process.

	Thanks

	Bruce

---

From: "Chuck Powers" <[email-masked]>
Date: Wed, 4 Dec 2002 19:40:58 -0600

Some clarifications on the W3C policy:

> you freely license your own IP when it is submitted by your competitor.

This actually depends upon whether or not you are participating in the W3C working group in which your competitor contributes your IPR. If you are in a working group, and a competitor submits technology into that working group which your company has IPR on of which you are not aware, then you will end up being forced to license that IPR on an RF basis. This is why a patent search will be de facto required for any large company with a significant patent portfolio to participate in a particular working group under the new W3C policy, assuming it is adopted.

If a competitor contributes your IPR into a working group in which you are not a member, then in fact you are not obligated to license that technology; so in theory you do not have to closely monitor working groups in which you are not officially participating. Of course, this will not prevent others from attempting to use public pressure on your company to make your IPR available on an RF basis once it is in the standard, despite the fact that you were unaware that it was included in the standard in the first place, but this is a different discussion. 

> claim exists. You have the option to make a blanket commitment early

This is slightly misleading - you can make a blanket _RF_ commitment, so you don't have to search your patent portfolio. However, the policy does not allow you to make a blanket RAND commitment or blanket opt out - to opt out of any of your patents in a working group in which your are participating, you have to disclose specific information about the patent(s) and/or patent application(s). Again - in practice your choices are to make a blanket RF commitment of your IPR to that working group effort, perform a detailed patent search, or do not participate in the standards process. Not much of a choice, really.
> implementing the standard, not for any other use.

I am not sure how making IPR available on an RF basis for the implementation of a standard which everyone hopes will become widely deployed is somehow NOT giving it away. You are giving it away for that standard, and it would be pointless for someone to contribute their IPR to an effort they hope is NOT successful. The more successful the standard, the more IPR value that is being given away. If it walks like a duck and quacks like a duck...
> blanket commitment that you can make in the draft W3C process.

Lastly, while "patent farming" was certainly one concern when the proposed W3C patent policy was being drafted, in fact the new policy is more likely to negatively impact W3C members who are unaware that their IPR is getting written into a standard (who then by definition are NOT patent farming), than it will those who are attempting to patent farm. Patent farmers know exactly what IPR they have, and where it may impact specific standards efforts. It is the companies whose participants aren't honestly aware of every patent their company has who will get impacted the most.

As with the current IPR IETF efforts, these issues are best addressed by an appropriate disclosure policy, and not by default licensing commitments.

regards,

chuck

---

From: Scott W Brim <[email-masked]>
Date: Wed, 4 Dec 2002 16:50:34 -0500

On Wed, Dec 04, 2002 02:20:20PM -0500, Eric Burger allegedly wrote:
> That is,

That's not something the IETF has control over.  However, in current USA
law, if you violate a standards group's disclosure conditions, that just
might happen to you.
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: [email-masked] (Bruce Perens)
Date: Wed, 4 Dec 2002 19:54:25 -0800 (PST)

From: "Chuck Powers" <[email-masked]>
> This actually depends upon whether or not you are participating in the
> W3C working group in which your competitor contributes your IPR. If you
> are in a working group, and a competitor submits technology into that
> working group which your company has IPR on of which you are not aware,
> then you will end up being forced to license that IPR on an RF basis.
> This is why a patent search will be de facto required for any large
> company with a significant patent portfolio to participate in a
> particular working group under the new W3C policy, assuming it is
> adopted.

You can make the blanket commitment early in the process, in which case you
would, in effect, declare that you don't care to search and would rather give
up the right to assert your IP in certain limited cases. If you don't like
that, you would have to search. If you care enough to assert your patent
rights, it seems fair for you to bear the onus of knowing what they are.

> Of course, this will not prevent others from attempting to use public
> pressure on your company to make your IPR available on an RF basis.

Which is the status quo, and could not be changed by any policy making.

> the policy does not allow you to make a blanket RAND commitment or blanket
> opt out

I beg to differ. You can indeed do either, simply by declining to make
the blanket RF committment. You would be obligated to disclose to the
WG that your patent exists. Let's walk through the consequences of your
holding a RAND or opt-out policy with regard to the patents you
disclose:

1. In the case of a blanket opt-out, the WG would have to find a way around
   the unavailable patent. It would not be fair of you to allow the WG
   to proceed unaware of a patent that you have made no committment to license.

2. In the case of a blanket RAND committment, it sounds as if, Chuck, you are
   asking for the right to _not_ disclose that your patent exists during
   the standards creation process, so that the WG would be incorporating
   a submarine RAND-licensed patent without its knowledge. Or perhaps, an
   arbitrarily large number of patents - each of which would carry its own
   fee. I fail to see how any working group would find that acceptable.

> Again - in practice your choices are to make a blanket RF commitment of
> your IPR to that working group effort, perform a detailed patent search,
> or do not participate in the standards process. Not much of a choice,
> really.

In this case the search is a reasonable expense to expect of the patent
holder. If you aren't willing to even find out what patents you own, why
should you expect to have the right to use them to restrain others?

> I am not sure how making IPR available on an RF basis for the
> implementation of a standard which everyone hopes will become widely
> deployed is somehow NOT giving it away.

I look at it as balancing your patent right and the public interest.
In a conflict of _any_ property right and the public interest, the property
owner will look at anything less than complete latitude to exercise his
property right as being compelled against his will to "give something away".
This has not prevented the implementation of easements on real estate, for
example, when such things are in the public interest: for example an
easement to permit utility wires and pipes to pass through your
property.

Having open standards that can be practiced by all implementors is in
the public interest. Thus, there are some areas of practice in which
your company _should_not_ expect to be able to assert a patent royalty
requirement.

> Lastly, while "patent farming" was certainly one concern when the
> proposed W3C patent policy was being drafted, in fact the new policy is
> more likely to negatively impact W3C members who are unaware that their
> IPR is getting written into a standard (who then by definition are NOT
> patent farming), than it will those who are attempting to patent farm.

Here we are balancing an odious offense: patent farming, against one
much less odious: someone who doesn't care to determine what monopoly
rights becoming somewhat less able to assert those rights. 

	Thanks

	Bruce