Subject: WG last call on draft-ietf-ipr-submission-rights-00.txt (fwd)

From: Steve Bellovin <[email-masked]>
Date: Wed, 04 Dec 2002 20:52:55 -0500

Reminder -- WG last call on this document expires on 9 December.

------- Forwarded Message

From: Steve Bellovin <[email-masked]>
To: [email-masked]
Subject: WG last call on draft-ietf-ipr-submission-rights-00.txt
Mime-Version: 1.0
Date: Mon, 18 Nov 2002 15:51:16 -0500

Since the only comments on draft-ietf-ipr-submission-rights-00.txt at 
the meeting today were minor, Rob and I are starting the Working Group 
last call on it.  Issues were raised on the other two documents; we 
need more discussion on the list (minutes will be posted very soon); and
possibly new versions.

Because this is IETF week, and next week is the U.S. Thanksgiving 
holiday, this last call will last three weeks.  Please send all 
comments to the list.

		--Steve Bellovin, http://www.research.att.com/~smb (me)
		http://www.wilyhacker.com ("Firewalls" book)

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 4 Dec 2002 18:11:23 -0800 (PST)

Hi -

> Subject: WG last call on draft-ietf-ipr-submission-rights-00.txt (fwd)
> Date: Wed, 04 Dec 2002 20:52:55 -0500
> Message-Id: <[email-masked]>
...
> Reminder -- WG last call on this document expires on 9 December.
...

I have a question regarding section 2.2, which reads:

|2.2  Confidentiality Obligations
|
|   No contribution that is subject to any requirement of confidentiality
|   or any restriction on its dissemination may be considered in any part
|   of the Internet Standards Process, and there must be no assumption of
|   any confidentiality obligation with respect to any such contribution.

Does this mean that any email sent to a WG mailing list bearing
one of the infamous auto-attached disclaimers MUST be ignored
by the working group?

Does this mean that such a message sent to the IESG or IAB
MUST be ignored?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  SJC-1.3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Contreras, Jorge" <[email-masked]>
Date: Mon, 9 Dec 2002 18:10:18 -0500

Sorry to get these out so late in the process, but here are some minor drafting/clarification comments on the Rights in Submissions document:

Abstract, first line:  "is" should be "are".

1. Introduction, paragraph 4:  The companion document should be referred to in the future tense: "A companion document [IETF IPR] will deal with rights in technologies..."

2.2.  Randy Presuhn made a good point about "automatic" confidentiality notices that are generated by email systems (such as my own company's).  In my view, these notices should be disregarded for any IETF contribution.  I might add the following sentence to address this point at the end of Section 2.2: "Each contributor hereby agrees that any statement in a contribution, whether generated automatically or otherwise, that states or implies that the contribution is confidential or subject to any privilege, can be disregarded for all purposes, and will be of no force or effect."

2.3, Intro paragraph: line 3, "their" should be "his or her" or some comparable variant.

2.3, Intro paragraph; line 4, insert "or is sponsored by" after "represents" [this is for consistency with other sections of the document].

2.3.a, line 3: insert "or is sponsored by" after "represents" 

2.4: for grammatical consistency, the first sentence should probably read: "With respect to each contribution, each contributor represents that to the best of his or her knowledge and ability..."

2.5: at the beginning of the 2nd sentence, ISOC should be added before IETF (to be consistent with the first sentence).

3.  Heading: delete "to support these rights grants".  This verbiage is not necessary, and the IETF should not imply that failure to include the required notices would impair the rights that have been granted in some way.

3.1, paragraphs 3-4:  Now that the grant of rights from the contributor to IETF is clearly delineated in Section 2.3, I would try to stick with it in the legend, rather than introducing in the legend a new set of language that is not directly tied to Section 2.3.  My suggestion is to replace paragraphs 3-4 with the following: "Each participant in the IETF standards process is granted a license with respect to this work of the scope set forth in Section 2.3.a of RFC [xxxx]."  I understand that changing the time-hallowed legend language might be controversial, and if it is, then I might save this point for any future "rechatering" of this WG.

3.1, paragraph 5: in line 3, insert "OR IS SPONSORED BY" after "REPRESENTS"

5.4: The second paragraph, regarding trademark licensing terms, was added in response to a comment.  However, I think that this paragraph should have been added as a new Section 2.6, rather than an addition to the explanatory text in Section 5.4.  Remember, Section 5 is just an explanation of the rights granted and obligations imposed under Sections 2-3.  Thus, any rights and obligations should be stated in Sections 2-3, rather than Section 5.

5.5:  The section cross-reference should be 4.7, not 4.6.

7, Heading:  change "copyright" to "legal".  In the case of MIBs, it is not the copyright notice, but the other legal notices that can be shortened and omitted.

Jorge Contreras