Subject: RE: Comment: I-D ACTION:draft-ietf-ipr-template-00.txt

From: "Ling, Hung C (Hung)" <[email-masked]>
Date: Fri, 16 May 2003 11:08:48 -0400

Valerie (and the template team):

Thanks for considering the specific comment raise by me and Chuck.  

Point A) Again, the template should reflect the policy as currently being clarified by the document (draft-ietf-ipr-technology-rights-05.txt).  Section 6.1 of this document says:

	6.1  Who must make an IPR disclosure?

	6.1.1  A Contributor's IPR in his or her Contribution
   	Any Contributor who reasonably and personally knows of IPR meeting
   	the conditions of Section 6.6 which the Contributor believes Covers
   	or may ultimately Cover his or her Contribution, or which the
   	Contributor reasonably and personally knows his or her employer or
   	sponsor intends to enforce against Implementing Technologies based on
   	such Contribution, must make a disclosure in accordance with this
   	Section 6.

These words clearly point to the personal knowledge of a contributor only. Hence the  words used in the template should reflect this and no more.   I still think changing from "patent holder believes" to "patent holder's participants believe" will work nicely.  

Point B) since there are attorneys on the template team, I would like to propose another minor clarification in section 2:

	2. The Patent Disclosure and Licensing Declaration Template 
    
   	<START OF TEMPLATE> 
    
   	This document is an IETF Patent Disclosure and Licensing Declaration 
   	Template and is submitted to inform the IETF of patent information 
   	for all IETF documents, and licensing information regarding IETF 
   	Standards Track documents.

The words "for all IETF documents" may imply one disclosure applies to all IETF documents (obviously not true).  How about ".....Template which can be used to inform IETF of patent information for the specific IETF document listed........"?  

Thanks, Hung

-----Original Message-----
From: Powers Chuck-rxcp20 [mailto:[email-masked]]
Sent: Thursday, May 15, 2003 2:50 PM
To: 'Valerie See'; [email-masked]; [email-masked]
Cc: [email-masked]; Scott W Brim; Allen Lo; Robert Barr
Subject: RE: Comment: I-D ACTION:draft-ietf-ipr-template-00.txt

Valerie,

   Hung raises a very good point - the IETF's disclosure obligation is based on the individual's knowledge (there are no members), and therefore the information called for by the disclsoure template needs to be specifically based on the individual participant's knowledge, and not on the collective "patent holder's" knowledge. The template must reflect the actual IPR policy, and not attempt to expand the scope of the disclosure statement beyond what the policy calls for.

   In fact, if the intent of the template is to capture the "patent holder's knowledge", the valid result could be that no disclosures are ever made using this template. Regardless of whether I as an individual participant believe that a patent owned by my employer may be essential to implement an IETF standard, if I never communicate this opinion to my employer, or my employer never officially reviews the patent to determine if it may be essential, I am acting in good faith to not disclose using this template, since I cannot legally represent "patent holder's knowledge" which doesn't even exist. My opinion does not legally equate to an official opinion from my employer.

   If the final template is worded as is currently proposed, I for one will recommend that it never be used to make a disclosure to the IETF, defeating the purpose of developing a template in the first place.

regards,

Chuck

> -----Original Message-----
> From: Valerie See [mailto:[email-masked]]
> Sent: Thursday, May 15, 2003 12:02 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; Scott W Brim; Allen Lo; Robert Barr
> Subject: Re: Comment: I-D ACTION:draft-ietf-ipr-template-00.txt
> 
> 
> On Thursday, May 15, 2003 Hung Ling wrote:
> 
> > In that case, I would like to propose clarifications in section 1:
> Introduction.  
> >
> > (1) RFC XXXX documents the current IETF policies and obligations
> containing patent claims that a "patent holder" 
> > believes "would be necessary" to implement.....
> >
> >   change "patent holder" to "patent holder's participants"
> >   change "would be necessary" to "may be necessary" since "would" is
> more definitive than "may" 
> 
> Hung, thanks for the review and the comments. We (the 
> template authors)
> talked about this
> some amongst ourselves, and came up with the following thoughts.
> 
> 1. On the suggestion to change the "patent holder" to the "patent
> holder's
> participants" - for the purposes of these disclosures, in 
> both the case
> of 
> the patent disclosure and the licensing commitment statement, it seems
> very 
> important to capture what the holder of the patent believes. 
> We think it
> is 
> better to keep this as currently written.
> 
> 2. On the suggestion to change "would" to "may" - We think it 
> better to
> also leave this as is - the reason being that the patent holder is
> obligated
> to disclose only those patents with claims that are "necessary" to
> implement
> the technology (this from the definition of "Covers" in
> technology-rights).
> 
> -- Val (and the template authors)
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Scott W Brim <[email-masked]>
Date: Sat, 17 May 2003 18:15:00 -0400

On Fri, May 16, 2003 11:08:48AM -0400, Ling, Hung C (Hung) allegedly
wrote:
> Point A) Again, the template should reflect the policy as currently
> being clarified by the document
> (draft-ietf-ipr-technology-rights-05.txt).  Section 6.1 of this
> document says:
> 
> 	6.1.1  A Contributor's IPR in his or her Contribution Any
> 	Contributor who reasonably and personally knows of IPR meeting
> 	the conditions of Section 6.6 which the Contributor believes
> 	Covers or may ultimately Cover his or her Contribution, or which
> 	the Contributor reasonably and personally knows his or her
> 	employer or sponsor intends to enforce against Implementing
> 	Technologies based on such Contribution, must make a disclosure
> 	in accordance with this Section 6.
> 
> These words clearly point to the personal knowledge of a contributor
> only. Hence the  words used in the template should reflect this and no
> more.   I still think changing from "patent holder believes" to
> "patent holder's participants believe" will work nicely.  

Participant contributions trigger disclosures, but disclosures are not
necessarily tightly bound to any particular participant action.  A
disclosure may occur because of one or more statements by one or more
individuals -- disclosures may even be submitted before any contribution
by anyone affiliated with the IPR holder.  

It would be nice if the disclosure fingered a particular person so that
people could look through archives to see what she/he had been saying,
but this doesn't remove the need for administrative contact information.
I'm pretty sure that if I went to, say, Keith Moore (to use an unlikely
example), and asked him about some UofT disclosure, he would refuse to
talk about it without a lawyer present.

So, sure, the form can have a line in it to name an IETFer who triggered
the disclosure, but that question may be impossible to answer, so
filling it in has to be optional.

> Point B) since there are attorneys on the template team, I would like
> to propose another minor clarification in section 2:
> 
>    	This document is an IETF Patent Disclosure and Licensing
>    	Declaration Template and is submitted to inform the IETF of
>    	patent information for all IETF documents, and licensing
>    	information regarding IETF Standards Track documents.
> 
> The words "for all IETF documents" may imply one disclosure applies to
> all IETF documents (obviously not true).  How about ".....Template
> which can be used to inform IETF of patent information for the
> specific IETF document listed........"?  

Good idea, but "documents".  You can have multiple documents listed in a
disclosure.  Technology-rights: "The disclosure must also list the
specific IETF Documents or activity affected."

.swb