Subject: RE: draft-savola-ipr-lastcall-01.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 9 May 2003 11:55:49 +0200

If we were too follow (as we currently have documented) the
ID-NITs serious (see: http://www.ietf.org/ID-nits.html) then
each document that gets Last Called (certainly IETF Last Call)
would have the IPR section in it, and that section DOES
(or at least SHOULD) make the statement that we invite IPR
to be reported and it also must state is we already know of
IPR. The authors and WG are responsible for putting it in
(according to current ID-nits) and so in my view that is
GOODNESS, cause it forces them to consider the issue.

Thanks,
Bert 

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]]
> Sent: vrijdag 9 mei 2003 9:35
> To: [email-masked]
> Subject: draft-savola-ipr-lastcall-01.txt
> 
> 
> Hi,
> 
> I've submitted a new version of the ipr-lastcall draft to the 
> repository.  
> In the meantime, it's available at:
> 
> http://www.netcore.fi/pekkas/ietf/draft-savola-ipr-lastcall-01.txt
> 
> Comments are welcome, of course -- as I don't know how to improve the 
> document at the moment :-)
> 
> Changes:
>  - all comments should be reflected in this revision
>  - some flexibility added for better DoS etc. resistance
>  - some verbiage on "quality of claims", and whether "claims 
> are known"
>  - some reordering of text
>  - require an IESG last call on documents only if the IETF has change 
> control over them (no need for 3rd party SDO republications 
> or proprietary 
> protocols)
>  - add IPR considerations section ;-)
> 
> Abstract
> 
>    This memo describes an additional policy with last calls regarding
>    Intellectual Property Rights (IPR) claims.  The existence and the
>    pointer to the IPR claims or an indication of non-existence of
>    knowledge of such claims must be mentioned in all IETF 
> last calls and
>    should be mentioned in working group last calls.  Additionally, all
>    documents under the IETF change control for which a last call prior
>    to the approval was not required and IPR claims are known, must now
>    be either last-called or rejected.
> 
>    This memo updates RFC 2026 and RFC 2418.
> 
> 
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Pekka Savola <[email-masked]>
Date: Fri, 9 May 2003 15:16:14 +0300 (EEST)

Thanks for the comment.

However, please note that there is:
 1) no obligation to have WG last calls, and
 2) no IETF last calls are made for working group 
experimental/informational document submissions

This policy also changes 2) if there are known IPR issues.

On Fri, 9 May 2003, Wijnen, Bert (Bert) wrote:
> would have the IPR section in it, 

WG chairs do not police ID-NITs when doing WG last calls, and there is no 
guarantee they would.

> and that section DOES
> IPR. 

Yep.

> The authors and WG are responsible for putting it in

Agree.

There is some overlapping text here, on what to do if you're aware of IPR 
and it has been recorded in the memo in "IPR considerations" section.

Such a document should be pushed back due to ID-nits, of course, too.

Any opinion on whether removing the overlap would be beneficial?

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 09 May 2003 15:03:30 +0200

Pekka Savola wrote:
...
> WG chairs do not police ID-NITs when doing WG last calls, and there is no

which is something we badly need to change (see various discussions
on the problem-statement list). 

   Brian