Subject: RE: clarification of blanket statement text

From: "Powers Chuck-RXCP20" <[email-masked]>
Date: Mon, 21 Feb 2005 13:54:47 -0600

I think it would make sense to note that blanket statements are no
longer effective for IDs submitted after 3668 was published, even if the
blanket statements were submitted prior to the adoption of RFC 3668. In
those instances, more specific disclosure statements are called for by
the terms of 3668.

IMO this could be done with a simple statement on the IETF IPR web site,
indicating that blanket IPR statements which do not conform to the terms
of RFC 3668 are not effective for any contributions made after the
publication date of RFC 3668 (whatever that specific date is). I don't
know if there is added value in marking each individual declaration; it
might be easier simply to organize them into a single group on the web
site.

However, those statement are still in effect for any work and/or
contributions which preceeded the official adoption of RFC 3668, and
this, too, should be made clear. No one is required to go back and
restate IPR assurances for work/contributions which took place under RFC
2026. 

-----Original Message-----
From: Robert Barr [mailto:[email-masked]] 
Sent: Monday, February 21, 2005 1:39 PM
To: Powers Chuck-RXCP20; 'Contreras, Jorge'; 'Harald Tveit Alvestrand';
'George T. Willingmyre'; 'Scott W Brim'; [email-masked]
Subject: RE: clarification of blanket statement text

I think the question is whether  a WG or implementers were under the
mistaken impression that a standard was unencumbered when it actually
was. I cant answer that. Regardless, such statements submitted before
3668 are no longer effective as a substitute for specific statements
relating to an Idraft, so if those statements remain posted this should
be noted. 

> -----Original Message-----
> From: Powers Chuck-RXCP20 [mailto:[email-masked]]
> Sent: Monday, February 21, 2005 9:10 AM
> To: [email-masked]; Contreras, Jorge; Harald Tveit 
> Alvestrand; George T. Willingmyre; Scott W Brim; [email-masked]
> Subject: RE: clarification of blanket statement text
> 
> I think the question should be: is there anything in RFC 2026 that 
> prevented blanket RAND statements from being effective? Considering 
> that an awful lot of them were filed with the IETF during the
> years that RFC
> 2026 was in force, it is a reasonable assumption that many members
> believed that doing so was in compliance with the IETF IPR 
> Policy at the
> time, particularly since RFC 2026 was not particularly 
> detailed on this
> topic.
> 
> Just as I don't believe that we can impose changes to the IPR Policy 
> retroactively, neither do I believe we can begin reinterpreting the 
> old policy, based on what we now want to do. If RFC 2026 clearly 
> prohibits the use of blanket RAND statements, then removing the 
> existing statements should be an option. If (as I believe) RFC 2026 is
> ambiguous
> on the topic of specific declarations, instead focusing on receiving
> assurances that licensing would be available if claimed 
> rights existed,
> then we should not try to go back and rewrite history.
> 
> IMO, the best approach will be to draw a line at the adoption of RFC 
> 3668, and ensure that declarations from that point conform to the more

> detailed disclosure requirements outlined in the latter document.
> 
> Regards,
> 
> Chuck
> 
> -----Original Message-----
> From: Robert Barr [mailto:[email-masked]]
> Sent: Monday, February 21, 2005 10:46 AM
> To: Powers Chuck-RXCP20; 'Contreras, Jorge'; 'Harald Tveit 
> Alvestrand';
> 'George T. Willingmyre'; 'Scott W Brim'; [email-masked]
> Subject: RE: clarification of blanket statement text
> 
> 
> Is there/was there  anything in 2026 that allows blanket RAND
> statements
> to be effective as a substitute for specific statements about an
> I-Draft?  
> 
> > -----Original Message-----
> > From: Powers Chuck-RXCP20 [mailto:[email-masked]]
> > Sent: Monday, February 21, 2005 7:24 AM
> > To: [email-masked]; Contreras, Jorge; Harald Tveit
> > Alvestrand; George T. Willingmyre; Scott W Brim; [email-masked]
> > Subject: RE: clarification of blanket statement text
> > 
> > It make no sense to simply "remove" all of the existing blanket
> > statements on the IETF IPR site, since the vast majority of 
> them were
> > made under RFC 2026, and were therefore compliant to the disclosure
> > process when they were made. To simply remove all of the blanket 
> > statements that exist certainly won't remove the obligation 
> to license
> 
> > the relevant technology, since the disclosures were made in good
> > faith, according to the rules in place; it will simply introduce 
> > confusion as to what was disclosed when. One can't apply changes to 
> > the disclosure rules retroactively, and then demand compliance.
> > 
> > Any non-RF blanket statements made after the publication of 3668 
> > are, of course, fair game, if it is determined that such a blanket 
> > statement does not meet the terms of 3668.
> > 
> > 
> > regards,
> > 
> > Chuck
> > 
> >   -----------
> >  
> > Chuck Powers, Corporate Standards Office
> > Motorola, Inc
> > phone: 847-576-4594
> > mobile: 847-208-0413
> > text message: [email-masked]
> >  
> > [email-masked]
> > 
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Robert Barr
> > Sent: Friday, February 18, 2005 9:18 PM
> > To: 'Contreras, Jorge'; 'Harald Tveit Alvestrand'; 'George T.
> > Willingmyre'; 'Scott W Brim'; [email-masked]
> > Subject: RE: clarification of blanket statement text
> > 
> > 
> > > Thus, if a participant states that it is willing to license all of

> > > its IPR on a RAND basis, the statement is not compliant.
> > > However, I'm not sure I understand the problem that's
> > > being identified.
> > 
> > The (many) non-compliant blanket RAND statements posted on the IETF 
> > IPR site should be marked non-compliant or removed. And (sigh)
> > the template
> > may need to be changed.
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On
> > > Behalf Of Contreras, Jorge
> > > Sent: Friday, February 18, 2005 5:30 PM
> > > To: Harald Tveit Alvestrand; [email-masked]; George T.
> > > Willingmyre; Scott W Brim; [email-masked]
> > > Subject: RE: clarification of blanket statement text
> > > 
> > > I've been asked to clarify, so here's my
> > > interpretation of the rules (sorry for repeating
> > > what's been said by others in slightly different
> > > words):
> > > 
> > > Under 6.4.3, a participant can satisfy its disclosure
> > obligations by
> > > making a "blanket" statement that it is willing to license
> > all of its
> > > potential IPR covering an IETF specification ONLY if
> > > 	
> > > 	(a) the license will be royalty-free, AND
> > > 
> > > 	(b) any other terms and conditions of the
> > > license are disclosed in an IPR disclosure statement.
> > > 
> > > No other "blanket" statements of licensing intention satisfy the
> > > participant's disclosure obligations under 3668. Thus, if a 
> > > participant states that it is willing to license all of 
> its IPR on a
> 
> > > RAND basis, the statement is not compliant.
> > > 
> > > The participant who wants to grant RAND licenses
> > > must comply with the
> > > specific disclosure rules in 6.4.1 and elsewhere.
> > > 
> > > If that was the intention, then the language works
> > > as written.  If not, then it can be fixed.
> > > However, I'm not sure I understand the problem that's being 
> > > identified.
> > > 
> > > Jorge
> > > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]On
> > > Behalf Of Contreras, Jorge
> > > Sent: Friday, February 18, 2005 6:07 PM
> > > To: Harald Tveit Alvestrand; [email-masked]; George T. 
> Willingmyre;
> > > Scott W Brim; [email-masked]
> > > Subject: RE: clarification of blanket statement text
> > > 
> > > 
> > > I agree with Robert -- this type of
> > > disclosure is not compliant.  This was
> > > actually discussed within the IP-WG when
> > > the rules were being drafted -- it is
> > > not just an oversight.  A change may
> > > be desirable, but it would be more
> > > than a simple correction of something
> > > inadvertent.
> > > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]On
> > > Behalf Of Harald Tveit Alvestrand
> > > Sent: Friday, February 18, 2005 1:52 PM
> > > To: [email-masked]; 'George T. Willingmyre'; 'Scott W Brim';
> > > [email-masked]
> > > Subject: RE: clarification of blanket statement text
> > > 
> > > 
> > > You're right.
> > > 
> > > I think this proves that we were not reading RFC 3668
> when we wrote
> > > it.
> > > 
> > > What do you suggest that we do about it?
> > > 
> > > --On fredag, februar 18, 2005 10:45:29 -0800 Robert Barr
> > > <[email-masked]>
> > > wrote:
> > > 
> > > >
> > > >
> > > >> -----Original Message-----
> > > >> From: [email-masked]
> > [mailto:[email-masked]] On
> > > >> Behalf Of Harald Tveit
> > > Alvestrand
> > > >> Sent: Friday, February 18, 2005 9:05 AM
> > > >> To: [email-masked]; 'George T. Willingmyre'; 'Scott W Brim'; 
> > > >> [email-masked]
> > > >> Subject: RE: clarification of blanket statement text
> > > >>
> > > >>
> > > >>
> > > >> --On fredag, februar 18, 2005 08:32:33 -0800 Robert Barr 
> > > >> <[email-masked]>
> > > >> wrote:
> > > >>
> > > >> >> Agreed - these companies will have to continue to make
> > > specific IPR
> > > >> >> statements. Making such statements is consistent with
> > the RFC,
> > > >> >> and provides information to the IETF community -
> > which I think
> > > >> >> is a Good Thing - but
> > > >> >> they do not lessen the requirement on the companies
> > > that make them.
> > > >> >>
> > > >> >>                            Harald
> > > >> > They should be marked non-compliant, as is done with
> > > other types of
> > > >> > statements. Why is it consistent w RFC?? The excerpt
> > above says
> > > >> > "requirement not satisfied"
> > > >>
> > > >> As I interpret it, they satisfy the formal requirements for a 
> > > >> disclosure, but do not satisfy the (more strict)
> > requirement for a
> > > >> disclosure that
> > > >> allows the filer to not file any more disclosures.
> > > >>
> > > >> Scott and Jorge will probably chime in if I got that one wrong.
> > > >
> > > >
> > > > they don't satisfy this formal requirement:
> > > >
> > > > 6.4.  What must be in a disclosure?
> > > >
> > > > 6.4.1.  .... The disclosure must also list the
> > > >    specific IETF or RFC Editor Document(s) or activity
> > > affected.  If the
> > > >    IETF Document is an Internet-Draft, it must be
> > > referenced by specific
> > > >    version number. ..
> > > >
> > > 
> > > 
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > Ipr-wg mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > > 
> > > 
> > > _______________________________________________
> > > Ipr-wg mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > > 
> > > 
> > > _______________________________________________
> > > Ipr-wg mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > > 
> > 
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > 
> 

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Robert Barr " <[email-masked]>
Date: Mon, 21 Feb 2005 12:30:29 -0800

> this, too, should be made clear. 

I think we should leave that to the courts to decide, IMO 2026 is unclear on
the effect of such statements.