Subject: RE: clarification of blanket statement text

From: "Powers Chuck-RXCP20" <[email-masked]>
Date: Mon, 21 Feb 2005 11:10:15 -0600

I think the question should be: is there anything in RFC 2026 that
prevented blanket RAND statements from being effective? Considering that
an awful lot of them were filed with the IETF during the years that RFC
2026 was in force, it is a reasonable assumption that many members
believed that doing so was in compliance with the IETF IPR Policy at the
time, particularly since RFC 2026 was not particularly detailed on this
topic.

Just as I don't believe that we can impose changes to the IPR Policy
retroactively, neither do I believe we can begin reinterpreting the old
policy, based on what we now want to do. If RFC 2026 clearly prohibits
the use of blanket RAND statements, then removing the existing
statements should be an option. If (as I believe) RFC 2026 is ambiguous
on the topic of specific declarations, instead focusing on receiving
assurances that licensing would be available if claimed rights existed,
then we should not try to go back and rewrite history.

IMO, the best approach will be to draw a line at the adoption of RFC
3668, and ensure that declarations from that point conform to the more
detailed disclosure requirements outlined in the latter document.

Regards,

Chuck

-----Original Message-----
From: Robert Barr [mailto:[email-masked]] 
Sent: Monday, February 21, 2005 10:46 AM
To: Powers Chuck-RXCP20; 'Contreras, Jorge'; 'Harald Tveit Alvestrand';
'George T. Willingmyre'; 'Scott W Brim'; [email-masked]
Subject: RE: clarification of blanket statement text

Is there/was there  anything in 2026 that allows blanket RAND statements
to be effective as a substitute for specific statements about an
I-Draft?  

> -----Original Message-----
> From: Powers Chuck-RXCP20 [mailto:[email-masked]]
> Sent: Monday, February 21, 2005 7:24 AM
> To: [email-masked]; Contreras, Jorge; Harald Tveit 
> Alvestrand; George T. Willingmyre; Scott W Brim; [email-masked]
> Subject: RE: clarification of blanket statement text
> 
> It make no sense to simply "remove" all of the existing blanket 
> statements on the IETF IPR site, since the vast majority of them were 
> made under RFC 2026, and were therefore compliant to the disclosure 
> process when they were made. To simply remove all of the blanket 
> statements that exist certainly won't remove the obligation to license

> the relevant technology, since the disclosures were made in good 
> faith, according to the rules in place; it will simply introduce 
> confusion as to what was disclosed when. One can't apply changes to 
> the disclosure rules retroactively, and then demand compliance.
> 
> Any non-RF blanket statements made after the publication of
> 3668 are, of
> course, fair game, if it is determined that such a blanket statement
> does not meet the terms of 3668.
> 
> 
> regards,
> 
> Chuck
> 
>   -----------
>  
> Chuck Powers, Corporate Standards Office
> Motorola, Inc
> phone: 847-576-4594
> mobile: 847-208-0413
> text message: [email-masked]
>  
> [email-masked]
> 
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf
> Of Robert Barr
> Sent: Friday, February 18, 2005 9:18 PM
> To: 'Contreras, Jorge'; 'Harald Tveit Alvestrand'; 'George T.
> Willingmyre'; 'Scott W Brim'; [email-masked]
> Subject: RE: clarification of blanket statement text
> 
> 
> > Thus, if a participant states that it is willing to
> > license all of its IPR on a RAND basis, the statement
> > is not compliant.
> > However, I'm not sure I understand the problem that's
> > being identified.
> 
> The (many) non-compliant blanket RAND statements posted on
> the IETF IPR
> site should be marked non-compliant or removed. And (sigh) 
> the template
> may need to be changed.
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Contreras, Jorge
> > Sent: Friday, February 18, 2005 5:30 PM
> > To: Harald Tveit Alvestrand; [email-masked]; George T.
> > Willingmyre; Scott W Brim; [email-masked]
> > Subject: RE: clarification of blanket statement text
> > 
> > I've been asked to clarify, so here's my
> > interpretation of the rules (sorry for repeating
> > what's been said by others in slightly different
> > words):
> > 
> > Under 6.4.3, a participant can satisfy its disclosure
> obligations by
> > making a "blanket" statement that it is willing to license
> all of its
> > potential IPR covering an IETF specification ONLY if
> > 	
> > 	(a) the license will be royalty-free, AND
> > 
> > 	(b) any other terms and conditions of the
> > license are disclosed in an IPR disclosure statement.
> > 
> > No other "blanket" statements of licensing intention satisfy the 
> > participant's disclosure obligations under 3668. Thus, if a 
> > participant states that it is willing to license all of its IPR on a

> > RAND basis, the statement is not compliant.
> > 
> > The participant who wants to grant RAND licenses
> > must comply with the
> > specific disclosure rules in 6.4.1 and elsewhere.
> > 
> > If that was the intention, then the language works
> > as written.  If not, then it can be fixed.
> > However, I'm not sure I understand the problem that's
> > being identified.
> > 
> > Jorge
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On 
> > Behalf Of Contreras, Jorge
> > Sent: Friday, February 18, 2005 6:07 PM
> > To: Harald Tveit Alvestrand; [email-masked]; George T. Willingmyre;
> > Scott W Brim; [email-masked]
> > Subject: RE: clarification of blanket statement text
> > 
> > 
> > I agree with Robert -- this type of
> > disclosure is not compliant.  This was
> > actually discussed within the IP-WG when
> > the rules were being drafted -- it is 
> > not just an oversight.  A change may
> > be desirable, but it would be more
> > than a simple correction of something
> > inadvertent.
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On 
> > Behalf Of Harald Tveit Alvestrand
> > Sent: Friday, February 18, 2005 1:52 PM
> > To: [email-masked]; 'George T. Willingmyre'; 'Scott W Brim';
> > [email-masked]
> > Subject: RE: clarification of blanket statement text
> > 
> > 
> > You're right.
> > 
> > I think this proves that we were not reading RFC 3668 when we wrote 
> > it.
> > 
> > What do you suggest that we do about it?
> > 
> > --On fredag, februar 18, 2005 10:45:29 -0800 Robert Barr 
> > <[email-masked]>
> > wrote:
> > 
> > >
> > >
> > >> -----Original Message-----
> > >> From: [email-masked]
> [mailto:[email-masked]] On
> > >> Behalf Of Harald Tveit
> > Alvestrand
> > >> Sent: Friday, February 18, 2005 9:05 AM
> > >> To: [email-masked]; 'George T. Willingmyre'; 'Scott W Brim';
> > >> [email-masked]
> > >> Subject: RE: clarification of blanket statement text
> > >>
> > >>
> > >>
> > >> --On fredag, februar 18, 2005 08:32:33 -0800 Robert Barr
> > >> <[email-masked]>
> > >> wrote:
> > >>
> > >> >> Agreed - these companies will have to continue to make
> > specific IPR
> > >> >> statements. Making such statements is consistent with
> the RFC,
> > >> >> and provides information to the IETF community -
> which I think
> > >> >> is a Good Thing - but
> > >> >> they do not lessen the requirement on the companies
> > that make them.
> > >> >>
> > >> >>                            Harald
> > >> > They should be marked non-compliant, as is done with
> > other types of
> > >> > statements. Why is it consistent w RFC?? The excerpt
> above says
> > >> > "requirement not satisfied"
> > >>
> > >> As I interpret it, they satisfy the formal requirements for a
> > >> disclosure, but do not satisfy the (more strict) 
> requirement for a
> > >> disclosure that
> > >> allows the filer to not file any more disclosures.
> > >>
> > >> Scott and Jorge will probably chime in if I got that one wrong.
> > >
> > >
> > > they don't satisfy this formal requirement:
> > >
> > > 6.4.  What must be in a disclosure?
> > >
> > > 6.4.1.  .... The disclosure must also list the
> > >    specific IETF or RFC Editor Document(s) or activity
> > affected.  If the
> > >    IETF Document is an Internet-Draft, it must be
> > referenced by specific
> > >    version number. ..
> > >
> > 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > 
> > 
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > 
> > 
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/ipr-wg
> > 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "George T. Willingmyre" <[email-masked]>
Date: Mon, 21 Feb 2005 13:50:21 -0500

I have posted previously  a concern that the IP disclosure  template at
https://datatracker.ietf.org/public/ipr.cgi  has elements beyond the
mandatory requirements  from the IETF policy/procedure at
http://www.ietf.org/rfc/rfc3668.txt?number=3668  and from    the  Template
for IETF Patent Disclosures and Licensing Declarations
http://www.ietf.org/rfc/rfc3905.txt?number=3905   My concerns would be
alleviated if those elements that go beyond the procedureal requirments were
somehow labled or idenfified as such.  Can we have a discussion of this at
the IPR WG meeting in Minneapolis?   Is there a date and time yet set?

I  dont argue that information requests or offerings that go beyond what is
the minimum required are not indeed sometimes relevant or helpful.  Take for
example the discussin here of a blanket RAND offering.  Such blanket
statements might be interesting and helpful and even relevant to convey the
"posture" of a company making such a statement.  But such a statement would
seem to me to be not compliant with the IP disclosure requirement  under the
current http://www.ietf.org/rfc/rfc3668.txt?number=3668    So do we wish to
discourage such statements or to prohibit them?  Or merely emphasize to
those making such statements they are not in accord with the current
procedural requirements?

List members may find interesting the case of Symbol V Proxim   where a
court found that  a blanket offer to license IPR essential to a standard
substituted for a duty to  disclose specific  IPR during the standards
setting.  The court found that what is "right and wrong"  greatly depends
upon the rules of the standards organization .  See more at
http://www.gtwassociates.com/answers/SYMBOLvPROXIM.htm

George T. Willingmyre, P.E.
GTW Associates
1012 Parrs Ridge Drive
Spencerville, MD 20868
301 421 4138 facsimile 301 421 0977
www.gtwassociates.com

----- Original Message ----- 
From: "Powers Chuck-RXCP20" <[email-masked]>
To: <[email-masked]>; "Contreras, Jorge" <[email-masked]>;
"Harald Tveit Alvestrand" <[email-masked]>; "George T. Willingmyre"
<[email-masked]>; "Scott W Brim" <[email-masked]>; <[email-masked]>
Sent: Monday, February 21, 2005 12:10 PM
Subject: RE: clarification of blanket statement text

---

From: "Robert Barr " <[email-masked]>
Date: Mon, 21 Feb 2005 11:39:22 -0800

I think the question is whether  a WG or implementers were under the
mistaken impression that a standard was unencumbered when it actually was. I
cant answer that.
Regardless, such statements submitted before 3668 are no longer effective as
a substitute for specific statements relating to an Idraft, so if those
statements remain posted this should be noted. 

> Sent: Monday, February 21, 2005 9:10 AM

---

From: "Robert Barr " <[email-masked]>
Date: Mon, 21 Feb 2005 11:34:09 -0800

George said

RB

Yes that case is interesting, so I asked Dave Ringle of IEEE about blanket
statements, and his answer was that they only accept statements for a
specific standard.

---

From: Scott W Brim <[email-masked]>
Date: Mon, 21 Feb 2005 19:51:13 -0500

> the IPR WG meeting in Minneapolis?   Is there a date and time yet set?

George, the web forms are not policy, they are a tool.  If the policy
is clear, there is nothing for the WG to do.  If the web forms do not
comply with policy, I would inform the Secretariat or Harald (Hi
Harald).  We can make it the Administrative Director's problem when we
have one.

swb

---

From: "Lawrence Rosen" <[email-masked]>
Date: Mon, 21 Feb 2005 14:42:58 -0800

> ... Can we have a discussion of this at
> the IPR WG meeting in Minneapolis?  

I've seen this suggestion in several recent emails. Some of us will not be
in attendance in Minneapolis. Of course, anyone can discuss anything they
want to anywhere. But I hope that important issues will be discussed
publicly in this online forum rather than privately among the few who will
be in Minneapolis. More specifically, I hope that there will be no attempt
to vote there on anything important without full discussion before-hand on
this list. Is that the way it works in IETF?

/Larry

Lawrence Rosen
Rosenlaw & Einschlag, technology law offices (www.rosenlaw.com)
3001 King Ranch Road, Ukiah, CA 95482
707-485-1242  ●  fax: 707-485-1243
Author of “Open Source Licensing: Software Freedom 
               and Intellectual Property Law” (Prentice Hall 2004)

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of George T. Willingmyre
> Sent: Monday, February 21, 2005 10:50 AM
> To: Powers Chuck-RXCP20; [email-masked]; Contreras, Jorge; Harald Tveit
> Alvestrand; Scott W Brim; [email-masked]
> Subject: Re: clarification of blanket statement text
>

---

From: "George T. Willingmyre" <[email-masked]>
Date: Mon, 21 Feb 2005 21:44:04 -0500

Interesting that the term  "blanket" can in one case mean: 

1) an offer to RAND license any essential patents one may have in ANY of one's submissions to ANY standards activity .  That is the general case now with all of the generic patent assurances I looked at quickly now on the site at https://datatracker.ietf.org/public/ipr_list.cgi  In my opinion these still contain relevant information albeit information that falls short of meeting the current requirements in 3668.  Based on a quick look I saw none of the generic statements to meet the 3668 requirements for a blanket exemption Under 6.4.3, a participant can satisfy its disclosure obligations by making a "blanket" statementthat it is willing to license all of its potentialIPR covering an IETF specification ONLY if (a) the license will be royalty-free, AND (b) any other terms and conditions of the license are disclosed in an IPR disclosure statement.  CAN SOMEONE REPORT IF ANYONE HAS USED THE NEW SECTION 6.4.3?  

2) or in another case the term blanket might mean an offer to license any essential patents that a company "might have"  or  "may be seeking"  (but without revealing those patents or patent applications)  that might apply to a  PARTICULAR  standard (take for example the Reback letter  at 
http://www.ietf.org/ietf/IPR/redback-ipr-draft-shen-nhop-fastreroute-00.txt

I read the court decision to say that Symbol was following IEEE procedure. The original Symbol LOA to IEEE is not available on the web site for the 802.11 at http://standards.ieee.org/db/patents/pat802_11.html
  But it seems to me it to fall in to category 2. What is indicated on the web site  seems to show that Symbol agrees to license any IPR it might have on 802.11 on RAND terms (though not disclosing what patents it might have). We would have to see the original Symbol LOA to confirm this.  But such a statement without identifying the specific patent still  meets the current IEEE procedures as they are found at  http://standards.ieee.org/guides/opman/sect6.html#6.3  and in the current IEEE LOA at http://standards.ieee.org/board/pat/loa.pdf

Such nuances are why I  become obsessed  with every single word in a patent policy or a procedure to implement a patent policy or in a LOA that purports to implement a patent policy procedure.  The nuance here is that IETF REQUIREs patent disclosures in the cases where the patent holder offers RAND terms.  In IEEE disclosing patent info is "Optional"  in the LoA

 [Note: Completion of the following section is optional. Nothing in this Letter of Assurance shall be interpreted as giving rise to a duty to conduct a patent search.]

See also Intellectual Property Rights Policies of selected   standards developers  http://www.gtwassociates.com/answers/IPRpolicies.html  and  Criteria for the Evaluation of a patent policy for a Standards Setting Organization  http://www.gtwassociates.com/answers/draftIPRcriteria.htm

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 25 Feb 2005 14:26:13 +0100

Well, I thought the latest update to the forms fixed this problem,
by adding the equivalent of a "none of the above" button. Have
you checked recently, George?

     Brian