Subject: Re: draft-josefsson-ipr-rules-update-00

From: [email-masked]
Date: Fri, 14 Oct 2005 15:13:46 +0000

Doesnt the copyright currently say that the CR must remain with the docs?

T
 -------------- Original message ----------------------
From: Simon Josefsson <[email-masked]>
> Bill Sommerfeld <[email-masked]> writes:
> 
> > On Thu, 2005-10-13 at 19:29, Simon Josefsson wrote:
> >> After I submitted that document, Branden Robinson of the Debian
> >> project (which are supporters of my effort) proposed to change the
> >> license text slightly, into:
> >> 
> >>    The Contributor grants third parties the right to copy and
> >>    distribute the Contribution, with or without modification, in any
> >>    medium, without royalty, provided that the copyright notice and
> >>    this notice are preserved, and that any claims of endorsement or
> >>    official status by the IETF or ISOC are removed.
> >
> > that text effectively removes the right to distribute unmodified copies.
> >
> > we definitely don't want that.
> 
> Thanks for catching that, it was unintentional.
> 
> Florian Weimer pointed out that the above license is a copyleft
> license, e.g., that modified version must retain the same copying
> conditions.  I don't believe we want that either, because
> incorporating parts of RFCs into closed source should be permitted
> too.
> 
> I have updated the license to address those two concerns, the new
> license reads:
> 
>         The Contributor grants third parties the right to
> 	copy and distribute the Contribution, with or without
> 	modification, in any medium, without royalty.  If the
> 	Contribution is modified, any claims of endorsement or
> 	official status by the IETF or ISOC must be removed.
> 
> I'm interested in hearing more feedback from this WG.
> 
> Thanks,
> Simon
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Simon Josefsson <[email-masked]>
Date: Sat, 15 Oct 2005 09:12:19 +0200

> Doesnt the copyright currently say that the CR must remain with the docs?

I'm not sure what you mean, but I can't identify a copyright conflict
in the license text below.  My license proposal doesn't say anything
about who owns the copyright.  The proposal only grants certain rights
to third parties.

Thanks,
Simon