Subject: Re: The Trust and licensing [Re: New version of my proposal posted]

From: [email-masked]
Date: Mon, 14 Nov 2005 15:58:04 +0000

Fred you small mind doesnt need to travel in cricles - you and the rest of the IETF management just need to stop trying to re-write global IP law by some bogus games in re to the submission rights, assignment of IP rights, and those propagated through the IETF.

This is an instance where technology is not right - the law is ... and technologist's who dont like that would better be served trying to change those laws rather than violate them left and right herein... or to generate some ridiculous full-body-condom approach to a one-size-fits all solution. This isnt about what the IETF wants or is willing to do its about the law and the practice of IP law.

Ever have to sue someone over IP rights violations - I have.

Todd Glassey

 -------------- Original message ----------------------
From: Fred Baker <[email-masked]>
> My small mind travels in circles on what a "derivative" and an  
> "implementation" constitute in your mind.
> 
> Lots of people implement IETF specifications. That's why we write  
> them. Sometimes a feature is added over and above the specification,  
> normally in response to a customer requirement. For example, a while  
> back we wanted to deploy a concept that eventually became known as  
> MPLS, and we needed to find ways to determine what path the LSP  
> needed to follow and we needed a protocol to install it. These were  
> instantiated in updated features in OSPF and RSVP. Both modifications  
> were brought back to the standards process. Similarly, various issues  
> require changes in global BGP routing, such as the fact that MD5 was  
> recently broken etc; these are discussed in the 26 current internet  
> drafts in idr. In general, when IETF protocols are modified, it is  
> for similar reasons, and in fact the modifications similarly make it  
> back.
> 
> What "commercial derivative" do you have in mind that is *not*  
> characteristically brought back? Can you get specific?
> 
> On Nov 11, 2005, at 11:30 AM, [email-masked] wrote:
> > I suggest that this is the way to kill the trust - No one who made  
> > a commercial derivative from a IETF public technology will want to  
> > give their work away and for the IETF to mandate that they must if  
> > the IP from the trust is used, insures lawsuits and pain for the  
> > IETF and the Trust both.

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: [email-masked]
Date: Mon, 14 Nov 2005 16:05:11 +0000

-------------- Original message ----------------------
> them. 

Likewise many people implement a process/protocol and then take it to the IETF - for all of those there is the possibility of patenting that work outside of the IETF itself which is where this whole line of questioning started several years ago as I recall.

> Sometimes a feature is added over and above the specification,  
> were brought back to the standards process. 

But since they were originally proposed outside the ITEF itself, the genesis and ownership of the extensions can be questioned - so here is an instance where the IETF have own underlying rights and not the published extensions really.

> Similarly, various issues  
> drafts in idr. 

Uh, yes but since the collission process and rate is as low as it is I suggest picking another metaphor or example.

> In general, when IETF protocols are modified, it is  

But since the modifications in most instances happen outside the IETF process or framework - they may not be formally part of the IP Gift or what the Gift was developed into - this is not rocket science, its law.

> characteristically brought back? Can you get specific?

Sure - how about where someone wanted to prepare and file for IP protection against their own work that occureed offlist or outside of the IETF process and framework but that referenced or was derived from conversations or work that was submitted to the IETF itself. This is common in the patenting of phsyical properties all the time. Why would it not happen here?