Subject: RE: Preventing Fake RFCs - Proposal

From: [email-masked]
Date: Wed, 16 Nov 2005 12:07:07 -0500

At the risk of disturbing agreement with Simon, there's an important
clarification to his comments:

> I notice that the GPL license text itself contain a similar condition:
> 
>  Everyone is permitted to copy and distribute verbatim copies
>  of this license document, but changing it is not allowed.
> 
> I believe that restricting the modification right on license text is
> acceptable to everyone.  Debian may have an issue if they were to
> consider the boilerplate external to the license (and thus would have
> to be modifiable in order to be available for inclusion in Debian),

The restrictive license I'm proposing on the "boilerplate" goes beyond
prohibiting modifications to the "boilerplate" itself to prohibit
modifications elsewhere in the RFC when the "boilerplate" is retained
in the result.

This is obviously (and deliberately) GPL-incompatible in order to
prevent abuse of the GPL (and similar licenses) to create fake RFCs.
The RFC extract case in which the "boilerplate" is removed (creates
source code, man pages, help text, etc, that Debian and the like
need to make the code work and explain what it does) isn't covered
by the restrictive license.

The simplest way for Debian to deal with the restrictive license is that
if Debian can't accept the "no fake RFCs" limitation on modifications,
then Debian simply doesn't distribute any document containing the
current "boilerplate", including unmodified RFCs (this has no effect
on source code).  There are a number of ways to work around this, such
as Debian distributing URLs for the RFCs that they consider important.
This shouldn't be a problem for either the IETF or Debian.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: Simon Josefsson [mailto:[email-masked]] 
> Sent: Wednesday, November 16, 2005 9:42 AM
> To: Black, David
> Cc: [email-masked]
> Subject: Re: Preventing Fake RFCs - Proposal
> 
> [email-masked] writes:
> 
> > I have an idea for separating out the "prevention of fake
> > RFCs" issue from the rest of the issues we're working
> > on and solving it.  I observe:
> > - Any fake RFC needs the "boilerplate", otherwise it's
> > 	not a credible fake.
> > - None of the RFC extracts need the "boilerplate" (or at
> > 	least don't need it in its entirety).
> > - The "boilerplate" is controlled by the IETF.  Nobody
> > 	else can grant permission to use it.  That's not
> > 	the case for most other RFC text.
> 
> I agree with all those observations.
> 
> > So, I suggest putting restrictive license conditions on
> > documents that contain the "boilerplate" (or just some crucial
> > piece of it like the various "Status of this Memo" texts that
> > appear on the first page of RFCs and I-Ds):
> 
> That is a very good idea!
> 
> I notice that the GPL license text itself contain a similar condition:
> 
>  Everyone is permitted to copy and distribute verbatim copies
>  of this license document, but changing it is not allowed.
> 
> I believe that restricting the modification right on license text is
> acceptable to everyone.  Debian may have an issue if they were to
> consider the boilerplate external to the license (and thus would have
> to be modifiable in order to be available for inclusion in Debian),
> but I believe the boilerplate could be considered an integral part of
> the license.  But I'm not sure.  We would have to be clear on that.
> 
> > - The "boilerplate" is for use on RFCs and Internet-Drafts.
> > 	All other uses are prohibited.
> > - Documents (RFCs and Internet-Drafts) containing the
> > 	"boilerplate" may be modified outside the IETF
> > 	in a fashion that retains the "boilerplate", only
> > 	for:
> > 	- formatting for publication
> > 	- translation
> > 	- creating Internet-Drafts to submit to the IETF.
> > 	All other modifications outside the IETF that
> > 	retain the "boilerplate" are prohibited.
> > Extracts (modifications that remove the "boilerplate")
> > can then be dealt with separately without fear of
> > enabling fake RFCs, because any such fake RFC either
> > contains the boilerplate, and hence violates the license
> > conditions, or doesn't contain the boilerplate and hence
> > can't be taken seriously as a fake RFC.
> >
> > The result should be more flexibility in the options
> > for permitting extracts and modified extracts outside
> > the IETF because the permissions we grant don't have
> > to consider preventing fake RFCs.
> 
> I agree with all that, and you have my support on this.
> 
> Thanks for proposing this.  I believe it solve a problem that we have
> spent way too much time on.  Nobody here want to enable fake RFCs.
> 
> Regards,
> Simon

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Simon Josefsson <[email-masked]>
Date: Wed, 16 Nov 2005 18:43:24 +0100

> modifications elsewhere in the RFC when the "boilerplate" is retained

Ouch.  You are right.  Still, I believe there is a chance that this
solution may be acceptable to everyone.

You would still be permitted to modify the content of the RFC, if you
remove the boiler plate, right?

This situation seem similar to requests that I recall in some licenses
that confusing author or name information should be removed if you
modify the work.  I recall that some projects required that if you
release a modified work, you would have to remove all references to
the original name.  You can't call it X any more, which imply several
changes of the work.  I think that is considered to be acceptable in
the free software community.

One example may be Apache, which has a license that include:

 * 4. The names "Apache" and "Apache Software Foundation" must
 *    not be used to endorse or promote products derived from this
 *    software without prior written permission. For written
 *    permission, please contact [email-masked].

That has been accepted by Debian.

Part of the Apache license is a license on PCRE which says:

2. The origin of this software must not be misrepresented, either by
   explicit claim or by omission. In practice, this means that if you use

Another part of Apache is mod_mime_magic, which include:

 * 3. Altered versions must be plainly marked as such, and must not be
 * misrepresented as being the original software.  Since few users ever read
 * sources, credits must appear in the documentation.

I think there is wiggle room in permitting your proposal from the free
software community.

I will modify my proposed license to include something what you
propose, and let the Debian legal people have a look at it.

> prevent abuse of the GPL (and similar licenses) to create fake RFCs.

I'm not certain it is GPL incompatible.  GPL contain a clause like:

    2. You may modify your copy or copies of the Program or any
       portion of it, thus forming a work based on the Program, and
       copy and distribute such modifications or work under the terms
       of Section 1 above, provided that you also meet all of these
       conditions:

       a) You must cause the modified files to carry prominent notices
          stating that you changed the files and the date of any
          change.

That may be considered similar to what we want to achieve here.

Regards,
Simon