Subject: Re: Mixing GPL and BSD licenses

From: [email-masked]
Date: Thu, 17 Nov 2005 22:01:20 +0000

Realize that what you are talking about Sam is a process for formally putting the IETF on Notice of something... what would the difference between this and a new Document called an "informational reference" be? - the purpose would be to put the IETF on notice without conveying rights to the new IP right?

Todd

 -------------- Original message ----------------------
From: Sam Hartman <[email-masked]>
> >>>>> "Black" == Black David <[email-masked]> writes:
> 
>     Black> Sam,
>     >> A large vendor makes incompatible changes to an important ietf
>     >> protocol.  They have a lot of market share.
>     >> 
>     >> Which world serves the Internet better?
>     >> 
>     >> A) The vendor cannot easily document their changes so they do
>     >> not.
>     >> 
>     >> B) The vendor can publish a clearly labeled and modified RFC
>     >> that documents their change.  They don't want the IETF to pick
>     >> up the text they wrote--after all they paid expensive tech
>     >> writers to write that text--but they'd be happy to let the
>     >> world know what the change is.
>     >> 
>     >> In the second world the Internet is a better place.
> 
>     Black> And it's even better if the modified RFC is submitted to
>     Black> the IETF as a "may only publish as an Internet-Draft"
>     Black> Internet-Draft as that brings the changes to the attention
>     Black> of the IETF experts on the protocol that the vendor
>     Black> modified.
> 
> Yes.  My position though is that requiring this does not serve our
> goals.  I'm basically in the documenting is always better than not
> documenting camp.
> 
>     Black> Flipping this back over to open source, it raises an
>     Black> interesting question.  I hope it's clear to everyone that
>     Black> GPL on RFCs (at least for standards-track RFCs) is not a
>     Black> good idea because it can have the effect of preventing use
>     Black> of RFC extracts by exactly the sort of large vendors Sam
>     Black> envisions in his example.  
> 
> Yes.  Fortunately I don't think many people even in the open source
> community will argue that GPL is a good license for RFCs.
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Sam Hartman <[email-masked]>
Date: Thu, 17 Nov 2005 17:06:38 -0500

>>>>> "todd" == todd glassey <[email-masked]> writes:

    todd> Realize that what you are talking about Sam is a process for
    todd> formally putting the IETF on Notice of something... what
    todd> would the difference between this and a new Document called
    todd> an "informational reference" be? - the purpose would be to
    todd> put the IETF on notice without conveying rights to the new
    todd> IP right?  Todd

No, actually that's not what I'm talking about but thanks for trying
to explore what I am saying.

--Sam