Subject: Re: FreeBSD has to change its manual because of IETF IPR rules

From: [email-masked]
Date: Tue, 08 Nov 2005 16:49:18 +0000

Brian - the key point you made was "did they talk to the IETF"... the point is that they didnt obviously. This says everything that needs to be said I think. The question is whether the IPR-WG recommends to people that it actually speak to the IETF about these matters... but since there is no formal membership - who would they talk to, Jorge directly?

Todd

 -------------- Original message ----------------------
From: Brian E Carpenter <[email-masked]>
> Did they think of *talking* to the IETF before these changes? It looks
> as if they have completely misinterpreted both the intent and the actual
> legal meaning of the IETF language.
> 
>      Brian
> 
> Stephane Bortzmeyer wrote:
> > Just to illustrate that the problem is not only with Debian. FreeBSD
> > was apparently unable to keep texts from the RFC in its manual pages
> > (6.0 has been released yesterday) because of restrictive IETF policy:
> > 
> > http://www.freebsd.org/releases/6.0R/relnotes-i386.html
> > 
> > The following manual pages, which were derived from RFCs and possibly
> > violate the IETF's copyrights, have been replaced: gai_strerror(3),
> > getaddrinfo(3), getnameinfo(3), inet6_opt_init(3),
> > inet6_option_space(3), inet6_rth_space(3), inet6_rthdr_space(3),
> > icmp6(4), and ip6(4).
> > 
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: [email-masked]
Date: Tue, 08 Nov 2005 17:51:51 +0000

Uh Simon - the publishing of an RFC does not make that RFC policy. What it makes it, is a document that is published within the Organization for Commentary and possibly outside the organization. 

This is the core flaw in the Entire IPR-WG's RFC process. Just becuasse RFC3978 was issued a RFC number doesnt mean its accepted policy or is even embraced by the IETF.

The wonder of it all astounds me. You folks are worried about the law but you still seem to think that by writing a RFC you are complying with the legal requirements herein... or are in fact writing the law - what a joke. Ahahahahaha 

Todd

 -------------- Original message ----------------------
From: Simon Josefsson <[email-masked]>
> The legal meaning of RFC 3978 seem clear to me.  There are no rights
> granted to third parties whatsoever.  This issue has been pointed out
> on this list for well over a year, so people have certainly been
> talking to the IETF about this.  I don't think it is reasonable to
> expect people to contact an organization to check whether they mean
> what they say.  I'm here in Vancouver to describe similar problems
> that I encountered, so I hope the intended direction of the IETF will
> be easier to deduct soon.
> 
> Regards,
> Simon
> 
> Brian E Carpenter <[email-masked]> writes:
>