Subject: Re: A couple of questions about the IETF trust outbound licensing.

From: [email-masked]
Date: Wed, 16 Nov 2005 14:13:50 +0000

Brian - how will the existing IP portfolio and and amendments to pre-existing IP's be treated? Will they be 'inducted into the Trust', and if so will it require a release from those parties - my take is that it would certainly.

That said, let me also ask at the management level whether there is a plan and the financial commitment for managing the IP's as well? For instance, what is the IETF's responsibility and its form of action when it discovers a violation of the licensing rules? 

Todd Glassey

 -------------- Original message ----------------------
From: Brian E Carpenter <[email-masked]>
> a) It was Lucy Lynch who presented briefly in the IPR WG, not Lynn.
> 
> b) That isn't the intent of clause 9.5. It's actually intended to
> ensure that work done for us by the secretariat or any other service
> provider reverts to the IETF, and that mods made by other bodies
> to our specifications revert to us. But since it could be interpreted
> the way Thierry is concerned about, we will put clarifying text
> in place (outside the Trust agreement itself) to avoid this unintended
> side effect. We worked on this in Vancouver with other people who
> noticed the same point and the clarifications are in preparation.
> 
>     Brian
> 
> Harald Tveit Alvestrand wrote:
> > 
> > 
> > --On 14. november 2005 09:11 -0500 Thierry Moreau 
> > <[email-masked]> wrote:
> > 
> >> The licenses to be granted by the trust have a "contaminating
> >> property" even stronger than GPL'ed source code. This is how I
> >> read the clause 9.5 of the trust agreement:
> >>
> >> 9.5 Licenses. The Trust (acting through the Trustees) shall have
> >> the right to grant licenses [...] the licensee agrees to grant
> >> and assign to the Trust all right, title, and interest it may
> >> have or claim in any derivative works of Licensee that are based
> >> on or incorporate the IPR. [...]
> > 
> > 
> > I believe that this is poorly written.
> > 
> > The part of the problem I encountered in my time as IETF chair was the 
> > case where a contractor got a license from the IETF Trust to use the 
> > IETF history databases and the management tools written so far to 
> > generate new management tools for the IETF (under contract) - think "I-D 
> > tracker version II".
> > 
> > The language here seems to be trying to make it clear that the IETF 
> > would be able to use the result of such work even after the expiration 
> > of the contract.
> > 
> > I do not think that there was ever an intent to enforce any such 
> > "giveback" on the implementors of IETF standards.
> > 
> > (note - I'm currently at the IEEE, where they are no longer using the 
> > online ballot and registration system they were using at the previous 
> > meetings - apparently, the reason why involves a contract dispute and 
> > substantial legal fees. These are not hypothetical questions, but they 
> > are not about the content of the standards.....)
> > 
> >                  Harald
> > 
> > 
> > 
> > 
> > 
> > ------------------------------------------------------------------------
> > 
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ipr-wg
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: [email-masked]
Date: Wed, 16 Nov 2005 15:11:32 +0000

Simon - you have hit on one of the problems that the IETF has not addressed but that is becoming more and more of an issue, and that is the sheer number of documents that the individual must be an expert in to participate in the IETF processes.

While I understand the intent, as a contract document, its not likely that one would write a binding document that was split across multiple documents with specific terms and conditions in each of them because the acknowledgement process for that would be very painful.

"Uh did you read and understand RFC yada yada yada, and did you read and understand RFC beeboo beeboo beeboo, and finally did you read RFC wabba wabba wabba? AND do you agree to be bound by them?" ... and does your local legal status allow you to agree to these terms and conditions?

Todd
 -------------- Original message ----------------------
From: Simon Josefsson <[email-masked]>
> Brian E Carpenter <[email-masked]> writes:
> 
> That is another instance of where the license text suggest one thing,
> people read it in another way, leading to clarifying text outside the
> license.
> 
> The problem with that approach is that the clarifying text may not
> mean what the license says.  When people go to the license text, they
> realize they were fooled by "clarifying text".  The FAQs are not
> legally binding.
> 
> History indicate that this has happened several times.  The RFC Editor
> has still not updated its incorrect RFC 3978 "explanation" although
> everyone appear to agree it is incorrect.
> 
> Please, PLEASE, make the license text say what you mean, rather than
> add clarifying text outside the license.  This is very important.
> 
> I strongly suggest that people should avoid reading the IPR Trust FAQs
> and IAOC "clarification" and go straight to the license agreement.  If
> you find a problem with the text, don't settle with a clarifying
> update that is not part of the contract.
> 
> Having to read too many FAQs that claim various things, which are not
> legally binding, and that nobody is accountable for, before you read
> the license text smell like a smoke screen to me.
> 
> Thanks,
> Simon
> 
> 
> >    Brian
> >
> >> The part of the problem I encountered in my time as IETF chair was
> >> the case where a contractor got a license from the IETF Trust to use
> >> the IETF history databases and the management tools written so far
> >> to generate new management tools for the IETF (under contract) -
> >> think "I-D 
> >> tracker version II".
> >> would be able to use the result of such work even after the
> >> expiration of the contract.
> >> (note - I'm currently at the IEEE, where they are no longer using
> >> the online ballot and registration system they were using at the
> >> previous meetings - apparently, the reason why involves a contract
> >> dispute and substantial legal fees. These are not hypothetical
> >> questions, but they are not about the content of the standards.....)
> >>                  Harald

---

From: [email-masked]
Date: Thu, 17 Nov 2005 14:12:44 +0000

Brian

 -------------- Original message ----------------------
> Simon Josefsson wrote:
> > "Lucy E. Lynch" <[email-masked]> writes:
> > 
> > 
> >>The issue I *think* you're concerned about has to do with the content
> >>of IDs/RFCs and as those belong to the authors and not the IETF I don't
> >>believe your issue applies.
> > 
> > 
> > The IETF, and the IPR Trust, will, if I understand correctly, have the
> > legal capability of sub-licensing rights to the IDs/RFCs.  

If true, then this ONLY works if the people 'gifting' the IETF had that specific intent in their submissions. In going forward how would the trust deal with people that wanted to use the old process? Would the IETF refuse to allow those participants to do that, beause I believe that this would cause litigation against the IETF and ISOC both... 

> > It is
> > important that the IETF is able to influence the copying conditions
> > used for the IDs/RFCs that will be owned by the IPR Trust.
> > 
> > Has the IAOC been following the outbound rights copying condition
> > discussion in the IPR WG?  Would there be a problem assigning third
> > parties rights to IDs/RFCs that will be owned by the IPR Trust?
> 
> It's exactly because of that issue and related concerns that the draft
> text in the name of the Settlors that Lucy sent was developed last
> week. We intend to make sure that the Trustees can and will do what
> the IETF wants in this respect.

Ewww.  How would this determination and process work? And since the IETF prides itself on the paper-fiction 'that it has no membership' how would it dertermine a concensus here???

> 
> > What we have been discussing is to permit third parties to use, copy,
> > publish and modify IDs/RFCs, under some constraints (e.g., removing
> > the boilerplate).  Of course, it would only apply to RFCs which the
> > IPR Trust actually have a legal right to sub-license.
> 
> Exactly true.  We (the Trustees) will have to do some work to try to
> obtain the missing rights for older documents.

Its my opinion that no one in their right mind would give them to you. Especially those that have IPR disclosures against them. What value to do present them with for their 'second gift' of signing a contracual release to convert their existing RFC or other documents to the property of the Trust?

There is a larger issue here of what happens to people who dont want to play the trust game and whether they are damaged by the operations of the trust and the failure of the IETF to protect their IP's... that is where the real argument here is going to be waged I bet...

> 
> Just to be clear once again, the sample license you saw is not in the
> least intended to apply to RFCs.
> 
>      Brian
> 
>