Subject: Re: One copyright issue or Two?

From: [email-masked]
Date: Tue, 15 Nov 2005 16:03:51 +0000

Simon - 
 -------------- Original message ----------------------
From: Simon Josefsson <[email-masked]>
> [email-masked] writes:
> 
> >> > In doing so, it appears that attempts are being made to resolve the
> >> > discussion with a single solution when I believe the two can and should
> >> > be addressed separately, as to me they merit very different solutions.
> >
> > They HAVE to be addressed separately, as derivative rights dont come
> > through simple copyright...
> 
> Sorry, I don't follow.  Copying conditions can clearly be used to
> permit derivative works.  What are you thinking of here?

Permitting the copying of source image of code for the purpose of documenting that code's operation for example does not give you the right or the permission to 'compile and run' that code for instance or to develop derivatives from it. 

I think the key concept here is that the copyright release for this use-set provides permission to use the "image in print" or exceprts from it,  but not to develop derivative products from it.

> 
> >> Where do we draw the line between source code and text?  
> >
> > yes. Well that also is a very simple question to answer. Is FBNF a
> > programming language? Yep. Is it a modeling language for which there
> > are RPG tools to convert the models into exwecutable code? YEP... so
> > then is there really a question as to what FBNF or ASN.1 or any of
> > the other psuedocoding models that are used qualify as?
> 
> What is your answer for ASN.1 or FNBF?  To me, it isn't a simple
> question.

Since both of these code-modeling languages have tools that convert their output into encoded inferences (i.e. programs), like DER or BER for ASN.1, this qualifies these as exactly programming languanges... like fortran, C, Assembler or the like.

> 
> >> For example,
> >> is ABNF code or text?
> >
> > Code... As noted above - It is Pseudocode and as such needs to be
> > controlled with more than a copyright. It is no different than say
> > "Stage one" output of a multi-pass compiler for instance.
> 
> What control beyond copyright are you talking about here?  I thought
> this discussion was solely about copyright.

The problem is that Copyright alone is not enough. Derivative rights to do virtually anything are what this WG seems to want to add to the IETF's processes and capabilities and that is totally cool - as long as the processes note the legal requirements herein.

For instance if a MIB were to be published, it would be CODE and people would want to be able to use it as it sat, and likely to make their own mods to it, so a copyright would address the reprinting of the IP but not its use in a system as far as I can tell.

> 
> >> Secondly, the text of RFCs is widely used inside comments in source
> >> code.  
> >
> > yes but this is used in the form of commentary, and as such is
> > managed by Copyright in most instances.
> 
> I don't understand the distinction between code and commentary here.

Commentary - i.e. material that is reprinted, is just that reprinted. Not licensed for use say as a program or as a compilable workflow. For instance a work of finction can be copyrighted but a program or business process can get a utility patent. [As a side note - Whether you agree with patenting code or not its the law today...]

> 
> Copyright and copying conditions apply to entire works, including both
> comments and code; there is no difference as far as the BSD or GPL
> license is concerned.

Yes there is - the purpose of the use model is what is different.

> 
> >> This is example 1 in my draft.  Several free software projects
> >> do this today (Apache, Samba, ...).
> >> 
> >> I have not gotten the impression that how RFCs are used in open source
> >> projects is something the IETF want to forbid.  
> >
> > The problem is again the IETF's Standard of Care and its
> > responsibilities to protect what it claims is its IP...
> 
> You don't have to defend a copyright to claim it.  You don't even have
> to register it.

Uh, to claim a registered copyright you do have to register it. What you are referring to are "copy rights" and not the Copyright Law itself, which like all other IP Controls must be exerted and promulgated to be effective and not considered abandoned.

> 
> >> I believe it would be
> >> better to harmonize the legal text with how IETF standards are used.

I agree which is why I think that more than one release process is needed. The question is how to keep this from becoming a nightmare for the IETF's editors and release process monitors to manage. For instance anyone using a MIB that was published should get a "release permitting the use of that MIB in the operations of their network infrastructure without recompense or payment to the IETF" otherwise, it can be said that the MIB has a provable value compared to other MIBs which are only available commercially and as such the IETF could come back and demand tribute or payment for the entitie's profiting from the use therein of their (the IETF's) IP.

> >
> > Assuming the use models are legal...
> 
> I think we have several examples of illegal use of RFCs already.
> That's not my point.  My point is to try to decide what we should
> permit, and have that be reflected in the license properly.

The problem is that illegal uses that went unresponded to set a precedent in the IETF for its failing to manage or abandoning its IP rights and that's the problem in a nutshell. Anyone who has had to protect IP rights knows how painful and expensive this is. 

> 
> >> >    For the other issue, that of reuse of the normative text by anyone
> >> > who wants to do so, I am still struggling to understand why there is a
> >> > _need_ to make the text of the RFCs broadly available for use in
> >> > derivative works
> >> 
> >> Example 1 and 5 in my draft is about this.  RFC text is useful as
> >> commentary in source code or documentation.  To adapt the commentary
> >> for a specific audience, you need the right to make modifications to
> >> it.
> >
> > No you dont - you need the right to make excerpts from it. This is a
> > gross misconception in what derivative rights actually pertain to
> > and documents how little this WG actually knows about IP use models
> > and the law as a whole.
> 
> Please re-read those examples.  The RFC text need to be modifiable to
> be useful in those examples.

Modifiable or Excerptable? - they are two types of IP Rights. The first requires a derivative use license, the second is only a Copyright and "right to reprint and excerpt from" license.  

> If it is not possible to modify the
> text, it likely won't be used.  So the right to modify the text is
> important.

Agreed - but this is a derivative right. So that would need to be specifically licensed.

> 
> >> Compare the getaddrinfo man page in Solaris.  I think Sun made good
> >> decision by using the RFC text there, and that the IETF should support
> >> that behaviour.  
> >
> > The problem with this example is that Sun may not have had legal
> > right to do so under the current use license models, and if that's
> > true the IETF's negligence and gross failures in protecting its IP
> > may have invalidated any claim the IETF may have had to any of the
> > submitted IP.
> 
> Again, copyright does not have to be defended.
yes it does. Anytime a CR is violated and the individuals who own it do nothing, the rights become stale and are said in most instances to be abandoned. Its all about this concept of the IETF's mandatory Standard of Care... and what it means to the operations of the IETF itself.

> 
> > Bluntly speaking - US IP Law is really simple, you dont get to make
> > rules about IP's use and not enforce them. If you fail to protect
> > the IP's you claim to control, then they become 'abandoned' or at
> > the very least the claim that 'you' *(in this case the IETF) own
> > them is invalidated for lake of maintanence, and the performance of
> > the "Standard of Care" the IETF is required to exhibit and put
> > forth.
> 
> Are you talking about patents, perhaps?  The current topic is not
> patents, it is about copyright and copying conditions.  The term IP is
> confusing, since it include so many different and completely
> orthogonal matters.

Again - Copyright doesnt allow for use of code, for any other purpose than printing it. If you want to run it you need a more durable use release.

> 
> >> > and therefore risking all of the potential harm, to both the IETF
> >> > process and to interoperability, that I believe could ensue.
> >> 
> >> I believe the fear here is mis-placed.  The open source community
> >> permit free modifications, and while there certainly has been forks,
> >> none of them indicate that there is any long-term harm for the
> >> Internet.  Quite the contrary, the major forks (e.g., OpenBSD)
> >> contribute to a better working Internet.
> >
> > If your intent is that the IETF should ONLY allow opensource or
> > free-ware submissions then possibly...
> 
> That is not what I want.  We have the example of the getaddrinfo man
> page in Solaris.  My license would make it possible to do what Sun
> did.  We can't change existing RFC copying conditions, however, future
> ones will be covered.

Which brings up the changing IP rules create a slippery slope for the WG chairs to stand on since the previous ones with no new IP constraints would be said to have been given a lessor class of hurdle to scamper over relative to the new proposed ones.

> 
> >> > If I were to write some code which implemented an IETF RFC, and at
> >> > various points I decided that I have a better way to implement the
> >> > protocol than as defined in the RFC, then I am certainly free to do
> >> > so, and I am also free to draft man pages, comments, etc indicating
> >> > what I have done without having to use to RFC text itself as a
> >> > starting point.  
> >
> > No you are not - you only have this capability if a derivative
> > rights release is included with the submission and the intent of the
> > person 'submitting the IP originally' is to enable you to do
> > this. Otherwise the "GIFT" is invalid and the ownership of the IP
> > remains with the original submitter and those involved in any
> > vetting or otherwise, have damage claims against the IETF...
> 
> I'm arguing that I should have that right.

By the way - is it a right or a privilege? - this is an important distinction since Rights are not supposed to be taken away and privileges can be suspended or terminated.

> 
> >> > Copyright law does not prevent me from writing my
> >> > own description of what I have done, 
> >
> > Actually it may - depending on how much of the original text you
> > modify... By the way - this gross lack of IP law knowledge is what
> > is spurring this conversation on.

I want to make it real clear I am not slamming anyone personally on this list. I do understand what it is you want to accomplish and FWIW I can see what it will take to implement a clean set of releases for this process. There are two levels of submission as far as I can see here, and these were documented in a draft I am working on for which a copy was sent to fred baker for initial review - Simon - do you want a copy too? I will send it when I get home this afternoon.

> 
> By "writing my own description" I mean that NO original text is
> re-used.

OK so then this would be a pure derivative instance then right?

> 
> >> > Since the right already exists to redistribute the IETF
> >> > document as a whole in unmodified form, then it would be easy to
> >> > indicate with my own text where my code differed from the RFC (and
> >> > presumably why) without having to use the existing RFC text.
> >
> > I would challenge the effectivity of the IETF's existing releases to
> > the point of stating that bassed in the IETF's gross failures to
> > protect any of its IP it has abandoned any onsiderations of rights
> > it might have had and the ownership of EVERY single RFC, I-D and
> > other IETF document published to date probably belongs to the
> > original submitters of those documents.
> >
> > Again - this is about what the person submitting the IP to the IETF
> > expects and under what terms they submitted it - not what terms the
> > IETF accepted it.
> 
> As above, I don't follow this, because copyright does not have to be
> defended.

Again YES it does. Not defending IP rights assertions or filings is tantamount to abandoning them. Further the response to an unauthorized use MUST come within a timely window or its just too late... and while this excerpt from a BLOG was about EFF and Copyright Issues, it works here too.

There are, as Lawrence Lessig keeps saying, four forces in play: architecture, law, markets, and social norms. The issues of IP architecture can't be discussed in isolation. It can work in conjunction with these other forces, but cannot and will not stand alone. In the realm of intellectual property, our system has always been a dynamic and precarious balance of conflicting forces.

Laws are never fully enforceable; that doesn't make them toothless. Markets don't work perfectly either, but they do function. Social norms are the wildcard. If a reasonable amount of respect for the value of intellectual property ceases to be a social norm, then the system's out of whack -- and will over-correct. That's just what we see happening now. In response to perceived anarchy, this proposed Congressional bill strikes back with reverse anarchy. This kind of arms race can only further erode our social norms. 

> 
> Thanks,
> Simon
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 17 Nov 2005 01:20:45 +0100

[email-masked] writes:

> Permitting the copying of source image of code for the purpose of
> documenting that code's operation for example does not give you the
> right or the permission to 'compile and run' that code for instance
> or to develop derivatives from it.
>
> I think the key concept here is that the copyright release for this
> use-set provides permission to use the "image in print" or exceprts
> from it, but not to develop derivative products from it.

Ah, right!  I think the license text in my draft actually only says
"copy and distribute, with or without modification".  I will adjust my
license in an updated draft.

> Uh, to claim a registered copyright you do have to register it.
...
> yes it does. Anytime a CR is violated and the individuals who own it
> do nothing, the rights become stale and are said in most instances
> to be abandoned. Its all about this concept of the IETF's mandatory
> Standard of Care... and what it means to the operations of the IETF
> itself.

Sorry, I disagree here.  You don't have to register a copyright to
defend it.  You only have to be the author of the piece of work.  This
is covered in the Berne convention.  Do you have any examples of where
copyright was lost because it was not defended?  I'm not talking about
patents or any other IP.  Only the copyright.

> Again - Copyright doesnt allow for use of code, for any other
> purpose than printing it. If you want to run it you need a more
> durable use release.

Agreed.  But the copying condition license that third parties will get
from the IETF could include the right "to use" the work.  I believe
the IETF should grant that right.

> By the way - is it a right or a privilege? - this is an important
> distinction since Rights are not supposed to be taken away and
> privileges can be suspended or terminated.

Yup, that is important.  My draft doesn't use the term "irrevocable
right" either.  It should.  I will fix this as well.

Thanks,
Simon

---

From: "todd glassey" <[email-masked]>
Date: Wed, 16 Nov 2005 16:54:02 -0800

Simon
----- Original Message ----- 
From: "Simon Josefsson" <[email-masked]>
To: <[email-masked]>
Cc: "Powers Chuck-RXCP20" <[email-masked]>; <[email-masked]>
Sent: Wednesday, November 16, 2005 4:20 PM
Subject: Re: One copyright issue or Two?

> defend it.

No but if you dont react to people violating that copyright then you lose
it. Trust me on that one or better yet, ask Jorge about what happens in the
real world when IP protections are violated and those holding those
protections do not exercise them?

> You only have to be the author of the piece of work.

No, not necessarily. In many instances the author holds NO right whatsoever
to the work-product they produce, and this is the case with US Copyright and
those employed by Sponsors. In fact under what's called "Work for Hire", the
Author owns nada in many cases.

> This

Uh how about the term xerox, which was found by a court to have become
common-speak after Xerox corporation tried to nail someone in US Federal
Court over its use in print. There are many examples.

> >> patents, it is about copyright and copying conditions.

Uh, again I dont see how you can limit this to Copyright's only. Any patent
application would cover this as well. Any of these rules should apply to all
IP protection. Focusing on CR only is a major mistake in my opinion but I
understand.

> >> The term IP is

No its pretty straight forward - there are 5 principal types of protected IP
including the following:

o-    Copyright

o-    Trademark/Service Mark

o-    Patents

o-    Trade Secrets

o-    Industrial Design Rights
> the IETF should grant that right.

Depends on what and why the people submitting the 'gift' to the IETF did it,
and specifically what their understanding and/or expectations were. For
instance, are they intentionally giving this 'offering' away to the world?
Are they working with an already established framework and team and what the
IETF is offering them is a qualified pool of technology vetters? Are then
just publishing it to expose the Community and thus formally contaminate the
Technology Landscape to prevent other IP Claimants from filing a claim?
(watch out for this last one too - its going to happen way more than anyone
thinks I bet).

> right" either.  It should.  I will fix this as well.

No problem partner! Glad to be of service!

T

---

From: "todd glassey" <[email-masked]>
Date: Wed, 16 Nov 2005 17:14:42 -0800

I want to propose the following:

 That any and all published documents must remain under the control of the
IETF, in that there must be protection built into the IETF's processes to
allow materials to be removed from circulation by less than having to sue
the IETF to accomplish this.

All IP publishers acknowledge that IP Rights mandate that they have some
method of maintaining control on a document ***AFTER*** its published and
that means rethinking the basic "walk-away from it" grant that has been done
in the past...

This has to pertain to the publishing, derivative works, patent, and
industrial design rights in the very least IMHO

Todd Glassey

---

From: Don Armstrong <[email-masked]>
Date: Wed, 16 Nov 2005 17:52:01 -0800

On Wed, 16 Nov 2005, todd glassey wrote:
> No but if you dont react to people violating that copyright then you
> lose it. Trust me on that one or better yet, ask Jorge about what
> happens in the real world when IP protections are violated and those
> holding those protections do not exercise them?
> 
> > This is covered in the Berne convention. Do you have any examples
> > of where copyright was lost because it was not defended? I'm not
> > talking about patents or any other IP. Only the copyright.
> 
> Uh how about the term xerox, which was found by a court to have
> become common-speak after Xerox corporation tried to nail someone in
> US Federal Court over its use in print. There are many examples.

You're conflating trademark law and copyright law. They are not the
same. Discussions which lump them together blindly with other forms
of "IP" (whatever that means) are fundamentally flawed.

Don Armstrong

-- 
She was alot like starbucks.
IE, generic and expensive.
 -- hugh macleod http://www.gapingvoid.com/batch3.htm

http://www.donarmstrong.com              http://rzlab.ucr.edu

---

From: "todd glassey" <[email-masked]>
Date: Sat, 19 Nov 2005 05:19:13 -0800

Don

----- Original Message ----- 
From: "Don Armstrong" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 16, 2005 5:52 PM
Subject: Re: One copyright issue or Two?

> > Uh how about the term Xerox, which was found by a court to have
> You're conflating trademark law and copyright law.

Don, I wasn't trying to insinuate otherwise in that example, but the order
of
the Court in that matter was that both the trademark and copyright against
any use of the term either as a trademark or term of art, was thrown down
because of the common use in society. Perhaps more than anything, that
matter is a proof to that if your product name becomes too popular you lose
it too.

Todd

> They are not the