Subject: Preventing Fake RFCs - Proposal

From: [email-masked]
Date: Tue, 15 Nov 2005 21:16:21 -0500

I have an idea for separating out the "prevention of fake
RFCs" issue from the rest of the issues we're working
on and solving it.  I observe:
- Any fake RFC needs the "boilerplate", otherwise it's
	not a credible fake.
- None of the RFC extracts need the "boilerplate" (or at
	least don't need it in its entirety).
- The "boilerplate" is controlled by the IETF.  Nobody
	else can grant permission to use it.  That's not
	the case for most other RFC text.

So, I suggest putting restrictive license conditions on
documents that contain the "boilerplate" (or just some crucial
piece of it like the various "Status of this Memo" texts that
appear on the first page of RFCs and I-Ds):
- The "boilerplate" is for use on RFCs and Internet-Drafts.
	All other uses are prohibited.
- Documents (RFCs and Internet-Drafts) containing the
	"boilerplate" may be modified outside the IETF
	in a fashion that retains the "boilerplate", only
	for:
	- formatting for publication
	- translation
	- creating Internet-Drafts to submit to the IETF.
	All other modifications outside the IETF that
	retain the "boilerplate" are prohibited.
Extracts (modifications that remove the "boilerplate")
can then be dealt with separately without fear of
enabling fake RFCs, because any such fake RFC either
contains the boilerplate, and hence violates the license
conditions, or doesn't contain the boilerplate and hence
can't be taken seriously as a fake RFC.

The result should be more flexibility in the options
for permitting extracts and modified extracts outside
the IETF because the permissions we grant don't have
to consider preventing fake RFCs.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2005 15:36:55 +0100

I'd like a legal opinion on that, but it seems much more
practical than attempting to use trademark law as some have
suggested.

     Brian

---

From: Simon Josefsson <[email-masked]>
Date: Wed, 16 Nov 2005 15:42:20 +0100

> 	the case for most other RFC text.

I agree with all those observations.

> appear on the first page of RFCs and I-Ds):

That is a very good idea!

I notice that the GPL license text itself contain a similar condition:

 Everyone is permitted to copy and distribute verbatim copies
 of this license document, but changing it is not allowed.

I believe that restricting the modification right on license text is
acceptable to everyone.  Debian may have an issue if they were to
consider the boilerplate external to the license (and thus would have
to be modifiable in order to be available for inclusion in Debian),
but I believe the boilerplate could be considered an integral part of
the license.  But I'm not sure.  We would have to be clear on that.

> to consider preventing fake RFCs.

I agree with all that, and you have my support on this.

Thanks for proposing this.  I believe it solve a problem that we have
spent way too much time on.  Nobody here want to enable fake RFCs.

Regards,
Simon

---

From: Sam Hartman <[email-masked]>
Date: Wed, 16 Nov 2005 17:40:47 -0500

I'm not at all sure that your proposal would be acceptable to Debian
for distributing rfcs in Debian.  I'm sure i could live with that
though: the rfcs will be available in non-free and fairly easy for
users to install..

I'd also fight within the Debian community to make your proposal
acceptable.

so, yes, I think that this is a great approach.  I also think the IETF
should adopt and enforce appropriate trademarks, but I see no reason
to tie the two together.

--Sam

---

From: "todd glassey" <[email-masked]>
Date: Wed, 16 Nov 2005 17:23:07 -0800

Sam why dont we just write a release to the OpenSource TCP/IP Stack vendors
that allows them to republish the IETF RFC's as a part of their
documentation as long as they are printed in whole and bear the IETF's
copyright mark. Then we can take the OpenSource User's Republishing Rights
component out of this equation.

Todd Glassey