Subject: Re: Debian "desert island"

From: [email-masked]
Date: Mon, 14 Nov 2005 15:14:24 +0000

One of the biggest problems in dealing with the propagation of IP rights is in demonstrating the intent of the submitter in the process. This has not been done, and instead this group is spending a huge amount of time looking for what appears to be a one-size-fits-all solution which just doesnt exist. 

What this group really needs to do is to settle on a set of end-use licensing models and then work backward to determine what is needed from the submitters and the IETF to meet those process needs.

Todd

 -------------- Original message ----------------------
From: Frank Ellermann <[email-masked]>
> Simon Josefsson wrote:
> 
> > My hope is that the IETF intentions can be expressed in a
> > license that is compatible with free software licenses.
> 
> The "desert island" test is apparently the same as "you can
> grab it, modify it, and sell the modified version _without_
> giving free access to the modification".  If that's the case
> then it's apparently incompatible with CC BY SA "some rights
> reserved", the share-alike aspect is lost on a desert island.
> 
>                            Bye, Frank
> 
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: [email-masked]
Date: Fri, 18 Nov 2005 16:11:47 +0000

Frank - in the real world once a patent is issued or filed ANYONE can file a derivative work against it, and that derivative is their property per se - there may be licensing issues, but derivatives cannot be prevented by patent processes and so it seems that they likewise, cannot be legally prevented herein either, except for CR issues one would think.

if Jorge wants to correct this then he should do so, otherwise this WG needs to get "what it is trying to do" in re: derivatives, and why the IP Trust is not likely to work IMHO.

Todd

 -------------- Original message ----------------------
> Simon Josefsson wrote:
> 
> > The modifications are included in the text you release,
> > aren't they?
> 
> Yes.  But my POV was as the author of the original text
> (with CC-BY-SA), so it's "them" who modify it.  And I or
> everybody else should be free to take their modifications
> and integrate them into a new I-D and later RFC nnnnbis,
> if the original document was published as RFC nnnn.
> 
> That's the idea of the "Share Alike" in CC-BY-SA (please
> add tons of IMHO / AFAIK / IANAL).
> 
> In other words, if they grab it, modify it, and then try
> to patent their modifications, it's not okay from my POV.
> 
> The US could be an excellent example of a "desert island",
> legally.  Where I live any text talking about "patented
> algorithms" (like the new MIME part 4) is utter dubious,
> AFAIK it's impossible to patent algorithms here.
> 
>                          Bye, Frank
> 
> 
>