Subject: RE: I-D ACTION:draft-josefsson-ipr-rules-update-02.txt

From: "Powers Chuck-RXCP20" <[email-masked]>
Date: Mon, 5 Dec 2005 13:52:26 -0600

I agree with Brian's scoping of the general cases below although, as
always, the devil will be in the details. IMO compatability with any/all
Open Source licenses is not an a priori requirement, in particular for
the reuse of the normative text of the IETF specs (e.g. the second case
below, and most (if not all) of its possible variants).

regards,

Chuck

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: Friday, November 25, 2005 9:27 AM
> To: IPR WG
> Subject: Re: I-D ACTION:draft-josefsson-ipr-rules-update-02.txt
> 
> 
> Personal comments:
> 
> I'm still of the opinion that Simon's proposal inadvertently 
> amounts to the IETF giving up change control of our own 
> documents, and that seems plain wrong to me.
> 
> IMHO we've *got* to limit the field of use such that we get
> to decide explicitly when it's OK for another body to
> update one of our specifications. How to do that while
> allowing the kind of uses we think are OK is really a
> problem for a legal drafting expert, not for a bunch of 
> engineers. I suspect the license will end up being much 
> longer than what we have today, and will enumerate cases, 
> both those that are allowed and those not allowed, e.g.
> 
> o License is granted to copy, use, extract, modify and distribute
>    the material when included in software code, provided only that
>    the material may not subsequently be extracted from the software
>    code for use other than in software code
> 
> o License is not granted to copy, use, extract, modify and distribute
>    the material in any document which appears or purports to be an
>    alternative version of a publicly available technical standard or
>    technical specification of a same or similar name
> 
> etc etc.
> 
>      Brian
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: [email-masked]
Date: Mon, 12 Dec 2005 16:18:11 +0000

Brian - Simon, lets define a baseline - an RFC is a request for comments as part of a standards initiative. It is a Request for Comments to whom though? Since the IETF's standards process does not allow non-WG members to participate in the vetting of IETF's Standards this claim to actually want response from outside the IETF is another "crock of merde".

If what you are trying to do is to get outside use of the IP in an RFC then the RFC itself should probably be advanced to a document allowing public response or participation, and a method for that defined, but since that doesnt exist at this time, i.e. some method of people participating in using the IETF's process vetting without participating in the IETF itself, this IPR-WG is the wrong venue for that.

An RFC by its very definition is a not a standard, and as such the IETF nor the IPR-WG has no right to represent it as either a finished work or a standard since it is not. 

That said Debian's and others publishing of RFC's for the purpose of documenting their own technologies is incorrect and a clear violation of the copyright and use rules already setup.  Those documents are not sufficiently advanced until the Standards Process is completed which it now seems like the IPR-WG wants to throw away, or until some process for formal notice of a response to an RFC is created for outside participants in the IETF's processes.

Todd Glassey
 -------------- Original message ----------------------
From: Simon Josefsson <[email-masked]>
> Brian E Carpenter <[email-masked]> writes:
> 
> > Sam,
> >
> > Sam Hartman wrote:
> > ...
> >> That effect is also incompatible with the GPL.  It's not about the
> >> text; it is about basic properties of what you are proposing.
> >
> > I want to make a positioning statement in response to that. It's
> > a personal position, not an AD position.
> >
> > If we do a first class job on the IETF license, there is every reason
> > it could become a very powerful force, just like the GPL.
> >
> > Therefore, I believe we should concentrate first on what we want,
> > not on what the GPL attempts to impose.
> 
> I believe we want RFCs to be as widely implemented as possible, and
> BSD/GPL is used for many implementations of IETF protocols,
> consequently compatibility with free licenses follow quickly.
> 
> I would welcome a document that collect all the requirements.
> 
> Regards,
> Simon
>