Subject: CLOSED #1198 Proposed resolution - Implementation and derivative work

From: Harald Alvestrand <[email-masked]>
Date: Wed, 01 Mar 2006 09:38:16 +0100

After having heard the discussion, I conclude that this resolution is
accepted by the WG, and the issue is closed.

Harald Tveit Alvestrand wrote:
> I think this has gone on long enough.
>
> This is a WG Last Call on issue #1198, with a timeout of one week, and 
> I'll close it on February 28.
>
> SUGGESTED RESOLUTION:
> ----------------------------------------------------------------
> Implementations of IETF standards that incorporate pieces of IETF 
> documents (such as MIBs or data tables) need to have the right to 
> produce derivative works based on those pieces.
>
> Implementations of IETF standards that do not incorporate such pieces 
> do not need the right to produce such derivative works.
> -----------------------------------------------------------------
> I believe that corresponds to the advice of counsel, and to the 
> opinion of the vast majority of this working group.
>
> Note that this has absolutely no effect on the need to have rights to 
> practice applicable patents; this is strictly about copyright.
>
> I know that Todd Glassey does not agree with this statement. Other 
> people who do not agree with this statement are hereby encouraged to 
> speak up; references to specific case law (in any jurisdiction) that 
> is clearly contrary to this opinion will be appreciated.
>
>                 Harald Alvestrand, co-chair of IPR WG
> ------------------------------------------------------------------------
>
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
>   

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "todd glassey" <[email-masked]>
Date: Wed, 1 Mar 2006 07:55:00 -0800

Sorry Harald - the derivative rights requirements can be gleaned from this
http://www.copyright.gov/circs/circ14.html#derivative the USD Government's
COPYRIGHT.GOV website's FAQ's on Derivative Works...

I suggest that you review the law as it stands and then recant these words
since the derivative rights section is also clearly broken - why is it that
this group thinks it gets to re-write law.

Todd Glassey

----- Original Message ----- 
From: "Harald Alvestrand" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, March 01, 2006 12:38 AM
Subject: CLOSED #1198 Proposed resolution - Implementation and derivative
work

---

From: Simon Josefsson <[email-masked]>
Date: Wed, 01 Mar 2006 22:39:31 +0100

> COPYRIGHT.GOV website's FAQ's on Derivative Works...

As far as I understood your original issue, I see nothing in that link
that support your case.

> this group thinks it gets to re-write law.

I have reviewed the copyright laws, and my conclusion is consistent
with Harald's resolution test: the right to produce a derivative work
(i.e., an implementation) of a document is only required if that
implementation include or adapt text from the document.

Thanks,
Simon

---

From: "todd glassey" <[email-masked]>
Date: Wed, 1 Mar 2006 15:23:43 -0800

No Simon - the derivative rights requirement is needed to republish exceprts
and in modifying them in submitting proposals to the IETF itself.

Todd Glassey

----- Original Message ----- 
From: "Simon Josefsson" <[email-masked]>
To: "todd glassey" <[email-masked]>
Cc: "Harald Alvestrand" <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 01, 2006 1:39 PM
Subject: Re: CLOSED #1198 Proposed resolution - Implementation and
derivative work

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 02 Mar 2006 09:57:35 +0100

> and in modifying them in submitting proposals to the IETF itself.

That is what Harald's proposed resolution says to me when I read it.
I'm not sure that I follow you here.  Are you sure you are talking
about implementations?

Thanks,
Simon

---

From: "todd glassey" <[email-masked]>
Date: Thu, 2 Mar 2006 05:56:03 -0800

Simon there are two types of derivative rights - one that lets you make
changes to the printed code itself, that is correcting, or republishing...
and I am talking about those derivative publishing rights in that anyone
that wants to edit and submit changes needs those rights.

There are YET another set of deriviative rights, and these are not
republishing, they are use-rights and these clearly have nothing to do with
IETF standards or the process of creating them except there is a rule that
there must be two (2) interoperable ports built - and the rights to build
those ports for the purpose of creating the standard have to be addressed
and also the rights to what happens to those rights when the standards
process is completed./

So the ability to publish excerpts that have been modified requires
derivative publishing rights per the US PTO and Copyright.GOV sites FAQ. But
the rights to implement a physical code body from the draft is another set
of derivative rights.For instance do the derivative rights give you the
right to productize the port built -

Why this is important is demonstrated by the RSA patent licensing and how it
happened - RSA produced a worst-case port for BSAFE and then everyone who
licensed it reimplemented it. The reason they could do so is that their Use
Licenses game them that pivilige as well The IETF's agreements dont.

Todd Glassey

----- Original Message ----- 
From: "Simon Josefsson" <[email-masked]>
To: "todd glassey" <[email-masked]>
Cc: "Harald Alvestrand" <[email-masked]>; <[email-masked]>
Sent: Thursday, March 02, 2006 12:57 AM
Subject: Re: CLOSED #1198 Proposed resolution - Implementation and
derivative work

> > No Simon - the derivative rights requirement is needed to republish
excerpts
> >> > since the derivative rights section is also clearly broken - why is
it
> > that