Subject: Status of IETF Policies and Rules

From: "Contreras, Jorge" <[email-masked]>
Date: Wed, 31 May 2006 08:46:16 -0400

I've been asked to discuss whether a "contract" exists between the IETF and its participants and, if so, whether that contract is written and, if so, whether it must be "signed".
 
As you know, unlike most other standards development organizations (SDOs), IETF does not currently require its participants to sign a formal "membership agreement".  This does not mean, however, that IETF lacks enforceable rules governing participation in IETF activities.
 
IETF's rules and procedures are, by and large, published in RFC documents or posted on the IETF web site.  IETF clearly notifies potential participants that participation in IETF activities is subject to compliance with these rules and procedures (see, e.g., the "Note Well" statement at http://www.ietf.org/overview.html).  A similar notification is distributed in hard copy to all registrants at IETF meetings and is published on various IETF mailing lists.  
 
In other words, every IETF participant must "agree" to comply with the IETF rules as a condition to participation in IETF activities.  This agreement is not manifested by a signature on a paper document, but by the participant's conduct.  Conduct is a perfectly valid means of establishing a contractual relationship.  To use an old law school chestnut:  John tells Mary that he will pay her $100 if she paints his house.  The next day, Mary paints the house.  Is John obligated to pay her $100?  The answer is "yes", at least under general contract law principles that exist in the U.S. and other common law jurisdictions.  In this example, the contract was an oral contract.
 
In the case of the IETF (which, for purposes of this discussion, I will assume is an entity capable of contracting in its own name), the conversation would go as follows:  IETF will permit Mary to participate in IETF activities if Mary agrees to comply with the IETF IPR rules published in BCP 78/79 and elsewhere.  Mary begins to post technical input to an IETF mailing list.  Is Mary obligated to comply with the IETF IPR rules?  Yes.  
 
In this case, the rules that Mary must comply with are clearly written.  In addition, the "contractual" terms binding Mary to comply with the rules are also written (i.e., in the Note Well statement).  The only element that is not written is Mary's assent to the agreement.  This is manifested by Mary's conduct.  Thus, an enforceable, written agreement would exist between IETF and Mary.
 
[Footnote:  Under a venerable doctrine called the "Statute of Frauds", certain types of contracts had to be "in writing" to be enforceable.  This Statute was developed centuries ago to prevent disagreements over the terms of certain important transactions.  Contracts covered by the Statute of Frauds include contracts not to be performed within one year or within the lifetime of the promisor, contracts to sell real estate, contracts to assume the debt of another, and contracts for the sale of goods for more than $500.  As the IETF IPR rules do not relate to any of these areas, the Statute of Frauds would generally not be relevant to this discussion.  Other statutes that have been cited on the IPR WG list, such as the Uniform Electronic Transactions Act, are equally inapplicable.  And in any case, as discussed above, the agreement that the IETF requires its participants to comply with *is* written.]
 
In addition to this agreement, Mary would be obligated to comply with the IETF IPR rules under various equitable doctrines providing, essentially, that it would be unfair for her to participate without complying with the rules established for such activities.  I'm not going to attempt to discuss these in detail here, but suffice it to say that these equitable doctrines ensure that corporations who send individual participants to IETF must themselves comply with the IETF rules to the extent applicable.
 
Regards,
Jorge

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "todd glassey" <[email-masked]>
Date: Wed, 31 May 2006 10:34:56 -0700

Counsel -  Thanks for responding. This is one of the best NON-ANSWERS I have seen in a long time...  I believe that you managed to totally not-answer any question I asked, and you did it in this amazingly legally-sounding manner too - yow! Nice :-)

---

As to your response, Nice try. MARY and her work-product is the service the IETF is pimping. MARY is a VETTER and not a SUBMITTER. Different Role, Different set of contracts binding them to the IETF...

Technically this one statement blows the entire response out of the water but you also say there is no assertion of act necessary to formally become a member of the item and I say while generally that is true that there is an act here which binds one to the IETF. 

My claims is that the IETF is joined formally by enrolling as a contractually-bound Engineering Design Review Resource in its Pay-for-Play VETTING POOLS - the ones that require you as a SUBMITTER to put the IP into the IETF to vet it in those Pools. 

Next subject - 

No Obligation to do anything - wrong... its a lottery seat - any Court would rule so.
--------------------------------------------------------
Many on this list have said THE IETF HAS NO OBLIGATION TO PUBLISH ANYTHING... which I dispute, but lets for the sake of argument say its true... SO then what is the process of filing a draft for publication with the IETF? it's a gamble that the IETF will publish it right? So then for the consideration of the republication rights, you just bought the slot before the IETF's Editors to make a decision as to whether they would publish you or not... 

This then is a lottery to participate. Its not a guarantee that you will be successful - just that you get a chance to participate in submitting material... So let me ask, how is this any different than a cellular lottery held by the FCC?   Seriously do the analysis, I have, and where this winds up is that if the IETF is not tied to the Submitter though the offer to provide competent Engineering Services for IP rights, then it is through the offer to participate in a Gamble, a Lottery with no defined set of evaluation rules, to be able to get those same Engineering Services.  

A transaction which oddly enough by comparison to the IETF's which cannot be finally consummated as a winning ticket without the signing of any number of documents - "no tickey - no washee".. this seems to me to be directly orthogonal to the idea of licensing and using the IP the IETF produces... No Signed Contract - No Conveyance of Title.

Either way - whether there is a contractual obligation to publish or there is just the lottery - its still a trade of consideration for IP rights and that makes this a contract... So Jorge - unless you can disprove this with specific precedent or law then lets move past the contract issue.

More responses justifying the existence of the 'Contracts' inline below to your response.
  ----- Original Message ----- 
  From: Contreras, Jorge 
  To: [email-masked] 
  Cc: Harald Alvestrand ; Steven M. Bellovin 
  Sent: Wednesday, May 31, 2006 5:46 AM
  Subject: Status of IETF Policies and Rules

  As you know, unlike most other standards development organizations (SDOs), IETF does not currently require its participants to sign a formal "membership agreement".  

Sorry Boss - Sure it does - this agreement under the contract is all implied in the boiler plate that the "Click Through" to the WG Signup List does. The act of joining the WG is what binds one to behave as defined under the IETF's membership 'performance of duty' rules.

The membership rules that codify Mary's behavior as noted are what are agreed to by the Click-Through Act of joining the WG - This is a CONTRACT and it has a formal acceptance process as well. 
  This does not mean, however, that IETF lacks enforceable rules governing participation in IETF activities.

  IETF's rules and procedures are, by and large, published in RFC documents or posted on the IETF web site.  IETF clearly notifies potential participants that participation in IETF activities is subject to compliance with these rules and procedures (see, e.g., the "Note Well" statement at http://www.ietf.org/overview.html).  A similar notification is distributed in hard copy to all registrants at IETF meetings and is published on various IETF mailing lists.  
So we agree that there is no issue with the IETF formally disclosing to people that there are rules for participation and that the way for people to agree to participate under these rules is to formally register in a Working Group. 

  In other words, every IETF participant must "agree" to comply with the IETF rules as a condition to participation in IETF activities.  

In my best Miss Prissy Voice... "yeeeeeeeeeeeeuuuuuuuuuuuuuuss" -  (Dont know Miss Prissy - remember Foghorn Leghorn, he was the Rooster of Bugs Bunny fame.)

  This agreement is not manifested by a signature on a paper document, but by the participant's conduct.  

No actually I would disagree... that behavior is what demonstrates that agreement to be bound in an ongoing manner. The click-through process of signing-up for the WG is what is the signature on the contract,  the agreement between the VETTER and the IETF.

  Conduct is a perfectly valid means of establishing a contractual relationship.  

True - but its not necessary here. After signing up through the WG's a failure to perform as such by the VETTER would constitute a breach of the contract... 

Again the basis of the agreement is codified initially in the WG agreement as what is known as click-through. The question here is whether Click-Through by itself is strong enough to cover the value of the IP transferred to the IETF over the period of hat member's participation as a VETTER (and I say no its not)...

  To use an old law school chestnut:  John tells Mary that he will pay her $100 if she paints his house.  The next day, Mary paints the house.  Is John obligated to pay her $100?  The answer is "yes", at least under general contract law principles that exist in the U.S. and other common law jurisdictions.  In this example, the contract was an oral contract.

  In the case of the IETF (which, for purposes of this discussion, I will assume is an entity capable of contracting in its own name), 

Which I disagree is the case BTW... very few participants in the IETF relatively speaking have any release or knowledge from their General Counsel's as to what they are up to. The GC's likewise have no idea what is being vetting inside these WG's or how they work.

There is no oversight in 99% of the companies on this planet reviewing what their engineers are doing with their IP... 

  the conversation would go as follows:  IETF will permit Mary to participate in IETF activities 

i.e. the IETF agrees to receive the value of Mary's Participation in the IETF so that the IETF can remarket these services to the SPONSORS, in the form of the Tenured Pools of Industry Professionals the IETF offers to its Submitters as the Value Proposition. This is no different than a Big-4 consulting firms actions - except it happens entirely through the meetings and the email service process.

  if Mary agrees to comply with the IETF IPR rules published in BCP 78/79 and elsewhere.  Mary begins to post technical input to an IETF mailing list.  Is Mary obligated to comply with the IETF IPR rules?  Yes.  

Is this a contractual relationship - I SAY "YES IT IS"...

  [Footnote:  Under a venerable doctrine called the "Statute of Frauds", certain types of contracts had to be "in writing" to be enforceable.  

See also the PAROLE EVIDENCE RULE which is used to qualify contracts as well.

  This Statute was developed centuries ago to prevent disagreements over the terms of certain important transactions.  Contracts covered by the Statute of Frauds include contracts not to be performed within one year or within the lifetime of the promisor, 

Both of which arguably define the IETF's submission process to a tee;

  contracts to sell real estate, contracts to assume the debt of another, and contracts for the sale of goods for more than $500.  

So here again the valuation of the IP submitted and the proposition of the value of the service of the vetting is what's on the table here. Under the $500 rule though its not just the Sale of Goods >= $500  - but any transfer of ownership greater than $500 which results in some consideration being exchanged.

For instance how about an act of barter for instance like "the transfer of sole copyright to some particular IP' which is a jointly owned 'derivative work' to the IETF for the chance to participate in the Lottery that is the submission of new projects to the developmental chaos of a WG" , similar to the one that is going on here.

  As the IETF IPR rules do not relate to any of these areas, the Statute of Frauds would generally not be relevant to this discussion.  

If there is a contract it is...

  Other statutes that have been cited on the IPR WG list, such as the Uniform Electronic Transactions Act, are equally inapplicable.  And in any case, as discussed above, the agreement that the IETF requires its participants to comply with *is* written.]

  In addition to this agreement, Mary would be obligated to comply with the IETF IPR rules under various equitable doctrines providing, essentially, that it would be unfair for her to participate without complying with the rules established for such activities. 

Wouldn't that agreement be codified through the contract that Mary created around her participating as a Vetter in the IETF?

   I'm not going to attempt to discuss these in detail here, but suffice it to say that these equitable doctrines ensure that corporations who send individual participants to IETF must themselves comply with the IETF rules to the extent applicable.

Which is even more insane since you have just said in no uncertain terms that these individuals can legally bind their sponsors into conduct. That is ludicrous - and I bet if you talk to people like John Chambers about how he feels about his Engineers being able to bind Cisco into conduct contracts with the IETF without corporate legal's being involved earns you a response I dont think you or the IETF will like.

In closing - I'll ask again - what rights does the IETF need to create and manage its Standards and why? What is it specifically going to do - Not what does it want to do, but what does the process of standardization really require here - will one of you folks please answer this. 

  Regards,
  Jorge

---

From: "todd glassey" <[email-masked]>
Date: Wed, 31 May 2006 11:12:00 -0700

Jorge - my apologies - this was all remarked and nullified by the email
service. My comments are not identified in the mix below so I have fixed
this by prefacing them with a TSG: in this repost.

Todd

----- Original Message ----- 
From: todd glassey
To: Contreras, Jorge ; [email-masked]
Cc: Harald Alvestrand ; Steven M. Bellovin
Sent: Wednesday, May 31, 2006 10:34 AM
Subject: Re: Status of IETF Policies and Rules

Counsel -  Thanks for responding. This is one of the best NON-ANSWERS I have
seen in a long time...  I believe that you managed to totally not-answer any
question I asked, and you did it in this amazingly legally-sounding manner
too - yow! Nice :-)

---

As to your response, Nice try. MARY and her work-product is the service the
IETF is pimping. MARY is a VETTER and not a SUBMITTER. Different Role,
Different set of contracts binding them to the IETF...

Technically this one statement blows the entire response out of the water
but you also say there is no assertion of act necessary to formally become a
member of the item and I say while generally that is true that there is an
act here which binds one to the IETF.

My claims is that the IETF is joined formally by enrolling as a
contractually-bound Engineering Design Review Resource in its Pay-for-Play
VETTING POOLS - the ones that require you as a SUBMITTER to put the IP into
the IETF to vet it in those Pools.

Next subject -

No Obligation to do anything - wrong... its a lottery seat - any Court would
rule so.
--------------------------------------------------------
Many on this list have said THE IETF HAS NO OBLIGATION TO PUBLISH
ANYTHING... which I dispute, but lets for the sake of argument say its
true... SO then what is the process of filing a draft for publication with
the IETF? it's a gamble that the IETF will publish it right? So then for the
consideration of the republication rights, you just bought the slot before
the IETF's Editors to make a decision as to whether they would publish you
or not...

This then is a lottery to participate. Its not a guarantee that you will be
successful - just that you get a chance to participate in submitting
material... So let me ask, how is this any different than a cellular lottery
held by the FCC?   Seriously do the analysis, I have, and where this winds
up is that if the IETF is not tied to the Submitter though the offer to
provide competent Engineering Services for IP rights, then it is through the
offer to participate in a Gamble, a Lottery with no defined set of
evaluation rules, to be able to get those same Engineering Services.

A transaction which oddly enough by comparison to the IETF's which cannot be
finally consummated as a winning ticket without the signing of any number of
documents - "no tickey - no washee".. this seems to me to be directly
orthogonal to the idea of licensing and using the IP the IETF produces... No
Signed Contract - No Conveyance of Title.

Either way - whether there is a contractual obligation to publish or there
is just the lottery - its still a trade of consideration for IP rights and
that makes this a contract... So Jorge - unless you can disprove this with
specific precedent or law then lets move past the contract issue.

More responses justifying the existence of the 'Contracts' inline below to
your response.

----- Original Message ----- 
From: Contreras, Jorge
To: [email-masked]
Cc: Harald Alvestrand ; Steven M. Bellovin
Sent: Wednesday, May 31, 2006 5:46 AM
Subject: Status of IETF Policies and Rules

I've been asked to discuss whether a "contract" exists between the IETF and
its participants and, if so, whether that contract is written and, if so,
whether it must be "signed".

As you know, unlike most other standards development organizations (SDOs),
IETF does not currently require its participants to sign a formal
"membership agreement".

TSG: Sorry Boss - Sure it does - this agreement under the contract is all
implied in the boiler plate that the "Click Through" to the WG Signup List
does. The act of joining the WG is what binds one to behave as defined under
the IETF's membership 'performance of duty' rules.

TSG: The membership rules that codify Mary's behavior as noted are what are
agreed to by the Click-Through Act of joining the WG - This is a CONTRACT
and it has a formal acceptance process as well.

This does not mean, however, that IETF lacks enforceable rules governing
participation in IETF activities.

IETF's rules and procedures are, by and large, published in RFC documents or
posted on the IETF web site.  IETF clearly notifies potential participants
that participation in IETF activities is subject to compliance with these
rules and procedures (see, e.g., the "Note Well" statement at
http://www.ietf.org/overview.html).  A similar notification is distributed
in hard copy to all registrants at IETF meetings and is published on various
IETF mailing lists.

TSG: So we agree that there is no issue with the IETF formally disclosing to
people that there are rules for participation and that the way for people to
agree to participate under these rules is to formally register in a Working
Group.

In other words, every IETF participant must "agree" to comply with the IETF
rules as a condition to participation in IETF activities.

TSG: In my best Miss Prissy Voice... "yeeeeeeeeeeeeuuuuuuuuuuuuuuss" -
(Dont know Miss Prissy - remember Foghorn Leghorn, he was the Rooster of
Bugs Bunny fame.)

This agreement is not manifested by a signature on a paper document, but by
the participant's conduct.

TSG: No actually I would disagree... that behavior is what demonstrates that
agreement to be bound in an ongoing manner. The click-through process of
signing-up for the WG is what is the signature on the contract,  the
agreement between the VETTER and the IETF.

Conduct is a perfectly valid means of establishing a contractual
relationship.

TSG: True - but its not necessary here. After signing up through the WG's a
failure to perform as such by the VETTER would constitute a breach of the
contract...

TSG: Again the basis of the agreement is codified initially in the WG
agreement as what is known as click-through. The question here is whether
Click-Through by itself is strong enough to cover the value of the IP
transferred to the IETF over the period of hat member's participation as a
VETTER (and I say no its not)...

To use an old law school chestnut:  John tells Mary that he will pay her
$100 if she paints his house.  The next day, Mary paints the house.  Is John
obligated to pay her $100?  The answer is "yes", at least under general
contract law principles that exist in the U.S. and other common law
jurisdictions.  In this example, the contract was an oral contract.

In the case of the IETF (which, for purposes of this discussion, I will
assume is an entity capable of contracting in its own name),

TSG: Which I disagree is the case BTW... very few participants in the IETF
relatively speaking have any release or knowledge from their General
Counsel's as to what they are up to. The GC's likewise have no idea what is
being vetting inside these WG's or how they work.

TSG: There is no oversight in 99% of the companies on this planet reviewing
what their engineers are doing with their IP...

the conversation would go as follows:  IETF will permit Mary to participate
in IETF activities

TSG: i.e. the IETF agrees to receive the value of Mary's Participation in
the IETF so that the IETF can remarket these services to the SPONSORS, in
the form of the Tenured Pools of Industry Professionals the IETF offers to
its Submitters as the Value Proposition. This is no different than a Big-4
consulting firms actions - except it happens entirely through the meetings
and the email service process.

if Mary agrees to comply with the IETF IPR rules published in BCP 78/79 and
elsewhere.  Mary begins to post technical input to an IETF mailing list.  Is
Mary obligated to comply with the IETF IPR rules?  Yes.

TSG:  Is this a contractual relationship - I SAY "YES IT IS"...

In this case, the rules that Mary must comply with are clearly written.  In
addition, the "contractual" terms binding Mary to comply with the rules are
also written (i.e., in the Note Well statement).  The only element that is
not written is Mary's assent to the agreement.  This is manifested by Mary's
conduct.  Thus, an enforceable, written agreement would exist between IETF
and Mary.

TSG: again I assert the Click-through is that agreement.

[Footnote:  Under a venerable doctrine called the "Statute of Frauds",
certain types of contracts had to be "in writing" to be enforceable.

TSG: See also the PAROLE EVIDENCE RULE which is used to qualify contracts as
well.

This Statute was developed centuries ago to prevent disagreements over the
terms of certain important transactions.  Contracts covered by the Statute
of Frauds include contracts not to be performed within one year or within
the lifetime of the promisor,

TSG: Both of which arguably define the IETF's submission process to a tee;

contracts to sell real estate, contracts to assume the debt of another, and
contracts for the sale of goods for more than $500.

TSG: So here again the valuation of the IP submitted and the proposition of
the value of the service of the vetting is what's on the table here. Under
the $500 rule though its not just the Sale of Goods >= $500  - but any
transfer of ownership greater than $500 which results in some consideration
being exchanged.

TSG: For instance how about an act of barter for instance like "the transfer
of sole copyright to some particular IP' which is a jointly owned
'derivative work' to the IETF for the chance to participate in the Lottery
that is the submission of new projects to the developmental chaos of a WG" ,
similar to the one that is going on here.

As the IETF IPR rules do not relate to any of these areas, the Statute of
Frauds would generally not be relevant to this discussion.

TSG: If there is a contract it is...

Other statutes that have been cited on the IPR WG list, such as the Uniform
Electronic Transactions Act, are equally inapplicable.  And in any case, as
discussed above, the agreement that the IETF requires its participants to
comply with *is* written.]

TSG: but not how they are to agree to it... that is a click-through
assertion.

In addition to this agreement, Mary would be obligated to comply with the
IETF IPR rules under various equitable doctrines providing, essentially,
that it would be unfair for her to participate without complying with the
rules established for such activities.

TSG: Wouldn't that agreement be codified through the contract that Mary
created around her participating as a Vetter in the IETF?

 I'm not going to attempt to discuss these in detail here, but suffice it to
say that these equitable doctrines ensure that corporations who send
individual participants to IETF must themselves comply with the IETF rules
to the extent applicable.

TSG: Which is even more insane since you have just said in no uncertain
terms that these individuals can legally bind their sponsors into conduct.
That is ludicrous - and I bet if you talk to people like John Chambers about
how he feels about his Engineers being able to bind Cisco into conduct
contracts with the IETF without corporate legal's being involved earns you a
response I dont think you or the IETF will like.

TSG: In closing - I'll ask again - what rights does the IETF need to create
and manage its Standards and why? What is it specifically going to do - Not
what does it want to do, but what does the process of standardization really
require here - will one of you folks please answer this.

Todd