Subject: RE: RFC Author Count and IPR

From: "Gray, Eric" <[email-masked]>
Date: Wed, 24 May 2006 14:48:08 -0400

Sam, et al,

	There are so many things tied up in this, that I am
afraid it is bound to turn into a rat-hole.

	For one thing, I thought Russ was talking about the
complication that arise from whether or not the BCP 78/79
stuff applies to people who made some contribution but are
not listed as "Authors".  I may have missed his point, but
this probably is an issue as there are other things in IPR
than "copyrights".

	For another, there is a clear distinction between
attribution and being listed as an author.  Most drafts I've
seen acknowledge the people making contributions.

	Also, RFCs are not (at least usually) a compilation of
related works by separate authors. An RFC typically requires
some unification and typically this is performed by one or 
more editors.  Because of churn-and-merge complexity, it is
usually the case that there is only one "editor" at any given
moment, and the list of "token holders" is both well defined
and small - consequently is is quite reasonable to ask that
a long list of authors be replaced by a shorter list of the
people who actually took turns as editors.

	I think the biggest issue is that the RFC Editor has
established guidelines that use a fixed number.  This can
lead to rather arbitrary decisions about who is an editor,
author or contributor.  Probably a better approach would be
to explicitly define what the RFC Editor means by the terms
contributor, author, editor and - perhaps - something even
more specific that that (e.g. - final editor?) and then
saying that some number of names MAY be listed on the first 
page and that the approach to determining what names should
be included is to pick the category that has no more than
that many in the list.

	I was pretty much under the impression that this is 
the informal approach used now. 

--
Eric

--> -----Original Message-----
--> From: Sam Hartman [mailto:[email-masked]] 
--> Sent: Wednesday, May 24, 2006 2:06 PM
--> To: Russ Housley
--> Cc: [email-masked]; [email-masked]; 
--> [email-masked]; [email-masked]
--> Subject: Re: RFC Author Count and IPR
--> 
--> >>>>> "Russ" == Russ Housley <[email-masked]> writes:
--> 
-->     Russ> I am concerned that the current RFC Editor practice that
-->     Russ> limits the number of authors is in conflict with the IETF
-->     Russ> IPR policies.  The RFC Editor currently limits the author
-->     Russ> count to five people.  Recent IPR WG discussions make it
-->     Russ> clear to me that authors retain significant copyright.
--> 
--> [There is this concept in US copyright law called a joint work.  I'm
--> ignoring that concept for the moment basically because I don't
--> understand how it applies to either software or text developed using
--> an open process.  As far as I can tell, no one else understands it
--> either.  Please be aware that this may be a huge gap in my advice.]
--> 
--> So, here we have a conflicting definitions problem.
--> 
--> The author of a work retains the copyright interest.  That's true if
--> if I'm listed as an author or not.
--> 
--> If I write text and do not assign the copyright to someone, I retain
--> copyright interest in that text.
--> 
--> So the sixth person still owns the copyright interest in 
--> the text they
--> write even if they are not listed.
--> 
--> That means if you have unlisted authors who have contributed
--> significant chunks of text, you still need to get their clearance to
--> do anything interesting with that text.
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
--> 

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 11:56:15 -0700 (PDT)

*> 
  *> I am concerned that the current RFC Editor practice that limits the 
  *> number of authors is in conflict with the IETF IPR policies.  The RFC 
  *> Editor currently limits the author count to five people.  Recent IPR 
  *> WG discussions make it clear to me that authors retain significant copyright.

Note that the number 5 is not magic here.  When the phenomenon of
balooning lists of authors (say, one or more from every telecom vendor
you ever heard of) was first noticed, there was a discussion on the
IETF list.  The community consensus was that author list inflation was
"un-IETF".  I don't recall the details (there may have been a last call
from the IESG, but I am not sure), but it was left to the RFC Editor to
formulate the precise guideline.  Five seemed like a reasonable limit.
Do you like 6 better?

We do tend to push back (via the WG chairs) a bit on more than 5
authors, since we knew that if there were many exceptions granted,
everyone would discover they needed an exception, defeating the purpose
of the limitation.  We have found that almost everyone affected by
the limit has understood the problem and been very cooperative in
keeping to it.

I do not recall the IPR issue raised before.

Bob Braden for the RFC Editor

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 24 May 2006 15:02:54 -0400

Henning,

	IRT BCP 78/79 IPR statements, it's actually worse than 
you indicate.

	The issue is that (because of the "Note Well") you can't
effectively "take back" a contribution and (because of the need
for proper attribution) you really cannot de-list someone who
has made any significant contribution to the document.

	Because of the wording in current IPR BCPs, however, any
"author" is not only agreeing to be responsible for IPR that
he (or she) may have in their contribution, but also any IPR
they may know of that relates to other contributions made in an
RFC for which they are a listed "author".

	One seriously detrimental effect of these considerations
is that this actively discourages an RFC "author" (and possibly
any other contributor) from trying to determine if his (or her)
employer actually has any IPR in the technology about which they
are writing - and, thus, encouraging a separation between those
who do things and those who write about it...

--
Eric

--> -----Original Message-----
--> From: Henning Schulzrinne [mailto:[email-masked]] 
--> Sent: Wednesday, May 24, 2006 2:43 PM
--> To: Vijay Devarapallli
--> Cc: [email-masked]; Sam Hartman; 
--> [email-masked]; [email-masked]; [email-masked]
--> Subject: Re: RFC Author Count and IPR
--> 
--> Authorship discussions have a long history in the sciences. I'm not 
--> aware of any other scientific or technical publication that 
--> limits the 
--> number of authors. (Indeed, I have had to extend the maximum author 
--> count on a largish conference management system I run 
--> [edas.info] a few 
--> times.) The current limit of 5 seems to be motivated by formatting 
--> constraints and maybe by the notion that "vanity" 
--> publishing should be 
--> prevented. It is not clear to me that these motivations have legal 
--> standing and essentially, for practical purposes, force 
--> authors to give 
--> up their rights. In the past, I know that for some drafts, 
--> this limit 
--> has been extended when the AD made the right noises to the 
--> RFC editor, 
--> so it is not universally observed.
--> 
--> My understanding is that "contributors" generally have 
--> inferior rights, 
--> not much different from those individuals acknowledged in the 
--> acknowledgment section of technical papers and RFCs.
--> 
--> After some of the recent science scandals, there also seems to be a 
--> movement afoot (e.g., for Science and Nature) to force all 
--> authors to 
--> take responsibility for the paper and its content. That's a 
--> flip-side, 
--> also from an IPR perspective: If somebody can plausibly 
--> claim that they 
--> just got added to the author list without their consent, they could 
--> weasle out of the IPR disclosure rules. At least from my 
--> experience, it 
--> is not uncommon that I-D authors add others as a courtesy and, 
--> currently, nobody seems to check whether these authors consented to 
--> being an author...
--> 
--> Henning
--> 
--> Vijay Devarapallli wrote:
--> > On 5/24/06, Sam Hartman <[email-masked]> wrote:
--> > 
--> >> That means if you have unlisted authors who have contributed
--> >> significant chunks of text, you still need to get their 
--> clearance to
--> >> do anything interesting with that text.
--> > 
--> > typically the unlisted authors are ignored.
--> > 
--> > also during the AUTH48 period, the RFC Editor contacts 
--> only the listed 
--> > authors.
--> > 
--> > Vijay
--> > 
--> > 
--> > 
--> ------------------------------------------------------------
--> ------------
--> > 
--> > _______________________________________________
--> > Ietf mailing list
--> > [email-masked]
--> > https://www1.ietf.org/mailman/listinfo/ietf
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: Andy Bierman <[email-masked]>
Date: Wed, 24 May 2006 12:03:54 -0700

David Harrington wrote:
> If I remember correctly, we only limit the number of suthors on the
> first page of the document. 
> 
> It is perfectly acceptable to list a longer set of names inside the
> document in an contributors section.

It's not just the first page.
It also affects the reference citation used in
the RFC Index and all other RFCs.

I believe the 5 author rule was used as justification to remove
most of the original SNMPv2 authors from the author list and all
further reference citations, when the RFC 1901-1909 series was
advanced.  I don't really understand what purpose this serves.

> 
> I also have concerns about who should be listed as an "author" and
> have copyrights when a work is developed by a WG. The demand to do
> things with IETF documents beyond IETF standards work seems to be
> growing, so it will be an increasingly difficult problem if we do not
> identify all the people who contributed significant portions of a
> document (where significant is of course open to debate).

There is a problem with companies piling on the authors
for I-D proposals to make it look like lots of people
worked really hard on it and all agree on the contents.
(This is hardly ever the case.)

Then when you go to WG draft, there are already 5 or 7 names
as authors, and the WG wants to add more.  I think then, you
have to pick a real Editor (responsible for all edits all
the way through AUTH48) and just list that person as Editor
on the first page and citations, and put everybody in
the Authors section in the back.

IMO, this is different than removing the author(s) of a previous
version of an RFC.  I object to that practice.

> dbh

Andy

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 12:16:50 -0700 (PDT)

In case anyone is unsure, the actual policy being followed by
the RFC Editor will be found at:

   http://www.rfc-editor.org/policy.html#policy.authlist

---

From: "John Loughney" <[email-masked]>
Date: Wed, 24 May 2006 22:42:19 +0300

Andy,

For what it's worth, I agree with you. Having a single editor simplifies many things, but having a authors list allows full credit to all parties.

John 

- original message -
Subject:	Re: RFC Author Count and IPR
From:	Andy Bierman <[email-masked]>
Date:		05/24/2006 7:19 pm

Andy

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 13:22:44 -0700 (PDT)

Lucy Lynch wrote:

  *> a little history:
  *> 
  *> 28 authors!
  *> http://www.arkko.com/tools/rfcstats/authdistr.html
  *> 
  *> 20 authors!
  *> http://www.arkko.com/tools/stats/authdistr.html
  *> 
  *> Bob -
  *> 
  *> I think the 5 author rule applies to the listing in the ID/RFC header 
  *> and not to the authors listed under "Author Information" - is that 
  *> correct?
  *> 
  *> - lel
  *> 

Lucy,

Please see the URL I posted earlier; the policy was carefully crafted.

I would avoid calling it a "rule".  We think of it as a guideline, a
threshold below which no discussion is necessary.

Bob Braden

  *> > Bob Braden for the RFC Editor
  *> >
  *> >
  *> >
  *> > _______________________________________________
  *> > Ietf mailing list
  *> > [email-masked]
  *> > https://www1.ietf.org/mailman/listinfo/ietf
  *> >
  *> 
  *> -- 
  *> Lucy E. Lynch 				Academic User Services
  *> Computing Center			University of Oregon
  *> llynch  @darkwing.uoregon.edu		(541) 346-1774
  *>

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 13:34:34 -0700 (PDT)

*> Bob -
  *> 

Lucy,

I neglected to answer your question directly.  The authors are, by
definition, the people listed on the first page.

There is no such section as "Author Information"; probably you mean
"Authors' Addresses".  The rules are spelled out in RFC2223bis, section
2.12.  At present Authors' Addreses section lists only authors, i.e.,
those listed on the first page.  The rules say that a Contributors
section can list additional contact information.

Bob Braden

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 13:59:03 -0700 (PDT)

*> 
  *> Bob -
  *> 
  *> Following Jari's link to the document (ID) with 20 authors I found:
  *> 
  *> http://www.ietf.org/internet-drafts/draft-ietf-pwe3-dynamic-ms-pw-00.txt
  *> 
  *> which lists 3 editors on the front page and includes a section (17)
  *> titled "Author Information" which includes 20 addresses.

Lucy,

You are suggesting that the definition of "author" is determined by some
tool that produces the pretty graph.  I don't think so.  In all
documentation related to the RFC Editor, an author is a person listed
on the first page.  I cannot explain what was in the mind of the
person writing the tool.

Bob Braden

---

From: Bob Braden <[email-masked]>
Date: Wed, 24 May 2006 14:42:48 -0700 (PDT)

*> 
  *> Let me try re-stating my question. Is there a one-to-one relationship 
  *> between the listed authors on an IETF document and ownership of the
  *> given document's Intellectual Property?
  *> 
  *> - lel
  *> 
  *> 

Lucy,

It sounds like you need a lawyer.

Bob Braden

---

From: Bob Braden <[email-masked]>
Date: Thu, 25 May 2006 09:35:41 -0700 (PDT)

Todd Glassey wrote:

  *> 
  *> This is a very bad thing, since each of those authors has legal control over
  *> their portions of the work or derivatives of their contribution within the
  *> work itself. I.e. they are all legal signatories to any conveyance of
  *> copyrights or derivative use rights including implementaiton rights.
  *> 

This is all very puzzling.  Suppose that document editor X in a WG
receives a paragraph that has been crafted by another WG member Y.
Also, suppose that in fitting the paragraph into the document, X
changes the text a bit (or a lot).  Now, does Y retain "legal
control" (presumably you mean copyright) over the paragraph as
it finally appears in the finished document?

Bob Braden