Subject: outbound-rights-01

From: Frank Ellermann <[email-masked]>
Date: Sun, 26 Nov 2006 13:33:08 +0100

Hi, I can't parse the following convoluted statement:

| The IASA is therefore responsible for defining the rights to
| copy granted by the IETF to people who wish to make use of
| the material in these documents.

Is it possible to replace "rights to copy" by "copyrights"
everywhere in the text, or is "copyrights" bad English ?
With legalese I never know what it's exactly about, apart from
its ubiquitious "you lose" aspects.

| As early implementations of make use of descriptions
| in internet-drafts, similar desires apply to internet-drafts.

Is that s/of make use/also make use/ ?  There are several
typos and similar editorial nits in -01, I skip those for now.

| In principle, different grants of rights to copy can be
| granted to individuals based on the purpose or use being
| made, and the particular material being copied.

"Different grants can be granted" sounds like gibberish for me,
how about "different copyrights can be granted" ?

Section 5.2 has a SHOULD, the remark about deleting section 2
and the 2119-reference if it's unnecessary could be removed (?)

That SHOULD apparently covers "by attribution" in CC licenses.

| As such, the rough consensus is that code components of IETF
| contributions can be extracted, modified, and used by anyone
| in any way desired.

My consent doesn't necessarily cover "in any way desired", can
we strip that ?  For a "CC share alike" they've to share their
modification somehow, if it's a relevant modification.

Frank

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 26 Nov 2006 22:59:57 +0100

> its ubiquitious "you lose" aspects.

Answered without benefit of being a lawyer:
"copyright" is a legal term. At any given time, only one entity (person, 
company, organization) can hold "the copyright" for any given piece of text.

At any time, many entities can have permission to copy - for instance, by 
holding a license.
So I would definitely not want to use the term "copyright", but using the 
term "permission to copy" rather than "right" may make more sense. Can't 
say without going over the individual occurences.

> typos and similar editorial nits in -01, I skip those for now.

I think it should be "early implementations of IETF specifications". YMMV.
> how about "different copyrights can be granted" ?

"different permissions" is probably better.
> modification somehow, if it's a relevant modification.

That's one of the cases I think we've considered and rejected - one 
specific example of an attempted restriction that some people will find 
acceptable and others will find objectionable.

Other restrictions considered and rejected are "for use only in conformant 
implementations", "for use only in implementations of IETF protocols". Just 
to have those mentioned.

                 harald

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 27 Nov 2006 00:01:22 +0100

Harald Alvestrand wrote:

> I would definitely not want to use the term "copyright", but using the
> term "permission to copy" rather than "right" may make more sense.

Sounds good...

> Can't say without going over the individual occurences.

...one "copyright", one "copying rights", the rest is "rights to copy".
Some "rights to copy" in places where it's apparently about the right
to implement / port example code.

>>| in internet-drafts, similar desires apply to internet-drafts.
[...]
> I think it should be "early implementations of IETF specifications"

Yes, better than my guess.

> "different permissions" is probably better.

+1

 
> That's one of the cases I think we've considered and rejected -
> one specific example of an attempted restriction that some people
> will find acceptable and others will find objectionable.

Of course readers MUST be free to port code to their favourite O/S
or programming language, and for that they may need to modify the
code.  

But if they modify it substantially, e.g. invent MD6 with another
round, then they've IMO crossed the line.  As far as that's their
free and public contribution, to the IETF or elsewhere, it's still
acceptable.  But if they just grab it, modify it, maybe patent it, 
and finally sell it, it's not okay.  

If authors can't say so in their IETF contributions we might need
a new document series for CC-BY-SA example code published outside
of the outbound-rights-01 area, maybe independent submissions (?)

"The ABNF is published in a separate independent I-D (some rights
 reserved)".  Maybe post the dubious paragraph on the general list,
better don't waste time with it if it won't survive a Last Call.

"In any way desired" is too much, it's unnecesary for the stated
purpose (= the rest of section 5.3).

Frank

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 Nov 2006 22:39:26 -0500

--On Monday, 27 November, 2006 00:01 +0100 Frank Ellermann
<[email-masked]> wrote:

>...
> But if they modify it substantially, e.g. invent MD6 with
> another round, then they've IMO crossed the line.  As far as
> that's their free and public contribution, to the IETF or
> elsewhere, it's still acceptable.  But if they just grab it,
> modify it, maybe patent it,  and finally sell it, it's not
> okay.  
> 
> If authors can't say so in their IETF contributions we might
> need a new document series for CC-BY-SA example code published
> outside of the outbound-rights-01 area, maybe independent
> submissions (?)
> 
> "The ABNF is published in a separate independent I-D (some
> rights  reserved)".  Maybe post the dubious paragraph on the
> general list, better don't waste time with it if it won't
> survive a Last Call.
> 
> "In any way desired" is too much, it's unnecesary for the
> stated purpose (= the rest of section 5.3).

FWIW, +1
    john

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 27 Nov 2006 08:27:39 +0100

>> stated purpose (= the rest of section 5.3).

I despaired of finding any statement that would allow all the things we 
think need allowing (wide implementation of IETF standards, and inclusion 
of implementations based on IETF standards in all sorts of products, 
including GPL and commercial product) and still imposing some restriction.

But I may have despaired too early.

Send text.

                    Harald

---

From: "Contreras, Jorge" <[email-masked]>
Date: Mon, 27 Nov 2006 08:12:31 -0500

> At any given time, only one 
> entity (person, 

Not true.  Copyright may be jointly held by any number of 
entities/people.

However, the term "copyright", which does refer to legal
right, should definitely NOT be used when referring to the
right to make a copy.