Subject: Re: #1511: Incoming 5.10: Back-license to document authors in resulting RFCs

From: Harald Alvestrand <[email-masked]>
Date: Wed, 07 Nov 2007 14:48:13 +0100

[email-masked] wrote:
> One possibility might that after the following:
>
>   The IETF Trust is further requested to ensure that in all matters
>   pertaining to contributors' rights, the RFC Editor acts only as
>   an agent of the contributors and of the IETF.
>
> add this text:
>
>   ; the IETF Trust is requested to ensure that it does not act
>   as an owner of RFCs and their content independent of the
>   contributors and the IETF.
>
>   
(trying to find resolution on #1511 in the presence of other topics)
I would not want to add this. It is too unclear to me what it means - 
the terms "act as an
owner" and "independent of" both beg for further expansion.

We have already written in oh-so-many places that the Trust acts for the 
good of the IETF.

              Harald

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "TS Glassey" <[email-masked]>
Date: Wed, 7 Nov 2007 06:24:02 -0800

no No NO... ALL of the WIGGLE ROOM MUST be removed from these process 
defitions otherwise the processes are subject to noise and will be 
uneffective based on the interpretation of the idiot who doesnt want to play 
by the rules.

The net-net is that the IETF is not chartered to, no does it own any rights 
beyond those conveyed to it by the actual IP Owers and it must verify that 
to actually convey the proper ownership of those IP's.

Todd Glassey

----- Original Message ----- 
From: "Harald Alvestrand" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, November 07, 2007 5:48 AM
Subject: Re: #1511: Incoming 5.10: Back-license to document authors in 
resulting RFCs

> I would not want to add this. It is too unclear to me what it means - the 
> terms "act as an

---

From: [email-masked]
Date: Wed, 7 Nov 2007 10:08:06 -0500

Harald,

My original concern behind the suggested text was:

>> The resulting language should also explicitly state what the Trust is
>> not supposed to do - anything important that is being implied here
>> ought to be explicitly stated ... because it won't be obvious to all
>> other readers of the document.

> >   an agent of the contributors and of the IETF.

appears to me to be motivated by wanting to have the IETF trust *not*
do certain things that are obvious to people like you and Brian, but
may not be obvious to all others.  In essence, I'm suggesting that
the document contain the answer to 'Why is the "further requested"
language present?'.  A specific example or two of undesired behavior
might get the point across if the general text I wrote doesn't seem
to do the job.  OTOH, if there's nothing important being implied here
(is that the case?) then either this language ought to be deleted
or it ought to characterize itself as restating that principle to
be found on "oh-so-many places". 

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: Harald Alvestrand [mailto:[email-masked]] 
> Sent: Wednesday, November 07, 2007 8:48 AM
> To: Black, David
> Cc: [email-masked]; [email-masked]
> Subject: Re: #1511: Incoming 5.10: Back-license to document 
> authors in resulting RFCs
>

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 08 Nov 2007 08:14:04 +0100

> be found on "oh-so-many places". 
My worry is that this language would take a lot of time tweaking until 
it says just what the IETF Trust does what it is supposed to do.

For instance: One of the things the Trust is supposed to be able to do 
is to sublicense another organization to make derived works from an IETF 
standards-track document (for instance, when ceding change control to a 
specification to the IEEE, as we've recently done).

The language-as-suggested about what the Trust should do:

would seem to open the door for a contributor (listed in a Contributors 
section) popping up and saying "You did not consult me beforehand, 
therefore the Trust is not obeying the rules".

If you suggest that we should take out the "further requested" that 
pertains to the RFC Editor too, I'm sympathetic to that. It's another 
"state it again because we're not sure you heard us the first time"; any 
regulation of the RFC Editor should be in the contracts for the RFC 
Editor function, not in the IETF's IPR documents.

BTW - this language needs lawyer review too. We're diving into the 
mistake of having a community editing session on the mailing list.

                      Harald

---

From: "TS Glassey" <[email-masked]>
Date: Thu, 8 Nov 2007 07:05:27 -0800

Harald - typical Logic Flaw...

> My worry is that this language would take a lot of time tweaking until it 
> says just what the IETF Trust does what it is supposed to do.
>
> For instance: One of the things the Trust is supposed to be able to do is 
> to sublicense another organization to make derived works from an IETF 

Then the TRUST cannot own those rights - but hey, since documents are 
licensed on a Any and All use basis this is already covered. The problem is 
that ANYONE and not just the Trust could do this. And in fact there is NO 
REASON to pay or seek licenses from the TRUST for anything with an ANY and 
ALL USES license.

> regulation of the RFC Editor should be in the contracts for the RFC Editor 
> function, not in the IETF's IPR documents.
>
> BTW - this language needs lawyer review too. We're diving into the mistake 
> of having a community editing session on the mailing list.

No Harald you are diving into the Realm of Armchair Legal Work and as a 
typical techie you refuse to do what Lawyers do and that is to compose their 
case prior to exposing it to the other side.

---

From: "Walls, Endre" <[email-masked]>
Date: Thu, 8 Nov 2007 10:20:45 -0500

I'm just wondering if it's possible for any of you guys to have a
discussion about this stuff without the personal attacks and unnecessary
rhetoric. This isn't congress...it's an IETF working group. 

We probably have a lot of people who would like to contribute on this
list, but don't for fear of getting involved in the constant posturing
and in-fighting. I for one, have lost track of what we're even talking
about anymore.

Endre Walls
-----Original Message-----
From: TS Glassey [mailto:[email-masked]] 
Sent: Thursday, November 08, 2007 10:05 AM
To: Harald Alvestrand; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Logic Flaw - Re: #1511: Incoming 5.10: Back-license to
documentauthors in resulting RFCs

> My worry is that this language would take a lot of time tweaking until
it 
> For instance: One of the things the Trust is supposed to be able to do
is 

Then the TRUST cannot own those rights - but hey, since documents are 
licensed on a Any and All use basis this is already covered. The problem
is 
that ANYONE and not just the Trust could do this. And in fact there is
NO 
REASON to pay or seek licenses from the TRUST for anything with an ANY
and 
ALL USES license.

> regulation of the RFC Editor should be in the contracts for the RFC
Editor 
> BTW - this language needs lawyer review too. We're diving into the
mistake 

No Harald you are diving into the Realm of Armchair Legal Work and as a 
typical techie you refuse to do what Lawyers do and that is to compose
their 
case prior to exposing it to the other side.

This electronic message transmission contains information from the Company that may be proprietary, confidential and/or privileged. 
The information is intended only for the use of the individual(s) or entity named above.  If you are not the intended recipient, be 
aware that any disclosure, copying or distribution or use of the contents of this information is prohibited.  If you have received 
this electronic transmission in error, please notify the sender immediately by replying to the address listed in the "From:" field.

---

From: John C Klensin <[email-masked]>
Date: Thu, 08 Nov 2007 12:29:58 -0500

--On Thursday, 08 November, 2007 10:20 -0500 "Walls, Endre"
<[email-masked]> wrote:

> I'm just wondering if it's possible for any of you guys to
> have a discussion about this stuff without the personal
> attacks and unnecessary rhetoric. This isn't congress...it's
> an IETF working group. 
> 
> We probably have a lot of people who would like to contribute
> on this list, but don't for fear of getting involved in the
> constant posturing and in-fighting. I for one, have lost track
> of what we're even talking about anymore.

Me too.  And I was one of the people who pointed out, early on,
that, without what has become #1511, the effect of the WG's
evolving model would be to considerably reduce the rights of
authors relative to what they had (or had been assumed to have)
for the last 37 or so years.  I still believe that, but the
noise level makes it easier to concentrate on other work and
ignore this WG's lists until Last Call.

     john

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 09 Nov 2007 09:55:12 +1300

> therefore the Trust is not obeying the rules".

I agree. I think that this language would expose the Trust without
adding anything to the Trust's basic charge to operate for
the benefit of the IETF.

> Editor function, not in the IETF's IPR documents.

I suggested this text because concern was expressed that otherwise
there might be some erosion of the historical understanding of
the RFC Editor's role as an agent. I agree that the very existence
of a contract between IASA and the RFC Editor makes it pretty
clear that it's an agent. I'd have no problem if the text is not
included.

> mistake of having a community editing session on the mailing list.

Of course. I assume IANAL applies to most messages on this list.

     Brian

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 09 Nov 2007 09:38:23 +0100

Based on the recent spate of postings that do not bear relevance to the 
documents at hand, I have suspended the posting rights of T. S. Glassey 
to the IPR mailing list for a period of 2 weeks, from November 9, 2007 
to November 23, 2007.

                    Harald Alvestrand

TS Glassey wrote:
> uneffective based on the interpretation of the idiot who doesnt want 
> to play by the rules.
>
> The net-net is that the IETF is not chartered to, no does it own any 
> rights beyond those conveyed to it by the actual IP Owers and it must 
> verify that to actually convey the proper ownership of those IP's.
>
> Todd Glassey
>
> ----- Original Message ----- From: "Harald Alvestrand" 
> <[email-masked]>
>> We have already written in oh-so-many places that the Trust acts for 
>> the good of the IETF.
>>
>>              Harald
>>
>>

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 09 Nov 2007 09:57:50 +0100

After looking over the discussion, I propose that section 5.10 be 
replaced with an abbreviated version of Brian's proposal:

>
> 5.10. Contributors retention of rights
>
> Although contributors provide specific rights to the IETF, it
> is not intended that this should deprive them of any rights
> in their contributions. To underwrite this principle, the
> IETF Trust is requested to issue a form of license to contributors
> which ensures that they may each make use of their contributed
> material as published in an RFC in any way they wish, subject only
> to the restriction that no contributor has the right to represent
> any document as an RFC, or equivalent to an RFC, if it is not a
> full and complete copy or translation of the published RFC.

Scott, can you prepare a version -03 of draft-ietf-ipr-3978-incoming 
with this language in it, and publish it?

Once that's published, I'll send out a WG Last Call on this document; 
the WG Last Call will also admit the possibility of raising issues with 
draft-ietf-ipr-outbound-rights-04, if the participants' review of 
-incoming and -outbound together reveal issues that are best addressed 
in -outbound.

Once the Last Call is over and issues resolved, we can send these 
documents to the IESG.

                  Harald

---

From: John C Klensin <[email-masked]>
Date: Sat, 10 Nov 2007 07:50:24 -0500

--On Friday, 09 November, 2007 09:57 +0100 Harald Alvestrand
<[email-masked]> wrote:

> After looking over the discussion, I propose that section 5.10
> be replaced with an abbreviated version of Brian's proposal:
> 
>> 
>> IETF Trust is requested to issue a form of license to
>> contributors which ensures that they may each make use of
>> their contributed material as published in an RFC in any way
>> they wish, subject only to the restriction that no
>> contributor has the right to represent any document as an
>> RFC, or equivalent to an RFC, if it is not a full and
>> complete copy or translation of the published RFC.
> 
> Scott, can you prepare a version -03 of
> draft-ietf-ipr-3978-incoming with this language in it, and
> publish it?
>...
 
Harald,

While I can probably live with this, I note that it is still a
significant change from the situation the authors were presumed
to be in prior to recent tampering.  In the original model, the
authors had those rights intrinsically because:

	(i) The RFC Editor was acting as an agent/collaborator
	of the author(s), so that the authors had rights to the
	final edited version of the contribution (this part is
	covered adequately by your version of Brian's text as
	above).
	
	(ii) Since the author gave the RFC Editor and IETF only
	those rights needed to permit reproduction, use in the
	standards process, and use in implementing the
	standards, the rights covered above were intrinsic: no
	license back from the IETF was needed because the author
	never gave those rights to the IETF.

The difference between that situation and the proposed text is
that the proposed text involves a _request_ for a license back
from the IETF Trust to the author. In principle, the IETF Trust
can ignore or reject that request, or they or the IETF can
change their minds later.  Debates about how unlikely that is
are not relevant, only the fact that the structuring of the
arrangement makes that possible.

To preserve the status quo ante, the authors would need to
reserve those rights as a condition of letting the IETF post,
and the RFC Editor to edit and publish, the document and the
IETF [Trust] would need to accept the document with that
reservation.   As far as I can tell, that is the only
arrangement that doesn't leave this particular bit of author
rights subject, in principle, to the whim of future Trustees
and/or WGs.

As I said, I can live with this way of doing it, but the WG and
community should understand the nature of the change and its
implications.

        john

---

From: "John Calhoon (LCA)" <[email-masked]>
Date: Mon, 12 Nov 2007 09:47:55 -0800

IANAL, but after confering with internal counsel I'd like to offer the following simplification:

"While contributors provide certain copyright license rights to the IETF, contributors retain all ownership and use rights in their contributions.  The IETF Trust is instructed to grant no copyright licenses to users of IETF documents that infringe the copyrights of contributors in any way."

My internal counsel believes suggesting that contributors need a license from anyone to use their works, whether in original or derivative form, would actually call the contributor's rights into question rather than clarifying them

John Calhoon

-----Original Message-----
From: Harald Alvestrand [mailto:[email-masked]]
Sent: Friday, November 09, 2007 12:58 AM
To: Brian E Carpenter
Cc: [email-masked]
Subject: #1511: Proposed resolution of Incoming 5.10: Back-license to document authors in resulting RFCs

                  Harald

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Nov 2007 07:33:12 +1300

John,

That part is well understood. The point here is not the original
contributions, but the collective work that the IETF creates
based on the original contributions.

     Brian

On 2007-11-13 06:47, John Calhoon (LCA) wrote:
> ------------------------------------------------------------------------
>

---

From: "John Calhoon (LCA)" <[email-masked]>
Date: Mon, 12 Nov 2007 10:42:46 -0800

Thanks Brian,

Usual IANAL disclaimer

My internal counsel believes the statement I offered covers the contributors rights in the collective work in alignment with current (U.S.) copyright practice.

John Calhoon

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]]
Sent: Monday, November 12, 2007 10:33 AM
To: John Calhoon (LCA)
Cc: IPR WG
Subject: Re: #1511: Proposed resolution of Incoming 5.10: Back-license to document authors in resulting RFCs

John,

     Brian

---

From: John C Klensin <[email-masked]>
Date: Mon, 12 Nov 2007 14:02:44 -0500

--On Monday, 12 November, 2007 10:42 -0800 "John Calhoon (LCA)"
<[email-masked]> wrote:

> Thanks Brian,
> 
> Usual IANAL disclaimer
> 
> My internal counsel believes the statement I offered covers
> the contributors rights in the collective work in alignment
> with current (U.S.) copyright practice.

John,

I don't have any reason to doubt your internal counsel's
opinion, but you are ( both?) missing the point.   The point is
that, if we go through the following sequence:

	(1) some text is contributed by the original author, 
	
	(ii) it is edited by the RFC Editor in some sort of
	greater or lesser degree of collaboration with the
	author,
	
	(iii) the author gives final approval to publication of
	the edited document.  Note that, while there are some
	procedures if the author refused to cooperate, our
	normal procedure is that the final approval decision to
	publish a document rests with the author, not the IESG
	or RFC Editor.

Now, under current US Copyright practice, the author clearly
retains rights to the contribution in (i).  The long-standing
IETF position, and the one that Brian and I (and others) are
trying to preserve, is that the authors retains rights to the
edited version of the original contribution as it emerges from
(iii)... and retains those rights on the same basis as if the
contributed version and edited version are identical (as they
will be, sometimes).

     john

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 12 Nov 2007 20:52:18 +0100

> My internal counsel believes suggesting that contributors need a license from anyone to use their works, whether in original or derivative form, would actually call the contributor's rights into qu…
that's the first time I've heard of a theory that says that if nothing
else is said, a contributor has automatic rights to use whatever works
can be defined as derivative works from his original contribution - but
that's what your words seem to say (IANAL, of course).

Can you double-check with your counsel that this is indeed what he/she
intended to say?

If this is true, the language can indeed be simplified.

                    Harald

---

From: [email-masked]
Date: Mon, 12 Nov 2007 23:29:44 -0500

John,

While your internal counsel is almost certainly correct as far as
his/her statement goes, there appear to be two cases that are
not covered:
(A) Whether each author need to receive "full" rights to the published
	RFC, as opposed to the "joint" rights.  This is primarily a
	question to John Klensin about what's needed for the academic
	institutions that he's expressed concern about - I've
interpreted
	what he's written as requiring "full" rights to be returned to
	each author to get the multi-institution case right (as opposed
	to "joint" rights that each author can reserve), and would be
	quite happy to be wrong about this.
(B) The "derived works" case in which one or more authors revise
	an RFC that they did not originally write.  In this situation,
	publication of the revised RFC relies on the IETF's copyright
	in the original RFC, and absent some license to IETF's rights
	in the original RFC, the author or authors have rights *only*
	to their revisions, and not the resulting RFC.

Thanks,
--David

> From: John Calhoon (LCA) [mailto:[email-masked]] 
> Sent: Monday, November 12, 2007 1:43 PM
> To: Brian E Carpenter
> Cc: IPR WG
> Subject: RE: #1511: Proposed resolution of Incoming 5.10: 
> Back-license to document authors in resulting RFCs
> 
> Thanks Brian,
> 
> Usual IANAL disclaimer
> 
> Subject: Re: #1511: Proposed resolution of Incoming 5.10: 
> Back-license to document authors in resulting RFCs
> 
> John,
> 
> > "While contributors provide certain copyright license 
> rights to the IETF, contributors retain all ownership and use 
> rights in their contributions.  The IETF Trust is instructed 
> to grant no copyright licenses to users of IETF documents 
> that infringe the copyrights of contributors in any way."
> >
> > My internal counsel believes suggesting that contributors 
> need a license from anyone to use their works, whether in 
> original or derivative form, would actually call the 
> contributor's rights into question rather than clarifying them
> >
> > John Calhoon
> >
> > Subject: #1511: Proposed resolution of Incoming 5.10: 
> Back-license to document authors in resulting RFCs
> >

---

From: John C Klensin <[email-masked]>
Date: Tue, 13 Nov 2007 05:10:17 -0500

--On Monday, 12 November, 2007 23:29 -0500 [email-masked]
wrote:

> John,
> 
> While your internal counsel is almost certainly correct as far
> as his/her statement goes, there appear to be two cases that
> are not covered:

> (A) Whether each author need to receive "full" rights to the
> published 	RFC, as opposed to the "joint" rights.  This is
> primarily a 	question to John Klensin about what's needed for
> the academic 	institutions that he's expressed concern about -
> I've interpreted
> 	each author to get the multi-institution case right (as
> opposed 	to "joint" rights that each author can reserve), and
> would be 	quite happy to be wrong about this.

As far as the academic institutions are concerned, I frankly
don't know without checking and am out of the US and pressed for
time at the moment.  Perhaps someone with an appropriate
appointment and access to institutional lawyers who have been
active in that movement could check, or I'll get back to it at
the end of the week.

But the IETF tradition and long term assumption, at least as
I've understood it since Jon took over the RFC series, has
definitely been full rights.

> (B) The "derived works" case in which one or more authors
> revise 	an RFC that they did not originally write.  In this
> situation, 	publication of the revised RFC relies on the
> IETF's copyright 	in the original RFC, and absent some license
> to IETF's rights 	in the original RFC, the author or authors
> have rights *only* 	to their revisions, and not the resulting
> RFC.

Yes.  I have an opinion about that, based again on historical
assumptions, but it is clearly a more complex case if the old
authors are not actively part of the author team for the
revision.  The latter is more often the case than not in IETF
practice.  If the old authors are listed, and the "full"
provision in (A) applies, then this is a non-issue.

    john