Subject: On lurking

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Jan 2013 08:17:20 +0000

I think that there are at least four situations that might
need to be distinguished:

1. A person is sitting at the back doing email and ignoring the
meeting. A draft is discussed that includes a method that they or
a close colleague have written up for patenting. The person
doesn't notice this.

2. A person is interested in a topic but not actively contributing,
so they sit in a WG meeting, paying attention but not speaking.
They hear that a draft includes a method that they or a close
colleague have written up for patenting.

3. A person attends the IETF specifically to listen for new methods
that their company has patented, but never speaks.

4. A person attends the IETF specifically to listen for new methods
that their company can subsequently patent, but never speaks.

(#2, #3 and #4 have email or remote participation analogues, of course.)

Do we want our definition of "participate" to cover none, some,
or all of these cases?

Regards
   Brian

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 22 Jan 2013 09:35:25 +0000

Hi Brian,
A useful categorization.  Inline.
Stephan

>a close colleague have written up for patenting. The person

I do NOT want to see this covered.

>colleague have written up for patenting.

I do NOT want to see this covered.

>that their company has patented, but never speaks.

I would prefer that this person has a disclosure obligation, but do not
know how to distinguish it from point 2.  In the interest of openness and
wide participation, I would err on the side of no disclosure obligation.
For that reason, I would NOT want to see this covered.

>that their company can subsequently patent, but never speaks.

Ah, the speculative filing thing again.  For reasons of fairness, I want
to see this covered.  However, I do not see a way how to codify a
disclosure obligation for such a person beyond the sledgehammer method
currently in the draft, or worse.  The method of the draft has too many
bad side effects to be palatable.  Worse would be, for example, to go to a
membership model... no further commenting needed, I guess.  My view is
that the problem may be existing in practice, but is small compared to
other IPR related problems we have.  If we can find a solution to deal
with this problem without excessive negative side effects, I would support
it.

Overall, I continue to believe that "participation" ought to be defined as
"influencing the decision making process", for reasons of practicality.
An additional disclosure obligation for point 4 is desirable, but tricky
to codify.

>_______________________________________________
>Ipr-wg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ipr-wg
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 22 Jan 2013 05:36:20 -0500

--On Tuesday, January 22, 2013 08:17 +0000 Brian E Carpenter
<[email-masked]> wrote:

> meeting. A draft is discussed that includes a method that they
> or a close colleague have written up for patenting. The person
> doesn't notice this.
> 
> 2. A person is interested in a topic but not actively
> contributing, so they sit in a WG meeting, paying attention
> but not speaking. They hear that a draft includes a method
> that they or a close colleague have written up for patenting.
> 
> 3. A person attends the IETF specifically to listen for new
> methods that their company has patented, but never speaks.
> 
> 4. A person attends the IETF specifically to listen for new
> methods that their company can subsequently patent, but never
> speaks.
>...

Brian,

I think this list is very interesting.  It seems to me that it
is also useless because one cannot tell by observing which is
going on but have to rely completely on the person's post-hoc
assertions.  Excluding any of these from disclosure requirements
is equivalent to "disclose only if you feel like it unless you
actually speak up" (and probably "speak up on-topic").

It seems to me that a different distinction may be useful:

(1) We care whether or not someone discloses only if the try to
influence the standard this is produced.  "Influence" could
include posting drafts, speaking up in meetings or jabber,
posting on mailing lists, or sitting in a meeting and either
humming or making funny or obscene gestures when particular
ideas are presented.

(2) We care, not only about the above, but about those who are
trying to mine IETF work so that they can file their own patents
on it.  In the most extreme cases, they have access to mailing
list archives, I-Ds, and meeting minutes and audio without
having to identify themselves.

Once we decide which of those we care about, we get to questions
of practicality, including what behaviors are observable without
compromises other principles we think are important, for any
actual rules we want to create.  (A guideline that essentially
says "if you are privy to IETF information, you must disclose"
is easy but unenforceable.)

    john

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Jan 2013 10:47:49 +0000

On 22/01/2013 10:36, John C Klensin wrote:
> assertions.  

Exactly right. We can't write a rule that objectively distinguishes
these cases, yet we would probably only consider some of them as
unethical.

> Excluding any of these from disclosure requirements

Personally I care about both, but I still don't know how to
write a rule that catches (2) without also catching well-intentioned
observers.

   Brian

---

From: John C Klensin <[email-masked]>
Date: Tue, 22 Jan 2013 06:53:43 -0500

--On Tuesday, January 22, 2013 10:47 +0000 Brian E Carpenter
<[email-masked]> wrote:

>> trying to mine IETF work so that they can file their own
>> patents on it.  In the most extreme cases, they have access
>> to mailing list archives, I-Ds, and meeting minutes and audio
>> without having to identify themselves.
> 
> write a rule that catches (2) without also catching
> well-intentioned observers.

My definition of a "well-intentioned observer" includes someone
who will disclose the fact if he or see is personally aware of
relevant IPR even if it requires a third-party disclosure.  That
disclosure will be made, not because the IETF requires it and
makes threats of what will happen if it does not occur (see RFCs
6701 and 6702) but because informing the IETF community is The
Right Thing To Do.   Of course, if a well-intentioned observer
has nothing to disclose then there is nothing to disclose.
Someone who has knowledge of relevant IPR but who is trying to
figure out exactly where the boundaries are so he or she can get
away with not disclosing (and claim they had no obligation to
disclose) may be many things, but "well-intentioned observer"
isn't one of them.

Again, I think we should keep the rules (or guidelines) clear
and to write them with the understanding that we won't be able
to "catch" those who are determined to be deceitful or evade the
rules and change their behavior.

 best,
   john

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 22 Jan 2013 08:19:39 -0500

As far as I can tell, the need for clear rules is precisely to help 
those in the middle whom John describes as not being well-intentioned. 
Many companies are happy to comply with the letter and spirit of the 
rules.  But not all such companies wish to disclose everything they have 
in their portfolio.  They look to the rules to tell them what they need 
to disclose.  (And it should be emphasized that the individual 
participant ay b well-intentioned although the company may be moe nuanced.)

Yours,
Joel

---

From: John C Klensin <[email-masked]>
Date: Tue, 22 Jan 2013 08:49:02 -0500

--On Tuesday, January 22, 2013 08:19 -0500 "Joel M. Halpern"
<[email-masked]> wrote:

> As far as I can tell, the need for clear rules is precisely to
> help those in the middle whom John describes as not being
> well-intentioned. Many companies are happy to comply with the
> letter and spirit of the rules.  But not all such companies
> wish to disclose everything they have in their portfolio.
> They look to the rules to tell them what they need to
> disclose.  (And it should be emphasized that the individual

I think you misunderstood my note.

First, I think clear rules and clear guidance benefits everyone.
I consider being relatively simple, not a collection of cases
with boundaries that are fuzzier than we might initially
believe, is a condition of "clear".

Second, I think that, if we want the present IPR regime --rather
than, e.g., one based on company membership and explicit
membership or contributor agreements -- to be effective, it is
important that we establish a culture of "if you are in doubt as
to whether you are obligated to disclose, then you should
disclose in the interest of being a good community member".  If
that promotes more conversations between participants (including
observers, etc.) and their sponsors or others who might have
relevant IPR or claim IPR in work those people did, those
conversations are good for all concerned.  In particular, if an
employer gets anxious when an employee decides to start an
internal conversation about disclosure, think how much more
anxious they might get if the employee's failure to act resulted
in their being unable to enforce a patent.

My "not well-intentioned" observer is one who is perfectly aware
of whatever the rules are (and may have studied them to
determine just how far it is possible to participate while
denying any obligation to disclose, not someone who might be
confused about the clarity of those rules.

    john

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 22 Jan 2013 10:12:29 -0500

> Do we want our definition of "participate" to cover none, some,

If the evidence of their presence is the Blue Sheet, how can we tell which state
they were in?  Although I am a lawyer, I take that hat off, and guess that the rules
might shift the burden to the signed-in attendee to aver the state they were in else they may be 
deemed present and a participant.

Also, If the person sits in silence while the debate is going their way does that mean they weren't
participating?  What if there is a hum? 

Ray

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Jan 2013 19:01:21 +0000

> that their company can subsequently patent, but never speaks.

Let's be a bit more precise there. I doubt that someone can patent an idea that was just published in a draft. The draft would appear to be prior art, and our best action would be to make sure that patent reviewers can easily find that. 

What is much more likely to happen is "creative brainstorming." Some inventors watch the IETF WG trying to solve a problem, find potential solutions to the problem, and patent the solutions before the WG members had time to find and publish them. In short, they win the race. At that point, the defense against the patent is weak -- it has to rely on obviousness, and that's very hard to prove. 

Frankly, I don't know a safe way to protect against "independent invention moving faster than the WG." Apart of course from having efficient WG that publish solutions quickly. But then, if we want efficient WG, we may want fewer rules, not more rules.

-- Christian Huitema

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Jan 2013 08:11:24 +0000

On 22/01/2013 19:01, Christian Huitema wrote:
> Let's be a bit more precise there. I doubt that someone can patent an idea that was just published in a draft. 

Not everything you hear in a WG meeting ends up in a draft immediately,
and as you say below, submarines can move fast sometimes.

> The draft would appear to be prior art, and our best action would be to make sure that patent reviewers can easily find that. 
> 
> Frankly, I don't know a safe way to protect against "independent invention moving faster than the WG." 

We can't, and perhaps we shouldn't even try.

> Apart of course from having efficient WG that publish solutions quickly. But then, if we want efficient WG, we may want fewer rules, not more rules.

True, which brings us back to Joel's first concern, that extending
the disclosure requirement to passive participants will actually
have a chilling effect. I set out my four models really to show that
we can't write an objective rule that distinguishes well-intentioned
observers from ill-intentioned lurkers.

   Brian

---

From: tglassey <[email-masked]>
Date: Wed, 23 Jan 2013 05:33:55 -0800

> and as you say below, submarines can move fast sometimes.

I can create and file all of the documentation for a Provisional Patent 
in under 12 hours... and I am not a Professional Patent Agent so ... 
Christian - I think this is much more of an issue that you think. The 
other thing is patents which were already filed which become a part of a 
process or technology which is emerging inside the WG's... like the 
Cisco patent matter we just dealt with for the NEA effort.
>> The draft would appear to be prior art, and our best action would be to make sure that patent reviewers can easily find that.
Actually this will constitute (c) issues - again the research exemptions 
dont cover IETF publications

-- 
Regards TSG
"Ex-Cruce-Leo"

//Confidential Mailing - Please destroy this if you are not the intended recipient.

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 27 Jan 2013 14:32:22 +0000

> On 22/01/2013 19:01, Christian Huitema wrote:

<snip>

> observers from ill-intentioned lurkers.

That comment seemed to shut people up, but as Adrian says, this is
a change of principle that needs to be well argued and then debated
on the IETF list.

It seems a pretty binary choice to me: either passive participants
MUST disclose or they MAY disclose.

I've seen an argument for the change that it will discourage submarine
patent lurkers, and an argument against the change that it will
discourage some honest observers.

   Brian

---

From: tglassey <[email-masked]>
Date: Sun, 27 Jan 2013 08:50:10 -0800

> MUST disclose or they MAY disclose.
Isnt the real issue what the law requires? Is there some problem with 
that being a guiding principal here? Or is the real goal to create a 
world where there are no IP protections and all IP and all property is 
shared?

Its about time that specific question was formally answered  by the IETF 
- what is your formal policy on IP and Privately Owned IP and its use in 
any standards processes?

Todd

-- 
Regards TSG
"Ex-Cruce-Leo"

---

From: John C Klensin <[email-masked]>
Date: Sun, 27 Jan 2013 12:02:49 -0500

--On Sunday, January 27, 2013 14:32 +0000 Brian E Carpenter
<[email-masked]> wrote:

> I've seen an argument for the change that it will discourage
> submarine patent lurkers, and an argument against the change
> that it will discourage some honest observers.

FWIW, I don't believe the former.  The above is an actual
tradeoff only if one does.  I think it will make life a little
more difficult and annoying for submarine patent lurkers but, if
that is the business some unsavory organization wants to be in,
they will figure out a way to get around whatever rules exist.
The claims of a bad actor who would be discouraged by a barrier
this minor and easily circumvented would, for other reasons,
almost certainly not survive a serious challenge.

To the extent to which we have submarine patent lurkers,
would-be invention thieves, or other deliberate IPR bad actors
in our midst, the only effect of broader rules will be to
slightly raise the odds of their patents being declared
unenforceable (almost certainly after long and expensive court
battles) because whatever they did to get around the rules
showed that they were not acting in good faith.  

Personally, I don't think it is worth making our rules and
processes more complicated -- and possibly creating even more
loopholes and opportunities for hair-splitting in the process --
just to gain that marginal improvement... even if it could not
be shown to discourage honest observers.

Let me suggest something a little different in context with
suggestion by others about MAY disclose versus MUST disclose.
Let's reorient the document to make it extremely clear that the
IETF's principle and intent is that there be disclosure if there
is _any_ participation that makes one aware of IETF interest in
a technology in which one is aware of IPR or _any_ awareness of
IPR that is relevant to IETF activities.  For that general
expectation, distinctions like "personally known" the difference
between participants and observers, and other mitigating
circumstances, just don't count.  "If you know, we want you to
disclose."   Then we can identify specific scenarios _as
non-exclusive examples_ in which disclosure is mandatory.  

The net result of that as a strategy is that good-faith
participants (or observers) can either just disclose or, if they
have mitigating circumstances or interests sufficient to start
hair-splitting, they can study the examples and work the
boundaries out with their own legal counsel and assume the risks
of having done so.  Would-be bad actors will always be in
violation of the principle so if their actions are challenged,
they will have to convince a judge that they were acting in good
faith despite the symptoms to the contrary (that is what a
challenge to a bad act will almost always come down to anyway).

In many ways, I think this is "general principle and specific
examples" model is more or less where our IPR policies started
out.  Since then, we've tried to create more and more specific
rules to deal with various concerns and edge cases.  It is not
clear that has worked to our advantage, so maybe we should
return to first principles and try to get it right this time.

Now, if Jorge tells us that there is specific case law that
argues that we need a case-by-case listing of situations in
which one is obligated to disclose (or not), my mind will change
about the above.  But, so far, I think all we've heard is
"Clarity...would have been a good thing".  I think we pretty
much knew that already; I'm just suggesting that a very clear
statement of a principle that is as simple as we can make it may
be a better way to achieve clarity than a collection of detailed
rules that, inevitably, won't cover quite all of the cases.

    john