Subject: ipr-wg was Proposal to cease accepting IPR disclosures by unstructured email

From: tom petch <[email-masked]>
Date: Wed, 23 Dec 2020 17:07:16 +0000

On 22/12/2020 19:44, Brian E Carpenter wrote:
> John,
>
> IMHO your point is clearly out of scope for the admin list since it raises an IETF process issue. So I've have bcc'ed the admin list and, since we don't have an ipr-discuss list, added the IETF list. You said:

We used  to, the ipr-wg, and the website tells you how to subscribe to 
the mailng list although as the last archive entry is 2014 there would 
likely not be much traffic but if like me you never get reminders and 
never get around to unsubscribing there could still be interested 
parties on it.

Tom Petch

>> If IPR arises after adoption, the draft should
>> automatically return to an adoption call - but much better to simply not
>> allow it.
>
> Firstly, an adoption call is not a formal or required part of the IETF process, it is simply a pragmatic step that some WGs use (see RFC7221). So we can't have a requirement to repeat a step that isn't required in the first place.
>
> Secondly, we have no power to "disallow" late IPR disclosures. Sometimes people only discover patents late, and do us a favour by notifying them. That particularly applies to third party disclosures, or patents elsewhere in a large company**. Sometimes people are legally or contractually unable to make disclosures until their employer decides to publish an application. I'm sure there are other cases too, such as when an IETF Last Call triggers a disclosure by somebody who has been unaware of the draft until then. We may not like it, but there will always be late disclosures.
>
> Therefore we just have to deal with them when they arrive.
>
> Regards
>     Brian Carpenter
>
> ** Note that our rules do not require a patent search. From RFC8179:
>
>>>     m. "Reasonably and personally known": something an individual knows
>>>        personally or, because of the job the individual holds, would
>>>        reasonably be expected to know.  This wording is used to indicate
>>>        that an organization cannot purposely keep an individual in the
>>>        dark about patents or patent applications just to avoid the
>>>        disclosure requirement.  But this requirement should not be
>>>        interpreted as requiring the IETF Contributor or Participant (or
>>>        his or her represented organization, if any) to perform a patent
>>>        search to find applicable IPR.
>
> On 23-Dec-20 07:11, john heasley wrote:
>> Fri, Dec 18, 2020 at 09:27:11AM +1300, IETF Executive Director:
>>> The IETF Administration LLC is proposing to cease accepting IPR disclosures by unstructured email and making the existing mechanism of a structured form the sole mechanism for submitting IPR disclosures.  We are now seeking feedback on this proposal.
>>>
>>> IPR disclosures can currently be submitted by one of three Datatracker forms [1] [2] [3] or by email.  The forms are highly structured and the IPR disclosures are stored in a database that can be both browsed [4] and searched [5] using this structure,
>>>
>>> Email submissions, provided for historical compatibility, often require significant backend processing and judgement calls from the Secretariat on what data should be extracted from the email for each field in the database.  The volumes are small, generally only one or two a month, but on occasion they are tens of pages long with multiple disclosures extracted.  Notwithstanding the low volumes, it is our view that it is inappropriate to ask the Secretariat to decide what content to include/exclude and how to represent it, for such a legally sensitive area and that we should not be processing of IPR disclosures in this way.  Consequently, we propose to cease accepting IPR disclosure by email.
>>>
>>> If you have any feedback on this proposal, please send it directly to me or to the admin-discuss list before Friday 8th January 2021.
>>
>> I think this is a good idea.  I do not have negative comment on this
>> proposal, but on IPR in general.  I am of the opinion that IPR should be
>> required BEFORE a draft can be considered for adoption and allowed at no
>> time afterward.  If IPR arises after adoption, the draft should
>> automatically return to an adoption call - but much better to simply not
>> allow it.
>>
>> I think that WGs should have the opportunity to consider restrictions
>> of IPR before they spend any time on a draft.  I have no interest in
>> improving a work that has unclear or restrictive IPR - not knowing about
>> IPR until after adoption or even later amounts to free consulting.  It
>> is not unreasonable to require a company to figure-out their IPR beforehand.
>>
>> I have seen a few IPR that are open, but whose current and/or future
>> restrictions are unclear.
>>
>>> Any IPR disclosures received by email from now on will not be processed until a final decision is made on this proposal.  Submitters will be notified of that so that they can submit by a form if they choose.
>>>
>>> [1]  https://datatracker.ietf.org/ipr/new-specific/
>>> [2]  https://datatracker.ietf.org/ipr/new-generic/
>>> [3]  https://datatracker.ietf.org/ipr/new-third-party/
>>> [4]  https://datatracker.ietf.org/ipr/
>>> [5]  https://datatracker.ietf.org/ipr/search/
>>>
>>> --
>>> Jay Daley
>>> IETF Executive Director
>>> [email-masked]
>>>
>>>
>>>
>>> _______________________________________________
>>> IETF-Announce mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ietf-announce
>>
>
> .
>

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 23 Dec 2020 17:43:37 +0000

The IPR-WG list still exists, and the reason for keeping it open was IIRC that we may need it again when the IPR working group closed last time.
I'm throwing away about 10 SPAMs a week, otherwise there would be traffic :-)
Stephan

On 12/23/20, 09:07, "Ipr-wg on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    Tom Petch

    _______________________________________________
    Ipr-wg mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/ipr-wg